Ubuntu

lucid xorg regression - thinkpad x40 (855GM) freeze at xorg startup

Reported by PascalCavy on 2010-05-04
52
This bug affects 11 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

I upgraded this thinkpad x40 from a working version of kubuntu karmic with latest updates and even Kde recommanded PPA.

When booting into lucid, splash screen works and when xorg is initializing, the screen becomes black then the machine immediatly freezes. I suspect a freeze because even kernel magic keys do nothing. I have to power off/on the machine to reboot.

If I boot the latest karmic kernel 2.6.31-20-generic, the machine boots perfectly and the lucid xorg is usable without problem. So I don't know if the problem is related to xorg or the kernel.

I see no crash report in /var/crash.

The rescue lucid recue mode boots OK. If I use the option to fix xorg there I only see a rapid screen mode change then I am put back to the rescue menu with no freeze.

The freeze problem is reproducable at will. I could also reproduce this freeze when booting from a Kubuntu Lucid Live USB.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xorg (not installed)
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
Date: Tue May 4 01:36:04 2010
DkmsStatus: Error: [Errno 2] Aucun fichier ou dossier de ce type
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: IBM 237179G
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: root=UUID=f02b850e-f150-4a7c-88cb-9463ec54947e ro single
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg
dmi.bios.date: 12/21/2006
dmi.bios.vendor: IBM
dmi.bios.version: 1UETD3WW (2.08 )
dmi.board.name: 237179G
dmi.board.vendor: IBM
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: IBM
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnIBM:bvr1UETD3WW(2.08):bd12/21/2006:svnIBM:pn237179G:pvrThinkPadX40:rvnIBM:rn237179G:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:
dmi.product.name: 237179G
dmi.product.version: ThinkPad X40
dmi.sys.vendor: IBM
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-21-generic
xkbcomp:
 Error: command ['xkbcomp', ':0', '-w0', '-'] failed with exit code 1: Error: Cannot open display ":0"
                   Exiting
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/dsp', '/dev/snd/controlC0', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/pcmC0D1c', '/dev/snd/pcmC0D2c', '/dev/snd/pcmC0D3c', '/dev/snd/pcmC0D4p', '/dev/snd/by-path', '/dev/snd/controlC29', '/dev/snd/seq', '/dev/snd/timer', '/dev/sequencer2', '/dev/sequencer'] failed with exit code 1:
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'I82801DBICH4'/'Intel 82801DB-ICH4 with AD1981B at irq 17'
   Mixer name : 'Analog Devices AD1981B'
   Components : 'AC97a:41445374'
   Controls : 28
   Simple ctrls : 20
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 1UHTB2WW-1.62'
   Mixer name : 'ThinkPad EC 1UHTB2WW-1.62'
   Components : ''
   Controls : 2
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
   Playback channels: Mono
   Limits: Playback 0 - 14
   Mono: Playback 7 [50%] [on]
DistroRelease: Ubuntu 10.04
HibernationDevice: RESUME=UUID=4983e07e-b9d3-49eb-ad22-3f15e22264d9
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: IBM 237179G
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: root=UUID=f02b850e-f150-4a7c-88cb-9463ec54947e ro single
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Regression: Yes
RelatedPackageVersions: linux-firmware 1.34
Reproducible: Yes
RfKill:
 0: tpacpi_bluetooth_sw: Bluetooth
  Soft blocked: yes
  Hard blocked: no
Tags: lucid suspend resume regression-potential needs-upstream-testing
Uname: Linux 2.6.32-21-generic i686
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare
WpaSupplicantLog:

dmi.bios.date: 12/21/2006
dmi.bios.vendor: IBM
dmi.bios.version: 1UETD3WW (2.08 )
dmi.board.name: 237179G
dmi.board.vendor: IBM
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: IBM
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnIBM:bvr1UETD3WW(2.08):bd12/21/2006:svnIBM:pn237179G:pvrThinkPadX40:rvnIBM:rn237179G:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:
dmi.product.name: 237179G
dmi.product.version: ThinkPad X40
dmi.sys.vendor: IBM

PascalCavy (p92) wrote :
PascalCavy (p92) wrote :

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

PascalCavy (p92) wrote : Lspci.txt

apport information

apport information

apport information

apport information

apport information

PascalCavy (p92) wrote : UdevDb.txt

apport information

PascalCavy (p92) wrote : UdevLog.txt

apport information

apport information

Bryce Harrington (bryce) on 2010-05-04
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Bryce Harrington (bryce) on 2010-05-04
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
PascalCavy (p92) wrote :

I have tested successfully xorg with the following kernel for lucid
 linux-image-2.6.33-02063303-generic_2.6.33-02063303_i386.deb

PascalCavy (p92) wrote :

as a workaround replacing boot options "quiet splash" with "i915.modeset=0" fixes the problem on thinkpad x40 (from article in http://ubuntu-tutorials.com/2010/05/06/ubuntu-10-04-lucid-blank-screen-at-startup-workaround/ )

PascalCavy (p92) wrote :

sorry i915.modeset=1 should be the correct option.

Bryce Harrington (bryce) on 2010-05-09
tags: added: kubuntu
tags: added: freeze
sun (uwe-dormann) wrote :

FYI, i915.modeset=1 helps, but it doesn't solve it.

Just tried it on 2 of my Thinkpad X40's. I get to the desktop, but as soon as I try to play a movie, it hangs again.

dalailama (dalailama333) wrote :

Same X40, same problem.
I've searched around on the web and bug reports, and found a lot of people with the same problem on xserver-xorg-video-intel on lucid.

Problems correlated:
- can't play video,
- can't run tvtime,
- crash on some resolutions,
- crash on rhythmbox visualization,
- crash on some video embedded in pages on the web.

Gary M (garym) on 2010-05-16
tags: added: hw-specific regression-release
Gary M (garym) on 2010-05-18
tags: added: 855gm
Jim Rees (rees) wrote :

Any progress on this? I'm running kernel 2.6.32.10+drm33.1 (built from source), with "nomodeset" option, the last kernel that works for me. I've got a x40 2386BHU. The x41 has similar problems by the way.

carton (m8r-dno0hg) wrote :

The ppa:glasen/intel-driver and ppa:glasen/855gm-fix 855gm-fix-exp-dkms packages downloaded 2010-07-04 work for my X40 so far: booting does not hard-freeze with a black screen, compiz effects work, xv movie-playing works, suspend works. thank you.

I've made no other changes for the problem, though I have been running without 'quiet' and 'splash' in grub for years because I find all that pretty boot wallpaper garbage stupid and dangerous.

Suspend while playing a movie did not work. :) also I've only been testing for about 1 hour.

Download full text (6.9 KiB)

that's the reason why I am back to 9.04. everything, (including movies with
dvdcss script), works well on 9.04. there are minor and major bugs in 10.4
as well as bunch of extraneous software no one really needs.... whoever
started with 10.4 would choose another flavor of Linux. personally i like
9.04. it works like a champ

On Sun, Jul 4, 2010 at 9:25 AM, carton <email address hidden> wrote:

> *** This bug is a duplicate of bug 541511 ***
> https://bugs.launchpad.net/bugs/541511
>
> The ppa:glasen/intel-driver and ppa:glasen/855gm-fix 855gm-fix-exp-dkms
> packages downloaded 2010-07-04 work for my X40 so far: booting does not
> hard-freeze with a black screen, compiz effects work, xv movie-playing
> works, suspend works. thank you.
>
> I've made no other changes for the problem, though I have been running
> without 'quiet' and 'splash' in grub for years because I find all that
> pretty boot wallpaper garbage stupid and dangerous.
>
> Suspend while playing a movie did not work. :) also I've only been
> testing for about 1 hour.
>
> --
> lucid xorg regression - thinkpad x40 (855GM) freeze at xorg startup
> https://bugs.launchpad.net/bugs/574854
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (via bug 541511).
>
> Status in “xserver-xorg-video-intel” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: xorg
>
> I upgraded this thinkpad x40 from a working version of kubuntu karmic with
> latest updates and even Kde recommanded PPA.
>
> When booting into lucid, splash screen works and when xorg is initializing,
> the screen becomes black then the machine immediatly freezes. I suspect a
> freeze because even kernel magic keys do nothing. I have to power off/on the
> machine to reboot.
>
> If I boot the latest karmic kernel 2.6.31-20-generic, the machine boots
> perfectly and the lucid xorg is usable without problem. So I don't know if
> the problem is related to xorg or the kernel.
>
> I see no crash report in /var/crash.
>
> The rescue lucid recue mode boots OK. If I use the option to fix xorg there
> I only see a rapid screen mode change then I am put back to the rescue menu
> with no freeze.
>
> The freeze problem is reproducable at will. I could also reproduce this
> freeze when booting from a Kubuntu Lucid Live USB.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: xorg (not installed)
> ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
> Uname: Linux 2.6.32-21-generic i686
> Architecture: i386
> Date: Tue May 4 01:36:04 2010
> DkmsStatus: Error: [Errno 2] Aucun fichier ou dossier de ce type
> Lsusb:
> Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> MachineType: IBM 237179G
> PccardctlIdent:
> Socket 0:
> no product info available
> PccardctlStatus:
> Socket 0:
> no card
> ProcCmdLine: root=UUID=f02b850e-f150-4a7c-88cb-9463ec54947e ro single
> ProcEnviron:
> PATH=(custom, user)
> LANG=fr_FR.UTF-8
> SHELL=/bin/bash
...

Read more...

To post a comment you must log in.