Ubuntu

apport-gpu-error-intel.py crashed with KeyError in __getitem__()

Reported by Pedro Villavicencio on 2010-03-16
534
This bug affects 110 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

I've got an x crash and after a while got this crash report too, will try to reproduce it and put some steps here. thanks.

ProblemType: Crash
Architecture: i386
Date: Sat Mar 13 10:48:46 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
InterpreterPath: /usr/bin/python2.6
Package: xserver-xorg-video-intel 2:2.9.1-1ubuntu13
ProcCmdLine: root=UUID=baf39bdd-6797-4bb6-8e78-926244993df4 ro quiet splash
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
PythonArgs: ['/usr/share/apport/apport-gpu-error-intel.py']
SourcePackage: xserver-xorg-video-intel
Title: apport-gpu-error-intel.py crashed with KeyError in __getitem__()
Uname: Linux 2.6.32-16-generic i686
UserGroups:

dmi.bios.date: 06/12/2008
dmi.bios.vendor: Intel Corp.
dmi.bios.version: PRG3110H.86A.0052.2008.0612.1910
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: DG31PR
dmi.board.vendor: Intel Corporation
dmi.board.version: AAD97573-305
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrPRG3110H.86A.0052.2008.0612.1910:bd06/12/2008:svn:pn:pvr:rvnIntelCorporation:rnDG31PR:rvrAAD97573-305:cvn:ct3:cvr:
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-16-generic

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation 82G33/G31 Express Integrated Graphics Controller [8086:29c2] (rev 10)
     Subsystem: Intel Corporation 82G33/G31 Express Integrated Graphics Controller [8086:29c2]

Pedro Villavicencio (pedro) wrote :
tags: removed: need-duplicate-check
visibility: private → public
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed

Based off of the number of duplicates, and myself experiencing this, I'm marking this as confirmed.

I just had this happen with my Lenovo x200s, with an Intel GMA 4500.

Bryce Harrington (bryce) on 2010-03-17
description: updated
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
Michael Vogt (mvo) wrote :

I just ran into this on a hardy->lucid upgrade on a i830 gpu

Odin Hørthe Omdal (velmont) wrote :

I ran into this.

After 20-30 minutes my screen becomes totally BLANK. The screen reports «check your cables», and I do. The machine still runs, so I think there's a kernel error that causes it. And afterwards I get this bug when it's trying to report the other (real) bug.

Bryce Harrington (bryce) wrote :

Thanks Jan, I put in a slightly modified version of the patch. Since we're frozen for the beta release it will be a day or two before it shows up in the archive I guess.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Committed

This has happened to me a few times in the past couple days. I have a Sony Vaio i686 running Lucid Alpha 3 with integrated Intel Corporation Mobile 915GM/PM/GMS/910GML graphics. Also happened when I closed the lid of my laptop to suspend. The computer comes back in graphics safe mode. This pops up along with https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/447159

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.9.1-1ubuntu16

---------------
xserver-xorg-video-intel (2:2.9.1-1ubuntu16) lucid; urgency=low

  * debian/apport-gpu-error-intel.py:
    + Better fix for checking MachineType and other parameters to
      be defined before using them in bug report titles. Thanks Jan!
      (LP: #539533)
 -- Bryce Harrington <email address hidden> Wed, 17 Mar 2010 11:36:02 -0700

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Committed → Fix Released

It says this bug was fixed in xserver-xorg-video-intel 2:2.9.1-1ubuntu16, but I am experiencing the bug with that exact version installed.

hpis2cool (hpis2cool) wrote :

Same as S. Christian Collins. Also experiencing this bug with the new version. I use a Toshiba Satellite laptop.

candtalan (aeclist) wrote :

I am using Live CD beta1, and got this crash immediately on booting up live.

Wayne Crannell (caruso81) wrote :

I just got this same thing today on a MacBook 2,1 after an install from Karmic to Lucid (formatted first)

-Install from Live CD
-Drop into terminal from GRUB
-Update/Upgrade (300+ changes)
-Reboot
-After 10 seconds on the desktop, I get: "Sorry, the program apport-gpu-error-intel.py closed unexpectedly."
-An attempt to "Report Problem" in the dialog window resulted in a "Collecting Information" progress screen for about 10 seconds and then a black screen crash.

I can reproduce this repeatedly. Booting the LiveCD does NOT produce this behavior.

Can I disable this driver (or whatever it is) at boot?

Wayne Crannell (caruso81) wrote :

UPDATE (in answer to my own question)

SInce it appears to be an Intel driver issue, I booted into recovery mode and deleted:

 /usr/lib/xorg/modules/drivers/intel_drv.so

Booted right up (very fast) and has been running for about 10 minutes.

tags: added: bugpattern-needed
jflaming (jay-flaming) wrote :

I had the same error, fresh install from release cd. Live cd will not display, but I installed server, then ubuntu-desktop, and it would not work. Deleted the intel_drv.so file, and now it works, but only in vesa mode.

kevin nunn (knunn52) wrote :

/usr/share/apport/apport-gpu-error-intel.py on every boot it also crashes my laptop most of the time ---emachines e732--

To post a comment you must log in.