Entering specific string(s) of characters causes X to restart

Bug #528076 reported by Jonas Clemen Larsen on 2010-02-25
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

How to reproduce:

1. Boot the system
   Notice that X starts on tty1 (compared to tty7 in earlier releases of Ubuntu)
2. Log in
3. Open gedit
4. Enter

     910#uC

   and press enter. X will crash and/or restart, and the login screen will be presented again.
   Notice that X now runs on tty7, and tty1 now shows the usual getty login prompt.

I've successfully reproduced this at least 10 times. The bug dosen't seem to be in effect after the first X restart. I've also noticed random/garbage text on tty1 after X had restarted. This text is clearly console input data, as the getty responds to it with a 'Password:' prompt. Here's an example of the text (seen after 'login:' prompt):

  164*888888888<6'(

It's clear that at least one other character string can trigger the same bug (has the same effect). The string above just happened to be part of one of my passwords - that is how I initially discovered this: X crashing everytime I tried logging in to a particular service.

ProblemType: Bug
Architecture: i386
Date: Thu Feb 25 23:07:48 2010
DistroRelease: Ubuntu 10.04
DkmsStatus: Error: [Errno 2] No such file or directory
MachineType: LENOVO 17043DU
Package: xserver-xorg 1:7.5+1ubuntu8
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: root=UUID=ae0c8ca7-2b60-4722-9eae-6ee7612e18c3 ro
ProcEnviron:
 LANG=en_DK.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
RelatedPackageVersions:
 xserver-xorg 1:7.5+1ubuntu8
 libgl1-mesa-glx 7.7-3ubuntu1
 libdrm2 2.4.18-1ubuntu2
 xserver-xorg-video-intel 2:2.9.1-1ubuntu6
SourcePackage: xorg
Uname: Linux 2.6.32-14-generic i686
dmi.bios.date: 06/19/2008
dmi.bios.vendor: LENOVO
dmi.bios.version: 7BETD6WW (2.17 )
dmi.board.name: 17043DU
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7BETD6WW(2.17):bd06/19/2008:svnLENOVO:pn17043DU:pvrThinkPadX60s:rvnLENOVO:rn17043DU:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 17043DU
dmi.product.version: ThinkPad X60s
dmi.sys.vendor: LENOVO
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.32-14-generic

Jonas Clemen Larsen (jclemen) wrote :
description: updated
Bryce Harrington (bryce) on 2010-02-26
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Bryce Harrington (bryce) on 2010-02-26
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2010-02-27
tags: added: crash
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers