"White screen of death" on Dell Studio 15

Bug #460664 reported by Erica Rosalle on 2009-10-25
54
This bug affects 6 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
Unassigned
linux (Ubuntu)
Medium
Canonical Kernel Team
Karmic
Medium
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

This appears to be a regression of bug #297245; in my case, a striped-but-mostly-white screen appears when I try to use a Karmic LiveCD. I'm on a Dell Studio 15 with the Intel GM965 graphics chipset; my laptop also has the AUO screen that was determined to have caused the funkiness the Intel video drivers in Jaunty.

Erica Rosalle (erosalle) wrote :
Erica Rosalle (erosalle) wrote :
baba lafayette (suncoolsu) wrote :

Hi,
I can confirm this bug. As was being discussed in bug #297245, changing the options to NOMODESET does show the boot screen, but the screen turns black after the splash screen. After sometime the WSoD appears.

I changed the driver from "intel" to "vesa" and i was able to atleast login.

Thanks
B.

Jerone Young (jerone) wrote :

This issue is a kernel mode settings (KMS) issue. Unfortunately the fix in 9.04 didn't get into the KMS code.

Based on other reports & video posted here:
          - Once KMS kicks in with Dell Studio 15 machines with 965 graphics & Aou panel you end up with a white screen.
             * No usplash screen
             * No X screen

          - By disabling KMS using "nomodeset" on command line , and forcing Xorg to use vesa you can then use the card.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Invalid
Changed in linux (Ubuntu):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)

Well, I'm a bit confused by this one. The fix we put together for Jaunty should already be in the kernel, but based on the pictures it does look like we're programming a bad mode. The machine should still be up though, so it would be good to get logs with DRM debugging enabled (you can force this by loading the drm module with the "debug=1" option, though on recent kernels you might need to use "debug=4" or "debug=5").

I'd also like to get a copy of the vbios for this machine:
# cd /sys/devices/pci0000\:00/0000\:00\:02.0/
# echo 1 > rom
# cat rom > /tmp/rom.bin
# echo 0 > rom

If we end up using the EDID on this machine, then maybe the fix didn't make it upstream. In that case this kernel patch might help:

diff --git a/drivers/gpu/drm/drm_edid.c b/drivers/gpu/drm/drm_edid.c
index 3c0d2b3..2c2f08b 100644
--- a/drivers/gpu/drm/drm_edid.c
+++ b/drivers/gpu/drm/drm_edid.c
@@ -647,6 +647,12 @@ static struct drm_display_mode *drm_mode_detailed(struct dr
        mode->vsync_end = mode->vsync_start + vsync_pulse_width;
        mode->vtotal = mode->vdisplay + vblank;

+ /* Some EDIDs have bogus h/vtotal values */
+ if (mode->hsync_end > mode->htotal)
+ mode->htotal = mode->hsync_end + 1;
+ if (mode->vsync_end > mode->vtotal)
+ mode->vtotal = mode->vsync_end + 1;
+
        drm_mode_set_name(mode);

        if (pt->misc & DRM_EDID_PT_INTERLACED)

Erica Rosalle (erosalle) wrote :

I'll post this information tonight when I get back to the machine.

Erica Rosalle (erosalle) wrote :
  • vbios Edit (64.0 KiB, application/octet-stream)
Erica Rosalle (erosalle) wrote :

Loading with the debug options (tried them all) didn't seem to yield anything different; am I supposed to put the debug option on the kernel command line, or do something else with it?

Erica Rosalle (erosalle) wrote :

Okay, the patch you posted worked for me; I didn't have to append modeset to the kernel line to get X to start.

Ok, thanks for testing. I just pushed the patch upstream, it should also be applied to the Ubuntu kernel.

Hi Jesse,

Just curious if you also had CC'd stable on the patch when you pushed upstream? If so, we'll get the patch automatically the next time we rebase with upstream stable.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged

Oh no, I forgot to cc stable. Will fix that now.

tags: added: 2.6.31.y
Luke Yelavich (themuso) wrote :

I can verify that the above patch from Jess fixes the issue. I have a machine loaned from Dell for other reasons, which is affected by this bug, and after building a kernel with the patch applied, the notebook LCD screen displays correctly.

Changed in oem-priority:
importance: Undecided → Medium
Erdem Öztürk (oztrkerdem) wrote :

How can i applie this patch? i can only enter my system using "nomodeset" with livecd. When i try to use "nomodeset" in normal mod my mouse and keyboard not working. Should i try this patch or wait for next kernel patch?

Jerone Young (jerone) wrote :

@Erdem
          To use this patch you will have to know how to apply patches & compile a kernel properly. As you can see from previous posts it does work. We are awaiting for the Ubuntu kernel team to integrate the patch into a kernel that is easy to consume. That way you will not have to use "nomodeset" to get something to the screen.

Erdem Öztürk (oztrkerdem) wrote :

Does this kernel patch is available in Current development kernel?

Jerone Young (jerone) wrote :

@Erdem
   Currently it is not. But finding out now when it will be.

Erdem Öztürk (oztrkerdem) wrote :

@Jerone Young
        Have you learned when it will be available?

Erdem Öztürk (oztrkerdem) wrote :

İ have installed new kernel and nothing happened the problem insist :)

Jerone Young (jerone) wrote :

@Erdem
        That kernel was only security updates. Will post to this bug when I find out more on when this fix will be integrated.

Hugh Blemings (hughhalf) wrote :

We have an embargoed CVE (Security patch kernel) waiting to go out - due to go out later this week.

Once that's done the deck is clear to do a SRU release which will include the fixes being discussed. Rough ETA for this SRU release is prior to Christmas - has to sit in proposed per normal policy.

We have taken the additional step of arranging to have this SRU release get some additional testing from our QA team.

Jerone Young (jerone) wrote :

@Hugh
          So has this fix been committed into the tree. Currently the status says "triaged"?

Jerone Young (jerone) on 2009-12-07
Changed in oem-priority:
status: New → In Progress

Hi Jerone,

This patch is in the recently released 2.6.31.7 upstream stable patch set. We're currently in the process of rebasing Karmic with 2.6.31.7. I anticipate this to land in our pre-proposed PPA in a day or two and eventually into karmic-proposed once the security updates get pushed out and the preceeding 2.6.31.6 proposed kernel has time to bake in karmic-proposed. Thanks.

tags: added: 2.6.31.7
removed: 2.6.31.y
Changed in linux (Ubuntu):
status: Triaged → In Progress
Erica Rosalle (erosalle) wrote :

I just finished an install of Lucid Alpha 1 on the affected hardware, and the issue seems to be fixed. I was able to log in without having to append nomodeset on the kernel command line.

Jerone Young (jerone) wrote :

@Leann
      Is there a kernel package in propsed that has all the 2.6.31.6 updates (including this one)? If so what is the version number ?

Tony Espy (awe) wrote :

@Jerone

2.6.31.6 is already in -proposed ( 2.6.31-17.54 ). What Leann said was that once we've successfully pushed out a kernel based on 2.6.31.6, then work will start on 2.6.31.7, which should contain the fixes we need.

FYI, for future reference, kernel mappings between upstream and Ubuntu can be found here:

http://kernel.ubuntu.com/~kernel-ppa/info/kernel-version-map.html

Stefan Bader (smb) wrote :

commit 669fb67d863ee859bec32221b58fb8b9a0b5fd64 in 2.6.31.7
Author: Jesse Barnes <email address hidden>
Date: Thu Nov 5 10:12:54 2009 -0800

    drm: work around EDIDs with bad htotal/vtotal values

Changed in linux (Ubuntu):
status: In Progress → Fix Committed

Accepted linux into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Stefan Bader (smb) on 2010-01-08
Changed in xserver-xorg-video-intel (Ubuntu Karmic):
status: New → Invalid
Changed in linux (Ubuntu Karmic):
importance: Undecided → Medium
status: New → Fix Committed
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Jerone Young (jerone) wrote :

Verified.. Kernel 2.6.41-18-generic in the proposed branch does fix the issue

Jerone Young (jerone) on 2010-01-11
Changed in oem-priority:
status: In Progress → Fix Committed
Martin Pitt (pitti) on 2010-01-12
tags: added: verification-done
removed: verification-needed
Camilo Soto (csotomon) wrote :

with the kernel 2.6.41-18-generic the problem is solved, but my wireless card BCM4312 is now dead

Jerone Young (jerone) wrote :

@Camilo
        You need to install the linux-headers for 2.6.41-18-generic so the wireless driver dkms package can recompile.

Launchpad Janitor (janitor) wrote :
Download full text (24.5 KiB)

This bug was fixed in the package linux - 2.6.31-20.57

---------------
linux (2.6.31-20.57) karmic-proposed; urgency=low

  [ Kees Cook ]

  * SAUCE: x86: brk away from exec rand area
    - LP: #452175

  [ Keng-Yu Lin ]

  * SAUCE: (drop after 2.6.31) input: Add hotkey quirk for Samsung
    Q210/P210 laptops
    - LP: #385683

  [ Pascal Bach ]

  * SAUCE: (drop after 2.6.31) input: Add hotkey quirk for Fujitsu Amilo
    1848+u
    - LP: #458503

  [ Stefan Bader ]

  * Revert "[Upstream] (drop after 2.6.31) acerhdf: fix fan control for
    AOA150 model"
    - LP: #494633
  * [Config] Disable CONFIG_USB_DEVICEFS
    - LP: #488274

  [ Upstream Kernel Changes ]

  * Revert "ext4: Don't update superblock write time when filesystem is
    read-only"
    - LP: #496816
  * Revert "ide: try to use PIO Mode 0 during probe if possible"
    - LP: #503430
  * Revert "isdn: isdn_ppp: Use SKB list facilities instead of home-grown
    implementation."
    - LP: #503430
  * nilfs2: fix kernel oops in error case of nilfs_ioctl_move_blocks
    - LP: #494633
  * cifs: don't use CIFSGetSrvInodeNumber in is_path_accessible
    - LP: #494633
  * cifs: clean up handling when server doesn't consistently support inode
    numbers
    - LP: #494633
  * cifs: clear server inode number flag while autodisabling
    - LP: #494633
  * CIFS: fix oops in cifs_lookup during net boot
    - LP: #494633
  * CIFS: Duplicate data on appending to some Samba servers
    - LP: #494633
  * rtl8187: Fix kernel oops when device is removed when LEDS enabled
    - LP: #494633
  * md: don't clear endpoint for resync when resync is interrupted.
    - LP: #494633
  * md/raid5: make sure curr_sync_completes is uptodate when reshape starts
    - LP: #494633
  * md/raid1/raid10: add a cond_resched
    - LP: #494633
  * ALSA: usb-audio: fix combine_word problem
    - LP: #494633
  * ALSA: hda - Dell Studio 1557 hd-audio quirk
    - LP: #494633
  * ALSA: AACI: fix AC97 multiple-open bug
    - LP: #494633
  * ALSA: AACI: fix recording bug
    - LP: #494633
  * jffs2: Fix memory corruption in jffs2_read_inode_range()
    - LP: #494633
  * sound: rawmidi: disable active-sensing-on-close by default
    - LP: #494633
  * sound: rawmidi: fix checking of O_APPEND when opening MIDI device
    - LP: #494633
  * sound: rawmidi: fix double init when opening MIDI device with O_APPEND
    - LP: #494633
  * sound: rawmidi: fix MIDI device O_APPEND error handling
    - LP: #494633
  * highmem: Fix race in debug_kmap_atomic() which could cause warn_count
    to underflow
    - LP: #494633
  * highmem: Fix debug_kmap_atomic() to also handle KM_IRQ_PTE, KM_NMI, and
    KM_NMI_PTE
    - LP: #494633
  * powerpc: Fix DEBUG_HIGHMEM build break from d4515646699
    - LP: #494633
  * kmap: fix build errors with DEBUG_HIGHMEM enabled
    - LP: #494633
  * V4L/DVB (13169): bttv: Fix potential out-of-order field processing
    - LP: #494633
  * V4L/DVB (13170): bttv: Fix reversed polarity error when switching video
    standard
    - LP: #494633
  * V4L/DVB (13109): tda18271: fix signedness issue in
    tda18271_rf_tracking_filters_init
    - LP: #494633
  * V4L/DVB (13107): tda18271: fix overflow in FM radio frequency...

Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
Camilo Soto (csotomon) wrote :

But is actived again in the 2.6.41-19 kernel

Jerone Young (jerone) wrote :

@Camilo
         According the post above it is in 2.6.31-20 kernel .. not -19.

Jerone Young (jerone) on 2010-03-25
Changed in oem-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers