[i945GM] Configuring laptop screen and external monitor to run with different resolutions freezes X

Bug #454957 reported by alcCapone on 2009-10-18
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

Responsible package is only a rough guess!

I'm using my Thinkpad X60s with an external monitor. X60s has a native resolution of 1024x768, external monitor's native resolution is 1280x1024.

Having them both in a mirrored or extended view at 1024x768 works fine.
Having the external monitor at its native resolution and the laptop's LCD disabled also works nicely.

But having them both running at their native resolutions forming one desktop (yes, then theirs a rectangle unused) freezes the X session. All I see then is my mouse cursor, X reacts to nothing: neither keyboard nor mouse. To illustrate what I'm talking about, a screen shot of the gnome display configuration tool is attached. If I would click "apply" - X would freeze.

Actually I wouldn't care for this "feature" since it's IMHO completely useless. The thing is that I like to switch between my (external) display settings with [Fn] + [F7] - and the freezing configuration is the first one that this key combo will switch to.

Btw: Besides that karmic's great so far!

ProblemType: Bug
Architecture: i386
Date: Sun Oct 18 22:15:28 2009
DistroRelease: Ubuntu 9.10
MachineType: LENOVO 17045UG
Package: xserver-xorg-video-intel 2:2.9.0-1ubuntu2
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: root=UUID=59e55a12-8e81-4220-8d2e-08f8cb5b8b5e ro quiet splash
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.31-14-generic i686
XsessionErrors:
 (polkit-gnome-authentication-agent-1:2652): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2637): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (gnome-help:3132): Yelp-WARNING **: Yelper initialization failed for 0x88e1f48
 (gnome-help:3132): Yelp-WARNING **: Yelper initialization failed for 0x8a5ac28
 (gnome-help:3132): Yelp-WARNING **: Yelper initialization failed for 0x8a5acf8
dmi.bios.date: 03/07/2007
dmi.bios.vendor: LENOVO
dmi.bios.version: 7BETC7WW (2.08 )
dmi.board.name: 17045UG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7BETC7WW(2.08):bd03/07/2007:svnLENOVO:pn17045UG:pvrThinkPadX60s:rvnLENOVO:rn17045UG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 17045UG
dmi.product.version: ThinkPad X60s
dmi.sys.vendor: LENOVO
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-14-generic

alcCapone (alcc) wrote :
Bryce Harrington (bryce) on 2009-10-19
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Mathieu Marquer (slasher-fun) wrote :

Confirming on a Samsung NC10 with Karmic :
* First Fn+F4 show both internal and external screens with the same resolution (800x600 I guess)
* Second Fn+F4 shows a black screen with only the mouse cursor moving, then freezing.

mtheripper (magatheripper) wrote :

Also happening On Toshiba Satellite A105 with LG Flatron Wide (Monitor).
Same problem as discribed above.

How can I fix it?
I am very happy with Karmic, and I am one step away to complete a change from Windows Xp.
But this Bug is holding me.

Thank you for advice!

Geir Ove Myhr (gomyhr) on 2009-10-31
tags: added: 945gm dual-head karmic
summary: - Configuring laptop screen and external monitor to run with different
- resolutions freezes X
+ [i945GM] Configuring laptop screen and external monitor to run with
+ different resolutions freezes X
mtheripper (magatheripper) wrote :

I tried Ubuntu Studio (9.10 Beta) and it worked just fine! Also It worked in Ubuntu 9.04!?
IS it a Kernel problem? Is there a way to upgrade from ubuntu to Ubuntu studio (system) somehow??

alcCapone (alcc) wrote :

The problem does also occur if I plug-in the external monitor _after_ the laptop has booted. If I then go to the Gnome "Display Preferences" and click "Detect Monitors" my X server freezes as described before.

alcCapone (alcc) wrote :

In case it matters: the monitor is a "Fujitsu C17-2".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers