FFe for updating -intel to 2.9.0

Bug #446080 reported by Bryce Harrington on 2009-10-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Wishlist
Unassigned
Karmic
Wishlist
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

[Request]
Update of xserver-xorg-video-intel to version 2.9.0.

[Rationale]
2.9.0 is almost entirely a bugfix-only release. It contains one new feature, which is the addition of support for a new chipset. No existing functionality is removed. There are no changes in ABI/API. There are no changes in dependency versions.

At UDS we knew the schedule for 2.9.0 placed it at around beta, and so set our requirements to 2.8.x, with a "maybe" for 2.9.0 if it was entirely bug-fix and was especially stable. In our evaluation, it does meet the criteria we required of it. It is proving to be quite stable, and aside from the one chipset feature (which we need in order to support customers) is entirely bug fixes. In fact it includes fixes for a number of bugs we have forwarded to them over the past few months, including solving some longstanding i8xx regressions that have plagued us for several releases.

[Testing]
In addition to going through Intel's QA testing procedures, we have carried git snapshots of the 2.9.0 driver and the release candidates leading up to it in our xorg-edgers repository. A number of people run this repository routinely, and report bugs to launchpad so we have had good visibility into the quality of this particular release.

Additionally, the specific package version we propose to incorporate is derived from Debian's xserver-xorg-video-intel (2:2.9.0-1), which is being tested in unstable presently.

[Contingency]
If this FFe is accepted, we will also place the current 2.8.x driver into the x-retro PPA at the same time, versioned in a way that enables reversion to the older driver. If by chance there are any serious regressions found in the 2.9.0 driver, we will be able to revert back to the prior 2.8.x driver with minimal effort.

If this FFe is not accepted, we can cherrypick individual patches from the release (indeed, we've already been doing this), although we probably will not have time to backport all the fixes we would like to see in karmic.

Related branches

Bryce Harrington (bryce) wrote :
Download full text (6.2 KiB)

Here is the changelog and release notes:

Release 2.9.0 (2009-09-28)
==========================
We are pleased to announce the 2.9.0 release of the xf86-video-intel
driver. (If you have been following along at home, this release is
identical to the 2.8.99.902 release candidate other than the version
number).

-Carl

Where to obtain the release
===========================
git tag: 2.9.0

http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-2.9.0.tar.bz2
MD5: 34ff2582993d64dddd62d0cb7b30d759 xf86-video-intel-2.9.0.tar.bz2
SHA1: 62e29344824a5de421178fec568d7ff0688309f8 xf86-video-intel-2.9.0.tar.bz2

http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-2.9.0.tar.gz
MD5: a3b2f3f9abcbf2d6add4d0c3a6e06279 xf86-video-intel-2.9.0.tar.gz
SHA1: 25bb6948223db5e8f140f42aa6de2dfb7f7d9a50 xf86-video-intel-2.9.0.tar.gz

New features in 2.9 compared to 2.8
===================================
* Support for the B43 chipset.

Major fixes in 2.9.0 compared to 2.8.0
======================================
* Multiple fixes to make the driver stable for 8xx chipsets, (855GM,
  865G, etc.). The 2.8 driver series was extremely unstable with many
  of these chipsets.

  https://bugs.freedesktop.org/show_bug.cgi?id=22904 (and many duplicates)
  https://bugs.freedesktop.org/show_bug.cgi?id=22947

* Add support for BACKLIGHT property when using kernel modesetting
  (KMS). This allows backlight adjustment with programs such as
  "xbacklight -set <percentage>" or "xrandr --set BACKLIGHT <value>".

  https://bugs.freedesktop.org/show_bug.cgi?id=20963

* Fix so that "xrandr --scale" works when using KMS.

  https://bugs.freedesktop.org/show_bug.cgi?id=22893

* Fix segfaults of X server when logging out.

  https://bugs.freedesktop.org/show_bug.cgi?id=20516

* Avoid falling back to software for 1-bit alpha-only masks.

  https://bugs.freedesktop.org/show_bug.cgi?id=23184

* Fix pixel sampling position for 8xx chipsets, (fixes some cairo-test
  suite failures).

All changes from 2.8.0 to 2.9.0
===============================
Adam Jackson (1):
      Fix the chip names printed in the log to be less obnoxious.

Carl Worth (8):
      debug: i830_valid_command: Return invalid for subopcodes with no name
      NEWS: Add notes for the 2.8.99.901 snapshot
      Update version to 2.8.99.901 for snapshot.
      8xx: Fallback for any non-affine transformation.
      NEWS: Add notes for 2.8.99.902
      Increment version to 2.8.99.902
      NEWS: Add notes for the 2.9.0 release.
      Increment version to 2.9.0

Chris Wilson (10):
      i830: do not use stale mask transform
      i830: remove padding NOOPs from composite
      i830: Trim composite setup
      i830: Update comments
      i830/i915: Set the sample position to the pixel center.
      i915: Restore nearest sampling
      Avoid fallbacks for compositing gradient patterns
      Avoid fallbacks for a1 src/mask
      Check the correct Picture for error during creation.
      Revert "8xx: Fallback for any non-affine transformation."

Dave Airlie (5):
      intel: remove unneeded includes
      intel: update for resources/RAC API removal
      intel: since driver depends on newer server don't ...

Read more...

Bryce Harrington (bryce) wrote :

Format: 1.8
Date: Wed, 07 Oct 2009 20:09:54 -0700
Source: xserver-xorg-video-intel
Binary: xserver-xorg-video-intel xserver-xorg-video-intel-dbg
Architecture: source
Version: 2:2.9.0-1ubuntu1
Distribution: karmic
Urgency: low
Maintainer: Ubuntu Developers <email address hidden>
Changed-By: Bryce Harrington <email address hidden>
Description:
 xserver-xorg-video-intel - X.Org X server -- Intel i8xx, i9xx display driver
 xserver-xorg-video-intel-dbg - X.Org X server -- Intel i8xx, i9xx display driver (debug symbols)
Changes:
 xserver-xorg-video-intel (2:2.9.0-1ubuntu1) karmic; urgency=low
 .
   [Tormod Volden]
   * Merge with Debian. Remaining Ubuntu changes:
     + debian/control: Add lpia architecture
   * Drop patches now included upstream:
     + 100_8xx_perf_pict_a8.patch
     + 101_reload_cursors.patch
     + 102_dont_destroy_bufmgr_at_closescreen_time.patch
   * Ubuntu bugs fixed in this release:
     + Calculate the DVO relative offset in LVDS data entry to get the DVO
       timing. Fixes black screen at boot on i855 due to not finding LVDS
       modes.
       (LP: #410455)
     + Fix brightness by enabling BACKLIGHT property for KMS.
       (LP: #397617)

Timo Aaltonen (tjaalton) wrote :

Ack'ed, this is part of intel Q3-2009 bugfix release (with kernel 2.6.31.2, libdrm 2.4.14, mesa 7.6), and it makes sense to have the whole stack in 9.10. Possible bugreports are easier to forward upstream when the baseline is well known to them.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Bryce Harrington (bryce) wrote :

I went ahead and uploaded this after getting a thumbs up from pitti, but I'd still like to see an official approval from the release team for this one, just for the sake of formality...

Martin Pitt (pitti) wrote :

As discussed on IRC, the changes are bug fixes and aren't too many of them either, and QA on intel's side looked very thorough. The package was tested in x-updates PPA before as well. The only new feature was support for b43 which we planned anyway.

Approved.

Changed in xserver-xorg-video-intel (Ubuntu Karmic):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.