[Karmic]Crash with black screen when trying to enable second monitor

Bug #445609 reported by Laurens Bosscher on 2009-10-07
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

Stepts to reproduce :

1. Open Display
2. Enable the second monitor (first one running on 1280x800, second on 1650x1050)
3. Press aply

Results :

A black screen with a mouse pointer that cant be moved, I also can't open a console (ctrl + alt + F1) or do anything else.

Expected results :

I expected to use the second monitor or an error that this configuration was not supported.

Using Karmic 9.10 and xserver-xorg-video-intel 2:2.8.1-1ubuntu3

I could not find any related bugs but I could find some information about UXA not supporting this. Perhaps an warming should be provided to intel users since UXA is default in 9.10?

ProblemType: Bug
Architecture: i386
CheckboxSubmission: aea6262879f79abe590b5b4f9a85847d
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Wed Oct 7 18:32:51 2009
DistroRelease: Ubuntu 9.10
MachineType: Dell Inc. MM061
Package: xserver-xorg-video-intel 2:2.8.1-1ubuntu3
ProcCmdLine: root=UUID=f6f00661-d7a6-47b4-b545-129619ac3c82 ro quiet splash
ProcEnviron:
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.7.0~git20090925.c19482b1-0ubuntu0tormod~jaunty
 libdrm2 2.4.14-0ubuntu0tormod~jaunty
 xserver-xorg-video-intel 2:2.8.1-1ubuntu3
 xserver-xorg-video-ati 1:6.12.99+git20090925.3efecebb-0ubuntu0tormod~jaunty
SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.31-11-generic i686
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 04/02/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A14
dmi.board.name: 0KD882
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA14:bd04/02/2007:svnDellInc.:pnMM061:pvr:rvnDellInc.:rn0KD882:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: MM061
dmi.sys.vendor: Dell Inc.
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-11-generic

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
     Subsystem: Dell Device [1028:01bd]

Bryce Harrington (bryce) on 2009-10-08
tags: added: crash
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Luis Carlos Cobo (luiscarlos) wrote :

This happens to me too, but multiple monitor works fine when using, on Section "Device" in xorg.conf:

 Option "DRI" "false"

Bryce Harrington (bryce) on 2009-10-09
tags: added: karmic
Bryce Harrington (bryce) on 2009-10-10
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers