[i915gm] [Karmic] X freezes when using compiz on external monitor

Bug #441873 reported by Jens Georg on 2009-10-04
This bug affects 15 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Nominated for Karmic by Rex Kerr
Nominated for Lucid by Rex Kerr

Bug Description

Binary package hint: xserver-xorg-video-intel

When using an external monitor connected via DVI exclusively configured via xrandr or the gnome display settings, and enabling compiz, X freezes. Compiz runs just fine when using the notebook's internal monitor.

ProblemType: Bug
Architecture: i386
Date: Sun Oct 4 03:10:50 2009
DistroRelease: Ubuntu 9.10
Package: xserver-xorg-video-intel 2:2.8.1-1ubuntu2
 Socket 0:
   no product info available
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-11-generic root=UUID=4b08fc2e-6021-4ec7-a416-93de2031528d ro quiet splash rootfstype=ext4 resume=/dev/sda3
 PATH=(custom, user)
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu7
 libdrm2 2.4.13-1ubuntu1
 xserver-xorg-video-intel 2:2.8.1-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu2
SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.31-11-generic i686
dmi.bios.date: 09/16/2005
dmi.bios.vendor: FUJITSU // Phoenix Technologies Ltd.
dmi.bios.version: Version 1.07
dmi.board.name: FJNB19C
dmi.board.vendor: FUJITSU
dmi.board.version: CP234410-01
dmi.chassis.type: 10
dmi.chassis.vendor: FUJITSU SIEMENS
dmi.chassis.version: S7020
dmi.modalias: dmi:bvnFUJITSU//PhoenixTechnologiesLtd.:bvrVersion1.07:bd09/16/2005:svnFUJITSUSIEMENS:pnLIFEBOOKS7020:pvr:rvnFUJITSU:rnFJNB19C:rvrCP234410-01:cvnFUJITSUSIEMENS:ct10:cvrS7020:
dmi.product.name: LIFEBOOK S7020
dmi.sys.vendor: FUJITSU SIEMENS
fglrx: Not loaded
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-11-generic

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 03)
     Subsystem: Fujitsu Limited. Device [10cf:12de]

Jens Georg (yg-jensge) wrote :
Jens Georg (yg-jensge) wrote :

Problem can be easy reproduced:
  - call xrandr --output LVDS1 --off --output DVI1 --auto
  - call compiz --replace

Attached batchbuffer dump

Bryce Harrington (bryce) on 2009-10-04
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
lebb (lebber) wrote :

I have the same issue here on Dell inspiron 640m

Jens Georg (yg-jensge) wrote :

xrandr output with second monitor attached

Bryce Harrington (bryce) on 2009-10-09
tags: added: karmic
Bryce Harrington (bryce) on 2009-10-10
description: updated
Sitsofe Wheeler (sitsofe) wrote :

I'm seeing this too on an EeePC 900 with an intel i915 card. The problem is reproducible every time (just doing something like xranr --auto with the external monitor plugged in triggers it for me). Interestingly if I use a 2.6.32-rc kernel then I am still able to switch VTs (which I am not able to do with a 2.6.31 kernel) but dmesg is filled with the following:

[drm:i915_gem_execbuffer] *ERROR* Execbuf while wedged

From then on Xorg will not display a picture even if gdm is restarted.

Sitsofe Wheeler (sitsofe) wrote :

(This might be a dup of bug 414240)

Sitsofe Wheeler (sitsofe) wrote :
Urs (urs-ak) wrote :

I have this bug too. On Fujitsu Siemens V3205.

Just installed the Karmic and connected my external display. System halted (black screen and freezed mouse cursor)

Without Compiz, system is not halted.

Salva Perugorría (xenon-soft) wrote :

I have exactly the SAME bug. I am using a Coolbox Minidesk 2002 desktop PC (Atom 330 + Intel 945GC GPU) which had 9.04 preinstalled. Now I am using Xubuntu 9.10, fresh install, without Compiz. I've tried today to install and execute Compiz, and them everything freezes. I tried also to yesterday to do a fresh install of Ubuntu 9.10 but it freezes also. So now, Xubuntu.

Sitsofe Wheeler (sitsofe) wrote :

And I presume compiz works fine when you are using only a single monitor?

I have a feeling that it's probably time to collect lspci output for our graphics cards to see if different types are affected or if it's just a few. Here's mine for my EeePC 900:

00:02.1 Display controller [0380]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2792] (rev 04)

If it is affecting all cards using intel drivers then this should really go into the release notes as it's a very severe problem (on my machine Ubuntu defaults to using compiz out of the box).

Bryce Harrington (bryce) on 2009-11-02
summary: - [Karmic] X freezes when using compiz on external monitor
+ [i915gm] [Karmic] X freezes when using compiz on external monitor
Salva Perugorría (xenon-soft) wrote :


My Atom + Intel computer is a desktop one , so I only use my monitor, which is now a LG 20" TFT TV-Monitor. So I think this problem affects to intel drivers.



Sitsofe Wheeler (sitsofe) wrote :

I would strongly urge you to file another bug report and post a link to the new report here. Your case sounds different to that in the description of this bug report. If they are indeed the same it will be easy to merge them together later. If they are different it will be highly confusing to have both issues in one bug as it may be possible to fix one without fixing the other.

Sitsofe Wheeler (sitsofe) wrote :

I've managed to reproduce the problem on a colleague's Toshiba laptop. Mirroring (via xrandr --auto ) worked but setting side by side mode in gnome-display-properties caused a lock up.

00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
 Subsystem: Toshiba America Info Systems Device [1179:ff10]

Marcelo Lotif (mlotifjava) wrote :

There is a similar bug report around, looks like Salva's problem fits better with it:


maybe this bug and the one I pasted are related, don't know exactly.

Oswald-p (oswaldpp) wrote :

I have the same bug with a Dell mini 9 (intel GMA 950 I guess).

very frustrating....


Sitsofe Wheeler (sitsofe) wrote :

I should note that the external monitors are being connected by VGA in my cases.

Haggai Eran (haggai-eran) wrote :


I also suffer from this freeze, but only when running xrandr or the gnome display tool when compiz had already been running.

nanotube (nanotube) wrote :

same thing happens here, on a dell vostro a90 (which is a rebranded mini9, essentially).

running stock ubuntu 9.10, intel gma950 video card.

when connecting a vga external monitor and opening the display applet (enable the monitor), total system freeze.

if before enabling the monitor, i run "metacity --replace", then everything works just fine.

so it's definitely compiz-only problem.

if you need any more info, config files, lspci output, etc, i'd be willing to post whatever is required, just let me know what.

would be nice to get this fixed! :)

Jeff Fortin Tam (kiddo) wrote :

Actually, I'm thinking this is not compiz-specific (because it also happens with mutter), and that this is a duplicate of bug #414240 ... please check?

Jens Georg (yg-jensge) wrote :

Might be that this is the same bug, though it is about extending a screen while I initially filed it about not being able to use compiz on an exclusively (i.e. not extended Desktop, no mirroring) external Screen (see #2)

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Invalid
omanni (olli-mannisto) wrote :

i have the same problem with thinkpad X41 (Intel 915GM). when visual effects are set to none, then there is no crash when connecting external display.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers