Connecting External Monitor does not work on Thinkpad x60

Bug #42898 reported by Littleiffel on 2006-05-04
28
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

I cannot connect an external monitor to my thinkpad x60. When I am pressing the button nothing happens. As far as I know I have a Intel graphics Media 950.(If this may help).

Littleiffel (thierry-nicola) wrote :

Hi, I have the same problem, out of the box it is not working. However, if you follow the blog on www.williambrownstreet.net/bmachine/
there is a hint to get it partly working. Just plug the external monitor and both display the same.

change the xorg.conf file(section Device to)

Section "Device"
Identifier "Intel Corporation Mobile Integrated Graphics Controller"
Driver "i810"
BusID "PCI:0:2:0"
Option "MonitorLayout" "CRT,LFP"
Option "Clone" "true"
Option "DevicePresence" "true"
EndSection

David Eriksson (meldavid) wrote :

I also have this problem on my X60s. Fn +F7 works in Grub-menu, during Windows startup and in Windows but as soon as the Ubuntu kernel has booted it stops work. I can get it to work in Clone-mode.

Kerouac (lubiapolo) wrote :

Hello,
I just got a brandnew Thinkpad T60 and have the same effect with Feisty. Fn + F7 doesnt work, but when I press Fn+Home what normally should change brightness, it switches to the external monitor. After hitting that combination several times it switches back to Laptop screen....

chastell (chastell) wrote :

In my X60:

For brightness, blacklisting video in /etc/modprobe.d allows the brightness keys to work.

For external monitor, Fn+F7 doesn’t work, but patched i810switch works for me: https://launchpad.net/ubuntu/+bug/92528

ttoine (ttoine) wrote :

that is for every intel graphic chipset i8xx and i9xx

install "i810switch" package and run "i810rotate" in a terminal.

the command line "i810switch" echo the state : internal, external, internal+external, etc...

You can then create the keayboard shortcut in the keyboard preferences of gnome

Jean Jordaan (jean-jordaan) wrote :

I get the same as Kerouac (Thinkpad T60, Feisty): Fn + F7 doesn't work, but brightness control switches to external monitor. ?!
The laptop display is switched off while the external monitor is on. Is the weird keyboard issue just a misconfiguration in Feisty? How does one fix this?

ttoine (ttoine) wrote :

Jean,

Did you try i810switch ?

> Did you try i810switch ?

jean@klippie:~$ i810switch
PCI id of i810 is not recognized.

HW details (by HAL Device Manager 0.5.9):

"""
Device: Mobile 945GM/GMS/940GML Express Integrated Graphics Controller
OEM Product: Thinkpad R60e model 0657
"""

Yes, it says R60e even though this is T60 (1951-CN9).

--
jean . .. .... //\\\oo///\\

chastell (chastell) wrote :

Jean, try the patch attached to https://bugs.launchpad.net/ubuntu/+bug/92528

Jean Jordaan (jean-jordaan) wrote :

Hi Shot

> Jean, try the patch attached to
> https://bugs.launchpad.net/ubuntu/+bug/92528

It works for me :-)

"""
 jean@klippie:~/tmp/i810switch-0.6.5$ sudo ./i810switch
Password:
CRT: off
LCD: on
 jean@klippie:~/tmp/i810switch-0.6.5$ sudo ./i810switch crt on
Enabling CRT display...
 jean@klippie:~/tmp/i810switch-0.6.5$ sudo ./i810switch
CRT: on
LCD: on
 jean@klippie:~/tmp/i810switch-0.6.5$ sudo ./i810switch crt off
Disabling CRT display...
"""

--
jean . .. .... //\\\oo///\\

chastell (chastell) wrote :

Cool, I hope the patch makes it into Gutsy.

Also, at least on my machine, /usr/bin/i810switch is setuid root, so you don’t need to run it with sudo.

trollord (trollenlord) wrote :

I doubt the patch gets into Gutsy. Gutsy is supposed to have newer X that supports hot-plugging stuff like external monitors on a completely new level. It should take care of this bug. We will see the status of this bug after Gutsy has attempted to deliver that.

Timo Aaltonen (tjaalton) wrote :

Please try gutsy with the -intel driver and report back.

Bryce Harrington (bryce) on 2007-09-29
Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
chastell (chastell) wrote :

For me (current Gutsy) the intel driver turns on both monitors and Fn+F7 still doesn’t work. Unfortunately, if the external monitor has bigger resolution (1280×1024 vs. internal’s 1024×768), both monitors are set to the bigger one, the internal monitor then shows only part of the viewport, *and* I can’t maximise windows past the *smaller* resolution.

With i810, everything works as in Feisty (patched i810switch switches the monitors properly, windows maximise propery).

David Tansey (djtansey) wrote :

I have the same problem with gutsy that Shot describes. I have gone back to the i810 module.

To be more specific, /proc/acpi/ibm/video reacts properly to Fn-F7. But the video (xorg) just doesn't care. So when I boot, my laptop monitor is blank (as expected) all the way up until x starts. I don't know how many thinkpad users use external monitors, but having the intel module be the detected/default module will cause problems for those who do...

unggnu (unggnu) wrote :

I think this bug has been fixed in Gutsy with the new Intel driver. You can use xrandr for configuring your external monitor (clone, extend, disable and so on).
The problem that the screen switch key doesn't work with xrandr is another bug report e.g. Bug #157596.
Marking as fixed. Feel free to open it again if external Monitor still doesn't work under Gutsy with external monitor and new Intel driver.

Changed in xserver-xorg-video-intel:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers