kdm crashes system on logout

Bug #428662 reported by Thorsten on 2009-09-12
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Critical
xserver-xorg-video-intel (Ubuntu)
High
Alberto Milone
Karmic
High
Alberto Milone

Bug Description

Binary package hint: kdm

After logging out of a KDE or GNOME session, kdm appears to hang with a black screen (with single white cursor) and a "dead" keyboard (Ctrl-Alt-F{1..9} doesn't do anything; not even NumLock can be triggered.)

If I am also remotely logged into this system via ssh, I can see that there is a kdm but no X process. It looks like kdm can't restart X after the logout (which apparently completes just fine, complete with saving the session and the logout sound.)

This happens on two similar, but not identical DELL Latitude E5500 notebooks, both with Intel on-board video and running Kubuntu Karmic AMD64 with the latest updates. (Everything runs fine under Kubuntu Jaunty i386.)

The problem does not occur when I use gdm instead of kdm.

Please advise if you need additional debugging info.

ProblemType: Bug
Architecture: amd64
Date: Sat Sep 12 19:22:40 2009
DistroRelease: Ubuntu 9.10
Package: kdm 4:4.3.1-0ubuntu3
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
 LANGUAGE=
ProcVersionSignature: Ubuntu 2.6.31-10.32-generic
SourcePackage: kdebase-workspace
Uname: Linux 2.6.31-10-generic x86_64

Thorsten (kdefan) wrote :
Jonathan Thomas (echidnaman) wrote :

Most likely X is dying when restarting kdm. Could you attach a copy of /var/log/Xorg.0.log after a failed logout? A copy of the output of the command "lscpi -vvnn" would be helpful too.

Changed in kdebase-workspace (Ubuntu):
status: New → Incomplete
Thorsten (kdefan) wrote :

Exactly. As requested, I'm attaching Xorg.0 and lscpi.out. Also, these lines from /var/log/messages and /var/log/syslog from an earlier after-logout-crash might be relevant:

[messages]
Sep 13 01:27:17 navy kernel: [28206.866210] Xorg[12786] general protection ip:4843d9 sp:7fff68d3f5c0 error:0 in Xorg[400000+1c2000]

[syslog]
Sep 13 01:27:18 navy kdm[12784]: X server for display :0 terminated unexpectedly
Sep 13 01:27:18 navy kdm[12784]: Unable to fire up local display :0; disabling.

Thorsten (kdefan) wrote :

And here's Xorg.0.log...

Jonathan Thomas (echidnaman) wrote :

Thanks for the logs. This is a bug with the intel driver code, even though KDM is triggering the situation that leads to the crash.

affects: kdebase-workspace (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
Scott Kitterman (kitterman) wrote :

This really needs to get fixed since it kills the multiple-user case where people have to logout and log back in.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Medium → High
milestone: none → ubuntu-9.10-beta
tags: added: regression-potential
Albert Damen (albrt) wrote :

The most easy way to get logout/login working on intel in Kubuntu is to set TerminateServer=true in kdmrc.

--- /etc/kde4/kdm/kdmrc.orig 2009-09-17 00:06:11.209433377 +0200
+++ /etc/kde4/kdm/kdmrc 2009-09-17 00:02:03.920288377 +0200
@@ -493,7 +493,7 @@
 # Restart instead of resetting the local X-server after session exit.
 # Use it if the server leaks memory etc.
 # Default is false
-#TerminateServer=true
+TerminateServer=true
 # The signal needed to reset the local X-server.
 # Default is 1 (SIGHUP)
 #ResetSignal=1

Would that be an option?

That's a workaround at best. It sounds like another user's session would
not survive that, so I think it's unlikely to help the multi-user case.

Martin Pitt (pitti) wrote :

Alberto, can you please have a look at this? I guess this needs some more debugging info for upstream.

Changed in xserver-xorg-video-intel (Ubuntu Karmic):
assignee: nobody → Alberto Milone (albertomilone)
Alberto Milone (albertomilone) wrote :

Upstream already has a fix for this bug.

Maybe this is a duplicate of bug #364508

Changed in xserver-xorg-video-intel:
status: Unknown → Fix Released
Scott Kitterman (kitterman) wrote :

Thanks for looking into it. It would be really good to get this fixed for
the beta.

Alberto Milone (albertomilone) wrote :

Can you test the intel package in my PPA, please? (it will build soon)
https://launchpad.net/~albertomilone/+archive/x-testing

Changed in xserver-xorg-video-intel (Ubuntu Karmic):
status: Confirmed → In Progress
Scott Kitterman (kitterman) wrote :

I can test tonight or tomorrow.

Alberto Milone (albertomilone) wrote :

I'm no longer able to reproduce the problem in Kubuntu with my fix. X doesn't seem to crash any more.

See the attached debdiff

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.8.1-1ubuntu2

---------------
xserver-xorg-video-intel (2:2.8.1-1ubuntu2) karmic; urgency=low

  * Add 102_dont_destroy_bufmgr_at_closescreen_time.patch: Don't destroy
    bufmgr at CloseScreen time (LP: #428662).

 -- Alberto Milone <email address hidden> Fri, 25 Sep 2009 14:53:26 +0200

Changed in xserver-xorg-video-intel (Ubuntu Karmic):
status: In Progress → Fix Released
LightI3ulb (lighti3ulb) wrote :

I am using the Karmic Kubuntu Netbook Remix on a Lenovo Ideapad S10 (GMA950) and I am still experiencing this issue with xserver-xorg-video-intel 2:2.8.1-1ubuntu2 installed. Logout returns me to a blank screen with only my mouse cursor. I am able to drop to TTY though and restart kdm manually to return to the login screen.

Alberto Milone (albertomilone) wrote :

@LightI3ulb
Right but that's a different bug. The xserver didn't crash.

Thorsten (kdefan) wrote :

Still, the problem remains: kdm does not relaunch after logging out. The difference: X keeps running, and the kdm interface can be brought up by sending HUP to the X process (after logging in to VT1.)

What's the best way of addressing this? Fix a new bug against kdm? Keep discussing here?

Scott Kitterman (kitterman) wrote :

Keep discussing here. Nixternal is working at it, but didn't get it
figured out yet.

Joel (jocaez) wrote :

Still doen't work here. So I decided to use the TerminateServer workaround for now

Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
Changed in xserver-xorg-video-intel:
importance: Critical → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.