[i945gme] attaching external monitor: laptop display is black, external monitor too, with frozen mouse coursor

Bug #419328 reported by j^ on 2009-08-26
604
This bug affects 123 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Critical
compiz (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Franck
Nominated for Lucid by ManDay
xserver-xorg-video-intel (Ubuntu)
High
Unassigned
Nominated for Karmic by Franck
Nominated for Lucid by ManDay

Bug Description

Binary package hint: xserver-xorg-video-intel

using latest Karmic on a Lenovo S10e.

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

attaching external monitor and launching gnome-display-properties
i can see the mouse pointer on the external screen, the laptop screen is black, no reaction from mouse and keyboard
i can ssh into the laptop

last line of dmesg might be relevant:
[ 140.379174] [drm] DAC-6: set mode f

attaching /var/log/Xorg.0.log

j^ (j) wrote :
j^ (j) wrote :

more errors in dmesg trying to restart X via /etc/init.d/gdm restart does not work

[ 360.744203] INFO: task i915/0:841 blocked for more than 120 seconds.
[ 360.744219] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 360.744232] i915/0 D c080c380 0 841 2 0x00000000
[ 360.744253] f68a3f04 00000046 f68dc000 c080c380 f6806718 c080c380 e71988b2 00000020
[ 360.744282] c080c380 c080c380 f6806718 c080c380 00000000 00000020 c080c380 f5f75340
[ 360.744309] f6806480 f691c014 f691c018 ffffffff f68a3f30 c0568e26 c0737180 f691c01c
[ 360.744336] Call Trace:
[ 360.744365] [<c0568e26>] __mutex_lock_slowpath+0xc6/0x130
[ 360.744382] [<c0568d40>] mutex_lock+0x20/0x40
[ 360.744450] [<f824e94a>] i915_gem_retire_work_handler+0x2a/0x70 [i915]
[ 360.744483] [<c015311e>] run_workqueue+0x6e/0x140
[ 360.744539] [<f824e920>] ? i915_gem_retire_work_handler+0x0/0x70 [i915]
[ 360.744569] [<c0153278>] worker_thread+0x88/0xe0
[ 360.744590] [<c0157920>] ? autoremove_wake_function+0x0/0x40
[ 360.744610] [<c01531f0>] ? worker_thread+0x0/0xe0
[ 360.744623] [<c015762c>] kthread+0x7c/0x90
[ 360.744637] [<c01575b0>] ? kthread+0x0/0x90
[ 360.744654] [<c0103f17>] kernel_thread_helper+0x7/0x10
[ 360.744704] INFO: task Xorg:2480 blocked for more than 120 seconds.
[ 360.744714] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 360.744724] Xorg D c080c380 0 2480 2479 0x00400004
[ 360.744743] f5da3e28 00003082 00000000 c080c380 f662c168 c080c380 bddf3835 00000020
[ 360.744770] c080c380 c080c380 f662c168 c080c380 bddedbed 00000020 c080c380 f6712c40
[ 360.744798] f662bed0 f691c014 f691c018 ffffffff f5da3e54 c0568e26 00000000 f691c01c
[ 360.744824] Call Trace:
[ 360.744841] [<c0568e26>] __mutex_lock_slowpath+0xc6/0x130
[ 360.744857] [<c0568d40>] mutex_lock+0x20/0x40
[ 360.744914] [<f824ebcb>] i915_gem_throttle_ioctl+0x2b/0x70 [i915]
[ 360.744932] [<c01e43a5>] ? do_sync_readv_writev+0xb5/0xf0
[ 360.745003] [<f81466c0>] drm_ioctl+0x180/0x360 [drm]
[ 360.745093] [<f824eba0>] ? i915_gem_throttle_ioctl+0x0/0x70 [i915]
[ 360.745121] [<c02c4c4f>] ? security_file_permission+0xf/0x20
[ 360.745142] [<c01e463f>] ? rw_verify_area+0x5f/0xe0
[ 360.745157] [<c01e4a88>] ? rw_copy_check_uvector+0x78/0xf0
[ 360.745174] [<c01244f8>] ? default_spin_lock_flags+0x8/0x10
[ 360.745191] [<c015aaa5>] ? __remove_hrtimer+0x25/0x70
[ 360.745207] [<c015b303>] ? hrtimer_try_to_cancel+0x33/0x80
[ 360.745225] [<c0144b2e>] ? do_setitimer+0x23e/0x300
[ 360.745252] [<c01f1fa3>] vfs_ioctl+0x73/0x90
[ 360.745267] [<c01f2271>] do_vfs_ioctl+0x71/0x310
[ 360.745283] [<c0144c2b>] ? sys_setitimer+0x3b/0x90
[ 360.745297] [<c01f256f>] sys_ioctl+0x5f/0x80
[ 360.745312] [<c010334c>] syscall_call+0x7/0xb

Bryce Harrington (bryce) wrote :

Hi j, you mention that this bug occurs "using the latest Karmic" but that's a bit ambiguous - could you report if you have been using karmic and this regressed after a recent update, or if you've just upgraded from jaunty to karmic and are now seeing the problem, or if this is a first time install and you are just noticing the error now?

Please also run the command 'apport-collect 419328', which will attach some additional information which may be useful in analyzing the bug.

From what you've described, and your stack trace, this appears to be an X freeze bug. We have a recipe for debugging these issues. Please follow the directions on this guide to collect a Batchbuffer Dump:

https://wiki.ubuntu.com/X/Troubleshooting/Freeze#How%20to%20Get%20a%20Batchbuffer%20Dump%20%28-intel%20only%29

Also, the 2.8.1 driver was released last night, which allegedly contains fixes for some freeze bugs. We should have that available in Karmic within the next few days, so that would be worth testing as well. If it still occurs there in 2.8.1, then we can forward this bug upstream at that point.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
status: New → Incomplete
j^ (j) wrote : apport-collect data

Architecture: i386
DistroRelease: Ubuntu 9.10
MachineType: LENOVO 40684JG
NonfreeKernelModules: wl
Package: xserver-xorg-video-intel 2:2.8.0-0ubuntu2
PackageArchitecture: i386
PccardctlIdent:

PccardctlStatus:

ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-7-generic root=UUID=3964fa8c-ff06-41bb-ae6e-a55d04a8cf22 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-7.27-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu3
 libdrm2 2.4.12+git20090801.45078630-0ubuntu1
 xserver-xorg-video-intel 2:2.8.0-0ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090629.f39cafc5-0ubuntu6
Uname: Linux 2.6.31-7-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 11/19/2008
dmi.bios.vendor: LENOVO
dmi.bios.version: 14CN51WW
dmi.board.name: Kuril
dmi.board.vendor: Lenovo
dmi.board.version: Rev 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Lenovo
dmi.chassis.version: Rev 1.0
dmi.modalias: dmi:bvnLENOVO:bvr14CN51WW:bd11/19/2008:svnLENOVO:pn40684JG:pvrLenovo:rvnLenovo:rnKuril:rvrRev1.0:cvnLenovo:ct10:cvrRev1.0:
dmi.product.name: 40684JG
dmi.product.version: Lenovo
dmi.sys.vendor: LENOVO
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-7-generic

j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :

i upgraded the laptop longer ago and am testing support for external monitors from time to time, before it would happen that the external monitor was empty but the mouse worked and the laptop screen would have a scrambled image on the top part. with an update in the last days this degraded further to the problem described above. will test 2.8.1 once it hits the repository and let you know if anything changed.

j^ (j) wrote :

xranr with external monitor attached

j^ (j) wrote :

updated to new version. still same problem.
start laptop, login, attach external monitor, open configure display, hangs
attached xorg.log output after attaching monitor and opening configure displays

this was with
Linux atom 2.6.31-8-generic #28-Ubuntu SMP Thu Aug 27 14:43:30 UTC 2009 i686 GNU/Linux

xserver-xorg-video-intel
Version: 2:2.8.1-1ubuntu1

after 120 seconds i also get a backtrace in dmesg again
[ 5160.748389] INFO: task i915/0:834 blocked for more than 120 seconds...

j^ (j) wrote :

and the backtrace

pablomme (pablomme) wrote :

I have the same problem. Booting with the external screen attached is OK, and gnome-display-properties works fine. Attaching the screen once X has started and opening gnome-display-properties hangs the computer as described by j^.

Geir Ove Myhr (gomyhr) on 2009-08-29
tags: added: 945gme corruption dual-head karmic
summary: - attaching external monitor: laptop display shows corrupted desktop
+ [i945gme] attaching external monitor: laptop display shows corrupted
+ desktop
Download full text (3.1 KiB)

I recently updated to kernel 2.6.31-9.29 and xserver-xorg-video-intel 2:2.8.1-1ubuntu1 (from whatever karmic was about a month ago, which worked fine), and I'm seeing this deadlock as well (on a Thinkpad W500). I'm also seeing all kinds of display corruption (leftover shadows, images scrambled, etc), but I don't know if it's the same bug or not.

Below is the kernel dmesg output; the X server is locked up and unresponsive, but otherwise the machine is running (accessible via ssh over the network, for instance). I have an external VGA monitor attached. So far my machine has locked up twice in a few hours.

[ 5880.448104] INFO: task i915/0:874 blocked for more than 120 seconds.
[ 5880.448113] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 5880.448119] i915/0 D 00000000ffffffff 0 874 2 0x00000000
[ 5880.448131] ffff880134597d70 0000000000000046 0000000000000000 0000000000015580
[ 5880.448142] ffff8801348a3110 0000000000015580 0000000000015580 0000000000015580
[ 5880.448151] 0000000000015580 ffff8801348a3110 0000000000015580 0000000000015580
[ 5880.448161] Call Trace:
[ 5880.448180] [<ffffffff8151f617>] __mutex_lock_slowpath+0xd7/0x160
[ 5880.448190] [<ffffffff8151f516>] mutex_lock+0x26/0x50
[ 5880.448244] [<ffffffffa0060768>] i915_gem_retire_work_handler+0x38/0x90 [i915]
[ 5880.448272] [<ffffffffa0060730>] ? i915_gem_retire_work_handler+0x0/0x90 [i915]
[ 5880.448284] [<ffffffff8106e805>] run_workqueue+0x95/0x170
[ 5880.448292] [<ffffffff8106e984>] worker_thread+0xa4/0x120
[ 5880.448300] [<ffffffff81073b90>] ? autoremove_wake_function+0x0/0x40
[ 5880.448308] [<ffffffff8106e8e0>] ? worker_thread+0x0/0x120
[ 5880.448315] [<ffffffff810737a6>] kthread+0xa6/0xb0
[ 5880.448324] [<ffffffff8101308a>] child_rip+0xa/0x20
[ 5880.448331] [<ffffffff81073700>] ? kthread+0x0/0xb0
[ 5880.448338] [<ffffffff81013080>] ? child_rip+0x0/0x20
[ 5880.448365] INFO: task Xorg:3092 blocked for more than 120 seconds.
[ 5880.448369] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 5880.448374] Xorg D 0000000000000000 0 3092 3085 0x00400004
[ 5880.448384] ffff88012bc73cb8 0000000000000086 ffff88012bc73c90 0000000000015580
[ 5880.448394] ffff88012c9d1a60 0000000000015580 0000000000015580 0000000000015580
[ 5880.448403] 0000000000015580 ffff88012c9d1a60 0000000000015580 0000000000015580
[ 5880.448413] Call Trace:
[ 5880.448422] [<ffffffff8151f617>] __mutex_lock_slowpath+0xd7/0x160
[ 5880.448432] [<ffffffff814205b0>] ? sock_aio_write+0x0/0x150
[ 5880.448440] [<ffffffff8151f516>] mutex_lock+0x26/0x50
[ 5880.448467] [<ffffffffa0060a56>] i915_gem_throttle_ioctl+0x36/0x90 [i915]
[ 5880.448507] [<ffffffffa0026cae>] drm_ioctl+0x17e/0x3a0 [drm]
[ 5880.448537] [<ffffffff81032439>] ? default_spin_lock_flags+0x9/0x10
[ 5880.448547] [<ffffffff815208da>] ? _spin_lock_irqsave+0x2a/0x40
[ 5880.448557] [<ffffffff81128e2c>] vfs_ioctl+0x7c/0xa0
[ 5880.448566] [<ffffffff811293f9>] do_vfs_ioctl+0x79/0x370
[ 5880.448574] [<ffffffff81129771>] sys_ioctl+0x81/0xa0
[ 5880.448585] [<ffffffff81011fc2>] system_call_fastpath+0x16/0x1b

... and the same message continues every 120 secon...

Read more...

Bryce Harrington (bryce) wrote :

Thank you for the additional files, however I still don't quite understand the problem description. Please provide exact steps to reproduce the problem and if possible a photo of the monitor showing the corruption you're seeing.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
j^ (j) wrote :

Bryce, i don't see any corruption, but just get a black screen, to reproduce:
* disconnect external screen
* open gnome-display-properties
* press detect displays
* connect external screen
* press detect displays
* get two black screens, frozen mouse pointer on external screen
here a video: http://videobin.org/+dr/g5.html
and a photo of the black screens: http://oil21.org/~j/ubuntubugs/bug_419328.jpg

Bryce Harrington (bryce) wrote :

Oh sorry, it was nickolai who mentioned display corruption, and his comment confused me. nickolai - because your symptoms don't match j^'s you probably have some other unrelated bug that should be reported separately.

Bryce Harrington (bryce) wrote :

j^ - hmm I also notice the title of this bug mentions "corrupted desktop". Is that an incorrect title for this bug?

nickolai (nickolai) wrote :

The primary reason I wrote my comment was because I observed my X server hanging. Indeed, the reason I found this bug was because I get the same stack trace in dmesg showing where the deadlock occurs.

It is not known to me whether display corruption is related or not, and in my first comment, I indicated that it might or might not be the same bug. If it's makes things easier, let's ignore the display corruption and assume it's unrelated.

j^ (j) wrote :

ok, changed title, i had corruption earlier but with the latest version i only get a black screen.

summary: - [i945gme] attaching external monitor: laptop display shows corrupted
- desktop
+ [i945gme] attaching external monitor: laptop display is black, external
+ monitor too, with frozen mouse coursor
Bryce Harrington (bryce) wrote :

j^ - Thanks for the steps to reproduce. I've forwarded this bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=23718 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

From your additional information it looks like this may be an "X Freeze" bug. Some additional debug steps are available for this class of issue: https://wiki.ubuntu.com/X/Troubleshooting/Freeze#How%20to%20Get%20a%20Batchbuffer%20Dump%20(-intel%20only)

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Triaged
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
pablomme (pablomme) wrote :

This is still an issue as of the current karmic (25-sept-2009, with xserver-xorg-video-intel 2:2.8.1-1ubuntu1).

j^ (j) wrote :

from upstream bug:
Compiz fusion is required to reproduce this. Unfortunately it's enabled by
default in Karmic. Disabling Compiz fusion or even using Compiz core (like
default in Fedora 11) doesn't have this problem.

anything that can be done to track down the problem?

pablomme (pablomme) wrote :

I can confirm that running "metacity --replace", switching screens, and running "compiz --replace" serves as a workaround, proving that compiz[-fusion] is involved in/causing the problem.

Miguel Ramiro (mike.longbow) wrote :

I can confirm this behavior running on an Aspire One (Intel Corporation Mobile 945GME Express Integrated Graphics Controller) with xserver-xorg-video-intel 2:2.9.0-1ubuntu1 and compiz 1:0.8.3+git20091005-0ubuntu5.

As mentioned above, disabling compiz allows me to get into the screen configuration dialog, though the "detect monitors" button doesn't seem to work after this.

Baard Johansen (baard) wrote :

I also can confirm this on a Fujitsu Siemens V3205. The laptop only has one DVI socket for external monitors, and the problem only occurs when I connect the using a DVI to VGA adapter. Connecting with DVI works great.

Franck (alci) wrote :
Download full text (3.9 KiB)

Hi,

I encounter the same problem on a Sony Vaio (SZ4MN) with i945GM.

lspci -v

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
 Subsystem: Sony Corporation Device 81e6
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at f8300000 (32-bit, non-prefetchable) [size=512K]
 I/O ports at 1800 [size=8]
 Memory at d0000000 (32-bit, prefetchable) [size=256M]
 Memory at f8400000 (32-bit, non-prefetchable) [size=256K]
 Capabilities: <access denied>
 Kernel driver in use: i915
 Kernel modules: i915

The output in /var/log/message is :

Oct 13 09:42:05 franck-laptop kernel: [ 447.870056] i2c-adapter i2c-1: unable
to read EDID block.
Oct 13 09:42:05 franck-laptop kernel: [ 447.870061] i915 0000:00:02.0:
LVDS-1: no EDID data
Oct 13 09:42:05 franck-laptop kernel: [ 447.911682] [drm] TV-12: set mode
NTSC 480i 0
Oct 13 09:42:05 franck-laptop kernel: [ 448.054970] [drm] TV-12: set mode
NTSC 480i 0
Oct 13 09:42:05 franck-laptop kernel: [ 448.303017] [drm] DAC-6: set mode 17
Oct 13 09:42:05 franck-laptop kernel: [ 600.630104] i915/1 D
0000000000000000 0 356 2 0x00000000
Oct 13 09:42:05 franck-laptop kernel: [ 600.630114] ffff8800798fdd70
0000000000000046 0000000000000000 0000000000015580
Oct 13 09:42:05 franck-laptop kernel: [ 600.630123] ffff88007a3347c0
0000000000015580 0000000000015580 0000000000015580
Oct 13 09:42:05 franck-laptop kernel: [ 600.630131] 0000000000015580
ffff88007a3347c0 0000000000015580 0000000000015580
Oct 13 09:42:05 franck-laptop kernel: [ 600.630139] Call Trace:
Oct 13 09:42:05 franck-laptop kernel: [ 600.630154] [<ffffffff81523387>]
__mutex_lock_slowpath+0xd7/0x160
Oct 13 09:42:05 franck-laptop kernel: [ 600.630161] [<ffffffff81523286>]
mutex_lock+0x26/0x50
Oct 13 09:42:05 franck-laptop kernel: [ 600.630201] [<ffffffffa00a08d8>]
i915_gem_retire_work_handler+0x38/0x90 [i915]
Oct 13 09:42:05 franck-laptop kernel: [ 600.630223] [<ffffffffa00a08a0>] ?
i915_gem_retire_work_handler+0x0/0x90 [i915]
Oct 13 09:42:05 franck-laptop kernel: [ 600.630232] [<ffffffff8106f725>]
run_workqueue+0x95/0x170
Oct 13 09:42:05 franck-laptop kernel: [ 600.630239] [<ffffffff8106f8a4>]
worker_thread+0xa4/0x120
Oct 13 09:42:05 franck-laptop kernel: [ 600.630246] [<ffffffff81074ab0>] ?
autoremove_wake_function+0x0/0x40
Oct 13 09:42:05 franck-laptop kernel: [ 600.630252] [<ffffffff8106f800>] ?
worker_thread+0x0/0x120
Oct 13 09:42:05 franck-laptop kernel: [ 600.630258] [<ffffffff810746c6>]
kthread+0xa6/0xb0
Oct 13 09:42:05 franck-laptop kernel: [ 600.630266] [<ffffffff8101308a>]
child_rip+0xa/0x20
Oct 13 09:42:05 franck-laptop kernel: [ 600.630272] [<ffffffff81074620>] ?
kthread+0x0/0xb0
Oct 13 09:42:05 franck-laptop kernel: [ 600.630278] [<ffffffff81013080>] ?
child_rip+0x0/0x20
Oct 13 09:42:05 franck-laptop kernel: [ 600.630307] Xorg D
0000000000000000 0 1110 1085 0x00400004
Oct 13 09:42:05 franck-laptop kernel: [ 600.630315] ffff880076debcb8
0000000000000082 ffff880076debc90 0000000000015580
Oct 13 09:42:05 franck-laptop kernel: [ 600.630323] ffff880076dc9a60
0000000000015580 0000000000015580 00000...

Read more...

Rob Frohne (frohro) wrote :

I also observe this bug with my Dell D610 Intel 915GM video. It doesn't happen if I turn off visual effects, or if I boot up with the display connected as noted above. It happens with xrandr as well as with the gnome-display-properties applet.

Rob Frohne (frohro) wrote :

I also note that turning on visual effects after switching to a 1400x1050 on LVCD and 1680x1050 for the VGA, it freezes identically as far as I can tell to when I try it with visual effects enabled in the first place. However, it works fine if I boot up with both connected and visual effects enabled.

Rob Frohne (frohro) wrote :

If I turn off the VGA in the Display preferences and then turn on visual effects, everything is okay.

j^ (j) wrote :

with the release of karmic coming up fast, is there anything that can be done to fix this issue.
is it possible to switch to metacity for graphic cards that are known to fail with compiz,
once an external monitor is attached?

Ron Bentley (rtbentley) wrote :

I'll add a "me, too."

HP Mini 110 (Intel 945GME) freezes (as in, I have to reboot) under these conditions: 1) I begin displaying to an external monitor in the Display Preferences, 2) while running Compiz. Both screens go black, and the circular "busy" icon is split between the two screens.

This is a regression. It worked fine under UNR 9.04. Test was run after a complete update of Karmic on 24-Oct-2009.

Eduard Carcole (ecarcole) wrote :

I posted this in the duplicate bug by mistake.... sorry!

I have the same problem in a Packard Bell easy note under Ubuntu 9.10 amd64.

I provide the following outputs:

lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

lshw

description: Computer
    width: 64 bits
    capabilities: vsyscall64 vsyscall32
  *-core
       description: Motherboard
       physical id: 0
     *-memory
          description: System memory
          physical id: 0
          size: 2038MiB
     *-cpu
          product: Intel(R) Core(TM)2 CPU T5600 @ 1.83GHz
          vendor: Intel Corp.
          physical id: 1
          bus info: cpu@0
          size: 996MHz
          capacity: 996MHz
          width: 64 bits
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall x86-64 constant_tsc arch_perfmon pebs bts rep_good pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm tpr_shadow cpufreq
     *-pci
          description: Host bridge
          product: Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub
          vendor: Intel Corporation
          physical id: 100
          bus info: pci@0000:00:00.0
          version: 03
          width: 32 bits
          clock: 33MHz
          configuration: driver=agpgart-intel
          resources: irq:0
        *-display:0
             description: VGA compatible controller
             product: Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 03
             width: 32 bits
             clock: 33MHz
             capabilities: bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:16 memory:a6280000-a62fffff ioport:60c0(size=8) memory:90000000-9fffffff(prefetchable) memory:a6300000-a633ffff
        *-display:1 UNCLAIMED
             description: Display controller
             product: Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2.1
             bus info: pci@0000:00:02.1
             version: 03
             width: 32 bits
             clock: 33MHz
             capabilities: bus_master cap_list
             configuration: latency=0
             resources: memory:a6200000-a627ffff

Eduard Carcole (ecarcole) wrote :

I am using a Panasonic CF-R8 to carry out presentations in my business trips.
When I use a secondary monitor with Ubuntu 9.10 amd64, if I connect a secondary monitor, I get all icons changed and I can not get mirror screens. If I restart the computer with the secondary monitor connected to the computer, I am able to make it work properly after switching screens several times using the keyboard (fn+f3 in my computer).

I provide the following:

lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

lshw

    description: Computer
    width: 64 bits
    capabilities: vsyscall64 vsyscall32
  *-core
       description: Motherboard
       physical id: 0
     *-memory
          description: System memory
          physical id: 0
          size: 1964MiB
     *-cpu
          product: Intel(R) Core(TM)2 Duo CPU U9300 @ 1.20GHz
          vendor: Intel Corp.
          physical id: 1
          bus info: cpu@0
          size: 800MHz
          capacity: 800MHz
          width: 64 bits
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx x86-64 constant_tsc arch_perfmon pebs bts rep_good pni dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 lahf_lm ida tpr_shadow vnmi flexpriority cpufreq
     *-pci
          description: Host bridge
          product: Mobile 4 Series Chipset Memory Controller Hub
          vendor: Intel Corporation
          physical id: 100
          bus info: pci@0000:00:00.0
          version: 07
          width: 32 bits
          clock: 33MHz
          configuration: driver=agpgart-intel
          resources: irq:0
        *-display:0
             description: VGA compatible controller
             product: Mobile 4 Series Chipset Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 07
             width: 64 bits
             clock: 33MHz
             capabilities: bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:28 memory:f0000000-f03fffff memory:e0000000-efffffff(prefetchable) ioport:e1c0(size=8)
        *-display:1 UNCLAIMED
             description: Display controller
             product: Mobile 4 Series Chipset Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2.1
             bus info: pci@0000:00:02.1
             version: 07
             width: 64 bits
             clock: 33MHz
             capabilities: bus_master cap_list
             configuration: latency=0
             resources: memory:f0400000-f04fffff

A file with Xorg.0.log is uploaded

May be this bug should be considered more important.

pablomme (pablomme) wrote :

@Edward: it looks like your problem is different. In this bug, attempting to switch screens freezes the computer, it's not just not being able to choose mirror/extend. You should report a new bug.

pablomme (pablomme) wrote :

@Eduard (not Edward, sorry): I was talking about your second report. The first one does look like this bug.

Eduard Carcole (ecarcole) wrote :

Thank you Pablomme. I already submitted a new bug report. Sorry for my mistake.

Steve Williams (sixw) wrote :

I can confirm that the problem also goes away if all the desktop effects are removed, i.e. set to none. I only had normal enabled before on my 945GME, and observed the problem, so must be something with that setting.

mtheripper (magatheripper) wrote :

I can conform the same that Steve Williams wrote above.
Disable the desktop effects will prevent from freezing.

Eduard Carcole (ecarcole) wrote :

Same here. If desktop effects are removed in my Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) it works.
It is great to be able to use the external monitor again!

MatchkeY (matchkey) wrote :

I have the same issue, both with and without desktop effects.

X locks up but the mouse is still working. Can SSH to the machine from another machine.

See attached files for info.

MatchkeY (matchkey) wrote :

2nd attachment

MatchkeY (matchkey) wrote :

third attachment

MatchkeY (matchkey) wrote :

fourth attachment

HannesB (hannesb) wrote :

Reproduced on EEEPC 1000H (same GPU)
gnome-display-properties -> crash
You can even crash it by just typing
"xrandr" in a console after plugging in an external screen.
Screens get black and the mouse pointer is visible but stucked.

Tried with a shorter VGA-cable:
gnome-display-properties: X-Server does not crash, both screens get black, it chooses
a side by side desktop view (also i didnt tell him), i can move mouse from the left to the right, no desktop elements accessible, but on the left
corner I can see a 2-3 pixel wide stripe of my desktop but I cannot access anything,

after that I can recover with my self-configured hotkey: xrandr --output LVDS1 --auto --output VGA1 --off
Then I find the propperties and can configure it correctly either by th GUI or by another xrandr call

typing xrandr after reboot,plugging in results also in those two black screens

After having the screen succesfully set up once, I can reconnect it as often as I like

My questiones:
-why does my system change the screen setup without me asking it to do so????
-why does my system crash if the VGA-Cable is too long (and it maybe cannot read monitor settings propperly?)

I hope to have given some hints...
9.04 just worked perfectly....

Dimitrios Symeonidis (azimout) wrote :

Can someone please confirm that disabling compiz (or mutter, or anything other than metacity) makes the problem go away?

Thank you

sam tygier (samtygier) wrote :

yes. with plain metacity i get no crash and can set up a span across 2 screens.

if i then open glxgears, that runs, until i enlarge the window across the full width. then x crashes

HannesB (hannesb) wrote :

--Can someone please confirm that disabling compiz (or mutter, or anything other than metacity) makes the --problem go away?

For me it works better without compiz, but...
Activating the external screen with my self-configured hotkey does not work the first time after reboot (false resolution or black screen with movable mouse), i have to press it twice, but after that i can connect / disconnect my external screen, change resolution etc. without any problems.

Having desktop effects enabled is similar: depending on the external screen that I connect(!) the system crashes or is just not working after the first try, but can be activated with the second try and after that it is also working flawlessly...

Dennis van Dok (dvandok-gmail) wrote :

reply to comment #62:

Here is what I did:
- booted up with VGA cable disconnected from laptop
- logged in as ordinary user
- turned off visual effects in preferences
- killed compiz-decorator process (not sure this step is necessary)
- connected the VGA cable
- ran xrandr --auto: this went OK (no crash)
- ran display prefs to use dual-head mode; this went fine.
- removed the VGA cable
- logged off then on again
- turned on visual effects
- connected the cable
- ran display preferences and X crashed (black screens, external screen is on, it is showing an immobile mouse pointer in the left middle). No response whatsoever to keyboard, mouse or touchpad. I Had to powercycle the machine.

Note: I can use compiz in dual head mode, I just need to connect the VGA cable prior to the start of the X server.

MarkS (mark-marksyms) wrote :

Mutter has the same problem, so it's not a compiz issue, looks like a COMPOSITE extension issue.

irve (jaagup-irve) wrote :

Please read a duplicate: https://bugs.launchpad.net/bugs/438000

The issue was best summarized by dhenry:

"The problem is that "xrandr" and "gnome-display-properties" will
systematically setup the external monitor next to the LVDS, without
checking if it's possible. Those tools should not do this if hardware
does not allow it. The problem is that those tools are not aware that
compiz is running (which reduces the hardware limit to 2048x2048), and
so try to create the too large frame buffer (which is legal without
compiz)."

MarkS (mark-marksyms) wrote :

That's all well and good, so we know the root cause. However things should still fail more gracefully than hard locking the video output of the machine. Refusing to accept the new frame buffer would be a good start.

alcCapone (alcc) wrote :

Confirming that Disabling Compiz and temporarily using metacity for attaching the monitor makes the problem go away!

MarkS (mark-marksyms) wrote :

It seems pretty clear that the problem is that arandr, gnome-display-properties et. al. are requesting display sizes that are bigger than the maximum texture size that can be supported by the i945gme chipset. The problem really needs to be fixed in at least two places though, the tools shouldn't request sizes that are bigger than the maximum texture size compiz will be able to obtain, compiz should be guarded to make sure it doesn't request oversize textures and fallback gracefully and the driver shouldn't lock hard if it is requested to provide a texture size bigger than it supports. Defence is depth is required otherwise this can be used to DOS a machine even if the userland tools are fixed up.

inkhorn (matt-dubins) wrote :

I also have this problem (using a laptop with an Intel GMA 945 graphics controller). I can confirm that no crash happens with the following sequence:

Boot laptop with external monitor unplugged,
Disable visual effects,
Plug in the monitor,
Type "xrandr --auto" in Terminal,
Go to Display Prefs,
Turn laptop monitor off,
Keep external monitor on/Set external monitor to max resolution,
Fini!

Now how can I get the external monitor plugged in without having to go through this process?

inkhorn (matt-dubins) wrote :

Addendum to previous note: I'm using Ubuntu 9.10

DenisP (denisp) wrote :

I can confirm this problem on my laptop with Intel GMA 945 on ubuntu 9.10. If I connect external monitor and set up both monitors on in side by side configuration X11 crashes. Mouse cursors are displayed on both monitors but system is not responsive, keyboard and mouse don't work so nothing can be done but switch off the laptop by pressing the power button, all other display combinations work. In prior versions of ubuntu I had no such problem.

It is very huge problem for me because the new version of gnome-settings-daemon 2.28.1-0ubuntu2 automatically switches external monitor on together with internal monitor in side by side configuration when display settings application is started or when "xrandr" command is run and this side by side configuration crashes the system.

Rob Frohne (frohro) wrote :

Great Mathieu! Thanks!

A note for those of you like myself, who are having problems with the link Mathieu gave us. Just enable proposed updates in Software Sources and check for new updates and they are there!

Thanks again to everyone who brought this fix to fruition.

Rob

Marek Kawczynski (mkawczynski) wrote :

Fix proposed in PPA didn't help me. Still same behaviour - black screen with mouse cursor after connecting external monitor or after closing lid. Could anyone confirm that fixed package from PPA is working on Intel 945GM Express Card? Should I use also kernel newer then 2.6.31-15?

Marek

MarkS (mark-marksyms) wrote :

The changelog in the PPA only mentions crashes with wobbly windows and multi-screen. I think that is something different. I don't have wobbly windows enabled and this seems to purely be a texture size issue.

Eduard Carcole (ecarcole) wrote :

I had this problem in a Packard Bell easy note under Ubuntu 9.10 amd64 with an Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03).
I installed the pre-released updates and I can confirm the problem has been solved at least for my computer.
Thank you all for your work!!!!

HannesB (hannesb) wrote :

Not fixed for me, still crashing. (EEEPC 1000H)

MarkS (mark-marksyms) wrote :

Still crashing on Samsung N110 as well and killing th X server from an ssh session causes a hard kernel lock.

oudalrich (uhkeller) wrote :

Still crashing for me on a Lenovo T60 with the symptoms described in the original bug report.
I used the updates in proposed. If you want to test them, but don't want to install all updates in proposed, do the following:

In a terminal, run:
gksudo gedit /etc/apt/preferences

Copy this into the editor window and save:
Package: *
Pin: release a=karmic-proposed
Pin-Priority: 400

In a terminal, run:
sudo aptitude install -t karmic-proposed compiz compiz-core compiz-gnome compiz-plugins compiz-wrapper libdecoration

Reboot, attach monitor, and be happy. Or not, like me.

oudalrich (uhkeller) wrote :

What I forgot in #81: you have to enable "Pre-released updates (karmic-proposed)" in Software Sources/Updates and reload the information about available software before running the "sudo aptitude..." line in terminal.

pablomme (pablomme) wrote :

Doesn't work for me either. Neither the packages from the compiz PPA nor those in karmic-proposed fix the problem.

Mathieu Marquer (slasher-fun) wrote :

OK so... it was working yesterday (yup, I was able to have dual screen with compiz enable using Fn+F4 on my Samsung NC10), but today it crashes again... Sorry.

inkhorn (matt-dubins) wrote :

I also got the compiz updates from karmic-proposed yet the crash is still happening when I try to detect my external monitor. Sigh...

alcCapone (alcc) wrote :

I'm on an X60s with an Intel 945GM and when I go to "Configure Display Settings" the problem is *not* fixed.

sam tygier (samtygier) wrote :

An Intel dev upstream suggests working around this in compiz. I am not sure is a proper solution, but it would reduce the number of crashes.

Id2ndR (id2ndr) wrote :

I got this message in dmesg on my server running Ubuntu desktop 9.10. The server has currently no attached display and has reboot 2 hours ago (latest linux update). Metacity is running on the server (no compiz), and there is an automatic gdm login (I use it sometime as a mediacenter).

Id2ndR (id2ndr) wrote :

The load of the server is 2 : it seems there was 2 crashes in the dmesg, and the server is idle.

Id2ndR (id2ndr) wrote :

This may be a duplicate of Bug #451518

pablomme (pablomme) wrote :

@Id2ndR: your problem doesn't sound like this bug.

th3darkang3l (th3darkang3l) wrote :

This <a href="https://bugs.launchpad.net/ubuntu/+source/linux/+bug/465318">Bug #465318</a> could be a duplicate of this problem

jadorno (javier-adorno) wrote :

I have the same problem with and Aspire One D250 and I totally agree that xrandr should avoid going further than the capacity of the driver.

This is the way I managed to avoid hangups without enabling and disabling compiz

I've created three custom keyboard shortcuts to diferent xrandr configurations

1. super+F1 calls --> xrandr --output LVDS1 --mode 1024x600 --output VGA1 --off
2. super+F2 calls --> xrandr --output LVDS1 --off --output VGA1 --mode 1440x900
3. super+F3 calls --> xrandr --output LVDS1 --mode 1024x600 --output VGA1 --mode 800x600 --right-of LVDS1

1. Is my internal LCD only config
2. Is my external LCD only config
3. Is a dual head config for projector use that can be further modified by using the display-configuration applet

ManDay (manday) wrote :

Confirmed for Karmic 9.10 on an ASUS EEE PC 1000h with Intel GMA 950.

Happens exactly as described (both screens turn black with mousepointer frozen near in-between) when either pressing Fn+F8 shortcut combo or opening Preferences > Display.

Only seems to happen, when trying to ACTIVATE the external screen. It doesn't seem to affect deactivating it.
Only seems to happen, when the external screen hasn't been plugged in on boot (not resume!), too, though.

Doughy (doughywilson) wrote :

I am having a very similar problem, only my screen does not go black. Instead, my screen freezes the exact image that was up when the crash occurs. The problem is recreated in the exact same way as described by others, plugging in a VGA cable and attempting to activate the external screen.

I did try booting with the cable already inserted, but this did not remedy the problem.

Aethex (aethex) wrote :

Can confirm on Asus EeePC 1005HA, Intel 945 GME (I think). Black screen, busy cursor stuck in between. TTYs don't work, nor do hotkeys. It worked fine in Jaunty.

Could this be fixed by reverting to the Jaunty graphics driver, if possible? What else has changed in the transition from Jaunty to Karmic for Intel users?

Doughy: that doesn't sound like this bug. Which chipset do you have? (use lspci | grep VGA)

Also, I use a Belkin KVM between my Asus and primary machine, and sometimes, Karmic doesn't even recognize my monitor. It is an LG, with a resolution of 1280 x 1024, but sometimes the closest match is something like 1178x900, a smidge smaller and distorted. Is this related to X? Should I file a new bug?

Doughy (doughywilson) wrote :

Aethex, my chipset is "Intel GM965/GL960 Integrated Graphics Controller"

wolfi (lammer-wolfgang) wrote :

Having the problem using QBOX-N270 running ubuntu-karmic: (fresh installed -no upgrade from jaunty)
2.6.31-15-generic #50-Ubuntu SMP Tue Nov 10 14:54:29 UTC 2009 i686
Only one display; It seems to occur when waking up from display-idle-state.

[<c056fd66>] __mutex_lock_slowpath+0xc6/0x130
[<c056fc80>] mutex_lock+0x20/0x40
[<f814ac0a>] i915_gem_retire_work_handler+0x2a/0x70 [i915]
[<c0157a7e>] run_workqueue+0x6e/0x140
[<f814abe0>] ? i915_gem_retire_work_handler+0x0/0x70 [i915]
[<c0157bd8>] worker_thread+0x88/0xe0
[<c015c280>] ? autoremove_wake_function+0x0/0x40
[<c0157b50>] ? worker_thread+0x0/0xe0
[<c015bf8c>] kthread+0x7c/0x90
[<c015bf10>] ? kthread+0x0/0x90
[<c0104007>] kernel_thread_helper+0x7/0x10
Xorg D c08145c0 0 942 926 0x00400004
ee29be28 00003082 f68e2000 c08145c0 f6bf6718 c08145c0 65f6c883 00023c9f
c08145c0 c08145c0 f6bf6718 c08145c0 00000000 00023c9f c08145c0 f6b8ca80
f6bf6480 f688b414 f688b418 ffffffff ee29be54 c056fd66 ee29be44 f688b41c
Call Trace:
[<c056fd66>] __mutex_lock_slowpath+0xc6/0x130
[<c056fc80>] mutex_lock+0x20/0x40
[<f814ae8b>] i915_gem_throttle_ioctl+0x2b/0x70 [i915]
[<f80cc6c0>] drm_ioctl+0x180/0x360 [drm]
[<f814ae60>] ? i915_gem_throttle_ioctl+0x0/0x70 [i915]
[<c010b16a>] ? restore_i387_xstate+0xda/0x210
[<c02c7f8f>] ? security_file_permission+0xf/0x20
[<c01f51b3>] vfs_ioctl+0x73/0x90
[<c01f5481>] do_vfs_ioctl+0x71/0x310
[<c0102771>] ? restore_sigcontext+0xc1/0xe0
[<c01f577f>] sys_ioctl+0x5f/0x80
[<c010336c>] syscall_call+0x7/0xb

ManDay (manday) wrote :

This bug certainly affects more than just 31 people and is pretty severe, it should be fixed asap.

pablomme (pablomme) wrote :

I've attached a little script I'm using to switch outputs without having compiz trigger this bug. It does so by disabling compiz, switching outputs, then re-enabling compiz.

Download the script, make it executable and (optionally) place it in your path. Usage examples:
  rnr_switch VGA1 # switch from the current output to the external monitor
  rnr_switch VGA1:1280x1024@75 # as above, but using a custom resolution and refresh rate
  rnr_switch LVDS1 # switch from the current output back to the laptop panel
With the 'commands' compiz plugin (for which you will need to install compizconfig-settings-manager) you can associate key combinations with the execution of any of the above commands. See the comments at the top of the script for more info.

Note that this script can only be used to turn one output on and the other one off. It wouldn't be difficult to make it do output cloning as well, but at present it just doesn't.

Needless to say, this script is a temporary, incomplete hack around this bug, but it does its job.

mag (mg5) wrote :

Confirmed for Karmic 9.10 on an ASUS EEE PC 1000he / Intel GMA 950.

It only happens when Monitor hasn't been plugged in at boot time. Sometimes I can avoid it by switching Fn-F8 into mirror both screens. Using gnome-display-manager after that works fine in most cases - any resolution.

Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
MikeCamel (mike-hingston) wrote :

Took proposed, same problem shown on Toshiba NB200-12B, with Intel 945GME. metacity --replace, then compiz --replace works.

MikeCamel (mike-hingston) wrote :

Also, turning off desktop effects fixes the problem.

Geir Ove Myhr (gomyhr) wrote :

The fix mentioned upstream (https://bugs.freedesktop.org/show_bug.cgi?id=23718) in comment #37 is included in the mesa version in the x-updates PPA (https://launchpad.net/~ubuntu-x-swat/+archive/x-updates/+packages?field.name_filter=&field.status_filter=published&field.series_filter=karmic). However, as noted upstream, rendering will slow down to a slideshow in mesa 7.6. The current plan is to ship mesa 7.7 in Lucid and it should work better there.

MikeCamel (mike-hingston) wrote :

Just a note that this affects gnome-shell, too. Given that this is very, very alpha, I suspect that noone cares at this point, but I thought I'd record it.

Starting display-manager with desktop effects off, and then starting gnome-shell works fine.

nanotube (nanotube) wrote :

So, what's the current status of this bug? It is marked as a 'fix released' - does that mean it is coming to the karmic repositories any time soon?

papukaija (papukaija) wrote :

@nanotube: This bug is fixed upstream (in xserver-xorg-video-intel), but not yet in Ubuntu.

alcCapone (alcc) wrote :

Does "not yet" mean it's going to make it into the Karmic repositories - before Lucid is out?

Don'T know whether this is of any relevance but I've talked to some guys on #ubuntu-x IRC channel and they asserted that, since the patch is based on a new MESA which will cause graphics - 3D only, if I got it correctly - to slow down to a horrid framerate.

On 25.01.2010 15:51, alcCapone wrote:
> Does "not yet" mean it's going to make it into the Karmic repositories -
> before Lucid is out?
>

Hendrik Grahl (grahl) wrote :

I still encounter this issue on lucid with xserver-xorg-video-intel-2.9.1-1ubuntu5 and mesa7.7-0ubuntu8 with an Intel '945GM/GMS/GME, 943/940GML Express'.

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x3b) [0x80e876b]
1: /usr/bin/X (0x8048000+0x61a1d) [0x80a9a1d]
2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb55410]
3: /usr/lib/dri/i915_dri.so (0xef4000+0x208a16) [0x10fca16]
4: /usr/lib/dri/i915_dri.so (_mesa_execute_program+0x2a2d) [0x103a63d]
5: /usr/lib/dri/i915_dri.so (_swrast_exec_fragment_program+0x1a4) [0x10fccb4]
6: /usr/lib/dri/i915_dri.so (0xef4000+0x16558f) [0x105958f]
7: /usr/lib/dri/i915_dri.so (_swrast_write_rgba_span+0xd40) [0x105a9b0]
8: /usr/lib/dri/i915_dri.so (0xef4000+0x17ebb2) [0x1072bb2]
9: /usr/lib/dri/i915_dri.so (0xef4000+0x15920f) [0x104d20f]
10: /usr/lib/dri/i915_dri.so (_swrast_Triangle+0x2d) [0x104c41d]
11: /usr/lib/dri/i915_dri.so (0xef4000+0x18b39f) [0x107f39f]
12: /usr/lib/dri/i915_dri.so (0xef4000+0x18b3e5) [0x107f3e5]
13: /usr/lib/dri/i915_dri.so (0xef4000+0x124d37) [0x1018d37]
14: /usr/lib/dri/i915_dri.so (0xef4000+0x126389) [0x101a389]
15: /usr/lib/dri/i915_dri.so (_tnl_run_pipeline+0x163) [0x100e103]
16: /usr/lib/dri/i915_dri.so (0xef4000+0x718cd) [0xf658cd]
17: /usr/lib/dri/i915_dri.so (_tnl_draw_prims+0xc66) [0x100ee46]
18: /usr/lib/dri/i915_dri.so (_tnl_vbo_draw_prims+0x79) [0x100f279]
19: /usr/lib/dri/i915_dri.so (vbo_exec_vtx_flush+0x5f4) [0x1007364]
20: /usr/lib/dri/i915_dri.so (vbo_exec_FlushVertices_internal+0x3a) [0x100323a]
21: /usr/lib/dri/i915_dri.so (vbo_exec_FlushVertices+0x50) [0x10032f0]
22: /usr/lib/dri/i915_dri.so (_mesa_MatrixMode+0x181) [0xfc7ed1]
23: /usr/lib/xorg/modules/extensions/libglx.so (0x317000+0x8d19) [0x31fd19]
24: /usr/lib/xorg/modules/extensions/libglx.so (0x317000+0x323f4) [0x3493f4]
25: /usr/lib/xorg/modules/extensions/libglx.so (0x317000+0x36c6e) [0x34dc6e]
26: /usr/bin/X (0x8048000+0x2a3a7) [0x80723a7]
27: /usr/bin/X (0x8048000+0x1ed4a) [0x8066d4a]
28: /lib/tls/i686/cmov/libc.so.6 (__libc_start_main+0xe6) [0x1d9bd6]
29: /usr/bin/X (0x8048000+0x1e931) [0x8066931]
Segmentation fault at address (nil)
Caught signal 11 (Segmentation fault). Server aborting

sam tygier (samtygier) wrote :

just tested in lucid.
on pluging in an external monitor, and pressing detect monitor, the new display is detected, and the screen spans across it. compiz seems to automatically fall back to metacity. apart from loss of desktop effects everything carries on working. no crash.

if i run glxgears, and then resize its window, after it passes a certain width the display of the gears is corrupted. but there is no crash.

seems that the freeze is fixed for me

Bryce Harrington (bryce) on 2010-03-02
summary: - [i945gme] attaching external monitor: laptop display is black, external
- monitor too, with frozen mouse coursor
+ [i945] [i945gme] attaching external monitor: laptop display is black,
+ external monitor too, with frozen mouse coursor
Bryce Harrington (bryce) on 2010-03-02
summary: - [i945] [i945gme] attaching external monitor: laptop display is black,
- external monitor too, with frozen mouse coursor
+ [i945gme] attaching external monitor: laptop display is black, external
+ monitor too, with frozen mouse coursor
Chris Conatser (sbquatre) wrote :

Just wanted to post a quick workaround that works on my HP Pavilion dv1648 laptop (two 1280x768 displays): when I leave the monitor configuration as side-by-side, per default, it crashes with all the usual symptoms described above. However, if I reconfigure to show one monitor as being above the other BEFORE trying to apply dual display, it works just fine. I assume that this means 1536 is within the limits of the video card; 2560 is not. This may make, for example, setting up a projector a little quicker than the metacity workaround, for those who like to stick to Compiz.

This bug appears to be fixed after updating to 2.6.31-20-generic #58-Ubuntu yesterday, about 4 hours use so far and no lockups yet.

lspci:
00:00.0 Host bridge: Intel Corporation 82830 830 Chipset Host Bridge (rev 04)
00:02.0 VGA compatible controller: Intel Corporation 82830 CGC [Chipset Graphics Controller] (rev 04)
00:02.1 Display controller: Intel Corporation 82830 CGC [Chipset Graphics Controller]
00:1d.0 USB Controller: Intel Corporation 82801CA/CAM USB Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 42)
00:1f.0 ISA bridge: Intel Corporation 82801CAM ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801CAM IDE U100 Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801CA/CAM SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801CA/CAM AC'97 Audio Controller (rev 02)
01:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 80)
01:00.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 80)
01:01.0 Communication controller: Conexant Systems, Inc. HCF 56k Data/Fax/Voice/Spkp Modem (rev 08)
01:04.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 08)

xorg-server 2:1.6.4-2ubuntu4.2 (buildd@)

Can send any other info if needed but will be unavailable for a few days.
cheers

xorg.o.log

Ron Bentley (rtbentley) wrote :

I just checked with 2.6.31-20-generic, and the problem still occurs with i945gme. (Test run on an HP Mini 110.) Same description: with Compiz on, as soon as I click "Detect Monitors" in the Display Preferences, the screen goes black with the cursor split between the two screens. Reboot is the only way out.

I still have to start Metacity temporarily when I connect the monitor or run the xrandr command directly to place the external monitor logically below the netbook's display.

I have sent this to the wrong tracker, came here from a duplicate link. Will try and put it under the correct tracker. Sorry for any confusion.

Haggai Eran (haggai-eran) wrote :

In lucid, running kernel 2.6.32-16-generic (on Asus Eee 1005HA) I don't get this bug anymore. However, as Ron Bentley described, I too can't run compiz when the external screen is set side-by-side. If compiz is running before I plug in the external monitor, it closes, and starts metacity as a fallback. When setting the external screen to be above or below the internal screen, compiz continues to run, without switching to metacity.

Chris Halse Rogers (raof) wrote :

The upstream fix is in Lucid's mesa 7.7 packages, and (for most people) seems to be working.

@Hendrik Grahl: Your backtrace seems to point to a different problem, as it's (correctly) wandering through the software-renderer code. If you can still reproduce that on an up to date Lucid install, please file a new bug.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Released
th3darkang3l (th3darkang3l) wrote :

EeePc 901 (Atom+i945) and 2.6.31-20-generic + proposed updates and stilla have the issue. I can fix this by disabling compiz and then reenabling on the external monitor but now I have another issue : on the external monitor I cannot see more than 600 vertical pixel (phisical limit of the LVD), so even if i disable internal monitor and use only the ext-VGA, i cannot set resolution more than 800x600, or I will get black bars on the bottom of the screen. I know this is not a limit of the card because under win I use the external monitor at 1680x1050, does anyone know how to fix this? Is it a linux driver limitation?

I confirm this bug on Gateway Tablet PC CX200X and Karmic. As long as I don't have Compiz unable I can do anything, dual screen, mirror, extended. My laptop has a res. of 1280 x 768 (16:10) and my Samsung monitor 1680 x 1050 (16:10). If I try to unable visual effects and the monitor is connected it would tell me "Desktop effects could not be enabled" and stays the same, but if I have the visual effects on and connect the second monitor it would go black screen with only showing the pointer but the system is none responsive.

I tried to install the files on https://launchpad.net/~compiz/+archive/ppa/+sourcepub/890268/+listing-archive-extra
but I get into a circular dependency problems compiz-core needs compiz-gnome, and vise-verse.
I would like to give this fix a try. I see in youtube people showing compiz and dual monitor with no problem at all, so I think this problem might not be so hard to fix.

Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
Travis Watkins (amaranth) wrote :

Compiz automatically falls back to metacity if it is unable to render a texture for any reason, although the main one is going over the max texture size. It has done this since early in the lucid cycle. That is all compiz can do for this problem, for now.

Changed in compiz (Ubuntu):
status: New → Fix Released
Changed in xserver-xorg-video-intel:
importance: Critical → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.