Ubuntu

[i945gme] attaching external monitor: laptop display is black, external monitor too, with frozen mouse coursor

Reported by j^ on 2009-08-26
604
This bug affects 123 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Critical
compiz (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Franck
Nominated for Lucid by ManDay
xserver-xorg-video-intel (Ubuntu)
High
Unassigned
Nominated for Karmic by Franck
Nominated for Lucid by ManDay

Bug Description

Binary package hint: xserver-xorg-video-intel

using latest Karmic on a Lenovo S10e.

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

attaching external monitor and launching gnome-display-properties
i can see the mouse pointer on the external screen, the laptop screen is black, no reaction from mouse and keyboard
i can ssh into the laptop

last line of dmesg might be relevant:
[ 140.379174] [drm] DAC-6: set mode f

attaching /var/log/Xorg.0.log

j^ (j) wrote :
j^ (j) wrote :

more errors in dmesg trying to restart X via /etc/init.d/gdm restart does not work

[ 360.744203] INFO: task i915/0:841 blocked for more than 120 seconds.
[ 360.744219] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 360.744232] i915/0 D c080c380 0 841 2 0x00000000
[ 360.744253] f68a3f04 00000046 f68dc000 c080c380 f6806718 c080c380 e71988b2 00000020
[ 360.744282] c080c380 c080c380 f6806718 c080c380 00000000 00000020 c080c380 f5f75340
[ 360.744309] f6806480 f691c014 f691c018 ffffffff f68a3f30 c0568e26 c0737180 f691c01c
[ 360.744336] Call Trace:
[ 360.744365] [<c0568e26>] __mutex_lock_slowpath+0xc6/0x130
[ 360.744382] [<c0568d40>] mutex_lock+0x20/0x40
[ 360.744450] [<f824e94a>] i915_gem_retire_work_handler+0x2a/0x70 [i915]
[ 360.744483] [<c015311e>] run_workqueue+0x6e/0x140
[ 360.744539] [<f824e920>] ? i915_gem_retire_work_handler+0x0/0x70 [i915]
[ 360.744569] [<c0153278>] worker_thread+0x88/0xe0
[ 360.744590] [<c0157920>] ? autoremove_wake_function+0x0/0x40
[ 360.744610] [<c01531f0>] ? worker_thread+0x0/0xe0
[ 360.744623] [<c015762c>] kthread+0x7c/0x90
[ 360.744637] [<c01575b0>] ? kthread+0x0/0x90
[ 360.744654] [<c0103f17>] kernel_thread_helper+0x7/0x10
[ 360.744704] INFO: task Xorg:2480 blocked for more than 120 seconds.
[ 360.744714] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 360.744724] Xorg D c080c380 0 2480 2479 0x00400004
[ 360.744743] f5da3e28 00003082 00000000 c080c380 f662c168 c080c380 bddf3835 00000020
[ 360.744770] c080c380 c080c380 f662c168 c080c380 bddedbed 00000020 c080c380 f6712c40
[ 360.744798] f662bed0 f691c014 f691c018 ffffffff f5da3e54 c0568e26 00000000 f691c01c
[ 360.744824] Call Trace:
[ 360.744841] [<c0568e26>] __mutex_lock_slowpath+0xc6/0x130
[ 360.744857] [<c0568d40>] mutex_lock+0x20/0x40
[ 360.744914] [<f824ebcb>] i915_gem_throttle_ioctl+0x2b/0x70 [i915]
[ 360.744932] [<c01e43a5>] ? do_sync_readv_writev+0xb5/0xf0
[ 360.745003] [<f81466c0>] drm_ioctl+0x180/0x360 [drm]
[ 360.745093] [<f824eba0>] ? i915_gem_throttle_ioctl+0x0/0x70 [i915]
[ 360.745121] [<c02c4c4f>] ? security_file_permission+0xf/0x20
[ 360.745142] [<c01e463f>] ? rw_verify_area+0x5f/0xe0
[ 360.745157] [<c01e4a88>] ? rw_copy_check_uvector+0x78/0xf0
[ 360.745174] [<c01244f8>] ? default_spin_lock_flags+0x8/0x10
[ 360.745191] [<c015aaa5>] ? __remove_hrtimer+0x25/0x70
[ 360.745207] [<c015b303>] ? hrtimer_try_to_cancel+0x33/0x80
[ 360.745225] [<c0144b2e>] ? do_setitimer+0x23e/0x300
[ 360.745252] [<c01f1fa3>] vfs_ioctl+0x73/0x90
[ 360.745267] [<c01f2271>] do_vfs_ioctl+0x71/0x310
[ 360.745283] [<c0144c2b>] ? sys_setitimer+0x3b/0x90
[ 360.745297] [<c01f256f>] sys_ioctl+0x5f/0x80
[ 360.745312] [<c010334c>] syscall_call+0x7/0xb

Bryce Harrington (bryce) wrote :

Hi j, you mention that this bug occurs "using the latest Karmic" but that's a bit ambiguous - could you report if you have been using karmic and this regressed after a recent update, or if you've just upgraded from jaunty to karmic and are now seeing the problem, or if this is a first time install and you are just noticing the error now?

Please also run the command 'apport-collect 419328', which will attach some additional information which may be useful in analyzing the bug.

From what you've described, and your stack trace, this appears to be an X freeze bug. We have a recipe for debugging these issues. Please follow the directions on this guide to collect a Batchbuffer Dump:

https://wiki.ubuntu.com/X/Troubleshooting/Freeze#How%20to%20Get%20a%20Batchbuffer%20Dump%20%28-intel%20only%29

Also, the 2.8.1 driver was released last night, which allegedly contains fixes for some freeze bugs. We should have that available in Karmic within the next few days, so that would be worth testing as well. If it still occurs there in 2.8.1, then we can forward this bug upstream at that point.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
status: New → Incomplete
j^ (j) wrote : apport-collect data

Architecture: i386
DistroRelease: Ubuntu 9.10
MachineType: LENOVO 40684JG
NonfreeKernelModules: wl
Package: xserver-xorg-video-intel 2:2.8.0-0ubuntu2
PackageArchitecture: i386
PccardctlIdent:

PccardctlStatus:

ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-7-generic root=UUID=3964fa8c-ff06-41bb-ae6e-a55d04a8cf22 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-7.27-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu3
 libdrm2 2.4.12+git20090801.45078630-0ubuntu1
 xserver-xorg-video-intel 2:2.8.0-0ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090629.f39cafc5-0ubuntu6
Uname: Linux 2.6.31-7-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 11/19/2008
dmi.bios.vendor: LENOVO
dmi.bios.version: 14CN51WW
dmi.board.name: Kuril
dmi.board.vendor: Lenovo
dmi.board.version: Rev 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Lenovo
dmi.chassis.version: Rev 1.0
dmi.modalias: dmi:bvnLENOVO:bvr14CN51WW:bd11/19/2008:svnLENOVO:pn40684JG:pvrLenovo:rvnLenovo:rnKuril:rvrRev1.0:cvnLenovo:ct10:cvrRev1.0:
dmi.product.name: 40684JG
dmi.product.version: Lenovo
dmi.sys.vendor: LENOVO
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-7-generic

j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :
j^ (j) wrote :

i upgraded the laptop longer ago and am testing support for external monitors from time to time, before it would happen that the external monitor was empty but the mouse worked and the laptop screen would have a scrambled image on the top part. with an update in the last days this degraded further to the problem described above. will test 2.8.1 once it hits the repository and let you know if anything changed.

j^ (j) wrote :

xranr with external monitor attached

j^ (j) wrote :

updated to new version. still same problem.
start laptop, login, attach external monitor, open configure display, hangs
attached xorg.log output after attaching monitor and opening configure displays

this was with
Linux atom 2.6.31-8-generic #28-Ubuntu SMP Thu Aug 27 14:43:30 UTC 2009 i686 GNU/Linux

xserver-xorg-video-intel
Version: 2:2.8.1-1ubuntu1

after 120 seconds i also get a backtrace in dmesg again
[ 5160.748389] INFO: task i915/0:834 blocked for more than 120 seconds...

j^ (j) wrote :

and the backtrace

pablomme (pablomme) wrote :

I have the same problem. Booting with the external screen attached is OK, and gnome-display-properties works fine. Attaching the screen once X has started and opening gnome-display-properties hangs the computer as described by j^.

Geir Ove Myhr (gomyhr) on 2009-08-29
tags: added: 945gme corruption dual-head karmic
summary: - attaching external monitor: laptop display shows corrupted desktop
+ [i945gme] attaching external monitor: laptop display shows corrupted
+ desktop
Download full text (3.1 KiB)

I recently updated to kernel 2.6.31-9.29 and xserver-xorg-video-intel 2:2.8.1-1ubuntu1 (from whatever karmic was about a month ago, which worked fine), and I'm seeing this deadlock as well (on a Thinkpad W500). I'm also seeing all kinds of display corruption (leftover shadows, images scrambled, etc), but I don't know if it's the same bug or not.

Below is the kernel dmesg output; the X server is locked up and unresponsive, but otherwise the machine is running (accessible via ssh over the network, for instance). I have an external VGA monitor attached. So far my machine has locked up twice in a few hours.

[ 5880.448104] INFO: task i915/0:874 blocked for more than 120 seconds.
[ 5880.448113] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 5880.448119] i915/0 D 00000000ffffffff 0 874 2 0x00000000
[ 5880.448131] ffff880134597d70 0000000000000046 0000000000000000 0000000000015580
[ 5880.448142] ffff8801348a3110 0000000000015580 0000000000015580 0000000000015580
[ 5880.448151] 0000000000015580 ffff8801348a3110 0000000000015580 0000000000015580
[ 5880.448161] Call Trace:
[ 5880.448180] [<ffffffff8151f617>] __mutex_lock_slowpath+0xd7/0x160
[ 5880.448190] [<ffffffff8151f516>] mutex_lock+0x26/0x50
[ 5880.448244] [<ffffffffa0060768>] i915_gem_retire_work_handler+0x38/0x90 [i915]
[ 5880.448272] [<ffffffffa0060730>] ? i915_gem_retire_work_handler+0x0/0x90 [i915]
[ 5880.448284] [<ffffffff8106e805>] run_workqueue+0x95/0x170
[ 5880.448292] [<ffffffff8106e984>] worker_thread+0xa4/0x120
[ 5880.448300] [<ffffffff81073b90>] ? autoremove_wake_function+0x0/0x40
[ 5880.448308] [<ffffffff8106e8e0>] ? worker_thread+0x0/0x120
[ 5880.448315] [<ffffffff810737a6>] kthread+0xa6/0xb0
[ 5880.448324] [<ffffffff8101308a>] child_rip+0xa/0x20
[ 5880.448331] [<ffffffff81073700>] ? kthread+0x0/0xb0
[ 5880.448338] [<ffffffff81013080>] ? child_rip+0x0/0x20
[ 5880.448365] INFO: task Xorg:3092 blocked for more than 120 seconds.
[ 5880.448369] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 5880.448374] Xorg D 0000000000000000 0 3092 3085 0x00400004
[ 5880.448384] ffff88012bc73cb8 0000000000000086 ffff88012bc73c90 0000000000015580
[ 5880.448394] ffff88012c9d1a60 0000000000015580 0000000000015580 0000000000015580
[ 5880.448403] 0000000000015580 ffff88012c9d1a60 0000000000015580 0000000000015580
[ 5880.448413] Call Trace:
[ 5880.448422] [<ffffffff8151f617>] __mutex_lock_slowpath+0xd7/0x160
[ 5880.448432] [<ffffffff814205b0>] ? sock_aio_write+0x0/0x150
[ 5880.448440] [<ffffffff8151f516>] mutex_lock+0x26/0x50
[ 5880.448467] [<ffffffffa0060a56>] i915_gem_throttle_ioctl+0x36/0x90 [i915]
[ 5880.448507] [<ffffffffa0026cae>] drm_ioctl+0x17e/0x3a0 [drm]
[ 5880.448537] [<ffffffff81032439>] ? default_spin_lock_flags+0x9/0x10
[ 5880.448547] [<ffffffff815208da>] ? _spin_lock_irqsave+0x2a/0x40
[ 5880.448557] [<ffffffff81128e2c>] vfs_ioctl+0x7c/0xa0
[ 5880.448566] [<ffffffff811293f9>] do_vfs_ioctl+0x79/0x370
[ 5880.448574] [<ffffffff81129771>] sys_ioctl+0x81/0xa0
[ 5880.448585] [<ffffffff81011fc2>] system_call_fastpath+0x16/0x1b

... and the same message continues every 120 secon...

Read more...

Bryce Harrington (bryce) wrote :

Thank you for the additional files, however I still don't quite understand the problem description. Please provide exact steps to reproduce the problem and if possible a photo of the monitor showing the corruption you're seeing.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
j^ (j) wrote :

Bryce, i don't see any corruption, but just get a black screen, to reproduce:
* disconnect external screen
* open gnome-display-properties
* press detect displays
* connect external screen
* press detect displays
* get two black screens, frozen mouse pointer on external screen
here a video: http://videobin.org/+dr/g5.html
and a photo of the black screens: http://oil21.org/~j/ubuntubugs/bug_419328.jpg

Bryce Harrington (bryce) wrote :

Oh sorry, it was nickolai who mentioned display corruption, and his comment confused me. nickolai - because your symptoms don't match j^'s you probably have some other unrelated bug that should be reported separately.

Bryce Harrington (bryce) wrote :

j^ - hmm I also notice the title of this bug mentions "corrupted desktop". Is that an incorrect title for this bug?

nickolai (nickolai) wrote :

The primary reason I wrote my comment was because I observed my X server hanging. Indeed, the reason I found this bug was because I get the same stack trace in dmesg showing where the deadlock occurs.

It is not known to me whether display corruption is related or not, and in my first comment, I indicated that it might or might not be the same bug. If it's makes things easier, let's ignore the display corruption and assume it's unrelated.

j^ (j) wrote :

ok, changed title, i had corruption earlier but with the latest version i only get a black screen.

summary: - [i945gme] attaching external monitor: laptop display shows corrupted
- desktop
+ [i945gme] attaching external monitor: laptop display is black, external
+ monitor too, with frozen mouse coursor
Bryce Harrington (bryce) wrote :

j^ - Thanks for the steps to reproduce. I've forwarded this bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=23718 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

From your additional information it looks like this may be an "X Freeze" bug. Some additional debug steps are available for this class of issue: https://wiki.ubuntu.com/X/Troubleshooting/Freeze#How%20to%20Get%20a%20Batchbuffer%20Dump%20(-intel%20only)

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Triaged
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
pablomme (pablomme) wrote :

This is still an issue as of the current karmic (25-sept-2009, with xserver-xorg-video-intel 2:2.8.1-1ubuntu1).

j^ (j) wrote :

from upstream bug:
Compiz fusion is required to reproduce this. Unfortunately it's enabled by
default in Karmic. Disabling Compiz fusion or even using Compiz core (like
default in Fedora 11) doesn't have this problem.

anything that can be done to track down the problem?

pablomme (pablomme) wrote :

I can confirm that running "metacity --replace", switching screens, and running "compiz --replace" serves as a workaround, proving that compiz[-fusion] is involved in/causing the problem.

41 comments hidden view all 121 comments
oudalrich (uhkeller) wrote :

What I forgot in #81: you have to enable "Pre-released updates (karmic-proposed)" in Software Sources/Updates and reload the information about available software before running the "sudo aptitude..." line in terminal.

pablomme (pablomme) wrote :

Doesn't work for me either. Neither the packages from the compiz PPA nor those in karmic-proposed fix the problem.

Mathieu Marquer (slasher-fun) wrote :

OK so... it was working yesterday (yup, I was able to have dual screen with compiz enable using Fn+F4 on my Samsung NC10), but today it crashes again... Sorry.

inkhorn (matt-dubins) wrote :

I also got the compiz updates from karmic-proposed yet the crash is still happening when I try to detect my external monitor. Sigh...

alcCapone (alcc) wrote :

I'm on an X60s with an Intel 945GM and when I go to "Configure Display Settings" the problem is *not* fixed.

sam tygier (samtygier) wrote :

An Intel dev upstream suggests working around this in compiz. I am not sure is a proper solution, but it would reduce the number of crashes.

Id2ndR (id2ndr) wrote :

I got this message in dmesg on my server running Ubuntu desktop 9.10. The server has currently no attached display and has reboot 2 hours ago (latest linux update). Metacity is running on the server (no compiz), and there is an automatic gdm login (I use it sometime as a mediacenter).

Id2ndR (id2ndr) wrote :

The load of the server is 2 : it seems there was 2 crashes in the dmesg, and the server is idle.

Id2ndR (id2ndr) wrote :

This may be a duplicate of Bug #451518

pablomme (pablomme) wrote :

@Id2ndR: your problem doesn't sound like this bug.

th3darkang3l (th3darkang3l) wrote :

This <a href="https://bugs.launchpad.net/ubuntu/+source/linux/+bug/465318">Bug #465318</a> could be a duplicate of this problem

jadorno (javier-adorno) wrote :

I have the same problem with and Aspire One D250 and I totally agree that xrandr should avoid going further than the capacity of the driver.

This is the way I managed to avoid hangups without enabling and disabling compiz

I've created three custom keyboard shortcuts to diferent xrandr configurations

1. super+F1 calls --> xrandr --output LVDS1 --mode 1024x600 --output VGA1 --off
2. super+F2 calls --> xrandr --output LVDS1 --off --output VGA1 --mode 1440x900
3. super+F3 calls --> xrandr --output LVDS1 --mode 1024x600 --output VGA1 --mode 800x600 --right-of LVDS1

1. Is my internal LCD only config
2. Is my external LCD only config
3. Is a dual head config for projector use that can be further modified by using the display-configuration applet

ManDay (manday) wrote :

Confirmed for Karmic 9.10 on an ASUS EEE PC 1000h with Intel GMA 950.

Happens exactly as described (both screens turn black with mousepointer frozen near in-between) when either pressing Fn+F8 shortcut combo or opening Preferences > Display.

Only seems to happen, when trying to ACTIVATE the external screen. It doesn't seem to affect deactivating it.
Only seems to happen, when the external screen hasn't been plugged in on boot (not resume!), too, though.

Doughy (doughywilson) wrote :

I am having a very similar problem, only my screen does not go black. Instead, my screen freezes the exact image that was up when the crash occurs. The problem is recreated in the exact same way as described by others, plugging in a VGA cable and attempting to activate the external screen.

I did try booting with the cable already inserted, but this did not remedy the problem.

Aethex (aethex) wrote :

Can confirm on Asus EeePC 1005HA, Intel 945 GME (I think). Black screen, busy cursor stuck in between. TTYs don't work, nor do hotkeys. It worked fine in Jaunty.

Could this be fixed by reverting to the Jaunty graphics driver, if possible? What else has changed in the transition from Jaunty to Karmic for Intel users?

Doughy: that doesn't sound like this bug. Which chipset do you have? (use lspci | grep VGA)

Also, I use a Belkin KVM between my Asus and primary machine, and sometimes, Karmic doesn't even recognize my monitor. It is an LG, with a resolution of 1280 x 1024, but sometimes the closest match is something like 1178x900, a smidge smaller and distorted. Is this related to X? Should I file a new bug?

Doughy (doughywilson) wrote :

Aethex, my chipset is "Intel GM965/GL960 Integrated Graphics Controller"

wolfi (lammer-wolfgang) wrote :

Having the problem using QBOX-N270 running ubuntu-karmic: (fresh installed -no upgrade from jaunty)
2.6.31-15-generic #50-Ubuntu SMP Tue Nov 10 14:54:29 UTC 2009 i686
Only one display; It seems to occur when waking up from display-idle-state.

[<c056fd66>] __mutex_lock_slowpath+0xc6/0x130
[<c056fc80>] mutex_lock+0x20/0x40
[<f814ac0a>] i915_gem_retire_work_handler+0x2a/0x70 [i915]
[<c0157a7e>] run_workqueue+0x6e/0x140
[<f814abe0>] ? i915_gem_retire_work_handler+0x0/0x70 [i915]
[<c0157bd8>] worker_thread+0x88/0xe0
[<c015c280>] ? autoremove_wake_function+0x0/0x40
[<c0157b50>] ? worker_thread+0x0/0xe0
[<c015bf8c>] kthread+0x7c/0x90
[<c015bf10>] ? kthread+0x0/0x90
[<c0104007>] kernel_thread_helper+0x7/0x10
Xorg D c08145c0 0 942 926 0x00400004
ee29be28 00003082 f68e2000 c08145c0 f6bf6718 c08145c0 65f6c883 00023c9f
c08145c0 c08145c0 f6bf6718 c08145c0 00000000 00023c9f c08145c0 f6b8ca80
f6bf6480 f688b414 f688b418 ffffffff ee29be54 c056fd66 ee29be44 f688b41c
Call Trace:
[<c056fd66>] __mutex_lock_slowpath+0xc6/0x130
[<c056fc80>] mutex_lock+0x20/0x40
[<f814ae8b>] i915_gem_throttle_ioctl+0x2b/0x70 [i915]
[<f80cc6c0>] drm_ioctl+0x180/0x360 [drm]
[<f814ae60>] ? i915_gem_throttle_ioctl+0x0/0x70 [i915]
[<c010b16a>] ? restore_i387_xstate+0xda/0x210
[<c02c7f8f>] ? security_file_permission+0xf/0x20
[<c01f51b3>] vfs_ioctl+0x73/0x90
[<c01f5481>] do_vfs_ioctl+0x71/0x310
[<c0102771>] ? restore_sigcontext+0xc1/0xe0
[<c01f577f>] sys_ioctl+0x5f/0x80
[<c010336c>] syscall_call+0x7/0xb

ManDay (manday) wrote :

This bug certainly affects more than just 31 people and is pretty severe, it should be fixed asap.

pablomme (pablomme) wrote :

I've attached a little script I'm using to switch outputs without having compiz trigger this bug. It does so by disabling compiz, switching outputs, then re-enabling compiz.

Download the script, make it executable and (optionally) place it in your path. Usage examples:
  rnr_switch VGA1 # switch from the current output to the external monitor
  rnr_switch VGA1:1280x1024@75 # as above, but using a custom resolution and refresh rate
  rnr_switch LVDS1 # switch from the current output back to the laptop panel
With the 'commands' compiz plugin (for which you will need to install compizconfig-settings-manager) you can associate key combinations with the execution of any of the above commands. See the comments at the top of the script for more info.

Note that this script can only be used to turn one output on and the other one off. It wouldn't be difficult to make it do output cloning as well, but at present it just doesn't.

Needless to say, this script is a temporary, incomplete hack around this bug, but it does its job.

mag (mg5) wrote :

Confirmed for Karmic 9.10 on an ASUS EEE PC 1000he / Intel GMA 950.

It only happens when Monitor hasn't been plugged in at boot time. Sometimes I can avoid it by switching Fn-F8 into mirror both screens. Using gnome-display-manager after that works fine in most cases - any resolution.

Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
MikeCamel (mike-hingston) wrote :

Took proposed, same problem shown on Toshiba NB200-12B, with Intel 945GME. metacity --replace, then compiz --replace works.

MikeCamel (mike-hingston) wrote :

Also, turning off desktop effects fixes the problem.

Geir Ove Myhr (gomyhr) wrote :

The fix mentioned upstream (https://bugs.freedesktop.org/show_bug.cgi?id=23718) in comment #37 is included in the mesa version in the x-updates PPA (https://launchpad.net/~ubuntu-x-swat/+archive/x-updates/+packages?field.name_filter=&field.status_filter=published&field.series_filter=karmic). However, as noted upstream, rendering will slow down to a slideshow in mesa 7.6. The current plan is to ship mesa 7.7 in Lucid and it should work better there.

MikeCamel (mike-hingston) wrote :

Just a note that this affects gnome-shell, too. Given that this is very, very alpha, I suspect that noone cares at this point, but I thought I'd record it.

Starting display-manager with desktop effects off, and then starting gnome-shell works fine.

nanotube (nanotube) wrote :

So, what's the current status of this bug? It is marked as a 'fix released' - does that mean it is coming to the karmic repositories any time soon?

papukaija (papukaija) wrote :

@nanotube: This bug is fixed upstream (in xserver-xorg-video-intel), but not yet in Ubuntu.

alcCapone (alcc) wrote :

Does "not yet" mean it's going to make it into the Karmic repositories - before Lucid is out?

Don'T know whether this is of any relevance but I've talked to some guys on #ubuntu-x IRC channel and they asserted that, since the patch is based on a new MESA which will cause graphics - 3D only, if I got it correctly - to slow down to a horrid framerate.

On 25.01.2010 15:51, alcCapone wrote:
> Does "not yet" mean it's going to make it into the Karmic repositories -
> before Lucid is out?
>

Hendrik Grahl (grahl) wrote :

I still encounter this issue on lucid with xserver-xorg-video-intel-2.9.1-1ubuntu5 and mesa7.7-0ubuntu8 with an Intel '945GM/GMS/GME, 943/940GML Express'.

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x3b) [0x80e876b]
1: /usr/bin/X (0x8048000+0x61a1d) [0x80a9a1d]
2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb55410]
3: /usr/lib/dri/i915_dri.so (0xef4000+0x208a16) [0x10fca16]
4: /usr/lib/dri/i915_dri.so (_mesa_execute_program+0x2a2d) [0x103a63d]
5: /usr/lib/dri/i915_dri.so (_swrast_exec_fragment_program+0x1a4) [0x10fccb4]
6: /usr/lib/dri/i915_dri.so (0xef4000+0x16558f) [0x105958f]
7: /usr/lib/dri/i915_dri.so (_swrast_write_rgba_span+0xd40) [0x105a9b0]
8: /usr/lib/dri/i915_dri.so (0xef4000+0x17ebb2) [0x1072bb2]
9: /usr/lib/dri/i915_dri.so (0xef4000+0x15920f) [0x104d20f]
10: /usr/lib/dri/i915_dri.so (_swrast_Triangle+0x2d) [0x104c41d]
11: /usr/lib/dri/i915_dri.so (0xef4000+0x18b39f) [0x107f39f]
12: /usr/lib/dri/i915_dri.so (0xef4000+0x18b3e5) [0x107f3e5]
13: /usr/lib/dri/i915_dri.so (0xef4000+0x124d37) [0x1018d37]
14: /usr/lib/dri/i915_dri.so (0xef4000+0x126389) [0x101a389]
15: /usr/lib/dri/i915_dri.so (_tnl_run_pipeline+0x163) [0x100e103]
16: /usr/lib/dri/i915_dri.so (0xef4000+0x718cd) [0xf658cd]
17: /usr/lib/dri/i915_dri.so (_tnl_draw_prims+0xc66) [0x100ee46]
18: /usr/lib/dri/i915_dri.so (_tnl_vbo_draw_prims+0x79) [0x100f279]
19: /usr/lib/dri/i915_dri.so (vbo_exec_vtx_flush+0x5f4) [0x1007364]
20: /usr/lib/dri/i915_dri.so (vbo_exec_FlushVertices_internal+0x3a) [0x100323a]
21: /usr/lib/dri/i915_dri.so (vbo_exec_FlushVertices+0x50) [0x10032f0]
22: /usr/lib/dri/i915_dri.so (_mesa_MatrixMode+0x181) [0xfc7ed1]
23: /usr/lib/xorg/modules/extensions/libglx.so (0x317000+0x8d19) [0x31fd19]
24: /usr/lib/xorg/modules/extensions/libglx.so (0x317000+0x323f4) [0x3493f4]
25: /usr/lib/xorg/modules/extensions/libglx.so (0x317000+0x36c6e) [0x34dc6e]
26: /usr/bin/X (0x8048000+0x2a3a7) [0x80723a7]
27: /usr/bin/X (0x8048000+0x1ed4a) [0x8066d4a]
28: /lib/tls/i686/cmov/libc.so.6 (__libc_start_main+0xe6) [0x1d9bd6]
29: /usr/bin/X (0x8048000+0x1e931) [0x8066931]
Segmentation fault at address (nil)
Caught signal 11 (Segmentation fault). Server aborting

sam tygier (samtygier) wrote :

just tested in lucid.
on pluging in an external monitor, and pressing detect monitor, the new display is detected, and the screen spans across it. compiz seems to automatically fall back to metacity. apart from loss of desktop effects everything carries on working. no crash.

if i run glxgears, and then resize its window, after it passes a certain width the display of the gears is corrupted. but there is no crash.

seems that the freeze is fixed for me

Bryce Harrington (bryce) on 2010-03-02
summary: - [i945gme] attaching external monitor: laptop display is black, external
- monitor too, with frozen mouse coursor
+ [i945] [i945gme] attaching external monitor: laptop display is black,
+ external monitor too, with frozen mouse coursor
Bryce Harrington (bryce) on 2010-03-02
summary: - [i945] [i945gme] attaching external monitor: laptop display is black,
- external monitor too, with frozen mouse coursor
+ [i945gme] attaching external monitor: laptop display is black, external
+ monitor too, with frozen mouse coursor
Chris Conatser (sbquatre) wrote :

Just wanted to post a quick workaround that works on my HP Pavilion dv1648 laptop (two 1280x768 displays): when I leave the monitor configuration as side-by-side, per default, it crashes with all the usual symptoms described above. However, if I reconfigure to show one monitor as being above the other BEFORE trying to apply dual display, it works just fine. I assume that this means 1536 is within the limits of the video card; 2560 is not. This may make, for example, setting up a projector a little quicker than the metacity workaround, for those who like to stick to Compiz.

This bug appears to be fixed after updating to 2.6.31-20-generic #58-Ubuntu yesterday, about 4 hours use so far and no lockups yet.

lspci:
00:00.0 Host bridge: Intel Corporation 82830 830 Chipset Host Bridge (rev 04)
00:02.0 VGA compatible controller: Intel Corporation 82830 CGC [Chipset Graphics Controller] (rev 04)
00:02.1 Display controller: Intel Corporation 82830 CGC [Chipset Graphics Controller]
00:1d.0 USB Controller: Intel Corporation 82801CA/CAM USB Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 42)
00:1f.0 ISA bridge: Intel Corporation 82801CAM ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801CAM IDE U100 Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801CA/CAM SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801CA/CAM AC'97 Audio Controller (rev 02)
01:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 80)
01:00.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 80)
01:01.0 Communication controller: Conexant Systems, Inc. HCF 56k Data/Fax/Voice/Spkp Modem (rev 08)
01:04.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 08)

xorg-server 2:1.6.4-2ubuntu4.2 (buildd@)

Can send any other info if needed but will be unavailable for a few days.
cheers

xorg.o.log

Ron Bentley (rtbentley) wrote :

I just checked with 2.6.31-20-generic, and the problem still occurs with i945gme. (Test run on an HP Mini 110.) Same description: with Compiz on, as soon as I click "Detect Monitors" in the Display Preferences, the screen goes black with the cursor split between the two screens. Reboot is the only way out.

I still have to start Metacity temporarily when I connect the monitor or run the xrandr command directly to place the external monitor logically below the netbook's display.

I have sent this to the wrong tracker, came here from a duplicate link. Will try and put it under the correct tracker. Sorry for any confusion.

Haggai Eran (haggai-eran) wrote :

In lucid, running kernel 2.6.32-16-generic (on Asus Eee 1005HA) I don't get this bug anymore. However, as Ron Bentley described, I too can't run compiz when the external screen is set side-by-side. If compiz is running before I plug in the external monitor, it closes, and starts metacity as a fallback. When setting the external screen to be above or below the internal screen, compiz continues to run, without switching to metacity.

Chris Halse Rogers (raof) wrote :

The upstream fix is in Lucid's mesa 7.7 packages, and (for most people) seems to be working.

@Hendrik Grahl: Your backtrace seems to point to a different problem, as it's (correctly) wandering through the software-renderer code. If you can still reproduce that on an up to date Lucid install, please file a new bug.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Released
th3darkang3l (th3darkang3l) wrote :

EeePc 901 (Atom+i945) and 2.6.31-20-generic + proposed updates and stilla have the issue. I can fix this by disabling compiz and then reenabling on the external monitor but now I have another issue : on the external monitor I cannot see more than 600 vertical pixel (phisical limit of the LVD), so even if i disable internal monitor and use only the ext-VGA, i cannot set resolution more than 800x600, or I will get black bars on the bottom of the screen. I know this is not a limit of the card because under win I use the external monitor at 1680x1050, does anyone know how to fix this? Is it a linux driver limitation?

I confirm this bug on Gateway Tablet PC CX200X and Karmic. As long as I don't have Compiz unable I can do anything, dual screen, mirror, extended. My laptop has a res. of 1280 x 768 (16:10) and my Samsung monitor 1680 x 1050 (16:10). If I try to unable visual effects and the monitor is connected it would tell me "Desktop effects could not be enabled" and stays the same, but if I have the visual effects on and connect the second monitor it would go black screen with only showing the pointer but the system is none responsive.

I tried to install the files on https://launchpad.net/~compiz/+archive/ppa/+sourcepub/890268/+listing-archive-extra
but I get into a circular dependency problems compiz-core needs compiz-gnome, and vise-verse.
I would like to give this fix a try. I see in youtube people showing compiz and dual monitor with no problem at all, so I think this problem might not be so hard to fix.

Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
Travis Watkins (amaranth) wrote :

Compiz automatically falls back to metacity if it is unable to render a texture for any reason, although the main one is going over the max texture size. It has done this since early in the lucid cycle. That is all compiz can do for this problem, for now.

Changed in compiz (Ubuntu):
status: New → Fix Released
Changed in xserver-xorg-video-intel:
importance: Critical → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
Displaying first 40 and last 40 comments. View all 121 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.