[i965gm] kernel backlight control method missing for macbooks

Bug #417770 reported by Henrik Rydberg on 2009-08-23
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Invalid
High
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

The kernel backlight control method, which uses the /sys/class/backlight interface, is missing knowledge of the mbp_backlight driver. Patch:
<pre>
--- xserver-xorg-video-intel-2.8.0.orig/src/i830_lvds.c
+++ xserver-xorg-video-intel-2.8.0/src/i830_lvds.c
@@ -81,6 +81,7 @@
     "asus-laptop",
     "eeepc",
     "thinkpad_screen",
+ "mbp_backlight",
     "acpi_video1",
     "acpi_video0",
     "fujitsu-laptop",
</pre>

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 03)
     Subsystem: Apple Computer Inc. Device [106b:00a2]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 03)
     Subsystem: Apple Computer Inc. Device [106b:00a2]

Bryce Harrington (bryce) wrote :

Hi rydberg,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Henrik Rydberg (rydberg) wrote :

Bryce, thank you for your reply. The issue behind the solution patch is that when setting the xrandr BACKLIGHT_CONTROL property to 'kernel' to use the sysfs interface to control the LCD backlight, the existing sysfs backlight interface is not detected. The MacBookAir, as well as many other macbooks, use the mbp_nvidia_bl kernel module, which produces the sysfs interface /sys/class/backlight/mbp_backlight. The current intel driver code seems to list an explicit set of possible names after /sys/class/backlight/, and mbp_backlight is not one of them. Applying the supplied patch fixes the problem. The Xorg log for the working code reveals this line:

/var/log/Xorg.0.log:(II) intel(0): found backlight control method /sys/class/backlight/mbp_backlight

When the patch is not present, it searches for the first name in the list in src/i830_lvds.c (asus-latop), does not find it and outputs a corresponding error message.

Output of lspci attached.

(Rant: Marking bugs as 'incomplete' by automacy is a good way of keeping the desk clean ;-))

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
Bryce Harrington (bryce) wrote :

Hi rydberg,

Thanks for including the attached files. Could you also include your /var/log/Xorg.0.log (or Xorg.0.log.old) from after reproducing the issue?

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Henrik Rydberg (rydberg) wrote :

I should make more clear that this issue is about the kernel backlight control method only. The native method works fine (at least after adding the nomodeset boot parameter). Thus, this issue should really just be about that single line in the first comment. Attaching the failing xorg log here anyways, on request.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
Bryce Harrington (bryce) on 2009-08-26
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Geir Ove Myhr (gomyhr) on 2009-08-30
summary: - kernel backlight control method missing for macbooks
+ [i965GM] kernel backlight control method missing for macbooks
tags: added: 965gm backlight karmic
removed: needs-lspci-vvnn needs-xorglog
Bryce Harrington (bryce) on 2009-10-10
description: updated
Matti Viljanen (direc85) wrote :

The -intel module has been updated to 2.9.0, so could you please upgrade your systems and post the results?

"Worksforme", as the backlight control, too!

Steffen Röcker (sroecker) wrote :

We need this for lucid where KMS is enabled by default.
mbp_backlight needs to be patched for older intel macbooks, like in bug #511965.

Brightness adjustment still not working in Lucid Alpha 3, KMS enabled, on a MacBook 4,1.

Bryce Harrington (bryce) on 2010-03-02
summary: - [i965GM] kernel backlight control method missing for macbooks
+ [i965] [i965GM] kernel backlight control method missing for macbooks
Bryce Harrington (bryce) on 2010-03-02
summary: - [i965] [i965GM] kernel backlight control method missing for macbooks
+ [i965gm] kernel backlight control method missing for macbooks
Steffen Röcker (sroecker) wrote :

Now that bug #511965 is fixed (except for MacBook1,1) this patch enables backlight control.

Confirmed fixed for the MacBook 4,1, where brightness adjustment is now working perfectly, without pommed. Thanks a lot!

Created an attachment (id=34712)
patch

Ubuntu-Bug: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/417770

The kernel backlight control method, which uses the /sys/class/backlight interface, is missing knowledge of the mbp_backlight driver.

Chris Halse Rogers (raof) wrote :

Fixed without the extra patch to xserver-xorg-video-intel, or only once that patch is applied? The patch looks sensible - has it been sent upstream? Is there an upstream bug open about this?

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Medium
Steffen Röcker (sroecker) wrote :

I opened an upstream bug for this.

Robert Hooker (sarvatt) on 2010-04-06
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
assignee: nobody → Bryce Harrington (bryceharrington)

Would be great to get some feedback on this patch before we include it in Ubuntu

*** This bug has been marked as a duplicate of bug 25901 ***

This did seem to be fixed about a week ago, but now it's stopped working again.

Bryce Harrington (bryce) wrote :

I'm a bit confused as to whether the patch in comment #8 is still needed - the recent comments are a little ambiguous as to whether the situation is fixed with the patch or not.

Changed in xserver-xorg-video-intel (Ubuntu Lucid):
status: Confirmed → Incomplete
Steffen Röcker (sroecker) wrote :

Hmm. I am not sure either now, but I can't test it until friday.

Someone at bug 397617 said it works with a liveCD (linux-generic 2.6.32.19.20).

Bryce Harrington (bryce) wrote :

Hmm. Okay well lets be optimistic and call it fixed. If someone can confirm the issue still occurs *and* test that by using the patch it positively resolves the issue, please reopen the bug and it can be investigated further.

Changed in xserver-xorg-video-intel (Ubuntu Lucid):
status: Incomplete → Fix Released
Balucio (bsaul) wrote :

Excuse me I published this on old post. I hope this help someone:
I have a macbook pro 5.3 and Ubuntu Lucid, with mpb-nvidia-dkms for display brightness and pommed key dimming.
If I remove pommed the key dimming not work at all. If I use the nvidia-bl-dkms, even though the brightness key trigger OSD display the brightness not change.

Bryce Harrington (bryce) on 2010-05-28
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: Bryce Harrington (bryceharrington) → nobody
Changed in xserver-xorg-video-intel (Ubuntu Lucid):
assignee: Bryce Harrington (bryceharrington) → nobody
Robert Hooker (sarvatt) wrote :

This is not fixed, I have pushed the patch to the xserver-xorg-video-intel git branch for ubuntu though for the next upload in maverick.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Released → Fix Committed
Changed in xserver-xorg-video-intel (Ubuntu Lucid):
status: Fix Released → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.11.0-1ubuntu1

---------------
xserver-xorg-video-intel (2:2.11.0-1ubuntu1) maverick; urgency=low

  [ Christopher James Halse Rogers ]
  * Merge from Debian experimental. Remaining Ubuntu changes:
    - debian/apport-gpu-error-intel.py, debian/xserver-xorg-video-intel.udev,
      debian/xserver-xorg-video-intel:
      Add apport script to collect debug information on GPU hangs
    - rules: Install udev rule to run the script when the kernel detects hung GPU
    - 101_copy-fb.patch: Adds feature to driver so Xserver can draw
      root windows with no background. This enables smooth boot with
      Plymouth.
    - control: Add Recommends on intel-gpu-tools to xserver-xorg-video-intel
      package for use by GPU hang scripts.
    - xserver-xorg-video-intel.preinst.in, xserver-xorg-video-intel.postinst.in,
      rules:
      Don't install /etc/modprobe.d/i915-kms.conf, and remove it on upgrades.
      At best it's redundant (as the kernel defaults to KMS), at worst it breaks
      the ability to disable KMS.

  [ Robert Hooker ]
  * Add 102-disable-page-flipping-v2.patch: Disables page flipping support which
    is causing frequent hangs, but leaves the events.
  * Add 103-mbp-backlight-support.patch: Enables xrandr backlight control for
    macbook's using the mbp_backlight module. (LP: #417770)

xserver-xorg-video-intel (2:2.11.0-1) experimental; urgency=low

  * New upstream release.

xserver-xorg-video-intel (2:2.10.903-1) experimental; urgency=low

  * New upstream release candidate.

xserver-xorg-video-intel (2:2.10.902-1) experimental; urgency=low

  [ Julien Cristau ]
  * Rename the build directory to not include DEB_BUILD_GNU_TYPE for no
    good reason. Thanks, Colin Watson!
  * Remove myself from Uploaders

  [ Brice Goglin ]
  * New upstream release candidate, closes: #567829.
    + User mode-setting is not supported anymore.
  * Bump xutils-dev build dependency for new util-macros.
  * Bump libdrm build dependency to 2.4.18-3 for latest i915 drm headers.
  * Build depend on libx11-xcb-dev, libxcb-aux0-dev and libxcb-dri2-0-dev
    for XVMC.
  * Recommends intel-gpu-tools since intel_reg_dumper is not provided
    by xserver-xorg-video-intel-dbg anymore.
 -- Robert Hooker <email address hidden> Sat, 29 May 2010 20:49:31 -0400

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Committed → Fix Released
Balucio (bsaul) wrote :

From ppa, I installed xserver-xorg-video-intel version 2:2.11.0-1ubuntu1~xup and then nvidia-bkms-0.16.9 lucid, but the problem persist, I can't change the brightness. I try also without nvidia-bkms. Indeed with the new driver the video effect (compiz) are a bit slower and there are more artifact, for example orizzontal orizzontal line in menu. Pommed is still required to use key dimming.

Just tried on 10.10, and brightness hotkeys didn't work until I installed pommed on a MacBook 5,2

Nope, I don't think this is fixed in Maverick unfortunately.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Released → Confirmed

Sorry, it turns out that this is actually fixed. It seems that the hotkeys are working, but they are nowhere near sensitive enough. (ie. it takes at least a minute of holding down a key to noticeably change the brightness)

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
Changed in xserver-xorg-video-intel:
importance: Unknown → High
mu3en (mu3en) wrote :

still nothing on maverick 64 macbook 3.1

brightness control monitor pops up with either brightness up or down keys, but does not change.

last known good in karmic, lucid was as maverick now.

Steffen Röcker (sroecker) wrote :

mu3en, can you post the output of

sudo dmidecode -s system-manufacturer
sudo dmidecode -s system-product-name
lspci | grep VGA

to bug #511965 ?

Changed in xserver-xorg-video-intel:
importance: High → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → High
Changed in xserver-xorg-video-intel:
status: Unknown → Invalid
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in xserver-xorg-video-intel (Ubuntu Lucid):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.