[i865g][Karmic Alpha 3] X corruption and freeze when clicking "Other" on GDM login screen

Bug #407793 reported by Michael Chang on 2009-08-01
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Andy Whitcroft
Karmic
High
Andy Whitcroft
xserver-xorg-video-intel (Ubuntu)
High
Unassigned
Karmic
High
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu.

michael@kiwi:~/dri_debug$ lsb_release -rd
Description: Ubuntu karmic (development branch)
Release: 9.10

2) The version of the package you are using, via 'apt-cache policy packagename' or by checking in Synaptic.

michael@kiwi:~/dri_debug$ apt-cache policy xserver-xorg-video-intel
xserver-xorg-video-intel:
  Installed: 2:2.8.0-0ubuntu1
  Candidate: 2:2.8.0-0ubuntu1
  Version table:
 *** 2:2.8.0-0ubuntu1 0
        500 http://ca.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

michael@kiwi:~/dri_debug$ apt-cache policy gdm
gdm:
  Installed: 2.27.4-0ubuntu6
  Candidate: 2.27.4-0ubuntu6
  Version table:
 *** 2.27.4-0ubuntu6 0
        500 http://ca.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

3) What you expected to happen

The screen would display a "username" field and allow me to type in my username.

4) What happened instead

The screen displays the username field, but black boxes (corruption?) appear above and below it, and the computer stops responding to all keyboard input, with the exception of Alt-SysRq keys. Hitting Caps Lock does NOT make the respective keyboard LED go on, but hitting Num Lock does. It is possible to move the cursor with the mouse, but clicking does not do anything.

--- As per https://wiki.ubuntu.com/X/Troubleshooting/Freeze

# When did you first notice it? Did you change any settings (Desktop Effects?) or update your system prior to first noticing it?

Freezes have generally been intermittent on this machine since Jaunty, but it hasn't been possible to reproduce with any sort of consistency. Doing a clean install of Karmic Alpha 3 causes this particular freeze to always happen when doing these particular steps.

# What frequency does it occur? Just once? Hourly? Daily?

Occurs every time I start the computer.

# Try to determine actions which reproduce it or make it more/less likely to reproduce.

Always reproduceable by clicking "Other" in gdm.

-- As per (https://wiki.ubuntu.com/X/Reporting)

- Paste in output of lspci -nn | grep VGA

michael@kiwi:~/dri_debug$ lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 82865G Integrated Graphics Controller [8086:2572] (rev 02)

Get a full backtrace (X/Backtracing)

How complete is the X failure?
+ Does ctrl+alt+f1 take you to a console?
No.
+ Does ctrl+alt+backspace restart X?
No.
+ Does mouse pointer still move?
Yes.
+ Does the keyboard LED come on when hitting the CAPSLOCK key?
No.
+ Can you ssh into the system from another computer?
Yes.

Michael Chang (thenewme91) wrote :
Dave Gilbert (ubuntu-treblig) wrote :

I've not tried logging in as Other... but I do notice when I select my username and the dialog reduces in size as it asks me for the password I do get the black bands top and bottom.

Dave

Geir Ove Myhr (gomyhr) on 2009-08-03
tags: added: 865g freeze karmic
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Triaged
importance: Undecided → High
Albert Damen (albrt) wrote :

There is a kernel fix in Eric Anholt's drm-intel-next git tree that seems to solve the freeze issue for me (on 865):

committer Eric Anholt <email address hidden>
 Fri, 11 Sep 2009 18:39:23 +0000 (11:39 -0700)
commit e517a5e97080bbe52857bd0d7df9b66602d53c4d

agp/intel: Fix the pre-9xx chipset flush.

Michael Chang (thenewme91) wrote :

I'm currently away from the machine in question which was exhibiting this behavior, so I can't say whether that commit solves my issue at this time.

esver (esver) wrote :

I think I have the same bug, here is my report : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/438070

With the "Fix the pre-9xx chipset flush." I have no freeze for the moment (1 day uptime)

Bryce Harrington (bryce) wrote :

Filing against linux since as per comment #4 this is fixed with a kernel patch.
Would be great to see this included by the Karmic release.

Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: xorg-needs-kernel-fix
Changed in linux (Ubuntu):
milestone: none → ubuntu-9.10
tags: added: cherry-pick
Changed in linux (Ubuntu Karmic):
status: New → Triaged
Andy Whitcroft (apw) wrote :

Seems that this commit has been submitted for 2.6.31-stable, and we are expecting to recieve it in 2.6.31.2. Watch this space.

Andy Whitcroft (apw) wrote :

Ok the suggest fix is now committed to our tree and contained in the Ubuntu-2.6.31-12.39 kernel. Could those affected please update to this kernel or later and retest. Please report success or failure here. Thanks!

Andy Whitcroft (apw) on 2009-10-07
Changed in linux (Ubuntu Karmic):
assignee: nobody → Andy Whitcroft (apw)
status: Triaged → Incomplete
Kalin Arsov (kalin-arsov) wrote :

For me the freezes have not appeared yet. It's a great improvement since the system froze seconds after the gdm login when using the latest xserver-xorg-video-intel driver (and I was forced to use the ubuntu-x-swat/x-retro 2.4 ppa driver just to be able to work... until now).

I can't be sure if the freezes have disappeared completely since the system was upgraded just an hour ago. However simply being able to work using the latest video driver is awesome.

esver (esver) wrote :

It works for me to. 4 hours without any freeze.

I continu to test but I think it's solved for me.

Andy Whitcroft (apw) wrote :

Thats sounding very positive and in line with expectations as the suspected fix is in that version. I'll close this Fix Released. Please reopen it by moving it to Triaged if you have a recurrance.

Changed in xserver-xorg-video-intel (Ubuntu Karmic):
status: Triaged → Fix Released
Andy Whitcroft (apw) on 2009-10-14
Changed in linux (Ubuntu Karmic):
status: Incomplete → Fix Released
Allen.McIntosh (mcintosh) wrote :

Unfortunately this bug seems to be still with us.

Fresh install of Karmic on a Lenovo T61, everything up to date. Get the dreaded
    INFO: task i915/0:365 blocked for more than 120 seconds.
message. It seems random, but on reflection I think it happens when I hit a key or move the mouse after the machine has powered down the display because of no mouse/keyboard activity. The call trace looks like this:

__mutex_lock_slowpath+0xc6/0x130
mutex_lock+0x20/0x40
i915_gem_retire_work_handler+0x2a/0x70 [i915]
run_workqueue+0x6e/0x140
? i915_gem_retire_work_handler+0x0/0x70 [i915]
worker_thread+0x88/0xe0
? autoremove_wake_function+0x0/0x40
? worker_thread+0x0/0xe0
kthread+0x7c/0x90
? kthread+0x0/0x90
kernel_thread_helper+0x7/0x10

which I have seen in other bug reports. The display is frozen, <ctrl><alt><f2> doesn't do anything. I didn't check keyboard lights, but it was possible to log in remotely. System log also shows my KVM interacting with the USB adapter.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers