[i945gm] dual screen not working with virtual resolution enabled: just a blank screen with a mouse pointer

Bug #383345 reported by Lucian Adrian Grijincu on 2009-06-03
122
This bug affects 16 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
High
linux (Ubuntu)
High
Unassigned
Nominated for Karmic by Lucian Adrian Grijincu
xserver-xorg-video-intel (Ubuntu)
High
Alberto Milone
Nominated for Karmic by Lucian Adrian Grijincu

Bug Description

Binary package hint: xserver-xorg-video-intel

I have a dual screen setup:
 * Dell Latitude's D820 own screen (1680x1050)
 * a LG secondary monitor (1280x1024)

To enable dual screen, I had to add
 SubSection "Display"
  Virtual 2960 1065
 EndSubSection
in Section "Screen" of /etc/X11/xorg.conf (this was added automatically by the "Display" applet).

I just ran a dist-upgrade which brought a new kernel:
   Linux lethe 2.6.30-7-generic #8-Ubuntu SMP Mon May 25 13:53:42 UTC 2009 i686 GNU/Linux
and a new xserver-xorg-video-intel:
   gringo@lethe:~$ apt-cache policy xserver-xorg-video-intel
   xserver-xorg-video-intel: 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu1

I rebooted the system, and after the system started I was left with a blank background and a working mouse pointer (by working I mean I can move it around and between the screens).

I Alt+Ctlr+F2'd and tried a few times to restart gdm but found the same result.
I removed the Subsection I mentioned above from xorg.conf and restarted gdm again. This time the menu and task-bar have loaded, but the screens are mirrored.

I proceeded to setting them as separate screens in the "Display" applet (from System->Preferences). I was notified that the "Virtual" line was going to be added to xorg.conf and that I should log out and in again, which I did. Unfortunately I had the same blank screen with functional mouse pointer.

I mention that I do not have Desktop Effects enabled as they are not supported in combination with the "Virtual" line in xorg.conf for my card: 00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

ProblemType: Bug
Architecture: i386
Date: Wed Jun 3 23:21:33 2009
DistroRelease: Ubuntu 9.10
MachineType: Dell Inc. Latitude D820
Package: xserver-xorg-video-intel 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu1
ProcCmdLine: root=UUID=04f2beb3-eaec-4174-bbd9-5d37c19979fb ro quiet splash
ProcEnviron:
 PATH=(custom, no user)
 LANG=ro_RO.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-7.8-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4~5ubuntu20
 libgl1-mesa-glx 7.4.1-1ubuntu1
 libdrm2 2.4.11-0ubuntu1
 xserver-xorg-video-intel 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu1
 xserver-xorg-video-ati 1:6.12.2-1ubuntu1
SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.30-7-generic i686
dmi.bios.date: 10/13/2006
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.name: 0GF470
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd10/13/2006:svnDellInc.:pnLatitudeD820:pvr:rvnDellInc.:rn0GF470:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude D820
dmi.sys.vendor: Dell Inc.
fglrx: Not loaded
fglrx-loaded: Error: command ['grep', 'fglrx', '/var/log/kern.log', '/proc/modules'] failed with exit code 1:
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.30-7-generic

Created an attachment (id=26414)
Xorg.0.log without virtual resolution on git HEAD verion of xserver-xorg-video-intel

Created an attachment (id=26415)
dmesg without virtual resolution on git HEAD verion of xserver-xorg-video-intel

Created an attachment (id=26416)
xrandr --verbose without virtual res on git HEAD

Created an attachment (id=26417)
dmesg with virtual resolution in xorg.conf - screen is blank, mouse woking

Created an attachment (id=26418)
Xorg.0.log with virtual resolution in xorg.conf - screen is blank, mouse woking

Binary package hint: xserver-xorg-video-intel

I have a dual screen setup:
 * Dell Latitude's D820 own screen (1680x1050)
 * a LG secondary monitor (1280x1024)

To enable dual screen, I had to add
 SubSection "Display"
  Virtual 2960 1065
 EndSubSection
in Section "Screen" of /etc/X11/xorg.conf (this was added automatically by the "Display" applet).

I just ran a dist-upgrade which brought a new kernel:
   Linux lethe 2.6.30-7-generic #8-Ubuntu SMP Mon May 25 13:53:42 UTC 2009 i686 GNU/Linux
and a new xserver-xorg-video-intel:
   gringo@lethe:~$ apt-cache policy xserver-xorg-video-intel
   xserver-xorg-video-intel: 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu1

I rebooted the system, and after the system started I was left with a blank background and a working mouse pointer (by working I mean I can move it around and between the screens).

I Alt+Ctlr+F2'd and tried a few times to restart gdm but found the same result.
I removed the Subsection I mentioned above from xorg.conf and restarted gdm again. This time the menu and task-bar have loaded, but the screens are mirrored.

I proceeded to setting them as separate screens in the "Display" applet (from System->Preferences). I was notified that the "Virtual" line was going to be added to xorg.conf and that I should log out and in again, which I did. Unfortunately I had the same blank screen with functional mouse pointer.

I mention that I do not have Desktop Effects enabled as they are not supported in combination with the "Virtual" line in xorg.conf for my card: 00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

ProblemType: Bug
Architecture: i386
Date: Wed Jun 3 23:21:33 2009
DistroRelease: Ubuntu 9.10
MachineType: Dell Inc. Latitude D820
Package: xserver-xorg-video-intel 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu1
ProcCmdLine: root=UUID=04f2beb3-eaec-4174-bbd9-5d37c19979fb ro quiet splash
ProcEnviron:
 PATH=(custom, no user)
 LANG=ro_RO.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-7.8-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4~5ubuntu20
 libgl1-mesa-glx 7.4.1-1ubuntu1
 libdrm2 2.4.11-0ubuntu1
 xserver-xorg-video-intel 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu1
 xserver-xorg-video-ati 1:6.12.2-1ubuntu1
SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.30-7-generic i686
dmi.bios.date: 10/13/2006
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.name: 0GF470
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd10/13/2006:svnDellInc.:pnLatitudeD820:pvr:rvnDellInc.:rn0GF470:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Latitude D820
dmi.sys.vendor: Dell Inc.
fglrx: Not loaded
fglrx-loaded: Error: command ['grep', 'fglrx', '/var/log/kern.log', '/proc/modules'] failed with exit code 1:
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.30-7-generic

The xorg conf file submitted by "ubuntu-bug -p xserver-xorg-video-intel" locate at http://launchpadlibrarian.net/27469629/XorgConf.txt is the one I currently use and which works, but gives me only mirrored dual screen.

Oh, and I forgot to mention: I have autologin enabled on my desktop.

I tried a few other resolution configurations.

In each configuration in which the Display applet alerted me that the "Virtual" line needed to be added to xorg.conf I was left with the blank screen I mentioned.

In each configuration in which the "Virtual" line was *NOT* needed I could successfully setup two different monitors without mirroring. For example now I have a working 1024x768 on both monitors and I had 800x600 on both working previously.

Just to make it clear, setups with *different* resolutions on the screens work too. E.g. 800x600 on the external screen and 1024x768 on the laptop screen works fine.

1. I selected a resolution that works fine if the Virtual line is not present in xorg.conf: both screens at 1024x786, and I added the Virtual line to xorg.conf.

After restarting gdm I was greeted by the same blank screen with a mouse pointer.

2. Taking a suggestion from https://wiki.ubuntu.com/X/Troubleshooting, I tried adding
        Option "DRI" "false"
while still having the "Virtual" line in xorg.conf. Unfortunately, after restating gdm I was left with the same blank screen.

3. As suggested in xorg.conf, I ran
    sudo dpkg-reconfigure -phigh xserver-xorg
and I was left with a xorg.conf with no "Virtual" line, with which I could use dual-screen without mirroring for some configurations that do not need the Virtual line.

I created a new PPA with the latest sources from upstream:
https://launchpad.net/~lucian.grijincu/+archive/xserver-xorg-video-intel

Unfortunately the problem is present in HEAD too.

I can confirm that this problem is not present in the previous version of xserver-xorg-video-intel=2:2.7.1-1ubuntu1

A workaround for the problem for now is to install the previous version which can be downloaded from:
  http://archive.ubuntu.com/ubuntu/pool/main/x/xserver-xorg-video-intel/
  http://archive.ubuntu.com/ubuntu/pool/main/x/xserver-xorg-video-intel/xserver-xorg-video-intel_2.7.1-1ubuntu1_i386.deb

summary: - dual screen not working: just a blank screen with a mouse pointer
+ [i945GM] dual screen not working with virtual resolution enabled: just a
+ blank screen with a mouse pointer

Updated according to https://wiki.ubuntu.com/X/Triaging and setting status to Confirmed.

tags: added: regression-update
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
tags: added: dual-head

I have similar problems on i915. In my case I don't even have to have virtual resolution enabled to encounter the problems. The only dual-head that works is mirroring screens. After I get black screen with movable mouse pointer the server doesn't react neither to ctrl+alt+F<n> nor ctrl+alt+backspace (I have DontZap set to false so this normally works). I can ssh to the machine: sending SIGTERM to X process doesn't have any effect. Sending SIGKILL freezes whole machine. I'm attaching Xserver logs, config and output of lspci.

Cheers

  Morg

The server that produced this log file started from mirroring screens. After I logged in I tried to make them independent which resulted in black screen with movable mouse pointer. Pressing ctrl+alt+{backspace,F<n>} had no effect. Then I sent SIGTERM to the server which also didn't have any effect. Then I sent SIGKILL and machine froze.

I tried to update the kernel to 2.6.30 but it didn't help much and I had black screen after attempt to use second screen. I'm attaching the logs.

I tried to investigate in which upstream commit this problem was introduced and it seems it was exactly the one from which the release was made (http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=ec2fde7c8250fdc30984f16c8a1d3587d70b0144).
I prepared packages from the previous commit (http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=704771f1c595df481d244a6f074e9f5620d4a720) in this PPA: https://launchpad.net/~morgwai/+archive/bug383345 (both for karmic and jaunty). If someone could check if they work for him also then we would have confirmed information that the bug was introduced exactly in the commit I mentioned.

Thanks

  Morg

One thing that I just noticed: on Intel Mobile 4 Series card the packages from my PPA solve the problem completely. However on i915 if virtual width is bigger than 2048 I get the results similar to those described initially by Lucian. Below 2048 it also works fine.

Cheers

  Morg

I tried xserver-xorg-video-intel - 2:2.7.99.1+git20090528.704771f1-0ubuntu0morgwai1 but got the same result: black screen with working mouse.

Note that unlink Piotr's case, I can Alt+Ctrl+Fn just fine and restart the server with
  /etc/init.d/gdm restart

Maybe these are two distinct bugs with similar symptoms?

Lucian,
Did you try reducing virtual resolution so both dimensions are lower than 2048?
Please also note that with the driver I provided and virtual width > 2048 I have *exactly* the same results as you: I can switch virtual console with alt+ctrl+F<n> and restart the server. Sorry if I didn't made this clear previously.

Cheers

  Morg

I can confirm this bug in the xorg-edgers PPA package version 2:2.7.99.1+git20090605.66ceedc0-0ubuntu0sarvatt2~jaunty on kernel 2.6.30-rc8.

The login screen remains black with a movable mouse courser, when a virtual resolution above 2048 is configured.

Things here seem better than bug#21190 (in which X even can't startup), with similar configuration.

*** Bug 22233 has been marked as a duplicate of this bug. ***

put the 2 monitors as top-bottom instead of left-right to fit virtual < 2048x2048 could be a workaround before this bug fixed.

jayprakash (jay-jay-cz) wrote :

Hi,
Confirming this bug.

Running on
https://launchpad.net/~xorg-edgers/+archive/ppa
(newest xorg, intel driver and kernel)
(so only UXA and DRI2)

I have some xrandr configurations bind to keyboard shortcuts, so it's easy for me to test without restarts.

Without compiz, everything works (curently running 2048x768 dual). Even resolutions greater than 2048x2048.

With compiz:
1. xrandr --output LVDS --mode 1024x768 --primary --output VGA --mode 1024x768 --right-of LVDS
Black or corrupt screen (but mouse shows it is in correct resolutions next to each other).

2. xrandr --output LVDS --mode 800x600 --primary --output VGA --mode 1024x768 --right-of LVDS
WORKS
3. xrandr --output LVDS --mode 1024x768 --primary --output VGA --mode 800x600 --right-of LVDS
WORKS
4. xrandr --output LVDS --mode 1024x768 --primary --output VGA --mode 1024x768 --same-as LVDS
WORKS
5. xrandr --output LVDS --mode 1024x768 --primary --output VGA --mode 1360x768 --above LVDS
WORKS - today morning worked :)

For compiz settings "loose bindings" or "indirect rendering" in any configuration have no effect.

Tested xserver-xorg-video-intel - 2:2.7.99.1+git20090528.704771f1-0ubuntu0morgwai1~jaunty1
No change.

Tested kernels 2.6.30-9 and 2.6.30-8 with no difference.

X log shows nothing interesting.

If you need anything to test, I'm availiable.

jayprakash (jay-jay-cz) wrote :

xserver-xorg-video-intel - 2:2.7.1-0ubuntu1~xup~1
from
https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

xrandr --output LVDS --mode 1024x768 --primary --output VGA --mode 1024x768 --right-of LVDS
WORKS with compiz enabled

with "loose bindings", problem with window textures not updating (for example, scrolling in firefox is not visible until compiz restarted or turned off). But this setting is primary for nvidia.

virtual entry beyond 2048x2048 in xorg.conf results in white screen with compiz enabled, regardless of resolution (even in clone setup) (without compiz works everything)

I ran a git bisect between today's HEAD (b5cd2130f97591f4a387db1b98c940c30bc6404c - TV: Set correct voltage level override values) - which, by the way still has this problem, and 2.7.1.

The problem appears at the commit:1b10745a2528622a32271f64c35fcdb7b7154d11
    Remove XAA support.

I guess you susspected that, but I wanted to make sure.
If you have any ideas regarding how to fix this, I can provide my spare time and a machine to test this.

I think this is a duplicate of bug 22328 -- when resizing the frame buffer with no DRI, the screen pixmap pointer would not get reset correctly. A fix for that has been pushed to the driver, please re-open this bug if that isn't sufficient.

*** This bug has been marked as a duplicate of bug 22328 ***

Changed in xserver-xorg-video-intel:
status: Confirmed → Invalid
jayprakash (jay-jay-cz) wrote :

Please, is here anyone able and willing to create .deb for us mortals :)

I'd like to check the fix reported:
https://bugs.freedesktop.org/show_bug.cgi?id=22328

(acording to : Comment #10 From Keith Packard 2009-07-07 15:25:53 PST
https://bugs.freedesktop.org/show_bug.cgi?id=22076#c10 )

jayprakash (jay-jay-cz) wrote :

todays update :
xorg-server - 2:1.6.2~git20090708+server-1.6-branch.6f1aff5a-0ubuntu0sarvatt~jaunty
xserver-xorg-video-intel - 2:2.7.99.901+git20090708.r1.40e7c950-0ubuntu0sarvatt~jaunty

xrandr --output LVDS --mode 1024x768 --primary --output VGA --mode 1360x768 --above LVDS
works with or without compiz.

xrandr --output LVDS --mode 1024x768 --primary --output VGA --mode 1024x768 --right-of LVDS
does NOT work with compiz. (nothing new)
does work without compiz. (nothing new).

Even with
Virtual 2732 2048
unable to set
xrandr --output LVDS --mode 1024x768 --primary --output VGA --mode 1360x768 --right-of LVDS

(not using xrandr but gnome display settings because of bug https://bugs.launchpad.net/ubuntu/+source/xrandr/+bug/394490 .
I write xranrd commands only to show the configuration.)

jayprakash (jay-jay-cz) wrote :

Activated KMS on 2.6.30-10
still the same.

With the new kernel, "Virtual" setting in xorg.conf crashes xserver on startup.
$ xrandr
Screen 0: minimum 320 x 200, current 1360 x 1536, maximum 2048 x 2048

Unable to set resolutions beyond 2048.
With compiz on 2048x768, black/white/or garbage screen (mostly black) with correct resolution and moving mouse between screens.

So the possibilities:
1 ) https://bugs.freedesktop.org/show_bug.cgi?id=22076 is NOT duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=22328
2 ) This bug is not related to https://bugs.freedesktop.org/show_bug.cgi?id=22076
3 ) I have completely different bug.

If you need testing, put a .deb somewhere and I'll test it as soon as an email comes to me :)

*** Bug 22718 has been marked as a duplicate of this bug. ***

Bryce Harrington (bryce) on 2009-07-13
Changed in xserver-xorg-video-intel:
status: Invalid → Unknown
Changed in xserver-xorg-video-intel:
status: Unknown → Fix Released
jayprakash (jay-jay-cz) wrote :

@Lucian
Please write if it's fixed for you.

It's not fixed for me, and even it's worse (xorg doesn't start with "virtual" in xorg.conf).

So It's possible I have different bug.

Bryce Harrington (bryce) on 2009-07-14
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Triaged

I don't think this is a duplicate of #22328.
First of all the bug descriptions are different:
* #22328 - says the display will be blank with resolutions 1280x800, 1024x768 and 800x600, but it can display normal when changed to 640x480
* this bug says that everything works fine with those resolutions, but stops working when using the Virtual line in xorg.conf.

I built the xserver containing the changes that fixed #22328
    non-DRI FB resize failed to assign the screen pixmap devPrivate.ptr (22328)
but it still does not fix my problem (and as you can read from the Launchpad bug it does not fix it for other either https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/383345).

* without "Virtual" in xorg.conf everything seems to work fine (no change from before - two screens can be mirrored)
* with "Virtual" in xorg.conf I tested two cases:
** Virtual 2960 1065 -- gdm would not start, and it seamed stuck in a loop trying to start the x server
** Virtual 2048 1065 -- gdm would start, but the image on the screen was destroyed (thin lines from the images dispersed over the screen), BUT the mouse pointer was displayed correctly.

I built the git HEAD last night and ran some tests:
* without "Virtual" in xorg.conf everything seems to work fine (no change)
* with "Virtual" in xorg.conf I tested two cases:
** Virtual 2960 1065 -- gdm would not start, and it seamed stuck in a loop trying to start the x server
** Virtual 2048 1065 -- gdm would start, but the image on the screen was destroyed (thin lines from the images dispersed over the screen), BUT the mouse pointer was displayed correctly.

Changed in xserver-xorg-video-intel:
status: Fix Released → Unknown
jayprakash (jay-jay-cz) wrote :

@Lucian
Please for clarification.
You have "destroyed screen" before login on login screen, or after login in gnome.

It never happened to me before login. On login screen I have Always cloned outputs.
After Login, only with compiz enabled, I have the bug you described.

jayprakash (jay-jay-cz) wrote :

@Lucian
... or do you have autologin enabled?

Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Geir Ove Myhr (gomyhr) on 2009-07-26
tags: added: 945gm
Bryce Harrington (bryce) on 2009-07-30
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
Bryce Harrington (bryce) on 2009-08-13
tags: added: karmic
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
24 comments hidden view all 104 comments
jayprakash (jay-jay-cz) wrote :

sorry for spam, but that was a terrible misspell :)
"A colleague just updated to karmic." is correct :)

Vincenzo Ciancia (vincenzo-ml) wrote :

For those who have the black screen problem with i945gm (e.g. eeepc 1005ha) try to boot with the vga cable attached. This works perfectly on my system (I use compiz on extended monitor setup).

jayprakash (jay-jay-cz) wrote :

@ vincenzo
Interesting comment of yours.

Attached VGA cable is regretfully not a solution, I nearly always start system with attached VGA cable.

And could you please provide lspci -vvn
and information if you are realy running on full karmic system and/or xorg-edgers repository?

Radomirs Cirskis (nad2000) wrote :

I confirm this problem with Dell Latitude D420 after upgrading to 9.10
I have it connected to an external display 1680x1050 (AOC 2216a)
When I set them mirrored I cannot set higher resolution;
When they are unmirrored after setting external display resolution screen gets dark with activer mouse pointer. After some time system stops to respond all together.
I didn't have this issue with 9.04.

lspci -nn |grep VGA
     00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)

sudo lshw -c video
  *-display:0
       description: VGA compatible controller
       product: Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 03
       width: 32 bits
       clock: 33MHz
       capabilities: msi pm bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:16 memory:eff00000-eff7ffff ioport:eff8(size=8) memory:d0000000-dfffffff(prefetchable) memory:efec0000-efefffff
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 03
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:eff80000-efffffff

Andcor (corneliussen) wrote :

I can confirm that this bug must be in desktop effects. When I have desktop effects enabled and connects a second screen, both screen blanks and the system crashes.

Has anyone made a bug-report of the problem in the desktop effects project?

MJB-ESOFT (mjb-esoft) wrote :

Based on input from http://www.thinkwiki.org/wiki/Xorg_RandR_1.2#Now_automate_it_on_login the following .xprofile fixed dual screen on Lenovo T60 for me:

$ cat .xprofile
xrandr --output LVDS1 --mode 1280x800 --output VGA1 --mode 1680x1050
xrandr --output VGA1 --off
xrandr --output VGA1 --auto --right-of LVDS1

MJB-ESOFT (mjb-esoft) wrote :

Based on input from

http://www.thinkwiki.org/wiki/Xorg_RandR_1.2#Now_automate_it_on_login

the following .xprofile fixed dual screen on Lenovo T60 for me:

$ cat .xprofile
xrandr --output LVDS1 --mode 1280x800 --output VGA1 --mode 1680x1050
xrandr --output VGA1 --off
xrandr --output VGA1 --auto --right-of LVDS1

Andcor (corneliussen) wrote :

Was that with or without desktop effects enabled?

MJB-ESOFT (mjb-esoft) wrote :
Download full text (3.7 KiB)

I was enabled, but I can see I was a bit too quick. In the end it only
worked with the xfce desktop. The Gnome desktop still doesn't work - at all.

On Tue, Nov 3, 2009 at 6:58 PM, Andcor <email address hidden> wrote:

> Was that with or without desktop effects enabled?
>
> --
> [i945GM] dual screen not working with virtual resolution enabled: just a
> blank screen with a mouse pointer
> https://bugs.launchpad.net/bugs/383345
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in X.org xf86-video-intel: Confirmed
> Status in “xserver-xorg-video-intel” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: xserver-xorg-video-intel
>
> I have a dual screen setup:
> * Dell Latitude's D820 own screen (1680x1050)
> * a LG secondary monitor (1280x1024)
>
> To enable dual screen, I had to add
> SubSection "Display"
> Virtual 2960 1065
> EndSubSection
> in Section "Screen" of /etc/X11/xorg.conf (this was added automatically by
> the "Display" applet).
>
> I just ran a dist-upgrade which brought a new kernel:
> Linux lethe 2.6.30-7-generic #8-Ubuntu SMP Mon May 25 13:53:42 UTC 2009
> i686 GNU/Linux
> and a new xserver-xorg-video-intel:
> gringo@lethe:~$ apt-cache policy xserver-xorg-video-intel
> xserver-xorg-video-intel: 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu1
>
> I rebooted the system, and after the system started I was left with a blank
> background and a working mouse pointer (by working I mean I can move it
> around and between the screens).
>
> I Alt+Ctlr+F2'd and tried a few times to restart gdm but found the same
> result.
> I removed the Subsection I mentioned above from xorg.conf and restarted gdm
> again. This time the menu and task-bar have loaded, but the screens are
> mirrored.
>
> I proceeded to setting them as separate screens in the "Display" applet
> (from System->Preferences). I was notified that the "Virtual" line was going
> to be added to xorg.conf and that I should log out and in again, which I
> did. Unfortunately I had the same blank screen with functional mouse
> pointer.
>
> I mention that I do not have Desktop Effects enabled as they are not
> supported in combination with the "Virtual" line in xorg.conf for my card:
> 00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
> 943/940GML Express Integrated Graphics Controller (rev 03)
>
> ProblemType: Bug
> Architecture: i386
> Date: Wed Jun 3 23:21:33 2009
> DistroRelease: Ubuntu 9.10
> MachineType: Dell Inc. Latitude D820
> Package: xserver-xorg-video-intel 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu1
> ProcCmdLine: root=UUID=04f2beb3-eaec-4174-bbd9-5d37c19979fb ro quiet splash
> ProcEnviron:
> PATH=(custom, no user)
> LANG=ro_RO.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.30-7.8-generic
> RelatedPackageVersions:
> xserver-xorg 1:7.4~5ubuntu20
> libgl1-mesa-glx 7.4.1-1ubuntu1
> libdrm2 2.4.11-0ubuntu1
> xserver-xorg-video-intel 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu1
> xserver-xorg-video-ati 1:6.12.2-1ubuntu1
> SourcePackage: xserver-xorg-video-intel
> Uname: Linux 2.6.30-7-generic i686
> dmi.bios.date: 10/13/2006
> dmi.bios.vendor: De...

Read more...

miloos (milooos) wrote :

I have notebook with intel 855
1400x1050 screen and 1600x1200 external monitor
it was working corectly in 8.10 (and 8.04 )
after upgrade on 9.04 I didnt found any way how to configure both screens, I was believe in 9.10 and it dont work also

if is screen wider than 2048 login box is not displayed
If I set autologin both screens are black with bliking text console login but no input is possible

I have compiz uninstalled

jayprakash (jay-jay-cz) wrote :

@milos
your problem is unrelated.
i8xx HW cannot display framebuffer larger then 2048x2048.
It's a hardware limitation, not a system BUG.

@Radomirs
Please, at which combined resolution you get the black screen?

@Andcor
Please, what is your hardware?
Ubuntu does not automatically change resolutions after attach of external display.
Your BUG is unrelated to this one, in this BUG system does not crash.

@MJB-ESOFT
Please write you hardware.
Compiz cannot work at resolution higher that 2048x2048 (yet) on i915/945 hardware.

Andcor (corneliussen) wrote :

Output from lspci:

VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03)
Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML
Express Integrated Graphics Controller (rev 03)

I did not mean to say that ubuntu automatically changes resolution to
external display. But when an external display is connected, and the
command

xrandr -q

is runned, the system will find the external screen and change to the
resolution last used with this external screen. At least that is what
my system does and I haven't done anything to make it do so. I'm not
so sure my bug is unrelated in the fact that the system doesn't
totally crash, but just shows me two blank screens which i cannot do
anything about other than a hard reboot.

MJB-ESOFT (mjb-esoft) wrote :
  • specs.txt Edit (16.7 KiB, text/plain; charset=US-ASCII; name="specs.txt")
Download full text (4.0 KiB)

Specs in file.

On Wed, Nov 4, 2009 at 11:25 AM, jayprakash <email address hidden> wrote:

> @milos
> your problem is unrelated.
> i8xx HW cannot display framebuffer larger then 2048x2048.
> It's a hardware limitation, not a system BUG.
>
> @Radomirs
> Please, at which combined resolution you get the black screen?
>
> @Andcor
> Please, what is your hardware?
> Ubuntu does not automatically change resolutions after attach of external
> display.
> Your BUG is unrelated to this one, in this BUG system does not crash.
>
> @MJB-ESOFT
> Please write you hardware.
> Compiz cannot work at resolution higher that 2048x2048 (yet) on i915/945
> hardware.
>
> --
> [i945GM] dual screen not working with virtual resolution enabled: just a
> blank screen with a mouse pointer
> https://bugs.launchpad.net/bugs/383345
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in X.org xf86-video-intel: Confirmed
> Status in “xserver-xorg-video-intel” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: xserver-xorg-video-intel
>
> I have a dual screen setup:
> * Dell Latitude's D820 own screen (1680x1050)
> * a LG secondary monitor (1280x1024)
>
> To enable dual screen, I had to add
> SubSection "Display"
> Virtual 2960 1065
> EndSubSection
> in Section "Screen" of /etc/X11/xorg.conf (this was added automatically by
> the "Display" applet).
>
> I just ran a dist-upgrade which brought a new kernel:
> Linux lethe 2.6.30-7-generic #8-Ubuntu SMP Mon May 25 13:53:42 UTC 2009
> i686 GNU/Linux
> and a new xserver-xorg-video-intel:
> gringo@lethe:~$ apt-cache policy xserver-xorg-video-intel
> xserver-xorg-video-intel: 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu1
>
> I rebooted the system, and after the system started I was left with a blank
> background and a working mouse pointer (by working I mean I can move it
> around and between the screens).
>
> I Alt+Ctlr+F2'd and tried a few times to restart gdm but found the same
> result.
> I removed the Subsection I mentioned above from xorg.conf and restarted gdm
> again. This time the menu and task-bar have loaded, but the screens are
> mirrored.
>
> I proceeded to setting them as separate screens in the "Display" applet
> (from System->Preferences). I was notified that the "Virtual" line was going
> to be added to xorg.conf and that I should log out and in again, which I
> did. Unfortunately I had the same blank screen with functional mouse
> pointer.
>
> I mention that I do not have Desktop Effects enabled as they are not
> supported in combination with the "Virtual" line in xorg.conf for my card:
> 00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
> 943/940GML Express Integrated Graphics Controller (rev 03)
>
> ProblemType: Bug
> Architecture: i386
> Date: Wed Jun 3 23:21:33 2009
> DistroRelease: Ubuntu 9.10
> MachineType: Dell Inc. Latitude D820
> Package: xserver-xorg-video-intel 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu1
> ProcCmdLine: root=UUID=04f2beb3-eaec-4174-bbd9-5d37c19979fb ro quiet splash
> ProcEnviron:
> PATH=(custom, no user)
> LANG=ro_RO.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.30-7.8-ge...

Read more...

Radomirs Cirskis (nad2000) wrote :

@jayprakash
I got the black screen with folloing crashing at compbined resolution:
- Laptop : 1280 x 800
- External monitor: 1680 x 1050

BTW: http://ubuntuforums.org/showpost.php?p=8221370&postcount=9

jayprakash (jay-jay-cz) wrote :

@Radomirs:
Please, before setting dual screen, disable desktop effects (compiz).
Compiz cannot work at resolution higher that 2048x2048 (yet) on i915/945 hardware, limitation of HW 2048x2048 max texture size.
Without Desktop effects your dual screen configuration should work. (it is then limited to 4096x4096 framebuffer size.)
With Desktop effects and resolution 1024+1024, you probably will experience this BUG.

@MJB-ESOFT:
The same as Radomirs.

@Andcor:
Please disable desktop effects. Then attach external display. Do what yo do to activate it.
Check combined screen resolution.
If it is 2040 width, then it is this BUG.
If it is larger, then the same as Radomir.
If lower, then different BUG.

Andcor (corneliussen) wrote :

Sorry, its larger, and I kinda knew that. But it's a bug that desktop
effects cannot support desktops larger than 2040 isn't it?

Mvh

Andreas Corneliussen

2009/11/4 jayprakash <email address hidden>:
> @Radomirs:
> Please, before setting dual screen, disable desktop effects (compiz).
> Compiz cannot work at resolution higher that 2048x2048 (yet) on i915/945 hardware, limitation of HW 2048x2048 max texture size.
> Without Desktop effects your dual screen configuration should work. (it is then limited to 4096x4096 framebuffer size.)
> With Desktop effects and resolution 1024+1024, you probably will experience this BUG.
>
> @MJB-ESOFT:
> The same as Radomirs.
>
> @Andcor:
> Please disable desktop effects. Then attach external display. Do what yo do to activate it.
> Check combined screen resolution.
> If it is 2040 width, then it is this BUG.
> If it is larger, then the same as Radomir.
> If lower, then different BUG.
>
> --
> [i945GM] dual screen not working with virtual resolution enabled: just a blank screen with a mouse pointer
> https://bugs.launchpad.net/bugs/383345
> You received this bug notification because you are a direct subscriber
> of the bug.
>

jayprakash (jay-jay-cz) wrote :

sorry, there was a typo. Correct is 2048.

And it is NOT a BUG.
It is Hardware limitation of i915/i945 graphics cards.
i965 works with compiz (desktop effects) until 4096x4096

Andcor (corneliussen) wrote :

Ok. Thanks for the clarification.

MJB-ESOFT (mjb-esoft) wrote :
Download full text (3.5 KiB)

Thank you very much.

On Wed, Nov 4, 2009 at 1:29 PM, Andcor <email address hidden> wrote:

> Ok. Thanks for the clarification.
>
> --
> [i945GM] dual screen not working with virtual resolution enabled: just a
> blank screen with a mouse pointer
> https://bugs.launchpad.net/bugs/383345
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in X.org xf86-video-intel: Confirmed
> Status in “xserver-xorg-video-intel” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: xserver-xorg-video-intel
>
> I have a dual screen setup:
> * Dell Latitude's D820 own screen (1680x1050)
> * a LG secondary monitor (1280x1024)
>
> To enable dual screen, I had to add
> SubSection "Display"
> Virtual 2960 1065
> EndSubSection
> in Section "Screen" of /etc/X11/xorg.conf (this was added automatically by
> the "Display" applet).
>
> I just ran a dist-upgrade which brought a new kernel:
> Linux lethe 2.6.30-7-generic #8-Ubuntu SMP Mon May 25 13:53:42 UTC 2009
> i686 GNU/Linux
> and a new xserver-xorg-video-intel:
> gringo@lethe:~$ apt-cache policy xserver-xorg-video-intel
> xserver-xorg-video-intel: 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu1
>
> I rebooted the system, and after the system started I was left with a blank
> background and a working mouse pointer (by working I mean I can move it
> around and between the screens).
>
> I Alt+Ctlr+F2'd and tried a few times to restart gdm but found the same
> result.
> I removed the Subsection I mentioned above from xorg.conf and restarted gdm
> again. This time the menu and task-bar have loaded, but the screens are
> mirrored.
>
> I proceeded to setting them as separate screens in the "Display" applet
> (from System->Preferences). I was notified that the "Virtual" line was going
> to be added to xorg.conf and that I should log out and in again, which I
> did. Unfortunately I had the same blank screen with functional mouse
> pointer.
>
> I mention that I do not have Desktop Effects enabled as they are not
> supported in combination with the "Virtual" line in xorg.conf for my card:
> 00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
> 943/940GML Express Integrated Graphics Controller (rev 03)
>
> ProblemType: Bug
> Architecture: i386
> Date: Wed Jun 3 23:21:33 2009
> DistroRelease: Ubuntu 9.10
> MachineType: Dell Inc. Latitude D820
> Package: xserver-xorg-video-intel 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu1
> ProcCmdLine: root=UUID=04f2beb3-eaec-4174-bbd9-5d37c19979fb ro quiet splash
> ProcEnviron:
> PATH=(custom, no user)
> LANG=ro_RO.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.30-7.8-generic
> RelatedPackageVersions:
> xserver-xorg 1:7.4~5ubuntu20
> libgl1-mesa-glx 7.4.1-1ubuntu1
> libdrm2 2.4.11-0ubuntu1
> xserver-xorg-video-intel 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu1
> xserver-xorg-video-ati 1:6.12.2-1ubuntu1
> SourcePackage: xserver-xorg-video-intel
> Uname: Linux 2.6.30-7-generic i686
> dmi.bios.date: 10/13/2006
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: A04
> dmi.board.name: 0GF470
> dmi.board.vendor: Dell Inc.
> dmi.chassis.type: 8
> dmi.chassis.vendor: Dell Inc.
> dm...

Read more...

angleet (j-trachtenberg) wrote :

I experience this bug even if both monitors are set to 1024x768. I can only run dual monitors w/ Compiz turned on if I set the LCD to 1024x768 and the external monitor to 800x600 or lower.

Stats from compiz-check below:

$ ./compiz-check

Gathering information about your system...

 Distribution: Ubuntu 9.10
 Desktop environment: GNOME
 Graphics chip: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
 Driver in use: intel
 Rendering method: AIGLX

Checking if it's possible to run Compiz on your system...

 Checking for texture_from_pixmap... [ OK ]
 Checking for non power of two support... [ OK ]
 Checking for composite extension... [ OK ]
 Checking for FBConfig... [ OK ]
 Checking for hardware/setup problems... [ OK ]

Bryce Harrington (bryce) on 2010-02-27
tags: added: resolution
tags: added: black-screen
Bryce Harrington (bryce) on 2010-03-02
tags: added: mouse-pointer
Bryce Harrington (bryce) on 2010-03-02
summary: - [i945GM] dual screen not working with virtual resolution enabled: just a
- blank screen with a mouse pointer
+ [i945] [i945GM] dual screen not working with virtual resolution enabled:
+ just a blank screen with a mouse pointer
Bryce Harrington (bryce) on 2010-03-02
summary: - [i945] [i945GM] dual screen not working with virtual resolution enabled:
- just a blank screen with a mouse pointer
+ [i945gm] dual screen not working with virtual resolution enabled: just a
+ blank screen with a mouse pointer
Jeremy Foshee (jeremyfoshee) wrote :

Added a kernel task and adjusted priority and status to match the Xorg task.

-JFo

Changed in linux (Ubuntu):
status: New → Triaged
importance: Undecided → High
Jeremy Foshee (jeremyfoshee) wrote :

Hi All,
      In my readback, and please correct me if I am wrong, I did not see where anyone had tested this against the latest Lucid Alpha 3? Would it be possible for those of you experiencing this to try this against a Live image? Many of you may be aware that modesetting has migrated into the kernel. As such, there have been a number of drivers changed to run as KVM enabled. I would really appreciate some testing in Lucid. I'd also appreciate a test against the latest mainline build of the kernel in the team PPa to verify if this issue is showing up in a generic linux kernel.

Thanks!

~JFo

Jeremy Foshee (jeremyfoshee) wrote :

set Xserver-xorg task as invalid.

-JFo

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Invalid

I also experience the same error with compiz on 2024x1152 resolution. Interestingly there is no such bug when using metacity's compositing manager. Has somebody tried out kwin yet?

Oh and this error still exists on xorg-edgers with 2.6.33.

Laurens (laurenssss) wrote :

I can confirm this bug on an updated Lucid Beta 1.
When the width of both screens together is 2048px.
The screen now is not always black, see attachments.
There is a difference between switching from metacity to compiz, and switching with compiz from 800 to 1024px resolution, see attachments.
The first pixel column is still normal.
Mouse-cursor is still changing when hovering a text field.

Laurens (laurenssss) wrote :
Laurens (laurenssss) wrote :
Laurens (laurenssss) wrote :
jayprakash (jay-jay-cz) wrote :

@Laurens
on the left side,

you have 1px visible or more?
(that white left border)

I had always 1px.
But on your screens it looks like more. (But probably just an illusion after img resize)

Laurens (laurenssss) wrote :

It is only 1px. It just on the photo where it seems to be more.

jayprakash (jay-jay-cz) wrote :

last night upgrade 9.10 to 10.04:

Confirming Bug in 10.04.
No change.

Laurens (laurenssss) wrote :

I found out that in lucid, it is only a resolution of exactly 2048px in total, which is a problem.
If the total width is greater, for example 1280 + 800 = 2080px, then compiz is automatically replaced by metacity and things work fine. While in karmic it is everything >= 2048px that won't work.

@jayprakash can you confirm this too?

Could it be that there is a misunderstanding if compiz should run until and with 2048px or until and without 2048px, because of hardware limitations?

jayprakash (jay-jay-cz) wrote :

@Laurens
my comments 42-43
compiz works even on that 1px.

In jaunty I was on my daily work on 1024+1024 with compiz.
Since Karmic I use 1024+1280 without compiz.

The switch from compiz to metacity on changed resolution is without problems (gnome always starts with black screen 2048, I have keyboard shortcut to 1024+1280 - xrandr).

Kwin nearly always crashes the whole xserver on this resolution change. Sometimes (20%) it's succesfull in survival after compositing is auto turned off.

The maximum size of a 3D texture on i915/i945 is 2048x2048px.
Since compiz is one big texture, it is supposed to work on that resolution.

(Somewhere I red, that compiz developers plan to make compiz multitextured. I that case also older HW would manage big resolutions. Don't ask me how. I just red it on some compiz blog.)

Laurens (laurenssss) wrote :

This issue apparently has been fixed with the latest update.
Compiz is now already replaced by metacity with a resolution width of 2048 px in total.

compiz --replace
compiz (core) - Warn: Exceeded max texture size
Launching fallback window manager

Changed in linux (Ubuntu):
status: Triaged → Fix Released
jayprakash (jay-jay-cz) wrote :

oh no no no no no
this is wrong
The texture size is not exceeded.

for 1&half years i was daily working on 2048 with compiz.
:'(

@jayprakash:
And you have an Intel 945GM?
AFAIK 2048 pixel is a hardware limit here, see http://lists.freedesktop.org/archives/intel-gfx/2009-December/005243.html

jayprakash (jay-jay-cz) wrote :

@Jakob:
yes,
the limit is 2048x2048
But 2048 is the maximum size of a texture. that means that texture CAN BE 2048.
2049 is 1px over the maximum.

Anyone with 945 can test it with intrepid live CD. Compiz WILL WORK on 2048x786 dual screen.

This bug is not about disabling compiz at 2048,
but about some mathematical problem with maximum size of a texture.

I'd bet somebody on i965 would have the same problem on 4096 size of a screen.

The original bug of not supporting a framebuffer larger than 2048x2048 for i915 class hardware has been fixed. The remaining bug that compiz does not respect the maximum renderbuffer and texture size of 2048 and gracefully fallback to metacity is a bug in compiz. i915 hardware can only support a maximum size of 2048 in the 3D pipeline, so attempting to use a GL compositor above such a size is futile.

(In reply to comment #19)
> The original bug of not supporting a framebuffer larger than 2048x2048 for i915
> class hardware has been fixed. The remaining bug that compiz does not respect
> the maximum renderbuffer and texture size of 2048 and gracefully fallback to
> metacity is a bug in compiz. i915 hardware can only support a maximum size of
> 2048 in the 3D pipeline, so attempting to use a GL compositor above such a size
> is futile.

This bug was about using compiz AT the maximum size - 2048 width, NOT ABOVE.
At the maximum size of texture (for example 2048x768) the screen was black (blank).

Compiz should drop at >2048, and all the time it did.

I have the feeling you just want to close this bug, without fixing...

I'll bet my shorts, that the same situation will happen at 4096 (i965) or 8192 (newer cards).

Changed in xserver-xorg-video-intel:
importance: Unknown → High
status: Confirmed → Fix Released
Changed in xserver-xorg-video-intel:
importance: High → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → High
Displaying first 40 and last 40 comments. View all 104 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.