[i945] Intel 945GME screen corruption

Bug #378794 reported by Matteo Croce on 2009-05-20
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Incomplete
Medium
xserver-xorg-video-intel (Fedora)
Confirmed
Medium
xserver-xorg-video-intel (Ubuntu)
Low
Unassigned

Bug Description

With latest update to Jaunty the screen is corrupted.
I think it's a software thing as I can capture the corruption with ksnapshot

[lspci]
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
     Subsystem: ASUSTeK Computer Inc. Device 8340
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
     Subsystem: ASUSTeK Computer Inc. Device 8340

Matteo Croce (teknoraver) wrote :
delance (olivier-delance) wrote :

Which graphic card?

Matteo Croce (teknoraver) wrote :

Intel 945G (Atom netbook)

delance (olivier-delance) wrote :

I have seen bugs related to corrupted screens, but they look different.

affects: ubuntu → xserver-xorg-driver-i810 (Ubuntu)
Matteo Croce (teknoraver) wrote :

Corruption happens even with Ubuntu 9.10 and custon 2.6.32.1 kernel with Intel KMS enabled.
I attach some details

Matteo Croce (teknoraver) wrote :
Matteo Croce (teknoraver) wrote :
Matteo Croce (teknoraver) wrote :
affects: xserver-xorg-driver-i810 (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Matteo Croce (teknoraver) wrote :
Bryce Harrington (bryce) on 2010-02-09
description: updated
Vikram Dhillon (dhillon-v10) wrote :

Seems like these statements:

Not using default mode "some_resolution" (exceeds panel dimensions)
Not using default mode "some_resolution" (monitor doesn't support reduced blanking)

are causing the issue and thanks for checking this against the latest kernel, that saves me the trouble of asking you to do so :) I wonder if this is causing the tearing on the screenshot. Alright so I have a "silly" solution that might just work: For your monitor connection try the VGA port instead of DVI, here [1] it seems to work but its a different card though.

In addition to that, paste back the output of xrandr, this bug: https://bugs.launchpad.net/bugs/396171 seems to have problems related to the screen refresh rate.

[1] http://blogs.gnome.org/newren/2007/08/11/dear-lazyweb-how-to-get-native-screen-resolution-in-f7/

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Download full text (6.0 KiB)

Created an attachment (id=33508)
A snapshot of the corruption

On my 945GME card the screen is corrupted.
I think it's a software thing as I can capture the corruption with ksnapshot

I have te corruption with both KMS enabled or disabled.
Actually I'm using the notebook fine with the Xorg fbdev driver

# lspci -vvv
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
        Subsystem: ASUSTeK Computer Inc. Device 8340
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at f3e00000 (32-bit, non-prefetchable) [size=512K]
        Region 1: I/O ports at cc00 [size=8]
        Region 2: Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Region 3: Memory at f3dc0000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
                Address: 00000000 Data: 0000
        Capabilities: [d0] Power Management version 2
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Kernel driver in use: i915

$ DISPLAY=:0.0 xrandr --verbose
Screen 0: minimum 320 x 200, current 1024 x 600, maximum 4096 x 4096
VGA1 disconnected (normal left inverted right x axis y axis)
        Identifier: 0x41
        Timestamp: 1579531
        Subpixel: unknown
        Clones:
        CRTCs: 0 1
        Transform: 1.000000 0.000000 0.000000
                    0.000000 1.000000 0.000000
                    0.000000 0.000000 1.000000
                   filter:
LVDS1 connected 1024x600+0+0 (0x43) normal (normal left inverted right x axis y axis) 0mm x 0mm
        Identifier: 0x42
        Timestamp: 1579531
        Subpixel: horizontal rgb
       ...

Read more...

$ xrandr
Screen 0: minimum 320 x 200, current 1024 x 600, maximum 4096 x 4096
VGA1 disconnected (normal left inverted right x axis y axis)
LVDS1 connected 1024x600+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x600 60.2*+
   800x600 85.1 72.2 75.0 60.3 56.2
   640x480 85.0 72.8 75.0 59.9
   720x400 85.0
   640x400 85.1
   640x350 85.1

Matteo Croce (teknoraver) wrote :

For now I can use the notebook fine with Xorg driver "fbdev" so I think that it's not an HW issue.
Also as the corruption happens in the screenshot too so it's a software issue IMHO.

summary: - screen corruption with latest update
+ Intel 945GME screen corruption
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed

Created an attachment (id=33542)
moblin snapshot

Created an attachment (id=33543)
moblin screenshot (2)

Matteo Croce (teknoraver) wrote :
Bryce Harrington (bryce) on 2010-02-25
tags: added: jaunty
tags: added: karmic lucid
tags: added: intel xorg
Changed in xserver-xorg-video-intel (Fedora):
importance: Undecided → Unknown
status: New → Unknown
Bryce Harrington (bryce) on 2010-02-27
tags: added: corruption
Bryce Harrington (bryce) on 2010-02-27
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Triaged
Bryce Harrington (bryce) on 2010-03-02
summary: - Intel 945GME screen corruption
+ [i945] Intel 945GME screen corruption
tags: added: i945
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Thanks for reporting this bug to help making the Intel graphics driver
better. We hear from upstream that a number of bugs (possibly including
this one) have been fixed in the newer DRM code from the 2.6.33 kernel.
I don't know if your bug is one of the ones fixed in this release,
though, but we've prepared a PPA with this DRM update. Would you mind
installing this, rebooting, and testing if the original issue can be
reproduced with it or not?

The DRM PPA is here:

    https://edge.launchpad.net/~apw/+archive/red

Note there could be new bugs... please file these as new reports using
the command 'ubuntu-bug linux' (for kernel or DRM or KMS bugs) or
'ubuntu-bug xorg' if you suspect them to be X.org issues.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Incomplete
importance: Undecided → High
Matteo Croce (teknoraver) wrote :

No luck with such a new kernel.
I have also tried a vanilla 2.6.33 but the issue is still

Have you reported this error to the freedesktop.org bugzilla?
Keve

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Matteo Croce
Sent: Saturday, March 06, 2010 11:33 AM
To: Gabbert, Keve A
Subject: [Bug 378794] Re: [i945] Intel 945GME screen corruption

No luck with such a new kernel.
I have also tried a vanilla 2.6.33 but the issue is still

--
[i945] Intel 945GME screen corruption
https://bugs.launchpad.net/bugs/378794
You received this bug notification because you are a member of Intel
Team, which is a direct subscriber.

Status in X.org xf86-video-intel: Confirmed
Status in “xserver-xorg-video-intel” package in Ubuntu: Incomplete
Status in “xserver-xorg-video-intel” package in Fedora: Unknown

Bug description:
With latest update to Jaunty the screen is corrupted.
I think it's a software thing as I can capture the corruption with ksnapshot

[lspci]
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
     Subsystem: ASUSTeK Computer Inc. Device 8340
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
     Subsystem: ASUSTeK Computer Inc. Device 8340

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Triaged
kittu (sreekrishna-vadde) wrote :

happening after 9.10 to 10.04 upgrade on dell 1505

Matteo Croce (teknoraver) wrote :

kittu, your desktop seems normal

Hi Matteo,

Could you provide at least the following version details:

Linux kernel version
libdrm version
X server version
xf86-video-intel version

It's possible that you're seeing a bug that has since been fixed in one of those components.

Thanks,

-Carl

(In reply to comment #3)
> Hi Matteo,
>
> Could you provide at least the following version details:
>
> Linux kernel version
2.6.33.1

> libdrm version
2.4.18

> X server version
1.7.5

> xf86-video-intel version
2.9.1

> It's possible that you're seeing a bug that has since been fixed in one of
> those components.
>
> Thanks,
>
> -Carl
>

Changed in xserver-xorg-video-intel:
status: Confirmed → In Progress
Chris Halse Rogers (raof) wrote :

To help upstream it would be useful if you could try the newer versions of the -intel driver components available in the xorg-edgers PPA here: https://edge.launchpad.net/~xorg-edgers/+archive/ppa

That PPA contains an up to date snapshot of all the relevant driver components. If you still see that problem with the packages from the xorg-egders PPA, could you please run “apport-collect 378794”, which will collect all sorts of interesting logs.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Incomplete

It looks like an incomplete blit. The first things that spring to mind are various flushing fixes in libdrm, xserver, xf86-video-intel and mesa. But it doesn't look typical of that style of failure... However, it does match one of possible artifacts fixed by 944001201ca.

Or it might be one of the many tiling bugs since fixed.

Jamie Lokier (jamie-shareable) wrote :

Fwiw, I get a lot of screen corruption with Karmic and now Lucid, but it looks different to all the screenshots in prior comments. I notice it mostly when using Gnome Terminal - usually a block of characters is drawn blank (as if spaces), but occasionally (~25% of the time) will contain a corrupt spattering of pixels. But that's probably because I use the terminal more than anything else. It does sometimes happen when rendering in Firefox.

I'll try to get a screen shot next time.

My system is a laptop with Intel 945GM, and I have not enabled compositing (Visual Effects == None).

I've had problems with the X Intel video drivers from all versions of Ubuntu since about Hoary Hedgehog (maybe earlier), including a different type of corruption in Jaunty (which I haven't seen since), but the "block of pixels misdrawn" corruption seems to be only the last two releases.

Jamie Lokier (jamie-shareable) wrote :

I also get occasional complete crashes of the X server, about once every 2 weeks (average). I guess that's a different bug, but they might be related. It is very annoying as all applications are killed instantly.

When that happens, it tries to restart X and that always fails - so eventually it stops trying, and offers to run in "low graphics mode". However, once, it didn't even do that, instead it had the appearance of repeatedly trying to restart X forever.

That suggests the hardware, or the kernel, can get into a state where the X driver cannot reinitialise it.

I have checked whether booting with/without KMS ("nomodeset" to the kernel) makes a difference. It certainly affects the bootup screen (it's obviously not been tested much with nomodeset ;-) ), but:

The X display issues - this block pixel corruption, and occasional crashes - are the same with and without KMS. So it can probably be ruled out as the cause.

Zombie Ryushu (zombie-ryushu) wrote :

I have a similar bug to this but it only appears on my S-Video out. Whenever I run a hardware accelerated game I get heavy graphic corruption on the TV-out on my laptop. It worked under 9.04, but not here.

I believe this to be fixed - though as we have had several similar bugs, there is still the likelihood of one more lurking...

Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
status: In Progress → Fix Released
Changed in xserver-xorg-video-intel (Fedora):
status: Unknown → Confirmed
Changed in xserver-xorg-video-intel:
importance: Medium → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
Changed in xserver-xorg-video-intel (Fedora):
importance: Unknown → Medium
Timo Aaltonen (tjaalton) wrote :

no reply from Matteo, assuming this is fixed so closing the bug.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released

Still broken with driver 2.14 and xserver 7.6

Matteo Croce (teknoraver) wrote :

Hi Timo,

unfortunately I didn't have access to this netbook in a while, but I can confirm that the bug is still in Natty

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Released → Confirmed
Changed in xserver-xorg-video-intel:
status: Fix Released → Confirmed
Matteo Croce (teknoraver) wrote :

Just upgraded to Oneiric, the bug is still

As of Today, with all latest updates from Ubuntu 11.10, that is:
Xorg 7.6, video-intel 2.17 on a 3.0.0 kernel, on a i915M (pentium M CPU), the bug is still here... Some portions of the screen are not refreshed, some menus are not refreshed (the K menu is never correctly displayed, one has to wave the mouse pointer up and down to show it), KDE4 notifications are usually only partially displayed, and the whole background sometimes shows stripes.

Mass status change to NEEDINFO based on presence of NEEDINFO keyword. Please reopen if you can still reproduce the bug and are able to provide the information requested, thanks.

Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
Mike Kovacevich (mikek) wrote :

This issue still exists in 12.04. Background image, Launchbar tooltips, menu items have been effected.

Chris Wilson (ickle) wrote :

We've changed everything upstream so please confirm the bug on an uptodate stack.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Chris Wilson (ickle) on 2013-04-22
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Matteo Croce (teknoraver) wrote :

Windows XP screenshot

Matteo Croce (teknoraver) wrote :

I think it's an hardware issue because I have the same issue under Windows

Matteo Croce, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-video-intel REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Invalid
importance: High → Low
status: Invalid → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.