Ubuntu

[i965] (Needs UXA) Choppy flash video and poor performance with compiz

Reported by Nathan Dorfman on 2009-05-12
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

Like others, I began having issues with Intel graphics after upgrading intrepid to jaunty. I happen to be lucky in that mine are not severe compared to others. If I can in any way help speed the fixes along, by testing new code or whatever, great.

I removed my card from the Compiz blacklist and have been using this Acer Aspire 5920 laptop constantly since upgrading two weeks ago. Since then, I have observed only the following issues:

- Flash video is choppy and unplayable. This is the most serious issue. By comparison, a 700MB " RIFF (little-endian) data, AVI, 720 x 304, 25.00 fps, video: XviD" file plays fine in totem, including full screen. Do I need to compare with a better quality video?

- "Reflection" Compiz plugin hangs X shortly into the session. No hangs have recurred since I disabled this plugin.

- "Rotate Cube" and "Shift Switcher" Compiz plugins perform poorly, although still would have been impressive a few years back. 2D plugins like wobbly windows, transparency, animations appear to work fine.

That's all. I hope the ubuntu-bug tool is attaching the right info, and I'll be glad to provide any more if it could help. Thanks, and have a good day!

ProblemType: Bug
Architecture: i386
Dependencies:

DistroRelease: Ubuntu 9.04
Package: xserver-xorg-video-intel None
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/usr/bin/zsh
ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009
SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.28-11-generic i686
UnreportableReason: This is not a genuine Ubuntu package

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 03)
     Subsystem: Acer Incorporated [ALI] Device [1025:0121]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 03)
     Subsystem: Acer Incorporated [ALI] Device [1025:0121]

Nathan Dorfman (ndorf) wrote :
Nathan Dorfman (ndorf) wrote :

Oh, I had just tried to roll this package to the 2.4.1 version, as per this:
https://wiki.ubuntu.com/ReinhardTartler/X/RevertingIntelDriverTo2.4

Interestingly, it didn't seem to have any perceptible effect. I'll move back to the jaunty 2.6.3 package now. I'd just realized this would affect any package info that ubuntu-bug attached. Sorry about that. To clarify, I have been running jaunty's 2.6.3 until an hour or two ago.

Nathan Dorfman (ndorf) wrote :

Update: *significant* improvement after enabling UXA accel mode. I can now watch most Flash video in full screen; 3D Compiz plugins "Rotate Cube" and "Shuffle Switcher" work perfectly. I've kept UXA enabled and have not noticed and issues, with stability or otherwise. I'll continue to run it and report back.

For completeness' sake: I tried the greedy migration heuristic in EXA mode first, and saw a marginal, barely noticeable performance improvement.

I'll retest the hangs with other Compiz plugins once I can get into an environment where I can log into the machine remotely.

Bryce Harrington (bryce) on 2009-05-12
summary: - GM965/GL960: video and compiz issues after jaunty upgrade
+ [i965] GM965/GL960: video and compiz issues after jaunty upgrade
Bryce Harrington (bryce) on 2009-05-17
description: updated
Bryce Harrington (bryce) on 2009-05-17
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed

I am happy to report that almost everything works great after enabling UXA. The performance problems are gone, and no stability issues or memory leaks have surfaced. Suspend and hibernation work fine.

Specifically, I added this single line to xorg.conf:
< Option "AccelMethod" "UXA"

Driver version:
ii xserver-xorg-video-intel 2:2.6.3-0ubuntu9

Also immediately noticeable is that the CPU usage of the Xorg process is dramatically reduced; even during playback of a 480p movie from Hulu, in full screen, it's around 10% or less, as opposed to 50-60% (and unwatchable results). Flash performance, of course, won't be mentioned in a family forum.

The Reflection Compiz plugin is still broken; it will hang X shortly after being enabled, just as without UXA. At this point, this is the only issue I can detect with this configuration. Everything else seems to be working flawlessly so far.

The Reflection hangs did not occur on the same machine running interpid, nor do they on a completely different system running jaunty today.

That's all .. thanks, and let me know if I can be of any help.

Bryce Harrington (bryce) on 2009-06-02
summary: - [i965] GM965/GL960: video and compiz issues after jaunty upgrade
+ [i965] (Needs UXA) GM965/GL960: video and compiz issues after jaunty
+ upgrade
summary: - [i965] (Needs UXA) GM965/GL960: video and compiz issues after jaunty
- upgrade
+ [i965] (Needs UXA) Choppy flash video and poor performance with compiz
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.7.99.1+git20090602.ec2fde7c-0ubuntu1

---------------
xserver-xorg-video-intel (2:2.7.99.1+git20090602.ec2fde7c-0ubuntu1) karmic; urgency=low

  * Update to git 20090602 (master branch) up to commit ec2fde7c
    - xvmc is disabled since DRI1 no longer supported
    - LP: #96991 - 3D stuff breaks with Compiz: Redirected Direct Rendering
      is needed in DRI
    - LP: #120834 - X freezes with I830WaitLpRing error when running OpenGL apps
    - LP: #337608 - X crashes in fbBlt() when using Sun Java Plugin 6 + firefox3.0
    - LP: #339555 - compiz slowmotion after Jaunty upgrade
    - LP: #363900 - X.org freezes with intel driver, no apparent trigger
    - LP: #331719 - VT switching doesn't work on Intel 915GM
    - LP: #339091 - X freezes a few minutes after resuming
    - LP: #348436 - Kubuntu: X server crash when screensaver is started (4500MHD)
    - LP: #279727 - Kubuntu: Display Corruption w/ Intel 4700MHD
    - LP: #357851 - Kubuntu: Distorted display after switching virtual desktops w/ exa
    - LP: #158415 - Front buffer dynamic resize not supported
    - LP: #324998 - x server restarts itself w/ compiz on Intel 945GM
    - LP: #355593 - after upgrade to 9.04, rotating desktop cube ran slow
    - LP: #357290 - 1 fps in 3d apps like neverball with EXA
    - LP: #360774 - Graphical Corruption with EXA on X4500
    - LP: #364126 - screensaver prefs dialog in 9.04 RC livecd leaves dirt
    - LP: #375712 - Native resolution for dell "2005fpw" monitor not listed
    - LP: #375264 - Choppy flash video and poor performance with compiz
    - LP: #349568 - Jaunty / Compiz slow and tearing on GMA 4500MHD
    - LP: #356056 - window tearing during movement on 965 (no compiz)
    - LP: #330460 - xorg shows black image/hangs with jpg in firefox
    - LP: #347587 - X asserts on pI830->batch_ptr != 0 on resume from suspend
  * Merge with Debian experimental. Remaining Ubuntu changes:
    - Add lpia architecture
    - Re-enable the patch system, add quilt to build-deps.
    - 110_quirk_hp_mini.patch: quirk (sent upstream)
    - 117_quirk_thinkpad_x30.patch: quirk (sent upstream)
  * Drop 116_8xx_disable_dri.patch. There have been fixes for 3d on 8xx
    chipsets upstream, so drop the DRI disablement so the fixes can be
    re-tested.
  * Drop 103_quirk_intel_mb890.patch. Better quirk available upstream.
    (LP: #305269)

 -- Bryce Harrington <email address hidden> Tue, 02 Jun 2009 10:47:32 -0700

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers