[i815] graphics corruption while moving mouse / opening menus (UXA bug)

Bug #373757 reported by SolidState2008 on 2009-05-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned

Bug Description

I've freshly installed Ubuntu 9.04 from the live-cd.

The place where my mouse was after logging in didn't have a proper background. The mouse cursor was surrounded by a black square.

Next to that, when I'm walking around with my mouse in the menu (pull-down the system menu), moving with my mouse leaves unwanted blocks visible.

Additional, opening any program (for example the help program) don't let the top-bar visible (with the buttons to resize or close the program). Also, most buttons in popup-windows are not visible.

Opening the terminal leaves a complete blank rectangle where normally a terminal window would be. There's nothing readable. I can type blind the word "exit" and press enter to leave the terminal, but nothing is visible of what I'm doing.

The display chip of this computer is an Intel 82815.

Ubuntu 8.04 and Ubuntu 8.10 didn't have these problems on this system with this display chip.

I'd like to go back to 8.10 because this worked perfectly, but I'd also like to move on to 9.04, hoping that this problem will be solved.

Thanks for reading.

If someone else has already reported this problem, I'm sorry. I haven't found this with google as a search machine.

I'm sorry if the chosen package is wrong. This system wasn't able to choose the radiobutton "I don't know"...

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/yelp
Package: yelp 2.25.1-0ubuntu5
ProcEnviron:
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
SourcePackage: yelp
Uname: Linux 2.6.28-11-generic i686

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82815 815 Chipset Host Bridge and Memory Controller Hub [8086:1130] (rev 02)
     Subsystem: Intel Corporation 82815 815 Chipset Host Bridge and Memory Controller Hub [8086:1130]
00:02.0 VGA compatible controller [0300]: Intel Corporation 82815 Chipset Graphics Controller (CGC) [8086:1132] (rev 02)
     Subsystem: Hewlett-Packard Company Device [103c:1245]

SolidState2008 (solidstate2008) wrote :
affects: yelp (Ubuntu) → ubuntu
SolidState2008 (solidstate2008) wrote :

Additional information: the system is a HP VL400 (model: P5071T).

In the attachment you can see Firefox, without the top-bar visible.

I opened a menu (System) and you can see by the non-white blocks how I moved my mouse down and up.

I hope this photo illustrates my described bug. My description may not be clear enough, because English isn't my native language...

Other experiences with Ubuntu 9.04: I've got it perfectly performing on an other machine (notebook) in a Virtual Machine (except for the VMware tools...).

affects: ubuntu → xorg (Ubuntu)
Martin Olsson (mnemo) wrote :

@SolidState2008, can you please run this command:
apport-collect 373757
(this command will automatically attach some info about your hardware etc to this bug report)

Random note to self: 373757 is a pretty cool bug number :-)

affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
description: updated
tags: added: corruption i815
summary: - General display bug, not only in yelp
+ [i815] graphics corruption while moving mouse / opening menus

Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-video-intel 2:2.6.3-0ubuntu9
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=nl_NL.UTF-8
ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

SolidState2008 (solidstate2008) wrote :
SolidState2008 (solidstate2008) wrote :
SolidState2008 (solidstate2008) wrote :
SolidState2008 (solidstate2008) wrote :

The apport was hard to do. As I stated earlier, my terminal screen was totally blank (nothing to read). I've tried to type in the command on good luck. Nothing happened.

Next, I started Ubuntu in recovery mode. Then at the prompt (with network) I typed the command again. It mentioned that a python-launchpad package was missing. So I added that (after googling how....).

Then I typed the apport command again and got some screen to type in the email and password. But that didn't work in textmode.

So I tried again with normal boot from a gui. I opened the terminal and I typed totally blind (nothing to read) the command. Now there was a webbrowser where I could add my email and password.

But then again, there was information about "Almost finished". I needed to go back to the application window in which I started the process and inform it that you have done your part of the process. After googling around I tried to hit the enter-key in the terminal screen (as I still couldn't read anything).

For still being a no-no in Linux I got two suggestions:
1. Describe a nice how-to about apport and what you can see on the screen and the dependencies in software and how to get it.
2. Try to make the command completely, so that no other activities need to be done in other screens, as users with problems like me can not always read screens....

Thanks for reading and thanks for all the effort you all did with this bug.

Much appreciated!

Martin Olsson (mnemo) wrote :

@SolidState2008, I agree completely, the "usability" aspect of that script is not what I should be, especially not for xorg bugs when you don't have a GUI browser.

From the looks of it, your driver seems to default to XAA mode (not EXA mode which is the default for modern intel cards on the 2.6.3 driver). I wonder if that means EXA is not supported for your chipset (I've never used an 82815 card before). Anyway, to narrow down the cause of this bug, could you please try a few tweaks?

What happens if you turn of DRI for the driver? Better or worse? You can do this by adding the line:
Option "DRI" "off"
inside the "Device" section of the file /etc/X11/xorg.conf (you can read more about setting up options for the driver in "man intel")

If the "DRI" "off" tweak doesn't fix it, then remove that "DRI" option again and try this one instead:
Option "NoAccel" "true"

Also, try upgrading to the 2.7.1 version of the intel driver and see if that version still exhibits the bug. You can do this by adding the X-Updates PPA in your /etc/apt/sources.list and then running the update-manager program:
https://launchpad.net/~ubuntu-x-swat/+archive/x-updates/

Finally, what happens if you run the intel driver in UXA mode? Did it work? Was it better or worse? You can do this by adding the line:
Option "AccelMethod" "UXA"
inside the "Device" section of the file /etc/X11/xorg.conf (you can read more about setting up options for the driver in "man intel")

Martin,

The option "DRI "off" solved my problem. Thank you very much. No mouse-tracks visible. Even the top-line from the programs (firefox and so on) are visible. Also the terminal works properly!

I'm very happy!

Do you like me to test the other suggestions?

Marcel

Martin,

I had a few hours left so I tried all your suggestions:

Adding
Option "DRI" "off"
-> Succesfull

Removing
Option "DRI" "off"
-> Problem is there again

Adding
Option "NoAccel" "true"
-> Succesfull

Removing
Option "No Accel" "true"
-> Problem is there again

Adding
Option "AccelMethod" "UXA"
-> Unsuccesfull. Problem is still there

Removing
Option "AccelMethod" "UXA"
-> Problem is still there

Upgrading intel driver through https://launchpad.net/~ubuntu-x-swat/+archive/x-updates/
-> Problem is still there

Adding (with new intel driver)
Option "AccelMethod" "UXA"
-> Unsuccesfull. Problem is still there

The first two options worked, so I'm happy. But which of the two options would you prefer en why?

Kind regards,
Marcel

Martin Olsson (mnemo) wrote :

@Marcel. Great work, this bug report is now has all the information necessary to open a upstream bug report. Can you please go do bugs.freedesktop.org and open a bug against "xorg" with component set to "Driver/Intel". Make sure you mention that the bug still repros using UXA because upstream have more or less stopped fixing EXA bugs. It's nice if you open the bug because the developers might eventually have more specific questions for you and they might ask you to test patches etc. Also, when the upstream bug report has been opened please click the "Also affects project" link here in the Launchpad bug report and paste the upstream bug URL there (this will make the bug reports connected so that Ubuntu the packagers get an automatic notification whenever the bug is fixed upstream). Thanks.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-05-17
description: updated
Bryce Harrington (bryce) on 2009-06-19
summary: - [i815] graphics corruption while moving mouse / opening menus
+ [i815] graphics corruption while moving mouse / opening menus (UXA bug)
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

A new major version of the -intel driver is now available in Karmic.

This version includes a major reworking of the acceleration
architecture, which resolves a huge number of issues. We do not know
whether it resolves the issue you reported.

Would you mind testing Karmic Alpha-2 and seeing if it is still a
problem? CD ISO images are available here:

  http://cdimages.ubuntu.com/releases/karmic/

If the issue can still be reproduced on karmic, please report here with
your findings, and attach a fresh Xorg.0.log from your test, and we will
be able to forward the bug upstream.

Otherwise, if the bug no longer exists in Karmic, let us know that as
well.

In the off chance you encounter different bugs while attempting to test
Karmic, please report those as new bug reports.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → New
status: New → Incomplete

Bryce,

Thanks for all the effort.

I was going to open an upstream bug, as Martin wrote on 2009-05-17, but I wanted to do this correctly in a for me quieter period of time.

Anyway, I'll test the Karmic release.

It was just raining over here so I thought "let's test Karmic".

I downloaded the ISO and burned a CD.

After that I tried to start the HP Vectra system. There was a menu and I choose for starting without changes to disk (option 1). Everything seems to go well, till the moment you would expect to get your normal Ubuntu desktop. Right at that moment it goes to prompt-mode:

ubuntu@ubuntu:~$

What to do now? Is this a bug which I need to report? Or do I need to give a command?

Please let me know... I've tried to start with the CD twice. Twice the same...

I hope to hear from you

Addition: For being sure it wasn't on the media, I did a integrity check on the CD afterwards.

Check finished: no errors found

Hope to year from you

Bryce Harrington (bryce) wrote :

> What to do now? Is this a bug which I need to report? Or do I need to give a command?

Hmm, that sounds pretty bad, but it's a different issue than you reported earlier, so yes you should report it as a separate bug.

If you know how to use the command prompt, you'll want to copy off dmesg, /var/log/Xorg.0.log, and /var/log/gdm/:0.log. If you don't know how to use it, you can ask for assistance at http://answers.launchpad.net/ubuntu/ and they can walk you through the procedure.

I suspect part of the issue is that i815 is no longer supported upstream, so it does not get tested or bug fixed. I hate to say it, but you may want to stick with 8.10 if that works for you, since we're unlikely to get much attention on this issue.

Bryce Harrington (bryce) on 2009-07-16
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Invalid

It seems this problems still occurs in 9.10. I had the same problem in a fresh install of version 9.10 with intel 815 graphics.

My workaround was to create a xorg.conf with

Section "Device"
Identifier "Configured Video Device"
Option "NoAccel" "true"
EndSection

The option with DRI didn't work.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Invalid → New
Bryce Harrington (bryce) wrote :

Upstream no longer supports i815 nor UXA in the -intel driver as of version 2.10, and because we are planning to include this version of the driver in Lucid we won't have i815 support. (We will try to transition to the -vesa driver for i815 so we at least don't leave you broken). I will leave the bug open against karmic in case someone wishes to propose a patch for this issue.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Won't Fix
Rolf Leggewie (r0lf) wrote :

Karmic has long since stopped to receive any updates. Marking the Karmic task for this ticket as "Won't Fix".

Changed in xserver-xorg-video-intel (Ubuntu Karmic):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers