[i945gm] X crashes after starting video

Bug #371288 reported by Szilárd Páll on 2009-05-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Although unfortunately I am often experiencing X lockups with "EQ Overflow" in the log this is the first time I notice another sort of message in the Xorg log, the also already known "Error in I830WaitLpRing" message.

The parts of log referring to the lockup are (only a couple of lines just to make this report easier to identify):

[...]
(II) AIGLX: Suspending AIGLX clients for VT switch
Error in I830WaitLpRing(), timeout for 2 seconds
pgetbl_ctl: 0x7ffc0001getbl_err: 0x0
[...]

My system consists of an HP nx7400 with Intel i945GM chipset and I am using an up to date Ubuntu 8.04.2 LTS.

Reproducing this particular flavor of the bug might not be that simple but typically one out of three clean boots I experience a lockup (typically the one with "EQ overflow") right after starting a video playback.

Attached I include the Xorg log.

Any suggestion for fixing this issue is welcome (unfortunately I have experienced it with 8.10 and 9.04 as well), I would be glad to do some testing as well if exact steps are pointed out.

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
     Subsystem: Hewlett-Packard Company Unknown device [103c:30a2]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03) (prog-if 00 [VGA controller])
     Subsystem: Hewlett-Packard Company Unknown device [103c:30a2]

Szilárd Páll (sin-pecado) wrote :
description: updated
description: updated
tags: added: i945
removed: 945
Evan R. Murphy (evanrmurphy) wrote :

Hi Szilárd Páll, thank you for taking the time to report this bug, and for helping to make Ubuntu better. Your report did not specify an associated package, which is important for ensuring that it gets looked at by the proper developers. (You can learn more about how to find the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage.) I have classified this as a bug in xorg.

For future reference, you might be interested to know that a lot of applications have bug-reporting functionality built into them. This is typically accessible via the Report a Problem option in the Help menu for the relevant application. (You can learn more about this feature at https://wiki.ubuntu.com/ReportingBugs.)

affects: ubuntu → xorg (Ubuntu)
Evan R. Murphy (evanrmurphy) wrote :

Hi again, Szilárd. According to https://wiki.ubuntu.com/X/Reporting, X lockup reports require some additional information not yet included here. You've already provided a detailed description of the problem, version information, the clearest steps for reproduction that you have available and your /var/log/Xorg.0.log.old file. But it seems as though we're still missing a full backtrace, details of the completeness of the X failure, and your /var/log/Xorg.0.log and ~/.xsession-errors files. Please follow the above link and see the "X crash, lockup, freeze, exit, or doesn't start/shutdown" category under "What to Include in Bug Reports" for details.

If you can provide these items, your report may be eligible for Confirmed status. In the meantime, I'm marking it Incomplete. Please post back if you recover any additional information or have any questions, and thanks again for spending time with this issue.

Changed in xorg (Ubuntu):
status: New → Incomplete
Martin Olsson (mnemo) wrote :

@Szilárd Páll, can you please attach the output os "lspci -vvnn".

And if you boot the ubuntu 9.04 jaunty live CD is the bug still there?

affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Bryce Harrington (bryce) on 2009-05-13
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Szilárd Páll (sin-pecado) wrote :

@Evan: Below I will try to supply additional information, I hope it's useful.

[from the page https://wiki.ubuntu.com/X/Reporting]

*Detailed description of problem -- described above, if more details needed let me know

*Get a full backtrace (X/Backtracing) -- as I am using Hardy this is slightly complicated and I did not have time to do it yet.

*List any versions you tried that did not have this issue -- none.

*Steps to reproduce -- described above, if more details needed let me know

*How complete is the X failure?
+ Does ctrl+alt+f1 take you to a console? - no
+ Does ctrl+alt+backspace restart X? - no
+ Does mouse pointer still move? - yes
+ Does the keyboard LED come on when hitting the CAPSLOCK key? - no
+ Can you ssh into the system from another computer? - yes

*/var/log/Xorg.0.log - see attached, I assume I am including the right file, just a regular Xorg log which does not contain traces of the lockup.

*/var/log/Xorg.0.log.old - see above

*~/.xsession-errors -> I will try to get these when the next lockup occurs however, as I mentioned the "EQ Overflow" type of lockup appears more often then the "Error in I830WaitLpRing". Therefore I might not even be able to reproduce the latter.

Szilárd Páll (sin-pecado) wrote :

@Martin: see attached the lspci output. I have tried Jaunty but unfortunately I have experienced lockup with that as well, although not when starting video playback.

Evan R. Murphy (evanrmurphy) wrote :

I'm changing the status of this report to Confirmed because it appears to catalogue a real bug and carry sufficient detail. At the same time, a couple possibly important pieces of information (i.e. the full backtrace and *~/.xsession-errors) have still not been included; hopefully Szilárd Páll can provide these in the near future. If the missing items are deemed critical, the report may be marked as Incomplete once again.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-05-17
description: updated
Bryce Harrington (bryce) on 2009-06-02
summary: - X crashes after starting video
+ [i945gm] X crashes after starting video
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

A new major version of the -intel driver is now available in Karmic.

This version includes a major reworking of the acceleration
architecture, which resolves a huge number of issues. We do not know
whether it resolves the issue you reported.

Would you mind testing Karmic Alpha-2 and seeing if it is still a
problem? CD ISO images are available here:

  http://cdimages.ubuntu.com/releases/karmic/

If the issue can still be reproduced on karmic, please report here with
your findings, and attach a fresh Xorg.0.log from your test, and we will
be able to forward the bug upstream.

Otherwise, if the bug no longer exists in Karmic, let us know that as
well.

In the off chance you encounter different bugs while attempting to test
Karmic, please report those as new bug reports.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

It seems likely to me this bug is gone; the -intel driver has improved immensely in Karmic and a lot of bugs are being reported as no longer present. So hopefully that's the case here too.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers