Slow flash video playback on Intel 945gm

Bug #370552 reported by Adam Portier on 2009-05-01
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

Playback is unbearably slow on sites like www.youtube.com, www.hulu.com. Fullscreen 3D video works fine, but video playback is choppy. I have tried so far...

Upgragind to Ubuntu-X Swat's 2.7 release of the intel drivers
Loading a 2.6.30 kernel
Modes UXA and EXA
MigrationHeuristic greedy
Modifying /proc/mtrr registers 0xa... to 0xe (see bug 314928)

Nothing has had any impact.

This is an Acer Aspire One 160gb HDD with an Intel 945gm

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-video-intel 2:2.7.0-1ubuntu1~xup~1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009
SourcePackage: xserver-xorg-video-intel
Tags: ubuntu-unr
Uname: Linux 2.6.28-11-generic i686
UnreportableReason: This is not a genuine Ubuntu package

Adam Portier (aportier) wrote :
Robert Hooker (sarvatt) wrote :

Aspire ones have buggy MTRR's by default, you have to boot with enable_mtrr_cleanup mtrr_spare_reg_nr=1 added to your grub default options to fix it.

[ 0.000000] MTRR default type: uncachable
[ 0.000000] MTRR fixed ranges enabled:
[ 0.000000] 00000-9FFFF write-back
[ 0.000000] A0000-BFFFF uncachable
[ 0.000000] C0000-C7FFF write-protect
[ 0.000000] C8000-EFFFF uncachable
[ 0.000000] F0000-FFFFF write-protect
[ 0.000000] MTRR variable ranges enabled:
[ 0.000000] 0 base 0FFFE0000 mask 0FFFE0000 write-protect
[ 0.000000] 1 base 0FFFC0000 mask 0FFFE0000 uncachable
[ 0.000000] 2 base 000000000 mask 0C0000000 write-back
[ 0.000000] 3 base 040000000 mask 0E0000000 write-back
[ 0.000000] 4 base 05F800000 mask 0FF800000 uncachable
[ 0.000000] 5 base 05F600000 mask 0FFE00000 uncachable
[ 0.000000] 6 base 05F500000 mask 0FFF00000 uncachable
[ 0.000000] 7 base 000000000 mask 0FFFE0000 uncachable
[ 0.000000] original variable MTRRs
[ 0.000000] reg 0, base: 4194176KB, range: 128KB, type WP
[ 0.000000] reg 1, base: 4194048KB, range: 128KB, type UC
[ 0.000000] reg 2, base: 0GB, range: 1GB, type WB
[ 0.000000] reg 3, base: 1GB, range: 512MB, type WB
[ 0.000000] reg 4, base: 1528MB, range: 8MB, type UC
[ 0.000000] reg 5, base: 1526MB, range: 2MB, type UC
[ 0.000000] reg 6, base: 1525MB, range: 1MB, type UC
[ 0.000000] reg 7, base: 0GB, range: 128KB, type UC
[ 0.000000] WARNING: BIOS bug: VAR MTRR 7 contains strange UC entry under 1M, check with your system vendor!

with mtrr cleanup and 1 spare reg you get

reg00: base=0x000000000 ( 0MB), size= 1024MB, count=1: write-back
reg01: base=0x040000000 ( 1024MB), size= 512MB, count=1: write-back
reg02: base=0x05f500000 ( 1525MB), size= 1MB, count=1: uncachable
reg03: base=0x05f600000 ( 1526MB), size= 2MB, count=1: uncachable
reg04: base=0x05f800000 ( 1528MB), size= 8MB, count=1: uncachable
reg05: base=0x060000000 ( 1536MB), size= 256MB, count=1: write-combining

so you actually get write combining for your video ram. Just edit your /boot/grub/menu.lst and add enable_mtrr_cleanup mtrr_spare_reg_nr=1 to your defoptions line and sudo update-grub afterwards.

beefcurry (jonzwong) wrote :

I really don't think this belongs as a duplicate, applying the solution for the duplicate has little relevance to this bug.

I don't seem to be able to get a 3D performance increase with this mtrr_cleanup in grub, I am using this in conjunction with bleeding edge xserver-xorg and kernel 2.6.30.

Robert Hooker (sarvatt) wrote :

I dont think it belongs as a duplicate either. Question though, are you adding enable_mtrr_cleanup mtrr_spare_reg_nr=1 or just enable_mtrr_cleanup to grub on your aspire one? You need both.

jherskow (joshua-herskowitz) wrote :

i have no idea what any of this means, im a noob.
i was directed here from the forums.

can anybody tell me how t do this, noob-friendly?

Bernhard (b.a.koenig) wrote :

jherskow,

you can check out bug #314928, there's a bit more info there. If you have an intel video card and you had some performance issues, try to check all boxes in the "Updates" tab of "Software Sources" (System > Administration), then do

sudo apt-get update
sudo apt-get upgrade

and you should have the latest version of your intel video driver. That one seems to fix the particular issue for most people.

huzbum (nhusby) wrote :

I would be absolutely exstatic if just one person would provide an example showing WHERE in the menu.lst file to add this!

I've looked everywhere and no where is there an example. I'm kinda newb.. do I put it at the begining? shove it in at the end? does it belong in any particular place? It's rather frustrating. It's pretty ridiculous to have to go use a different machine just to watch a video.

any instruction at all would have been helpful.

Bernhard (b.a.koenig) wrote :

huzbum, you type

sudo apt-get update
sudo apt-get upgrade

into a terminal after you have checked all the boxes mentioned in post #6. As of now, I would actually recommend you to upgrade to karmic right away if you still have the Intel slowdown. All these issues seem to be fixed in karmic.

How do you add "enable_mtrr_cleanup mtrr_spare_reg_nr=1" to Grub2?

Kevin Lake (kjl) wrote :

Martin, on Ubuntu (Karmic) you should edit the file /etc/default/grub and add the options in the GRUB_CMDLINE_LINUX parameter, so that it reads:
GRUB_CMDLINE_LINUX="enable_mtrr_cleanup mtrr_spare_reg_nr=1"
then run

update-grub

Note that this solution worked for a ThinkPad410 with Intel graphics (i915 driver), as follows:

Kevin Lake wrote on 2010-01-24:

Martin, on Ubuntu (Karmic) you should edit the file /etc/default/grub and add the options in the GRUB_CMDLINE_LINUX parameter, so that it reads:
GRUB_CMDLINE_LINUX="enable_mtrr_cleanup mtrr_spare_reg_nr=1"
then run

update-grub

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers