[g45] XVideo output flickers on GMA X4500MHD

Bug #368112 reported by Martin Emrich on 2009-04-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

Playing videos with some applications results in the background "flickering" through (Adobe Flash player) or displaying the frames in the wrong order (VDR with vdr-xineliboutput). Other applications (mplayer) are not affected.

My graphics card:
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

$ LANG=C apt-cache policy xserver-xorg-video-intel
xserver-xorg-video-intel:
  Installed: 2:2.6.3-0ubuntu9
  Candidate: 2:2.6.3-0ubuntu9
  Version table:
 *** 2:2.6.3-0ubuntu9 0
        500 http://de.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

To reproduce, install the Adobe 64bit flash player, and try a flash video, e.g. from http://revision3.com/tekzilla/. When playing a video in the embedded flash applet, sometimes the HTML behind it flickers through.

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 07)
     Subsystem: Lenovo Device [17aa:20e0]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
     Subsystem: Lenovo Device [17aa:20e4]

Bryce Harrington (bryce) on 2009-04-28
summary: - XVideo output flickers on GMA X4500MHD
+ [g45] XVideo output flickers on GMA X4500MHD
Bryce Harrington (bryce) wrote :

Hi emme,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Martin Emrich (emme) wrote :

Here's the logfile...

Martin Emrich (emme) wrote :

.. and here's the "lspci -vvnn" output.

Ciao

Martin

Martin Olsson (mnemo) wrote :

I was able to repro this issue on a intel G45 desktop machine (very similar to GM45) with pci ids 8086:2e22.

The exact repro steps I used was:

I uninstalled previous versions of flash using:
        sudo killall -9 firefox
        sudo apt-get remove -y --purge flashplugin-nonfree gnash gnash-common mozilla-plugin-gnash swfdec-mozilla libflashsupport nspluginwrapper
        sudo rm -f /usr/lib/mozilla/plugins/*flash*
        sudo rm -f ~/.mozilla/plugins/*flash*
        sudo rm -f /usr/lib/firefox/plugins/*flash*
        sudo rm -f /usr/lib/firefox-addons/plugins/*flash*
        sudo rm -rfd /usr/lib/nspluginwrapper

I installed the alpha of 64-bit flash from adobe using:
        wget http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.22.87.linux-x86_64.so.tar.gz
        tar zxvf libflashplayer-10.0.22.87.linux-x86_64.so.tar.gz
        mkdir ~/.mozilla/plugins
        mv libflashplayer.so ~/.mozilla/plugins

And then I opened this URL: http://revision3.com/tzdaily/2009-04-28unresponsive/

I saw the exact same thing as Martin Emrich saw, basically some HTML elements that flicker through the video playback surface.

Martin Olsson (mnemo) wrote :

@Martin Emrich, can you repro this using vlc, totem or similar? I looked into VDR as well but I don't have a DVB card so I can't run any repro in that app. If the only affected player is an alpha version of Flash then this bug will probably not get much attention.

Basically to get this accepted upstream as a intel video driver bug we need a solid repro.

Martin Emrich (emme) wrote :

I was not able to reproduce any bad video playback behaviour with vlc, mplayer or xine. The VDR+xineliboutput bug does not require a DVB hard to reproduce, as it only happens while cutting a recording: After pausing playback and moving a cut mark forwards or backwards, it alternately displays the second last and the last frame (so the currently paused position does not correspond to the GOP/I-Frame displayed on the screen).

I understand that a bug only affecting a binary-only product and a self-compiled application won't make it very high on the priority list. But it's good to know that it is reproducible on another box.

I just tried switching to metacity instead of compiz, that did not help.

Bryce Harrington (bryce) on 2009-05-01
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-05-06
tags: added: flicker
Bryce Harrington (bryce) on 2009-05-06
description: updated
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

A new major version of the -intel driver is now available in Karmic.

This version includes a major reworking of the acceleration
architecture, which resolves a huge number of issues. We do not know
whether it resolves the issue you reported.

Would you mind testing Karmic Alpha-2 and seeing if it is still a
problem? CD ISO images are available here:

  http://cdimages.ubuntu.com/releases/karmic/

If the issue can still be reproduced on karmic, please report here with
your findings, and attach a fresh Xorg.0.log from your test, and we will
be able to forward the bug upstream.

Otherwise, if the bug no longer exists in Karmic, let us know that as
well.

In the off chance you encounter different bugs while attempting to test
Karmic, please report those as new bug reports.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → New
status: New → Incomplete
Martin Emrich (emme) wrote :

With the newest packages and KMS, the flickering with flash videos is gone. The other problem with VDR seems to be related to VDR or libxine, as I can reproduce it on a radeon-based system, too (or even with X11/XShm output).

From my perspective, this bug can be marked as Fix Released.

Ciao

Martin

Bryce Harrington (bryce) wrote :

Thanks for letting us know the issue is resolved.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers