[g33] X does not detect correct LCD resolution through KVM switch

Bug #367604 reported by Amit Kucheria on 2009-04-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

I upgraded (actually reinstalled) a machine to Jaunty from Intrepid. This machine is connected to a 1680x1050 LG Flatron 226WTQ LCD display through a KVM switch.

With Intrepid, this resolution was correctly configured, but with Jaunty X defaults to 1152x864. Relevant information is attached.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-video-intel 2:2.6.3-0ubuntu9
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
 LC_PAPER=a4
ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009
SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.28-11-generic i686

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller [8086:29c0] (rev 02)
     Subsystem: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller [8086:29c0]
00:02.0 VGA compatible controller [0300]: Intel Corporation 82G33/G31 Express Integrated Graphics Controller [8086:29c2] (rev 02)
     Subsystem: Intel Corporation 82G33/G31 Express Integrated Graphics Controller [8086:29c2]

Amit Kucheria (amitk) wrote :
Amit Kucheria (amitk) wrote :

When the display is attached to the computer directly, everything works well. So I guess the problem is that X is not able to probe the correct resolution through a KVM switch.

Bryce Harrington (bryce) on 2009-04-28
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2009-05-06
tags: added: resolution
Bryce Harrington (bryce) on 2009-05-06
description: updated
Bryce Harrington (bryce) on 2009-05-08
summary: - X does not detect correct LCD resolution through KVM switch
+ [g33] X does not detect correct LCD resolution through KVM switch
Bryce Harrington (bryce) wrote :

This is the line marking where things are falling over:

 (II) intel(0): Using fuzzy aspect match for initial modes

Often this comes when there is not a match found between what the video card supports and what it detects the monitor is capable of. However, it looks like it is mis-detecting your monitor's capabilities:

 VGA connected 1152x864+0+0 (0x3d) normal (normal left inverted right x axis y axis) 0mm x 0mm

Note the 0x0 mm physical size, which clearly is wrong. I guess it is probably taking standard VESA modes or something:

  1360x768 (0x3c)
  1152x864 (0x3d)
  1024x768 (0x3e)
  800x600 (0x3f)
  640x480 (0x40)

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

From the above, my bet is that either the edid retrieval code is failing, or the EDID is being mis-parsed. Please run the command: 'get-edid | parse-edid' (from the read-edid package). Attach the output here.

If that command works and provides accurate info, but X isn't getting it, then that points to an error in X's edid parsing code. If this is the case then try running X with ModeDebug turned on so we can see what choices it's making.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Incomplete
Bryce Harrington (bryce) wrote :

As a short term solution, simply disable EDID:

Section "Device"
    ...
    Option "IgnoreEDID" "True"
EndSection

I believe this will force it over into using DDC routines (which is how it used to work, and may explain why it regressed in Intrepid -> Jaunty).

Brent (brentjhedges) wrote :

I have the same issue with low-graphics mode when using a KVM switch. Monitor is not recognized. However it works just fine when the monitor is connected straight to PC. I ran the command above "get-edid | parse-edid" Results attached with X log files.

Brent (brentjhedges) wrote :
Brent (brentjhedges) wrote :
Brent (brentjhedges) wrote :
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

A new major version of the -intel driver is now available in Karmic.

This version includes a major reworking of the acceleration
architecture, which resolves a huge number of issues. We do not know
whether it resolves the issue you reported.

Would you mind testing Karmic Alpha-2 and seeing if it is still a
problem? CD ISO images are available here:

  http://cdimages.ubuntu.com/releases/karmic/

If the issue can still be reproduced on karmic, please report here with
your findings, and attach a fresh Xorg.0.log from your test, and we will
be able to forward the bug upstream.

Otherwise, if the bug no longer exists in Karmic, let us know that as
well.

In the off chance you encounter different bugs while attempting to test
Karmic, please report those as new bug reports.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

It seems likely to me this bug is gone; the -intel driver has improved immensely in Karmic and a lot of bugs are being reported as no longer present. So hopefully that's the case here too.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Invalid
Brent (brentjhedges) wrote :

I downloaded the Karmic Beta using the Torrent link dated Oct 1, 2009 from this location: http://cdimages.ubuntu.com/releases/9.10/beta/ . When I booted up the Live CD, it ran into a loop with the following error message.

[drm:intelfb_restore] *ERROR* Failed to restore crtc configuration: -22

I let the loop run for approx. three minutes before hitting the power button.

Brent (brentjhedges) wrote :

Good news. I replaced my older Belkin Omni Cube 4-Port (PS-2) model F1D094 with a brand new IOGEAR 2 port (USB) model GCS632U and I no longer have the issue above. Ubuntu 9.04 now can see the LCD panel and allows compiz to run. The 9.10 Beta Live Disc I referenced above also works without any issues. Case solved. Spend the $50 and get a new KVM!

svarun13 (janhudi) wrote :

Helloo

I have downloaded Ubuntu 9.10 Karmic Coala yesterday, I installed it, and it does not recognize my Samsung SyncMaster 245B.
I also use KVM swithc.

svarun13 (janhudi) wrote :

Helo again
Here is the strange thing:)

When i log into GNOME, my monitor is not recognized, and max resolution is 640 x 480.
When i log into the xterm, all is the same.
Funny thing, when i log off from xterm, suddenly monitor is recognized and my resolution is as it should be, that is 1920 x 1200?

so it is not KVM svitch fault, i guess..

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers