firefox segmentation fault in kde4.2 jaunty on maximizing flash video

Bug #366937 reported by Gletscher on 2009-04-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: firefox

hitting the maximize button in a flash video, lets say youtube, firefox closes.

laptop:~$ firefox
Xlib: extension "GLX" missing on display ":0.0".
Segmentation fault
laptop:~$

I'm on Kubuntu 9.04 using an Asus U3s and the Intel GMA.

Gletscher (gletscherspalte) wrote :

Same thing in Xubuntu

Micah Gersten (micahg) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Could you please try to obtain a backtrace by following the instructions on https://wiki.ubuntu.com/MozillaTeam/Bugs? Also, please answer these questions:
Is this crash reproducible? If so, which are the steps that lead to it?
Which flash package do you have installed?
Which Java package do you have installed?
Which Firefox extensions do you have installed?

This will greatly aid us in tracking down your problem.

affects: firefox (Ubuntu) → firefox-3.0 (Ubuntu)
Changed in firefox-3.0 (Ubuntu):
status: New → Incomplete
Gletscher (gletscherspalte) wrote :

Hi, the same error persists in konqueror, so I guess it's a graphics / x-driver problem:

nspluginviewer(25944) NSPluginInstance::NPNewStream: results in 0
nspluginviewer(25944) NSPluginInstance::NPDestroyStream: results in 0
konqueror(25920) PluginPart::statusMessage: PluginPart::statusMessage ""
nspluginviewer(25944) NSPluginInstance::NPNewStream: results in 0
nspluginviewer(25944) NSPluginInstance::NPDestroyStream: results in 0
konqueror(25920) PluginPart::statusMessage: PluginPart::statusMessage ""
Xlib: extension "GLX" missing on display ":0.0".
konqueror(25920) KHTMLView::focusNextPrevChild: focusNode.name: "A"
KCrash: Application 'nspluginviewer' crashing...

It seems to be the same issue why google earth isn't working either:

laptop:~$ googleearth
Warning: Unable to create prefs directory '/home/geni/.googleearth'. File exists.
Xlib: extension "GLX" missing on display ":0.0".

Google Earth has caught signal 11.

The bug is totally reproducible, just fire up the maximize button on any flash player and konqueror / firefox closes.

I have Shockwave Flash 10.0 r22 installed, no java. The same problem persists without plugins.

I'm sorry I don't have the time to do a full backtrace right now and that since jaunty is absolutely unusable for me a have to be on lenny for the moment.

The problem also might be related to this bug:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/366941

Gletscher (gletscherspalte) wrote :

after adding this intel gma driver repo, flash fullscreen works:
http://webupd8.blogspot.com/2009/05/graphic-video-drivers-ubuntu-repository.html

Daniel T Chen (crimsun) on 2009-05-17
affects: firefox-3.0 (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Low
status: Incomplete → Triaged
CoderGuy (alec-bickerton) wrote :

I've been fighting this same problem since upgrading from Intrepid. I looks like X does not load all the dependencies for glx... here's my xorg.conf which works for my radeon 9600 dual monitor setup. (xorg-xserver-ati-video),

This appears to have solved the problem for me. I can't be sure without some more testing though.

Section "Module"
        Load "GLcore"
        Load "glx"
        Load "i2c"
        Load "bitmap"
        Load "ddc"
        Load "extmod"
        Load "int10"
        Load "vbe"
        Load "dri"
        Load "dbe"
        Load "v4l"

EndSection

Section "Monitor"
        Identifier "Configured Monitor"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Monitor "Configured Monitor"
        Device "Configured Video Device"
        SubSection "Display"
                Virtual 2560 1024
        EndSubSection
EndSection

Section "Device"
        Identifier "Configured Video Device"
        Option "AccelMethod" "EXA"
        Option "AddARGBGLXVisuals" "true"
        Option "RenderAccel" "true"
        Option "AllowGLXWithComposite" "true"
EndSection

Section "DRI"
        Mode 0666
EndSection

Section "Extensions"
        Option "Composite" "Enable"
EndSection

CoderGuy (alec-bickerton) wrote :

I forgot to mention I also had to do the following.

sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

A new major version of the -intel driver is now available in Karmic.

This version includes a major reworking of the acceleration
architecture, which resolves a huge number of issues. We do not know
whether it resolves the issue you reported.

Would you mind testing Karmic Alpha-2 and seeing if it is still a
problem? CD ISO images are available here:

  http://cdimages.ubuntu.com/releases/karmic/

If the issue can still be reproduced on karmic, please report here with
your findings, and attach a fresh Xorg.0.log from your test, and we will
be able to forward the bug upstream.

Otherwise, if the bug no longer exists in Karmic, let us know that as
well.

In the off chance you encounter different bugs while attempting to test
Karmic, please report those as new bug reports.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

It seems likely to me this bug is gone; the -intel driver has improved immensely in Karmic and a lot of bugs are being reported as no longer present. So hopefully that's the case here too.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers