Outlook Citrix screen tearing

Bug #365864 reported by Youri Matthys on 2009-04-24
4
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

After upgrade to 9.04 outlook via citrix shows screen tearing. In 8.10 it was working fine. It doesn't matter is desktop effects are enabled or disabled. When changing virtual desktop the window is rendered as it should, when changing a folder in outlook the window rendering is teared again. I attached a screenshot to show the error.

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

Description: Ubuntu 9.04
Release: 9.04

xserver-xorg-video-intel:
  Installed: 2:2.6.3-0ubuntu9
  Candidate: 2:2.6.3-0ubuntu9
  Version table:
 *** 2:2.6.3-0ubuntu9 0
        500 http://ftp.telfort.nl jaunty/main Packages
        100 /var/lib/dpkg/status

Youri Matthys (yourimatthys) wrote :
Crispin Murphy (crispin-myra) wrote :

I can also confirm this bug as affecting my system. Pertinent details:

Citrix Receiver version 11

INtel graphics chipset:
(--) PCI:*(0@0:2:0) Intel Corporation 82915G/GV/910GL Integrated Graphics Controller rev 4, Mem @ 0xcfe00000/524288, 0xe0000000/268435456, 0xcff00000/262144, I/O @ 0x00001800/8

Intel driver package version 2.2.6.3, same as noted above (actually system is fully up to date as of April 30th).

NB. not just outlook via citrix is affected - IE is also not rendering 100% properly, but word 2007 and excel 2007 seem to be fine.

Bryce Harrington (bryce) wrote :

Hi yourimatthys,

Thanks for including an image to demonstrate the issue. Could you also please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log or Xorg.0.log.old file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Crispin Murphy (crispin-myra) wrote :

Per request, here is lspci -vvnn

Crispin Murphy (crispin-myra) wrote :

Per request, here is lspci -vvnn

Crispin Murphy (crispin-myra) wrote :

And the xorg log file. My xorg.conf file is unmodified from the default installation process.

Thanks for looking at this!

Crispin Murphy (crispin-myra) wrote :

Oh, and here is a particularly messy screenshot...

Youri Matthys (yourimatthys) wrote :

Requested data. No changes have been made to my xorg.conf.

Youri Matthys (yourimatthys) wrote :

Requested data. No changes have been made to my xorg.conf.

Youri Matthys (yourimatthys) wrote :

Requested data. No changes have been made to my xorg.conf.

Bryce Harrington (bryce) on 2009-05-05
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-05-06
tags: added: tearing
Youri Matthys (yourimatthys) wrote :

It appears the problem has been resolved with the latest update:

xserver-xorg-video-intel:
  Installed: 2:2.6.3-0ubuntu9.2
  Candidate: 2:2.6.3-0ubuntu9.2
  Version table:
 *** 2:2.6.3-0ubuntu9.2 0
        500 http://ftp.telfort.nl jaunty-proposed/main Packages
        100 /var/lib/dpkg/status
     2:2.6.3-0ubuntu9 0
        500 http://ftp.telfort.nl jaunty/main Packages

Crispin Murphy (crispin-myra) wrote :

Have updated my 9.04 install to latest packages to test Youri's comment above. Screen tearing seems 'better' - seem to be getting relatively fewer screwed up screen paints, but I still get some, particularly with Outlook via Citrix, but also sometimes with Firefox or Word / Excel via Citrix.

NB. I just got tearing in Firefox now, typing in this text box.

The screen paints also seem slower than before, when switching between windows.

Youri Matthys (yourimatthys) wrote :

The problem is resolve on my 32bit box. The 64bit shows the same tearing though. Maybe this fix wasn't incorporated in the 64 bit package?

xserver-xorg-video-intel:
  Installed: 2:2.6.3-0ubuntu9.2
  Candidate: 2:2.6.3-0ubuntu9.2
  Version table:
 *** 2:2.6.3-0ubuntu9.2 0
        500 http://ftp.telfort.nl jaunty-proposed/main Packages
        100 /var/lib/dpkg/status
     2:2.6.3-0ubuntu9 0
        500 http://ftp.telfort.nl jaunty/main Packages

Distributor ID: Ubuntu
Description: Ubuntu 9.04
Release: 9.04
Codename: jaunty

2.6.28-12-generic #43-Ubuntu SMP Fri May 1 19:31:32 UTC 2009 x86_64 GNU/Linux

Crispin Murphy (crispin-myra) wrote :

Problem still unresolved on my system - NB I am running 32 bit:

root@x3:/var/log# uname -a
Linux x3 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

I am fully up to date with the latest packages - update manager shows no updates, ditto for apt-get update & upgrade.

Have found that turning off the visual effects (in appearance settings) has improved performance significantly and made it less of a nuisance to use.

Hoping for word of a fix soon.

Bryce Harrington (bryce) wrote :

Closing as fixed since the issue reported by the original reporter is resolved.

Others still experiencing problems are probably having an unrelated bug. Several more tearing-related fixes have gone into 2.7 and 2.8, which we'll be pulling into karmic.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers