[i855] Clone Mode makes external display very blurry/wobbly

Bug #36550 reported by Reinhard Tartler on 2006-03-25
52
Affects Status Importance Assigned to Milestone
X.Org X server
Invalid
Wishlist
xorg (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

I'm using this machine: https://wiki.ubuntu.com/LaptopTestingTeam/ThinkpadR50e

When pressing Fn-F7, I can cycle trough these display modes:
- Internal display only
- External display only
- clone mode

The first 2 modes are fine, clone mode makes the image on the external display unusably woobly and distorted.

Yes, I could definately add a CloneOnHotkey option. I'll try and do this next week.

That would be excellent. I'd be happy to test.

Before I add it, you should be able to get similar behaviour with the clone
option already. Try this...

Even though the second screen will be on at startup, if you hotkey, it should
cycle through the LFP, CRT and LFP+CRT for clone.

Yes, when Clone is set in xorg.conf, it does cycle properly. I guess the only
difference CloneOnHotKey option will have from Clone is to start up in the LFP
state, but the behaviour otherwise should be identical.

There is one other somewhat related issue - this laptop has a 1280x768
widescreen, if I don't remember to reset the resolution before switching it
makes the crt very unhappy, but that's probably a problem for another day.

Created an attachment (id=4802)
Patch for CloneOnHotKey option

I've given this a try on my own. The attached patch works for me...

Any chance this could get officially added?

Reinhard Tartler (siretart) wrote :

I'm using this machine: https://wiki.ubuntu.com/LaptopTestingTeam/ThinkpadR50e

When pressing Fn-F7, I can cycle trough these display modes:
- Internal display only
- External display only
- clone mode

The first 2 modes are fine, clone mode makes the image on the external display unusably woobly and distorted.

Sven Herzberg (herzi) wrote :

Same here with the X41 Tablet.

Paul Sladen (sladen) wrote :

ThinkPad R52. It is though there isn't enough video bandwidth available to service both pipes and it is 'tearing'.

I wonder if the internal (TFT) refresh-rate is getting raised from 60Hz to match the external refresh-rate.

Changed in xserver-xorg-driver-i810:
status: Unconfirmed → Confirmed

External monitor does not work at all (not clone, not external-only) for me with i810 driver. Picture on external monitor is shown, but it is broken in the middle and blurry.

I am using Acer Travelmate 3000:
http://www.iki.fi/karvinen/acer_travelmate_3004wtmi_with_linux.html

Paul Sladen (sladen) wrote :

Looking at the webpage, it looks like you're loading '915resolution' to reprogram to a widescreen mode.

The program here is that we blindly overright the 'width' and 'height' fields in the Video BIOS table but don't make any effort to setup the analogue mode-lines to match.

There is some code in the i810 CVS HEAD that adds the 915resolution patching ability and further still (only since last night) some code in some Intel that provides native mode-setting and avoids the BIOS completely. These will fix the problem both ways but whether it's safe to backport them is another question.

BTW, Dapper should not need anything like:

  noapic nolapic pci=noacpi” (or “noapic acpi=on irqpoll pci biosirq”)

to boot. Could you try removing as many of those parameters as possible and test again (mostly likely, if you need any of them it would be just the 'nolapic'). They also don't quite make sense (eg. 'noacpi' and then 'acpi=on').

Paul Sladen (sladen) wrote :

Hi Tero, yours is a different issue (which I've just answered). Could you please file a new bug again '915resolution' and I'll cut-n-paste my reply there.

Setting this back to 'i810' as that's where the original issue that Reinhard reported is.

Thanks for your comments Paul.

External display on Acer Travelmate 3004WTMi does not work with 915resolution, and it does not work without 915resolution either. lshw shows one (internal) display configured and one (external) unconfigured.

Without any boot parameters, 3004WTMi completely freezes on "Uncompressing Linux... Ok, booting the kernel. ".

> noapic nolapic pci=noacpi” (or “noapic acpi=on irqpoll pci biosirq”)
> They also don't quite make sense (eg. 'noacpi' and then 'acpi=on').

If you are referring to the line above, it says 'noapic', apic not acpi.

3004WTMi does not work with just "nolapic", freezes on "...booting the kernel. "

Paul:
> Could you please file a new bug again '915resolution'
> and I'll cut-n-paste my reply there.

I filed it agains i810, but you can change it if it really is 915resolution problem.

https://launchpad.net/distros/ubuntu/+source/xserver-xorg-driver-i810/+bug/38729

Seb Wills (sebwills) wrote :

Same problem with a Dell Latitude X300 (82852/855GM Integrated Graphics Device (rev 02)). Using Dapper release candidate.

More details:

Fn+F8 toggles between:

 * internal display (OK)
 * external only (no video playback - see bug #47716)
 * both displays (external display suffers bandwidth problems as described above).

I know of three workarounds:

1. Add the lines:
 Option "MonitorLayout" "CRT,LFP"
 Option "Clone" "true"
to the Device section of xorg.conf makes the laptop emit a clean signal to both displays all the time (see also https://bugs.freedesktop.org/show_bug.cgi?id=5817 ).

2. Install i855crt and use "i855crt swcursor on 1024x768@60" to switch into dual display mode. This used to work straight off in Hoary, but in Breezy and Dapper it produces a display with corrupted colours unless you toggle through the Fn+F8 states to initialise the hardware before invoking i855crt.

These two work-arounds both have the down-side that video playback doesn't work on the external display.

3. Use the vesa driver instead of i810, in conjunction with i855crt (patched with https://sourceforge.net/tracker/index.php?func=detail&aid=1422674&group_id=107484&atid=647739 ) to enable both displays. This achieves the holy grail of a clean display on internal and external display with video playback working on both. However, using the vesa driver gives worse graphics performance and sometimes causes screen corruption following logout or hibernation, which can be fixed with a Fn-F8 toggle.

Changed in xorg-server:
status: Unknown → Confirmed

Same problem with a LIFEBOOK FUJITSU SIEMENS S7010 (Intel 855GM).

I've found a workaround for watching videos in external only mode.

1.- Add the following lines in xorg.conf under Device Section
 Option "MonitorLayout" "NONE,CRT"
 Option "Clone" "false"
2.- Conect the external monitor to the vga port.
3.- Restart the X Server (log-out and press control+alt+backspace)

If you leave the xorg.conf like that then, when you start the computer, the laptop screen is black. You have to press Fn+F8 to swich on that screen, but then you have the same problems as before, you cannot watch videos in the external screen and when having CRT+LFP the image is blurry/wobbly.

bradleee (brad-edmondson) wrote :

I have the same issue on Fujitsu S6210 with 855GM. I was able to switch cleanly with i855crt as mentioned in the bug linked by Seb, but the hotkey switching produces dirty output on the VGA port.

Sergio Callegari (callegar) wrote :

Same problem here on a DELL D820 with an intel 945 graphics card ubuntu edgy and
 an ACER monitor

Just an additional note:

Fn+F8 toggles between:

 * internal display (OK)
 * external only video OK (vertical frequency 60 Hz)
 * both displays (external display suffers fuzzyness wobbling... vertical freque
ncy reported by monitor is now 63 Hz).

Why does the vertical frequency change?

Evgeny Kuznetsov (nekr0z) wrote :

Same thing on Fujitsu-Siemens Amilo M7400.

Sorry about the phenomenal bug spam, guys. Adding xorg-team@ to the QA contact so bugs don't get lost in future.

Timo Aaltonen (tjaalton) wrote :

closing bogus component

Changed in xserver-xorg-driver-i810:
status: Unconfirmed → Rejected

The bug priority was upgraded (P2->high) with the bugzilla configuration change.
I'm Changing the priority back to the normal one.
Sorry for the spam.

Evgeny Kuznetsov (nekr0z) wrote :

Looks like they have written a patch with a workaround about a year ago. Couldn't that patch be included in Ubuntu? They are not likely to put it in into upstream package for the reason unknown to me, and the problem seems to be mission-critical for those using laptops for presentations...

erlingre (erlingre) wrote :

To this day I have not been able to tweak Ubuntu (On Dell Latitude D50x) to work with VGA-out and the local display at the same time in a manner that is simple enough for my users. This is a serious problem for me. I have tried the solution suggested by Seb Wills in 06 with

 Option "MonitorLayout" "CRT,LFP"
 Option "Clone" "true"

This is the closest so far if I don't care about increased power requirements when VGA-out is not used. I use 1024x768 resolution which the projector (HP vp6300) connected to VGA-out accepts, but the right part of the Ubuntu desktop is missing on the projected image. On a standard Feisty desktop everything to the right of the battery status is missing like in the screenshot.

Currently my users use only VGA-out and not the local display with Dapper. It is OK, but far from perfect. I really hope this issue can be solved in a manner that regular users can accept. Feisty is very close to good enough for the desktop, but issues like this can be a showstopper in many cases.

Closing. Please use the new 2.0 driver.

Changed in xorg-server:
status: Confirmed → Rejected

I am using an R50e as well, and I have the same problem with the wobbly clone mode. I also have a problem with external-only mode, though, which is: Closing the lid cuts the VGA signal to the external monitor. This only happens once I'm logged into KDE/XFCE/Gnome - not if I close the lid while I'm still at the kdm login screen, or before that (during booting).

Can anyone suggest any ideas?

Clues:
* Nothing unusual in xorg's logs
* Closing the lid when in clone mode kills both displays. When I open the lid again, I'm in "Internal only" mode (ie external monitor doesn't come up until I switch to it with Fn-F7 again)

  Here's what I tried so far (with no effect):
* deleting /dev/input/event5, which is mapped to the lidswitch
* setting the KDE power manager to "Do Nothing" "When laptop lid closed" (duh)

  Help? I'd love to get this to work!

Matthew

Re: lid closing problem posted above. I fixed it. ACPI was still calling /etc/acpi/lid.sh when I closed the lid. So, just empty that file... I don't know why the other approaches didn't work though :o(

unggnu (unggnu) wrote :

Have somebody rechecked it with Gutsy and the new Intel Driver which is activated by default? Maybe FN-Key doesn't help but xrandr should be able to hotplug.

unggnu (unggnu) on 2007-10-14
Changed in xserver-xorg-video-i810:
status: Confirmed → Incomplete
Timo Aaltonen (tjaalton) wrote :

No reply, closing the bug.

Changed in xserver-xorg-video-i810:
status: Incomplete → Invalid

I use the following commands:

xrandr --output VGA --off
xrandr --output VGA --auto

and no problem. I haven't used F7 for a long time, I think it's still producing wobbly output.

Anaxagold (jean-demartini) wrote :

xrandr does not function for me and the Fn+F8 key has the same behaviour than other people.

Are some changes in the xorg.conf file necessary so that xrandr can function ?

Changed in xorg-server:
importance: Unknown → Wishlist
Changed in xorg-server:
importance: Wishlist → Unknown
Changed in xorg-server:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.