Jaunty: compiz reduced performance in Intel 945GM/GMS VGA Card

Bug #360138 reported by andrehsiqueira on 2009-04-12
2
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

I update Ubuntu from Intrepid (8.10) to Jaunty (9.04 beta) in a 64 bits machine. A intel Corde 2 Duo on Toshiba Satellite U205 S5034.

After update to Jaunty 9.04 beta, my VGA CARD ( VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)) get poorly performance on compiz! All 3D features is downhill... The same problem has happens before when I try to get the new xserver-xorg-video-intel package into intrepid 8.10 to fix a problem in VGA output. Now the VGA problem is gone (fixed). But the video performance is down in compiz.

We expect the normal performance in compiz - a litle bit more faster, really! But there isn't what occour. The compiz cube, fire and other effects is slow... Very slow...

VangelistX (vangelistx) wrote :

The bug report is invalid. It lacks basic info.
You don't even mentioned what is your graphics card chipset.
Please, update the description, if you want to get some help.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Invalid
Philip Muškovac (yofel) wrote :

@adrehsiqueira: You might want to check if your issue is the same as bug 252094. And for your next bug report you might want to read https://help.ubuntu.com/community/ReportingBugs first. Thanks in advance.

@VangelistX: https://wiki.ubuntu.com/Bugs/Responses#Not%20described%20well is a nicer way to say that IMHO ;)

andrehsiqueira (andrehsiqueira) wrote :
description: updated
description: updated
summary: - compiz reduce performance
+ Jaunty: compiz reduced performance in Intel 945GM/GMS VGA Card
andrehsiqueira (andrehsiqueira) wrote :

This bug is a duplicate of #252094. But I my case there is a fix:

Edit xorg.conf and put

Section "Device"
        Identifier "Configured Video Device"
        # ...
        # Option to restore compiz performance on INTEL 945GM/GMS VGA Card
        Option "AccelMethod" "uxa"
EndSection

VangelistX (vangelistx) wrote :

@Philip Muskovac
You are right. Sorry if someone feels offended.

But the most important is that andrehisqueira managed to fix that bug.
Thank you very much!

Perhaps Your fix is a hint to solve the problem described in bug #252094?

Can we mark this particular bug as Fix Released?

Look, bug 242094 is not really a bug. It is a collection of comments
from people who have various levels of performance problems on various
hardware. Those people experience several different bugs. As a bug
report it is not useful at all. It could have been closed as "invalid"
but it is kept open since it gives people a place to vent their
frustrations and look for workarounds (which should really be done in
a forum, not in a bug report, but even though Tormod Volden set up a
forum thread for this and posted its link in the bug report, people
still comment there) Read its bug description under [update].

@VangelistX: A bug report which does not have the required information
is not Invalid, it is simply Incomplete. The correct(tm) response is
to ask for the missing information, and set the status to Incomplete
(and preferably subscribe yourself to the bug, so you can set the
status to Confirmed once all information is there).

@andrehsiqueira: If you are intrested in following up on this, even
though you found a workaround that works for you, you may unset the
duplicate flag, upload the output of `lspci -vvnn`,
/var/log/Xorg.0.log, and give some very specific examples of things
that are slow, and how slow they are (preferably in fps). Also, go
through the performance troubleshooting guide at
https://wiki.ubuntu.com/X/Troubleshooting/IntelPerformance and report
back on the things you can look for. Finally, look at
https://wiki.ubuntu.com/X/Reporting if there is more information that
may be useful in a bug report. If you don't care about doing all of
this, you may leave this bug at its status quo.

For information about why
       Option "AccelMethod" "uxa"
is not used by default in Jaunty, see the recent posts about that on
ubuntu-x mailing list, https://lists.ubuntu.com/archives/ubuntu-x/ .

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments