[i855] Solved slow 2D performances with EXA

Bug #359600 reported by Pasquale on 2009-04-11
26
This bug affects 2 people
Affects Status Importance Assigned to Milestone
kdebase (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Wishlist
Unassigned

Bug Description

I have an Intel 855GM integrated graphic card. I've noticed several unstabilities with the UXA acceleration method. I got an impressive performance boost in both 2D and 3D performances with EXA by changing the MigrationHeuristic:

Section "Device"
 Identifier "Configured Video Device"
        Driver "intel"
        Option "AccelMethod" "EXA"
        Option "MigrationHeuristic" "greedy"
EndSection

The video 2D/3D runs very smoothly now, and is very stable. Please consider to use this as a default configuration for the 855GM integrated video.

affects: ubuntu → xserver-xorg-video-intel (Ubuntu)
Scott Kitterman (kitterman) wrote :

Very nice. Much better. Thanks.

Luka Renko (lure) wrote :

It is also much better here (ThinkPad X200s with GM45). And I can resume from suspend with EXA (not possible with UXA)

Bryce Harrington (bryce) wrote :

We used to ship this on by default, but dropped it in 2:2.5.1-1ubuntu1 since upstream indicated it should no longer be necessary.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Mario Limonciello (superm1) wrote :

Appears to make EXA smoother for me too on my latitude D630,
(00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c))

Bryce Harrington (bryce) wrote :

Patch in question...

Arthur Schiwon (blizzz) wrote :

This is delighting, with the addition to x.org my jaunty runs with a good performance again. Also it solves #350997

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Wishlist → Undecided

On Mon, Apr 13, 2009 at 08:18:49PM -0000, Scott Kitterman wrote:
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Importance: Wishlist => Undecided

Why did you change it from Wishlist?

I just tried Bryce's -intel package from http://people.ubuntu.com/~bryce/Testing/intel-bug359600/ and I get dumped into vesa :( Packaging problem? I'll try the xorg.conf method and see if that works.

LaserJock (laserjock) wrote :

OK, I tried adding the xorg.conf lines from the bug description and I don't get vesa so perhaps it's something in the packaging.

William Grant (wgrant) wrote :

There are other reports of failures too, and my X server segfaults on startup with the new driver. The changes look minimal, so is this the great prerelease toolchain breakage?

Bryce Harrington (bryce) wrote :

bug 360798 has a backtrace of the crash.

Bryce Harrington (bryce) wrote :

wgrant, re toolchain breakage, what are you referring to?

Bryce Harrington (bryce) wrote :

I think it has nothing to do with toolchain stuff. The backtrace indicates that this is bug 246581, which I was expecting (it is why we dropped the patch in the first place).

Bryce Harrington (bryce) wrote :

I'm am restoring to Wishlist. This is not a judgment on the priority of the issue (I gather some developers treat Wishlist as <Low), but rather that this bug report is not a report of a problem but rather a _request_ for a specific solution to that problem. "greedy" is a workaround rather than a true solution, but if it proves to be viable I have no problem including it.

In any case, I'm assigning it to myself. Don't freak out about the priority setting, it doesn't mean that I don't intend to fix the underlying problem, just that i consider this one of perhaps several approaches to resolving it.

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Bryce Harrington (bryceharrington)
importance: Undecided → Wishlist
status: Confirmed → In Progress

On Tue, 2009-04-14 at 02:16 +0000, Bryce Harrington wrote:
> wgrant, re toolchain breakage, what are you referring to?

I was simply joking that this might have been the first indicator of the
huge toolchain breakage that generally appears in the last month of each
release cycle. Fortunately I was wrong.

--
William Grant

Steve Langasek has found with the greedy option set that it causes a regression for him, in that firefox displays a black window after scrolling quickly and switching between windows. I also saw one comment on another bug that there was graphic corruption when connecting a second monitor.

Most testers seem to find it either a positive change, or at least makes things no worse. Of particular note is this study on Phoronix:
http://www.phoronix.com/scan.php?page=article&item=ubuntu_intel_greedy&num=1

Ken VanDine (ken-vandine) wrote :

My G965 box is dog slow with EXA and incredibly fast with UXA. This setting with EXA is a nice improvement for me, but not as fast as UXA.

Changed in kdebase (Ubuntu):
status: New → Invalid
Bryce Harrington (bryce) on 2009-04-24
summary: - Solved slow 2D performances with EXA
+ [i855] Solved slow 2D performances with EXA
Bryce Harrington (bryce) wrote :

Ultimately we decided not to switch on "greedy" for the release due to rendering issues found during testing.

I'll leave the bug open for now though.

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: Bryce Harrington (bryceharrington) → nobody
status: In Progress → Triaged
Bryce Harrington (bryce) wrote :

Switching to "greedy" was a good option to try out, and for some users definitely worth trying. We tested it pretty extensively and appreciate everyone who helped with this. We found that it helped a number of people with performance issues, but not everyone, and indeed some people found it caused graphics corruption or other issues. Furthermore, it is an option that upstream (Intel) does not support and actually advocates *not* using. Finally, we know that there are better fixes available (kernel patches).

For all these reasons, I opted to not go forward with setting it for the distro overall, but I did ensure it is widely documented as a possible workaround.

I will dupe this into the generic intel performance bug report. Sorry if this innundates you with bug mail.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers