[gm45] Warzone 2100 3D is rendered black with GMA4500MHD

Bug #359578 reported by Pascal de Bruijn on 2009-04-11
54
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

On my HP 6730s laptop with Intel GM45 chipset, and GMA4500MHD graphics accelerator, some games show 3D oddities.

The most prominent would be Warzone 2100, while everything in 3D is just black. Only 2D overlays are rendered. I do not have this issue, using the exact same driver with my Q35 chip. Only with the GM45.

ioQuake3 has some minor artifact too, for example in the player model selection menu. The actual game runs fine.

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 07)
 Subsystem: Hewlett-Packard Company Device [103c:30e8]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
 Subsystem: Hewlett-Packard Company Device [103c:30e8]

Pascal de Bruijn (pmjdebruijn) wrote :
Pascal de Bruijn (pmjdebruijn) wrote :
Pascal de Bruijn (pmjdebruijn) wrote :
Pascal de Bruijn (pmjdebruijn) wrote :
Pascal de Bruijn (pmjdebruijn) wrote :
Pascal de Bruijn (pmjdebruijn) wrote :
Ignacio Huerta (iox8) wrote :

I have the same problem with GMA4500MHD in Ubuntu Jaunty.

scalmer (scalmer) wrote :

confirmed. Using Dell Latitude D830

Bryce Harrington (bryce) on 2009-04-21
description: updated
Bryce Harrington (bryce) on 2009-04-24
summary: - Warzone 2100 3D is rendered black with GMA4500MHD
+ [g45] Warzone 2100 3D is rendered black with GMA4500MHD

I'm having the same problem with Warzone 2100, but I'm too new to know what information is useful to post. The laptop is an HP G70-111EM, which apparently has "the Intel GMA 4500 1277 MB shared graphics card" which I'm guessing is the same as mentioned above, and I'm also using Jaunty.

ivashov (ivashov) wrote :

I have same problem with Intel GL960. Laptop Acer Aspire 5315, Ubuntu 9.04.

Rohit V. Bhute (rvbhute) wrote :

I have the same problem with Dell Inspiron 1525 laptop with Ubuntu 9.04.

The motherboard is Intel 965 series with on-board graphics (Intel Graphics Media Accelerator X3100).

Bryce Harrington (bryce) on 2009-05-06
tags: added: 3d
Javier (jitoizlizarraga) wrote :

I have this problem too..

In Oki NB0508 with intel 4500
xserver-xorg-intel-drivers 2.7.1
kernel 2.6.30 rc7

I'm using the rc of warzone 2.2 with EXA mode in Ubuntu 9.04

Obed Javier (reddragon-soal) wrote :

I have this problem too..

dell inspiron 1525 with intel Mobile GM965

ubuntu 9.04

Bryce Harrington (bryce) on 2009-07-13
description: updated
description: updated
Bryce Harrington (bryce) wrote :

Well, next I'd like to forward this issue upstream, but first it must be retested on latest development version of Karmic to make sure the issue still happens there with the latest code. ISO images are available at http://cdimages.ubuntu.com/releases/karmic/. If you can reproduce it in the LiveCD environment, you shouldn't need to modify your installed system. Also please attach a fresh Xorg.0.log and dmesg from this testing.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
TSWMIN85 (tswmin85) wrote :

Acer Aspire 5315, Warzone 2100 3D is rendered black...

Bryce Harrington (bryce) on 2009-07-30
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Arvid Norlander (anmaster) wrote :

I have the same issue as the original reporter (with warzone 2100 at least) on my Lenovo Thinkpad R500. Same details reported by lspci for VGA compatible controller and Display controller. Using Ubuntu 9.04 (x86_64).

Joseph Maillardet (jokx) wrote :

Same problem here : Jaunty 9.04 x86_64, Intel X4500HD, Dell Latitude E6500.

I will test with Karmic Alpha4 after some of my upload is finish (~next 12h).

Joseph Maillardet (jokx) wrote :

So, same problem with Karmic 9.10 Alpha 4. (LiveCD) I attach an archive with fresh Xorg.0.log, dmesg, lspci and lshw.

Geir Ove Myhr (gomyhr) wrote :

Joseph, thank you for testing on Karmic. For xorg-related packages we prefer to have only one reporter per bug report, since there may often be some unnoticed differences between the problem of the original reporter and those who follow up. Could you report a new bug using `ubuntu-bug -p xserver-xorg-video-intel` from the Karmic LiveCD? That would give us all your log and none of other's in one bug report. Since the original reporter does not seem to respond, you can mark this bug report a duplicate of yours.

After you have done that it would also be nice if you could test the xorg-edgers PPA with the Karmic LiveCD. The reason for that is that there has been some fixes in the newest development version of mesa that may fix this issue, and it would be really nice to know if has already been fixed there or not. See the description at https://launchpad.net/~xorg-edgers/+archive/ppa for how to use the PPA from a LiveCD. On the link it is referred to it suggests using LiveUSB instead of a CD, but it works fine with a CD if you just download the script http://bazaar.launchpad.net/%7Exorg-edgers/xorg-server/xorg-pkg-tools/annotate/head%3A/xorg-edgers-live-test from the LiveCD session.

Geir Ove Myhr (gomyhr) on 2009-08-16
summary: - [g45] Warzone 2100 3D is rendered black with GMA4500MHD
+ [gm45] Warzone 2100 3D is rendered black with GMA4500MHD
tags: added: gm45
Bryce Harrington (bryce) on 2009-08-18
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Pascal de Bruijn (pmjdebruijn) wrote :

I just tried on Karmic, and it now renders properly (xserver-xorg-video-intel 2:2.8.1-1ubuntu1).

Although Warzone now seems to lock up X, when exiting the game.

Jaime Rave (jaimerave) wrote :

I'm having the same problem as Pascal. The game is working properly but when I try to exit the game it just get stuck and doesn't allow me to get back to the desktop. So I guess the original bug is fixed. I'm in Ubuntu 9.10 and latest intel drivers from xorg-edgers

Bryce Harrington (bryce) on 2010-02-18
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released
Pascal de Bruijn (pmjdebruijn) wrote :

I just tested this on Lucid (rc, updated to today), and Warzone works fine.

So I can confirm the fix.

 status fixreleased

Thanks for testing; marking as fixed based on your feedback.

Jan Tománek (janiktomanek) wrote :

The bug is back, I have Ubuntu 11.10 64bit and Intel 450MHD. With some games, changing some graphics options helps, however not in Warzone, everything rendered in 3D is black. Setting texture size to "64" showed some parts of the vehicles in the game, rendered correctly, for example cannon of a tank was cisible, however tank not. And some parts of buildings were like a rainbow.

Is there any info I could provide?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers