[i845] should use XAA for acceleration on i845 because EXA acceleration is known to cause instabilities

Bug #355441 reported by Paul Dufresne on 2009-04-05
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

I disklike the way https://bugs.launchpad.net/bugs/259385 was fixed.
For me the correct workaround to apply (there seems no one is willing to try to fix the real issue with the driver for somethins as old as i845) would have been to to automatically fallback to XAA acceleration when detecting i845 (and i830?).

As the jaunty doc intel driver says (/usr/share/doc/xserver-xorg-video-intel/README.gz):
Known Limitations:
- EXA support unstable on i845.

And latest comments after fix released, indeed suggest that this workaround works:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/259385/comments/133

FOR SOMEONE WISHING TO FIND THE BUG IN THE DRIVER:
Probably can ignore this bug, as it was fixed, but interesting to check to be sure it has nothing with current instability of EXA:
https://bugs.launchpad.net/bugs/126425

I'd like also to note a beginning of explicaton to what could be wrong with the driver:
https://bugs.launchpad.net/bugs/309849 (a duplicate of bug #259385).

Paul Dufresne (paulduf) wrote :

I will not attach lspci or Xorg log to this bug, because I am not affected by this bug.

Bryce Harrington (bryce) wrote :

Hi paulduf,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in xorg-server (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) wrote :

Technically, the -intel component of bug 259385 is still open, because the compiz "fix" is just a workaround to whatever's broken in the driver. So really this is a dupe of that bug.

affects: xorg-server (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Yel (yel) wrote :

hi. thanks for the response.
my problem was, that after a few minutes on 'alt'-tab' my pc hang completely (just reboot possible). so i've followed the instructions of bug 259385 (intreprid-proposed, xorg.config --> XAA & compiz-remark) and after a reboot the gui loaded, i saw a mouse but the desktop did not came up, nor other sessions could be accessed by (Ctrl)-Alt-F1/F2.
After changing the accelator to UXA until now i don't have the problem anymore (running metacity)
attached is my lspci.

here is the (now running) xorg.conf:
----------
Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
 SubSection "Display"
  Virtual 3600 1200
 EndSubSection
EndSection

Section "Device"
 Identifier "Configured Video Device"
 Driver "intel"
 Option "AccelMethod" "uxa"
# Option "AccelMethod" "XAA"
EndSection
------------

a will attach the xorg-logs in the following posts

Yel (yel) wrote :
Yel (yel) wrote :

correction: right after posting my last response, i've used alt-tab and my system hang again. here ist the xorg.0.log.old
might be interesting:

Paul Dufresne (paulduf) wrote :

Hi Yel!

It looks like a different bug to me. I suggest you open a separate bug, and leave a comment here of the newly open bug.

It appears to me that in your previous message, you were not REALLY using UXA accelleration:
(**) intel(0): Option "AccelMethod" "uxa"
..
(==) intel(0): Using EXA for acceleration

For me writing "uxa" in lowercase did work however.

But I am using version (Jaunty):
(II) Module intel: vendor="X.Org Foundation"
 compiled for 1.6.0, module version = 2.6.3
 Module class: X.Org Video Driver
 ABI class: X.Org Video Driver, version 5.0
and you are using version:
(II) Module intel: vendor="X.Org Foundation"
 compiled for 1.5.2, module version = 2.4.1
 Module class: X.Org Video Driver
 ABI class: X.Org Video Driver, version 4.1

Are you using Intrepid?
I think you should try with "UXA" instead of "uxa".
That said, I doubt UXA was much stable by Intrepid time.
On the other hand, I am using UXA right now, with common effects with Compiz without problems (i945G).

Maybe you should retest on latest Jaunty to make sure the issue still happens there with the latest code. ISO images are available at http://cdimages.ubuntu.com/daily/current/ - if you can reproduce it in the LiveCD environment, you shouldn't need to modify your installed system. Also please attach a fresh Xorg.0.log from this testing.

Yel (yel) wrote :

Hi Paul
Thank you for your response. Yes I'm using Intreprid and yesterday I've changed the WM to Xfce. Since then I had no crashes anymore.
I believe the problem comes from the 3D-effects - and I think also in conjunction with Firefox, but I'll have to check that again.
I'm leaving for holidays now and be back in one week. I'll post the results and open another report if needed

Bryce Harrington (bryce) on 2009-04-24
summary: - should use XAA for acceleration on i845 because EXA acceleration is
- known to cause instabilities
+ [i845] should use XAA for acceleration on i845 because EXA acceleration
+ is known to cause instabilities
Paul Dufresne (paulduf) wrote :

Seeing a change in this bug reminds me...

Well, I sure should/should have open a new bug, because UXA acceleration have become totally useless about ... well guess about 2 weeks ago on my i945. GDM was not usable because a big rectangle appearing on the screen. Fix it by using EXA... and then forgot it. Did not try back since then. I'll give the link to new bug after I confirm it is still present.

Paul Dufresne (paulduf) wrote :

Retesting with UXA acceleration on i945 (this bug about i845)... working fine... testing for 3 hours without problems.
So I guess 9.04 release is fine with UXA on i945.

Bryce Harrington (bryce) wrote :

I think we probably should wontfix this bug, and instead focus on getting upstream attention onto the issues on i845 with UXA. But I'll leave this bug open for the time being...

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers