[830m] mplayer appears to crash X

Bug #347527 reported by GordonSchumacher on 2009-03-23
6
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

When I launch a video from dolphin, I get an mplayer window momentarily, then X11 restarts. It does not appear to have left anything relevant in the logfiles, but I believe that the attached file resulted from this crash.

I'm running Jaunty Jackalope, installed from alpha5 and up-to-date as of about an hour ago.

GordonSchumacher (eleccham) wrote :
GordonSchumacher (eleccham) wrote :
Bryce Harrington (bryce) wrote :

Are you able to reproduce this issue with -intel 2.6.3? If so, please collect a full backtrace - see http://wiki.ubuntu.com/X/Backtracing for directions.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
GordonSchumacher (eleccham) wrote :

I am running xserver-xorg-video-intel 2:2.6.3-0ubuntu2, and it appears to be caused by something common to video players in general.

I've not gotten a backtrace yet - just got back to this, and it's a little late tonight - but I did get something more useful in the apport log, as shown here. I'd already been clever enough to install *most* of the relevant debug symbols, because of a different(?) problem I'm chasing.

From this info, I suspect one of the following:
http://lists.freedesktop.org/archives/xorg-commit/2009-February/020346.html
http://lists.freedesktop.org/archives/intel-gfx/2009-February/001426.html

If that's the case, then the good news would be that it's already fixed upstream...? (I'm having a hell of a time getting video to run stably on this i830 system; I only got it to quit randomly freezing by switching off DRI in my xorg.conf. See also https://bugs.freedesktop.org/show_bug.cgi?id=18319 - I have no idea if these are related but I thought I'd point it out.)

Carey Underwood (cwillu) wrote :

ElecCham, can you re-enable DRI (and generally return xorg.conf to a stock configuration temporarily), and see if the crash still occurs with all the recent updates applied?

tags: added: 830m hang intel
summary: - mplayer appears to crash X
+ [830m] mplayer appears to crash X
Bryce Harrington (bryce) on 2009-04-06
summary: - [830m] mplayer appears to crash X
+ [830m] mplayer appears to crash X unless DRI is disabled
Bryce Harrington (bryce) on 2009-04-06
summary: - [830m] mplayer appears to crash X unless DRI is disabled
+ [830m] mplayer appears to crash X
Bryce Harrington (bryce) wrote :

I'm a bit confused by the description of the problem. Let me see if I understand correctly...

a. You were having problems with freezes on i830, which you found went away by disabling DRI.

b. Subsequent to that, you notice that with DRI disabled, playing videos with Xv causes X to crash

Assuming I am understanding you correctly, I think I know what this bug is, and have a fix for it. If I'm wrong, please reopen the bug and clarify.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.6.3-0ubuntu7

---------------
xserver-xorg-video-intel (2:2.6.3-0ubuntu7) jaunty; urgency=low

  * Add 119_drm_bo_unreference_needs_null.patch:
    - The first time through the Xv code, an allocated buffer is
      unreferenced but the pointer is not reset to NULL. Thus, the next time
      a video is played, -intel thinks it has a valid buffer and crashes
      when it tries to access the freed memory. Fixes a number of crashes
      reported since moving to the 2.6.3 driver.
    - Fixes crash on i945 with frame buffer width > 2048. DRI is disabled
      on this chipset when the frame buffer exceeds this width.
      (LP: #354688)
    - Fixes crash on i865 where DRI is off because of patch 116
      (LP: #352760)
    - Fixes crash on i845 starting after 304871 was fixed
      (LP: #354889)
    - Fixes crash on i830 when manually disabling DRI
      (LP: #347527)

 -- Bryce Harrington <email address hidden> Mon, 06 Apr 2009 14:28:29 -0700

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.