[i855] xserver-xorg-video-intel-2.6.3 : Only green window when playing movies with XV extension

Bug #344740 reported by Stefan Glasenhardt on 2009-03-18
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

With the latest version of the intel-gfx-driver in Jaunty (xserver-xorg-video-intel_2.6.3-0ubuntu1_i386.deb), "totem" and "vlc" show only a green window when i want to play a movie on my notebook (855GM-chipset)

The bug can be easily solved, when the two following git-commits are backported to the driver 2.6.3 :

Fix Xv crash with overlay video :

http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=2026c57cf0a352d9e6f9d208cfb7d4d550614477

Fix XV with non-GEM kernels by allocating a larger fake bufmgr. :

http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=fb6e00f40f713a87c760fc7603159ed11ea9b0d5

Stefan Glasenhardt (glasen) wrote :
Stefan Glasenhardt (glasen) wrote :
Matteo Settenvini (tchernobog) wrote :

I can confirm the problem on:

00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 01)
 Subsystem: IBM Device [1014:0543]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx+
 Latency: 0
 Interrupt: pin A routed to IRQ 11
 Region 0: Memory at e0000000 (32-bit, prefetchable) [size=128M]
 Region 1: Memory at d0000000 (32-bit, non-prefetchable) [size=512K]
 Region 2: I/O ports at 1800 [size=8]
 Capabilities: [d0] Power Management version 1
  Flags: PMEClk- DSI+ D1+ D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
 Kernel modules: intelfb

Bryce Harrington (bryce) wrote :

The "...but hopefully not anger tiny-aperture systems..." bit does not fill me with confidence. I'm tempted to skip incorporating these fixes out of fear of regression risk, but since we've had a few people complain about this problem I'm willing to give it a shot.

We may back these out if we find them the source of regressions though.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.6.3-0ubuntu2

---------------
xserver-xorg-video-intel (2:2.6.3-0ubuntu2) jaunty; urgency=low

  * Add 114_fix_xv_with_non_gem.patch, 115_fix_crash_xv_overlay.patch:
    - Fix green window when playing movies with Xv extension (LP: #344740)

 -- Bryce Harrington <email address hidden> Wed, 18 Mar 2009 17:05:09 -0700

Changed in xserver-xorg-video-intel:
status: New → Fix Released
Matteo Settenvini (tchernobog) wrote :

It may be a bug in xorg core, but since this update, I've got frequent X crashes.

They all happen when the monitor resumes from sleep after being blanked, or when it goes to sleep, or when mplayer/totem end playing a video.

Also, I've noted that, if you move a gnome-terminal window with black background and some transparency enabled over a totem window with compiz *disabled*, some of the video "passes" through the terminal (the areas where the wallpaper is black) and shows on top of it.

Should I open a new bug?

By the way, dmesg says:

[18285.236782] Xorg[18926]: segfault at 10 ip b78ea4c9 sp bf856400 error 4 in libdrm_intel.so.1.0.0[b78e9000+8000]

Do anyone know why apport isn't working, nor why I can't find a stacktrace in Xorg.<n>.log?

Bryce Harrington (bryce) wrote :

> We may back these out if we find them the source of regressions though.

Sucks to be right. The regression here is 348428, which has been pinpointed to this bugfix. As bad as a green window playing movies sounds, the X lockups are worse, so I'm reverting patch 114.

115 sounds like it fixes a crash, so I'm going to try to keep that patch if it is innocent in the regression as I suspect.

So, additional analysis needs to be done to find a better, regression-free fix for this bug. If a solution comes to light, please assign this bug to me and I'll take a look.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Released → In Progress
summary: - xserver-xorg-video-intel-2.6.3 : Only green window when playing movies
- with XV extension
+ (855) xserver-xorg-video-intel-2.6.3 : Only green window when playing
+ movies with XV extension
Bryce Harrington (bryce) on 2009-04-04
summary: - (855) xserver-xorg-video-intel-2.6.3 : Only green window when playing
+ [i855] xserver-xorg-video-intel-2.6.3 : Only green window when playing
movies with XV extension
unggnu (unggnu) wrote :

I am not sure. I have removed some time ago both patches, at first the 115 and then the 114 and still got the same problem.

unggnu (unggnu) wrote :

Intel 2.6.3-ubuntu5 doesn't fix the freezing/switching to console problem but xv is still working too. No green screen.

Bryce Harrington (bryce) wrote :

Stefan, what are your findings?

Stefan Glasenhardt (glasen) wrote :

Hi,

The latest driver works for me. No more green screens.

Regarding the lockups a have a tip :

When i'm disabling all external monitor connections in the xorg.conf-file, the random lockups completely disappear (At least for me). The lockups occured sometimes when i'm watching a movie (Xv extension), used powertop or switched back from console.

I've attached my xorg.conf-file, so you can try it for yourself. Its not a perfect solution, but better than nothing.

unggnu (unggnu) wrote :

In my case the easiest way to confirm the lockup issue is to run a video with xv - starting is enough - and then initiate suspend afterwards. X should crash after a short time and you should find yourself at the login screen.

Anyway the green issue was fixed a long time ago and hasn't reappeard with Intel 2.6.3-ubuntu5 so for my concern this bug could still be marked as fixed released.

Bryce Harrington (bryce) wrote :

Okies.
Please make sure we have the right bugs opened on this.

Changed in xserver-xorg-video-intel (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers