Ubuntu

[i945GME] drm:i915_getparam *ERROR* Unknown parameter 6

Reported by Florent on 2009-03-11
118
This bug affects 17 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Andy Whitcroft
xserver-xorg-video-intel (Ubuntu)
Low
Unassigned

Bug Description

I got many errors in the dmesg log, after upgrade to 2.6.28-9.29.

root@jaunty# dmesg |grep drm
[ 54.113090] [drm] Initialized drm 1.1.0 20060810
[ 54.157005] [drm] Initialized i915 1.6.0 20080730 on minor 0
[ 54.163231] [drm:i915_getparam] *ERROR* Unknown parameter 6
[ 55.267287] [drm:i915_getparam] *ERROR* Unknown parameter 6
[ 73.376502] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0
[ 413.364710] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0
[ 417.776700] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0
[ 518.028692] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0
[ 781.018880] [drm:i915_getparam] *ERROR* Unknown parameter 6
[ 7402.782181] [drm:i915_getparam] *ERROR* Unknown parameter 6

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
MachineType: SAMSUNG ELECTRONICS CO., LTD. NC10
NonfreeKernelModules: ath_hal
Package: linux-image-2.6.28-9-generic 2.6.28-9.29
ProcCmdLine: root=UUID=9ceb4b9e-7677-4031-a6da-1996e3542ca2 ro vga=789 quiet
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-9.29-generic
SourcePackage: linux

Florent (florent.x) wrote :
Fridtjof Busse (fbusse) wrote :

I can confirm this with the jaunty beta 6, also on a Samsung NC10

Florent (florent.x) on 2009-03-13
Changed in xserver-xorg-video-intel:
status: New → Confirmed
Florent (florent.x) on 2009-03-13
Changed in linux:
status: New → Confirmed
Florent (florent.x) wrote :

AFAICT I assigned the bug to the wrong package.
It is specific to xserver-xorg-video-intel.

Changed in linux:
status: Confirmed → Invalid
Florent (florent.x) wrote :

I tracked the events that produced such messages.

1/ During boot
[ 54.163231] [drm:i915_getparam] *ERROR* Unknown parameter 6
[ 55.267287] [drm:i915_getparam] *ERROR* Unknown parameter 6

2/ First time you press "Ctrl+Alt+Fx" to switch to VT x (x=2), the screen flickers but it does not switch to the requested VT
[ 413.364710] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0

3/ Second time you press "Ctrl+Alt+Fx", it switches to the VT x, but write another error :
[ 417.776700] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0

4/ When I lock the screen, with command "xflock4" (XFCE desktop), it becomes black normally. But an error is written:
[ 781.018880] [drm:i915_getparam] *ERROR* Unknown parameter 6

Hope it helps.

Florent (florent.x) wrote :

I attach the last Xorg.0.log. Here is an extract.

root@jaunty# grep '\((EE\|WW)\)' /var/log/Xorg.0.log
[ 0.014365] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 0.740028] (WW) intel(0): libpciaccess reported 0 rom size, guessing 64kB
[ 1.896711] (WW) intel(0): Register 0x61200 (PP_STATUS) changed from 0xc0000008 to 0xd000000a
[ 1.896766] (WW) intel(0): PP_STATUS before: on, ready, sequencing idle
[ 1.896797] (WW) intel(0): PP_STATUS after: on, ready, sequencing on
[ 1.963592] (WW) intel(0): DRI2 requires UXA
[ 2.079349] (EE) intel(0): Non-contiguous GTT entries: (6295552,0x163ffbe000) vs (6291456,0x3fe00000)
[ 2.079393] (EE) intel(0): Non-contiguous GTT entries: (6299648,0x163fe02000) vs (6295552,0x3ffbe000)
[ 2.079471] (WW) intel(0): xf86AllocateGARTMemory: allocation of 10 pages failed
[ 2.079510] (EE) intel(0): Non-contiguous GTT entries: (6295552,0x163ffbe000) vs (6291456,0x3fe00000)
[ 2.079552] (EE) intel(0): Non-contiguous GTT entries: (6299648,0x163fe02000) vs (6295552,0x3ffbe000)
[ 2.079599] (EE) intel(0): Non-contiguous GTT entries: (6295552,0x163ffbe000) vs (6291456,0x3fe00000)
[ 2.079642] (EE) intel(0): Non-contiguous GTT entries: (6299648,0x163fe02000) vs (6295552,0x3ffbe000)
[ 9600.005588] (WW) intel(0): ESR is 0x00000001, instruction error
[ 9600.005617] (WW) intel(0): Existing errors found in hardware state.
...

Florent (florent.x) wrote :

Packages:
  linux-image-2.6.28-10-generic 2.6.28-10.32
  xserver-xorg-video-intel 2:2.6.1-1ubuntu4

These errors still happens (dmesg):
  [drm:i915_getparam] *ERROR* Unknown parameter 6
  [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0

But I have no more complains for "Non-contiguous GTT entries":
root@jaunty# grep '\((EE\|WW)\)' /var/log/Xorg.0.log
[ 0.006913] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 0.329147] (WW) intel(0): libpciaccess reported 0 rom size, guessing 64kB
[ 1.492971] (WW) intel(0): Register 0x61200 (PP_STATUS) changed from 0xc0000008 to 0xd000000a
[ 1.493012] (WW) intel(0): PP_STATUS before: on, ready, sequencing idle
[ 1.493035] (WW) intel(0): PP_STATUS after: on, ready, sequencing on
[ 1.526202] (WW) intel(0): DRI2 requires UXA
[ 1.598583] (WW) intel(0): ESR is 0x00000001, instruction error
[ 1.598610] (WW) intel(0): Existing errors found in hardware state.
[ 4022.332514] (WW) intel(0): ESR is 0x00000001, instruction error
[ 4022.332557] (WW) intel(0): Existing errors found in hardware state.
[ 4027.543634] (WW) intel(0): ESR is 0x00000001, instruction error
[ 4027.543701] (WW) intel(0): Existing errors found in hardware state.

Florent (florent.x) wrote :

With last packages, errors are slightly different.

Packages:
  linux-image-2.6.28-11-generic 2.6.28-11.34
  xserver-xorg-video-intel 2:2.6.3-0ubuntu1

root@jaunty# grep '\((EE\|WW)\)' /var/log/Xorg.0.log
[ 0.040641] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 0.646135] (WW) intel(0): libpciaccess reported 0 rom size, guessing 64kB
[ 1.911691] (WW) intel(0): Register 0x61200 (PP_STATUS) changed from 0xc0000008 to 0xd000000a
[ 1.911748] (WW) intel(0): PP_STATUS before: on, ready, sequencing idle
[ 1.911778] (WW) intel(0): PP_STATUS after: on, ready, sequencing on
[ 1.959036] (WW) intel(0): DRI2 requires UXA
[ 296.499802] (WW) intel(0): ESR is 0x00000001, instruction error
[ 296.499873] (WW) intel(0): Existing errors found in hardware state.
[ 303.605896] (WW) intel(0): ESR is 0x00000001, instruction error
[ 303.605965] (WW) intel(0): Existing errors found in hardware state.

root@jaunty# dmesg |grep drm
[ 30.275802] [drm] Initialized drm 1.1.0 20060810
[ 30.295251] [drm] Initialized i915 1.6.0 20080730 on minor 0
[ 30.301098] [drm:i915_setparam] *ERROR* unknown parameter 4
[ 30.301199] [drm:i915_getparam] *ERROR* Unknown parameter 6
[ 31.499223] [drm:i915_getparam] *ERROR* Unknown parameter 6
[ 321.548733] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0
[ 329.876751] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0
[ 347.439987] [drm:i915_getparam] *ERROR* Unknown parameter 6

Florent (florent.x) wrote :
Florent (florent.x) wrote :
Bryce Harrington (bryce) wrote :

Florent,

You mention this started after you upgraded to kernel 2.6.28-9.29. Does the issue go away if you downgrade (you can test by just booting an earlier kernel)?

Actually, my best guess is that this is related to the libdrm 2.4.5 update, which happened on the 9th. Do the issues go away if you downgrade that to 2.4.3?

(Fwiw, I've seen these messages myself, thanks for chasing down what triggers them.)

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → bryceharrington
status: Confirmed → Incomplete
Florent (florent.x) wrote :

You may be right.

root@jaunty# grep 'upgrade libdrm' /var/log/dpkg.log
2009-03-10 17:22:09 upgrade libdrm2 2.4.4-0ubuntu6 2.4.5-0ubuntu1
2009-03-10 17:22:10 upgrade libdrm-intel1 2.4.4-0ubuntu6 2.4.5-0ubuntu1

So I downgraded to previous versions of packages:

libdrm2:
  Installed: 2.4.4-0ubuntu6
  Candidate: 2.4.5-0ubuntu1
libdrm-intel1:
  Installed: 2.4.4-0ubuntu6
  Candidate: 2.4.5-0ubuntu1
xserver-xorg-video-intel:
  Installed: 2:2.6.1-1ubuntu4
  Candidate: 2:2.6.3-0ubuntu1

Result:
 - I don't find any error during boot
 - I don't find any error when locking the screen (xflock4)
 - But I still have an error when I switch to another VT (even if it works OK)

root@jaunty# grep '\((EE\|WW)\)' /var/log/Xorg.0.log
[ 0.041547] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 0.751200] (WW) intel(0): libpciaccess reported 0 rom size, guessing 64kB
[ 1.947025] (WW) intel(0): Register 0x61200 (PP_STATUS) changed from 0xc0000008 to 0xd000000a
[ 1.947064] (WW) intel(0): PP_STATUS before: on, ready, sequencing idle
[ 1.947085] (WW) intel(0): PP_STATUS after: on, ready, sequencing on
[ 2.003938] (WW) intel(0): DRI2 requires UXA
[ 2.119477] (EE) intel(0): Non-contiguous GTT entries: (6295552,0x163ffbe000) vs (6291456,0x3fe00000)
[ 2.119550] (EE) intel(0): Non-contiguous GTT entries: (6299648,0x163fe02000) vs (6295552,0x3ffbe000)
[ 2.119656] (WW) intel(0): xf86AllocateGARTMemory: allocation of 10 pages failed
[ 2.119704] (EE) intel(0): Non-contiguous GTT entries: (6295552,0x163ffbe000) vs (6291456,0x3fe00000)
[ 2.119761] (EE) intel(0): Non-contiguous GTT entries: (6299648,0x163fe02000) vs (6295552,0x3ffbe000)
[ 2.119828] (EE) intel(0): Non-contiguous GTT entries: (6295552,0x163ffbe000) vs (6291456,0x3fe00000)
[ 2.119887] (EE) intel(0): Non-contiguous GTT entries: (6299648,0x163fe02000) vs (6295552,0x3ffbe000)
[ 172.953133] (WW) intel(0): ESR is 0x00000001, instruction error
[ 172.953185] (WW) intel(0): Existing errors found in hardware state.

root@jaunty# dmesg |grep drm
[ 27.658539] [drm] Initialized drm 1.1.0 20060810
[ 27.686730] [drm] Initialized i915 1.6.0 20080730 on minor 0
[ 194.048507] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0

Bryce Harrington (bryce) wrote :

In that case, I suspect the issue is a mismatch between the libdrm version we're using, and the version of DRM in the kernel. It was updated to include the latest DRM bits for -ati. I also requested that the -intel DRM kernel bits be updated but I'm not certain whether that made it in or not. If not, perhaps we have to live with the error message (we can't downgrade libdrm because I think -intel 2.6.3 would fail to work; but maybe the error message could be suppressed some other way).

Opening task for the kernel team to look into this. Hopefully if it's just that newer DRM bits are needed, it's something they can pull in post-beta.

Changed in linux (Ubuntu):
status: Invalid → New
Bryce Harrington (bryce) wrote :

Setting importance to low because I *suspect* this is just a cosmetic warning. However if anyone can definitively tie it to an actual error condition we can raise the priority.

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Low
status: Incomplete → Triaged
assignee: bryceharrington → nobody
Matt Zimmerman (mdz) wrote :

I see this on every VT switch, and occasionally have seen a hang or server crash on VT switch (including bug 328035). I don't know whether there is a strong correlation.

Matt Zimmerman (mdz) on 2009-03-21
tags: added: regression-potential
Fuji (fuji001) wrote :

I suspect that the bug that I reported is related to this bug.While mine is happening in Jaunty Jackalope with Intel 915M (EeePC 900)

Fuji (fuji001) wrote :
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Steve Beattie (sbeattie) on 2009-03-23
Changed in xserver-xorg-video-intel:
assignee: nobody → canonical-desktop-team
Changed in linux:
assignee: nobody → canonical-kernel-team
Andy Whitcroft (apw) on 2009-03-24
Changed in linux:
assignee: canonical-kernel-team → apw
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

Bryce, if you think that the -intel driver is correct, and it's just the kernel drm bits which need updating from usptream, can you please invalidate the -intel task?

For the record, I get the bug as well; unknown if it causes any of my current woes with X.org (which is the occasional pipe underruns, which is unlikely, or the occasional crash on resume; both have separate bug reports).

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: canonical-desktop-team → bryceharrington

I'm experiencing the same problems that Florent (VT switches and unknow parameters in dmesg).
I've just upgrade to Jaunty (kernel 2.6.28-11-generic) with an Intel i945GM (driver 2.6.3).
In fact, I have first also bad performances with compiz as in Bug #303011
Maybe it is related ?

Andy Whitcroft (apw) wrote :

I also see this on a GM45 based chipset. I get exactly one of these during boot:

    [ 30.416631] [drm:i915_setparam] *ERROR* unknown parameter 4

and exactly one of these each time I VT switch to VT-1 and back:

    [98636.163946] [drm:gm45_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0

I have:

libdrm2:
  Installed: 2.4.5-0ubuntu2
  Candidate: 2.4.5-0ubuntu3
libdrm-intel1:
  Installed: 2.4.5-0ubuntu2
  Candidate: 2.4.5-0ubuntu3
xserver-xorg-video-intel:
  Installed: 2:2.6.3-0ubuntu2
  Candidate: 2:2.6.3-0ubuntu2

Bah I had better go update.

Andy Whitcroft (apw) wrote :

These errors seem unchanged by the update for me. As bryce has indicated they may be benign.

dentaku65 (dentaku65) wrote :

I confirm this error too on my Intel 82852/855GM with alpha 6 and kernel 2.6.28-11-generic, same package situation reported by Andy.
With this error/scenario it's impossible to use compiz (does not load at all), was working perfectly with the previously lidrm and/or intel driver packages.

Andres Mujica (andres.mujica) wrote :

Hi, after digging around i've found some discussion about this, maybe it's wothwhile to take a look into this patches

http://lkml.org/lkml/2009/3/20/452

i'm copying here what seems to be the cause of the issue:

"From: Jesse Barnes <email address hidden>

commit dc1336ff4fe08ae7cfe8301bfd7f0b2cfd31d20a upstream.

In the absence of kernel mode setting, many drivers disable IRQs across VT
switch. The core DRM vblank code is missing a check for this case however;
even after IRQ disable, the vblank code will still have the vblank_enabled
flag set, so unless we track the fact that they're disabled at IRQ uninstall
time, when we VT switch back in we won't actually re-enable them, which means
any apps waiting on vblank before the switch will hang."

The upstream bug seems to be

http://bugs.freedesktop.org/show_bug.cgi?id=18879

Andy Whitcroft (apw) wrote :

@Andres -- the kernel patches indicated at the upstream bug you mention are all already pulled into the Jaunty kernel via the stable updates tree.

@dentaku65 -- actually although I see these errors I do not find compiz disabled, indeed I am using it right now.

Brian Murray (brian-murray) wrote :

Looking at the attachments in this bug report, I noticed that "dmesg" was flagged as a patch. A patch contains changes to an Ubuntu package that will resolve a bug, since this was not one I've unchecked the patch flag for it. In the future keep in mind the definition of a patch. You can learn more about what qualifies as a patch at https://wiki.ubuntu.com/Bugs/Patches. Thanks!

I have the same errors. I however noticed that after resume, there is no image. I need to restart the X server to finish the resume from hibernation.

Bryce Harrington (bryce) wrote :

The error message seems to be on the linux side, not in X components (not that I can find anyway). After checking with upstream, it seems to be just an innocuous warning. It sounds scarier than it is.

It would be nice to suppress it, to help avoid future confusion by bug reporters that see it, but it's not really super important.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Won't Fix
Julius Bloch (jbloch) wrote :

Hi I getting the same errors on my thinkpad x41 tablet, with the effect that X is not starting.
Dmesg shows:
[ 81.241503] [drm:i915_setparam] *ERROR* unknown parameter 4
[ 81.241530] [drm:i915_getparam] *ERROR* Unknown parameter 6
[ 82.156766] [drm:i915_getparam] *ERROR* Unknown parameter 6
[ 86.160274] Xorg[3616]: segfault at 10 ip 080d8832 sp bfefca20 error 4 in Xorg[8048000+19d000]
[ 86.336111] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0
[ 88.823155] [drm:i915_setparam] *ERROR* unknown parameter 4
[ 88.823182] [drm:i915_getparam] *ERROR* Unknown parameter 6
[ 89.740913] [drm:i915_getparam] *ERROR* Unknown parameter 6
[ 94.478806] Xorg[3670]: segfault at 21 ip 080d8832 sp bfd798a0 error 4 in Xorg[8048000+19d000]
[ 94.677703] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0

Kernel:
Linux rost 2.6.28-11-generic #41-Ubuntu SMP Wed Apr 8 04:38:53 UTC 2009 i686 GNU/Linux

X:
xorg 1:7.4~5ubuntu18 X.Org X Window System
xserver-common 2:1.6.0-0ubuntu14 common files used by various X servers
xserver-xorg-video-intel 2:2.6.3-0ubuntu9

JP Vossen (jp-jpsdomain) wrote :

FYI, I'm getting logcheck messages from a Dell Mini-9 with the same error on a clean install of Jaunty via the 2009-04-11 http://cdimage.ubuntu.com/ports/daily/current/jaunty-alternate-lpia.iso. No big deal, everything works as far as I can tell.

I'll suppress it via a custom logcheck pattern:
# https://bugs.launchpad.net/ubuntu/+source/linux/+bug/341363
^\w{3} [ :0-9]{11} [._[:alnum:]-]+ kernel: \[[0-9. ]+\] \[drm:i915_getparam\] \*ERROR\* Unknown parameter 6

magbuntu (magnar-hirschberger) wrote :

It would be better to fix this cra*** problem as soon as possible. On my X60s this errorneous "intel" driver switch off my internal display unexpected. It's impossible to work without backlight (I havn't a second monitor at home)

dmesg:

[ 0.000000] BIOS EBDA/lowmem at: 0009f000/0009f000
[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 (Ubuntu 2.6.28-11.42-generic)
...
[ 294.785009] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 1
[ 294.789022] mtrr: no MTRR for d0000000,10000000 found
[ 296.765008] [drm:i915_setparam] *ERROR* unknown parameter 4
[ 296.765008] [drm:i915_getparam] *ERROR* Unknown parameter 6
[ 297.205010] [drm:i915_getparam] *ERROR* Unknown parameter 6

magbuntu

htraki (htraki-indamail) wrote :

Dear Andy,

Maybe I know where is the problem, but I dont have enough knowledge to create deb files.
There is a file conflict between kernel and the libdrm headers. You put them into the same directory, and when you compile intel driver, you compile aginst kernel's drm ( which is wrong). You have to compile against libdrm.
I include a patch which will move libdrm headers into separate dir, feel free to modify it.
Also You have to modify libdrm.pc.in before you run configure to set the correct headers dir.
After that just recomplie libdrm and the intel driver, and hopefully problem solved.

Note: I did not try this method on ubuntu !!!! I made a recipe for GoboLinux, there I had the same problem.

No more error messages since I've upgraded my kernel to the 2.6.30-rc3.

Although this may not be related, in 2.6.30-rc3 VT-switch are still perturbed.
But I also notice that in 2.6.30-rc2 with EXA and option "MigrationHeuristic" "greedy", VT-switch went back to normal.
Unfortunately this stills happen in 2.6.30-rc3.

Andy Whitcroft (apw) wrote :

These messages seems to be utterly benign. It is unlikley we are going to change the kernel in response unless we can show some failure resulting from them. Therefore moving the kernel task Won't Fix.

Changed in linux (Ubuntu):
status: In Progress → Won't Fix
rustle (rustle) wrote :

I can confirm this bug in 2.6.28-12-generic #43-Ubuntu SMP Fri May 1 19:27:06 UTC 2009 i686 GNU/Linux
on a ASUS Eee 1000HA Netbook (Jaunty UNR)
root@sputnik:~# dmesg
...
[drm:i915_getparam] *ERROR* Unknown parameter 6

linuxwarrior (linuxwarrior) wrote :

Hi, I confirm the error on an Asus eee Box running a fully updated Jaunty.

 I see this with dmesg.

[drm:i915_getparam] *ERROR* Unknown parameter 6

ALSO I get strange display quircks like quick shifts to the left and then right of about 1 inch. Then everything continues allright. It is very fast you need to be watching to catch it. (Those seem to be related to the get_vblank_counter message.

AND finally I get occasional X server black screens while everything keeps working fine, I just stop seeing the VT7, if I switch to VT1 I get text mode OK, but I can never get back to a visible VT7. (programs running on X do not stop, i.e.: mplayer keeps playing)

2.6.28-11-generic

On Wed, May 13, 2009 at 04:15:34AM -0000, linuxwarrior wrote:
> Hi, I confirm the error on an Asus eee Box running a fully updated
> Jaunty.
>
> I see this with dmesg.
>
> [drm:i915_getparam] *ERROR* Unknown parameter 6

It is a harmless warning and can be ignored.

The other issues you reported sound like each a separate bug, and should
be reported separately rather than here.

Liam O'Reilly (aliam13-2) wrote :

Hi, I am running Jaunty (fully up-to-date as of 9th July 2009) 64 bit version. My kern.log file shows alot of
[drm:i915_getparam] *ERROR* Unknown parameter 6
messages just before my system crashes.
My system is crashing in this way (on average) about once a day at the moment. I believe these messages in the kern.log file are the last messages produced before such a crash.

ZelinskiyIS (ivze) wrote :

After seing "[drm:i915_getparam] *ERROR* Unknown parameter 6" messages last befor crash in kern.log ang googling over this string, I found this launchpad bug entry. The videodevice is "Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)". The system crashes about once a day.

Liam O'Reilly (aliam13-2) wrote :

See recent comments these may obviously not be just harmless warning and may be the cause for a serious crash.

Changed in linux (Ubuntu):
status: Won't Fix → Confirmed
Liam O'Reilly (aliam13-2) wrote :

See recent comments these obviously may not be just harmless warnings and may be the cause for a serious crash.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Won't Fix → Confirmed
MrAuer (mr-auer) wrote :

My Asus Eee pc 901 with the Intel 945Gme chipset has its Xserver crash several times per day.
This behaviour has never disappeared and my original report was marked as a duplicate of a bug that has been fixed now. https://bugs.launchpad.net/bugs/337116

Today X has crashed 3 times, this is syslog around the latest event. No Compiz, Xubuntu 9.04 (had vanilla Ubuntu earlier, same thing, but with Gnome the crashes were less frequent). I installed and updated to latest packages yesterday, after trying Karmic daily build (hard locks all the time with that, no go yet). Presently, this crash behaviour makes this computer preetty unreliable in use.
I have the exact same install setup on my Eee pc 701, and that does not crash or lock up.

12 21:14:16 gekko-laama kernel: [13350.631788] ===>rt_ioctl_giwscan. 4(4) BSS returned, data->length = 435
Aug 12 21:15:33 gekko-laama kernel: [13428.040787] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0
Aug 12 21:15:33 gekko-laama gdm[23569]: WARNING: gdm_slave_xioerror_handler: Vakava X-virhe – :0 käynnistetään uudelleen
Aug 12 21:15:33 gekko-laama NetworkManager: <info> (ra0): device state change: 8 -> 3
Aug 12 21:15:33 gekko-laama NetworkManager: <info> (ra0): deactivating device (reason: 38).
Aug 12 21:15:33 gekko-laama NetworkManager: <info> ra0: canceled DHCP transaction, dhcp client pid 24076
Aug 12 21:15:33 gekko-laama NetworkManager: <WARN> check_one_route(): (ra0) error -34 returned from rtnl_route_del(): Sucess
Aug 12 21:15:33 gekko-laama avahi-daemon[3049]: Withdrawing address record for 192.168.1.101 on ra0.
Aug 12 21:15:33 gekko-laama avahi-daemon[3049]: Leaving mDNS multicast group on interface ra0.IPv4 with address 192.168.1.101.
Aug 12 21:15:33 gekko-laama avahi-daemon[3049]: Interface ra0.IPv4 no longer relevant for mDNS.
Aug 12 21:15:34 gekko-laama nm-dispatcher.action: Script '/etc/NetworkManager/dispatcher.d/01ifupdown' exited with error status 1.
Aug 12 21:15:35 gekko-laama acpid: client 23676[0:0] has disconnected
Aug 12 21:15:35 gekko-laama acpid: client connected from 5538[0:0]
Aug 12 21:15:36 gekko-laama kernel: [13431.410523] [drm:i915_setparam] *ERROR* unknown parameter 4
Aug 12 21:15:36 gekko-laama kernel: [13431.410578] [drm:i915_getparam] *ERROR* Unknown parameter 6
Aug 12 21:15:38 gekko-laama kernel: [13432.798607] [drm:i915_getparam] *ERROR* Unknown parameter 6

MrAuer (mr-auer) wrote :

Aug 12 21:15:33 gekko-laama gdm[23569]: WARNING: gdm_slave_xioerror_handler: Vakava X-virhe – :0 käynnistetään uudelleen
This line says "Serious X-error - :0 restarting", in finnish.
The [drm:i915_get_vblank_counter] always seems to precede X crashing, ie. something with the Intel driver, still?

MrAuer (mr-auer) wrote :

These are definitely a cause for a serious crash, these have happened always with Jaunty.
The log entries always looked the same right before X goes.
With vanilla Ubuntu, and not Xfce, this tends to cause a hard lock, ie. even Alt-SysRq-K does not work, but you need to hold the power button for 5 secs to hard shut down.

Bryce Harrington (bryce) wrote :

Again, "Error unknown parameter 6" is merely a warning message which pops up in various circumstances, and is not the *cause* of a crash or other problem. Suppression of the confusing warning error message is up to the kernel team. If you are experiencing an X crash, then again I would ask that you report it as a *separate* bug report so that it is simpler to troubleshoot.

For information on creating good bug reports about X problems please see http://wiki.ubuntu.com/X/Reporting, and in particular for crashes see http://wiki.ubuntu.com/X/Backtracing for directions on how to get proper debug output so the issue can be solved.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Invalid
Liam O'Reilly (aliam13-2) wrote :

As request I have filed a new bug related to my crash at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/412907

MrAuer (mr-auer) wrote :

Bryce Harrington:
Will do that, I installed the x server debug symbols and started Apport in the background. I will post the results in the bug report Liam O'Reilly started when this next crashes, since my crashes sound similar at least on the surface.
Thank you.

Andy Whitcroft (apw) wrote :

We have confirmed that these error messages are benign. They occur just before a crash commonly simply as they occur at specific points in the life cycle of the X server. If you are having a real crash it is highly unlikely to be related to these specific messages. Please file a separate bug for crashes.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix

On Thu, Aug 13, 2009 at 09:37:25AM -0000, MrAuer wrote:
> Bryce Harrington:
> Will do that, I installed the x server debug symbols and started Apport in the background. I will post the results in the bug report Liam O'Reilly started when this next crashes, since my crashes sound similar at least on the surface.

I'd ask that you not do this, but rather file a new bug report. The
reason is that developers look at a max of one issue per bug report, and
so your issue will not get investigated if it is appended to someone
else's. Launchpad makes it very cheap and easy to mark two bugs dupes,
so if it does turn out your issue is the same as Liam's, we are able to
handle that situation most cleanly if your issue is on a separate bug
report. Thanks.

John Ward (automail) wrote :

I can confirm as well but my problem is that I can't get to the desktop. I get a mixture of parameter 4 and 6 in the last lines of "dmesg". I will post my "dmesg.log" when I can. The odd thing is that the LiveCD worked fine, I got a fully functional desktop - even compiz was switched on automatically and worked well. But after install no desktop! Is this new?

Bryce Harrington (bryce) on 2009-10-02
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: Bryce Harrington (bryceharrington) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.