Ubuntu

[i965] Wrong Reflections in Blender 2.48a (fixed in 2.49RC2)

Reported by Johannes Langlotz on 2009-01-31
12
Affects Status Importance Assigned to Milestone
blender (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

see screenshots

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
 Subsystem: Dell Device [1028:01f9]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c)
 Subsystem: Dell Device [1028:01f9]

Geir Ove Myhr (gomyhr) wrote :

Thank you for filing this bug report and helping to make ubuntu better. We need some more information about you system to be able to do anything about this. Could you please upload as separate attachements:
- /var/log/Xorg.0.log
- /etc/X11/xorg.conf if you have made any changes to this
- the output of `lspci -vvnn`

Also, could you
- confirm that this the rendering looks fine if you use the VESA driver in Jaunty (add the line
Driver "vesa"
to the device section of your xorg.conf). This may slow down the rendering, but if it looks fine with this driver, it is a very good indication that it is a driver issue.
- try if adding some options to the driver in will make it render right. Basically, you can make the Device section of xorg.conf look like this:
Section "Device"
 Identifier "Configured Video Device"
# Driver "vesa"
# Option "NoAccel" "true"
# Option "DRI" "false"
# Option "AccelMethod" "EXA"
# Option "AccelMethod" "UXA"
# Option "AccelMethod" "XAA"
# Option "Tiling" "false"
EndSection
and then uncomment a single of the commented line, restart X and see if the rendering changes. It should be sufficient to try one uncommented line at a time.

Changed in xserver-xorg-video-intel:
status: New → Incomplete
Geir Ove Myhr (gomyhr) wrote :

And maybe you can upload kanister.blend so someone else easily can try to reproduce this. (Extra bonus for step-by-step instruction for how to render it in blender - I haven't used blender for a while)

I haven't made any changes but gnome-display-properties added the virtual screen size for the dual monitor setup (notebook display + external docking station display).

Just open the file with Blender. If you just see a wireframe, press Z-key to toggle between wireframe and shaded mode. But you don't need kanister.blend for this because this error also occurs with the cube which adds blender by default.

The following driver options gave good render results:
 Driver "vesa"
 Option "NoAccel" "true"
 Option "DRI" "false"
 Option "AccelMethod" "XAA"

With XAA X started in low graphics (vesa?) mode.

The following driver options gave bad/wrong render results:
 Option "AccelMethod" "EXA" BAD
 Option "AccelMethod" "UXA" BAD
 Option "Tiling" "false" BAD

Geir Ove Myhr (gomyhr) on 2009-02-14
description: updated

I can confirm this problem on my computer as well. It is a Thinkpad X61 Tablet and has the same graphics chipset as you have (965GM). I found it much easier to see that something was wrong with your file than with the standard cube.

Changed in xserver-xorg-video-intel:
status: Incomplete → Confirmed
Ubuntusho (ubuntusho) wrote :

I have also a problem caused by the xserver-xorg-video-intel with blender, it was "solved" when i did what you say here (Driver vesa + Option no acceleration) but in Hardy and eaven Intrepid i didn't had any problem with Blender + Compiz

Here my lspci

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

I asume it's the same problem but with a different result becouse i have a diferent graphics card

I really need this program so now i have inrtrepid but if it's necesary i give some more information i will use a live USB and keep going

Thanks!

Just Confirming this bug.....

Alexander L. (zdemoniac) wrote :

I can confirm this problem to, on Radeon X1300 Pro !
Kubuntu 9.04 RC x86_64 with all updates,
using "radeon" driver.

Geir Ove Myhr (gomyhr) wrote :

Thank you for reporting that, Alexander. This is the first sign that this isn't really a problem with the -intel driver.

Actually it seems to be a bug in blender --- or at least something that is fixed in the upcoming 2.49 release. I just downloaded blender-2.49-RC2-linux-glibc236-py26-i386.tar.bz2 from http://download.blender.org/release/Blender2.49RC/ and when opening kanister.blend with that, everything looks fine. To make sure this is really a difference between the blender versions and not due to some ubuntu packaging, I also downloaded
http://download.blender.org/release/Blender2.48a/blender-2.48a-linux-glibc236-py25-i386.tar.bz2
and with that version, the problem is still present.

So it looks like adding the new version of Blender will solve it in Karmic. If anyone has the dedication to track down the commit to the Blender SVN that fixes this bug, I guess it may also be possible to do a SRU (see https://wiki.ubuntu.com/StableReleaseUpdates) for Jaunty.

summary: - [i965] Wrong Reflections in Blender with intel graphics
+ [i965] Wrong Reflections in Blender 2.48a (fixed in 2.49a)
summary: - [i965] Wrong Reflections in Blender 2.48a (fixed in 2.49a)
+ [i965] Wrong Reflections in Blender 2.48a (fixed in 2.49RC2)
Vincent-Lin (chshlin) wrote :

Hello All, Thanks for this great thread.

First, I had the same issues with my EeePC
I follow the instruction above to modify the xorg.conf, butI got mess UI displaying, so I decided to test something out.

Finally, II found a quick solution for before the new version Blender releasing.

My system info
--------------------------------------------
EeePC 900HA
Ubuntu 9.04 netbook remix
--------------------------------------------

By simply added one line in your xorg.conf file at Device section.
Section "Device"
   Identifier "Configured Video Device"
   Option "NoAccel" "true" <-- this one.
EndSection

Now the blender just working fine.
Hopefully, this would help for both user and developer.

daresan (daresan21) wrote :

Hello everyone!
Confirm! ;)
I experienced the same problem (in the 3D View the lower part was not calculated properly and in some menues there were prolems as well, mostly with refreshing) on my Thinkpad T61 (Model: 7659-CTO, Mobile GM965/GL960 Integrated Graphics Controller) with Ubuntu 9.0.4 and with blender 2.48 as well as 2.49 RC3. I simply added the line as mentioned in the comment from Vincent Lin to the xorg.conf file:

Section "Device"
   Identifier "Configured Video Device"
   Option "NoAccel" "true" <-- this one.
EndSection

(you have to edit the file with su rights and restart afterwards)
I read that Intel is currently working on their drivers and that this issue hopefully will be solved in summer:
http://www.heise.de/open/Kernel-Log-X-org-7-5-im-Sommer-Intels-Grafiktreiber-wird-grundrenoviert--/artikel/137072
(sorry it's in german)
Regards,
Daresan

P.S.: Blender rules! :D

Bryce Harrington (bryce) wrote :

Well, next I'd like to forward this issue upstream, but first it must be retested on latest development version of Karmic to make sure the issue still happens there with the latest code. ISO images are available at http://cdimages.ubuntu.com/releases/karmic/. If you can reproduce it in the LiveCD environment, you shouldn't need to modify your installed system. Also please attach a fresh Xorg.0.log and dmesg from this testing.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete

There seems to be no reflection problem in Karmic.

Bryce Harrington wrote:
> Well, next I'd like to forward this issue upstream, but first it must be
> retested on latest development version of Karmic to make sure the issue
> still happens there with the latest code. ISO images are available at
> http://cdimages.ubuntu.com/releases/karmic/. If you can reproduce it in
> the LiveCD environment, you shouldn't need to modify your installed
> system. Also please attach a fresh Xorg.0.log and dmesg from this
> testing.
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: Confirmed => Incomplete
>

Bryce Harrington (bryce) wrote :

Thanks for letting us know the issue is resolved in karmic.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released
Geir Ove Myhr (gomyhr) on 2009-09-08
Changed in blender (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers