[i915GM] Regression in xserver-xorg-video-intel version 2.4.1-1ubuntu10.3

Bug #320893 reported by volkris on 2009-01-24
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Critical
xserver-xorg-video-intel (Ubuntu)
High
Unassigned
Intrepid
Critical
Bryce Harrington

Bug Description

After the upgrade to intrepid-updates's 2.4.1-1ubuntu10.3 (from 10.1) the display was scrambled on my computer. Downgrading to 10 (the only other version in synaptic) fixed the problem.

The difference I see in the xorg logs is this, when broken:
(EE) intel(0): Mode 1280x1024 does not fit virtual size 1024x1024 - internal error

instead of this, when working:
(EE) intel(0): Mode 1280x1024 does not fit virtual size 1024x768 - internal error

I am running at 1024x768, so it seems the update does not properly detect resolution.

lspci -vvvnn will be attached.

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller [8086:2590] (rev 03)
 Subsystem: COMPAL Electronics Inc Device [14c0:0012]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 03)
 Subsystem: COMPAL Electronics Inc Device [14c0:0012]

volkris (volkris) wrote :
volkris (volkris) wrote :

I regenerated my xorg config file to see if there was any misconfiguration in there causing the problem. No luck.

Also see bug #316672 which was fixed in this update and involved resolution stuff

Geir Ove Myhr (gomyhr) wrote :

Chris, could you for completeness also upload your Xorg.0.log?

description: updated
Geir Ove Myhr (gomyhr) on 2009-01-24
Changed in xserver-xorg-video-intel:
status: New → Incomplete
volkris (volkris) wrote :

Attached is my current Xorg.0.log from 2.4.1-1ubuntu10 . I don't seem to have a log saved from the new 10.3, but as I said the only significant different was the "fit virtual size" line.

Mauricio Tucci (mauriciotucci) wrote :

@Chris - I did downgrading and older version (10) works fine. Please, look the /var/log/Xorg.0.log attached. I couldn't find "do not fit virtual size".

volkris (volkris) wrote :

Mauricio, that's the log from 10.3 when it was broken, right? Nothing particularly weird jumped out at me, but it might be useful for you to diff the 10.3 log with your working 10 log.

Take the two files and run "diff file1 file2" and it will show the differences. Surely that can give a hint as to why one works and one doesn't.

Anyway, bughunters watching this will probably need the output from lspci

For now it looks like you and I will have to pin the version of the driver through synaptic.

Geir Ove Myhr (gomyhr) on 2009-01-26
Changed in xserver-xorg-video-intel:
status: Incomplete → Confirmed
Sean (ubuntu-inet-sys) wrote :

I also had this problem on my LG-LT20 laptop which also runs in 1024x768.

Rolling back to 10 'solved' the issue for me also.

00:00.0 Host bridge: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
00:00.1 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
00:00.3 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

Which I presume means I have a i855GM card.

please let me know if there is anything I can do to help.

Bryce Harrington (bryce) wrote :

Chris, I've reopened the bug that resulted in the change that appears to have caused your issue. It would be good if you could join the discussion on that bug:
https://bugs.freedesktop.org/show_bug.cgi?id=17292

Changed in xserver-xorg-video-intel:
importance: Undecided → High
status: Confirmed → Triaged
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Nicolas Van Wambeke (nicolasvw) wrote :

I'm having a similar problem with the update. I have an external monitor plugged into my laptop (Asus W6A) which has a i915GM.

After upgrading I observe the following:
 - blue/red stripes appeared on the LVDS display.
 - the external display's brightness gets set to the maximum.

Downgrading to 2.4.1-1ubuntu10 works fine.

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 04)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)

Mauricio Tucci (mauriciotucci) wrote :

@Chris -> I attaching "diff Xorg" from 10 to 10.3 and lspci -vvvnn. tks

Mauricio Tucci (mauriciotucci) wrote :
Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released

Same here, except that going back to 2.4.1-1ubuntu10 did not fix the problem that appeared with the update, even after a complete reboot. I still get errors like:
(EE) intel(0): Mode 1280x1024 does not fit virtual size 1024x1024 - internal error
while I'm using 1024x768. My logs only show this kind of error since I upgraded to 10.3.

Maybe this is just a problem of upgrade. How can I check the actual version of the intel driver that is loaded? Anyway, here's the diff between the logs, and I have a 915GM/GMS/910GML.

volkris (volkris) wrote :

Has there been any progress on this bug in the last month?

It's frustrating to have update manager constantly trying to updated me to the broken package, and I feel really sorry for new users whose installs simply don't work due to this...

The bug linked from freedesktop.org has been closed for a while, though I'm not sure that bug is actually related.

Mauricio Tucci (mauriciotucci) wrote :

Any news?

Mauricio Tucci (mauriciotucci) wrote :

Look at attached file what happens when I upgrade to 2.4.1-1ubuntu10.3.

Steve Beattie (sbeattie) on 2009-03-23
Changed in xserver-xorg-video-intel:
assignee: nobody → canonical-desktop-team
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: canonical-desktop-team → bryceharrington
Bryce Harrington (bryce) wrote :

Sorry, been focusing on jaunty.

Yes, I identified that patch 104_i830-vbt-timing-hack.patch in Intrepid needs to be replaced with the attached patch, which is what ended up going upstream. Will do the sru for it to intrepid when I next get a chance.

Bryce Harrington (bryce) wrote :
Martin Pitt (pitti) on 2009-03-24
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: bryceharrington → nobody
status: Triaged → Invalid
Changed in xserver-xorg-video-intel (Ubuntu Intrepid):
assignee: nobody → bryceharrington
importance: Undecided → Critical
status: New → In Progress
tags: added: regression-updates
removed: regression-proposed
volkris (volkris) wrote :

Is there a package available for testing the swapped out patch? If there are no immediate plans for the package, shall I try to do the swap based on 10.3 and put my package in my ppa?

Bryce Harrington (bryce) wrote :

Uploaded. pitti will handle the sru part to get it into intrepid officially.

Changed in xserver-xorg-video-intel (Ubuntu Intrepid):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Sean (ubuntu-inet-sys) wrote :

I am running the proposed 10.4 package and it is working fine on my LG LT20 which was reported as not working with 10.3 above

I can also confirm that the proposed packages do not have this problem which I experienced with 10.3 on my Asus laptop with an external monitor setup.

Thanks for the fix.

Martin Pitt (pitti) wrote :

Thanks for testing. Waiving the 7 day maturing period since this was a regression in -updates and thus is quite urgent.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.4.1-1ubuntu10.4

---------------
xserver-xorg-video-intel (2:2.4.1-1ubuntu10.4) intrepid-proposed; urgency=low

  * Update 104_i830-vbt-timing-hack.patch to final version taken upstream.
    Fixes incorrect modeline logic on certain models of monitors after the
    last release, resulting in incorrect resolution detection and/or
    screen corruption.
    (LP: #320893)

 -- Bryce Harrington <email address hidden> Mon, 30 Mar 2009 11:01:52 -0700

Changed in xserver-xorg-video-intel:
status: Fix Committed → Fix Released
Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
Changed in xserver-xorg-video-intel:
importance: Critical → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.