[i865G] 82865G freeze, works only with dri false

Bug #317457 reported by Max on 2009-01-15
58
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Bryce Harrington
Nominated for Jaunty by Max

Bug Description

Binary package hint: xserver-xorg-video-intel

this is a critic bug because don't let install jaunty.
to install i have had to switch to a consolle before gnome is fully loaded.
with
Option "DRI" "False"
X works, but with poor performances (the vesa driver performs better).
in attachment the Xorg.0.log.intel file of a freezed session with DRI enabled

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-video-intel 2:2.5.1-1ubuntu7
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.28-4-generic (buildd@vernadsky) (gcc version 4.3.3 20090111 (prerelease) (Ubuntu 4.3.2-2ubuntu11) ) #10-Ubuntu SMP Mon Jan 12 19:35:29 UTC 2009

SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.28-4-generic i686

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface [8086:2570] (rev 02)
     Subsystem: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface [8086:2570]
00:02.0 VGA compatible controller [0300]: Intel Corporation 82865G Integrated Graphics Controller [8086:2572] (rev 02)
     Subsystem: IBM Device [1014:0285]

Max (maxter) wrote :
Max (maxter) on 2009-01-15
description: updated
Bryce Harrington (bryce) on 2009-01-16
Changed in xserver-xorg-video-intel:
status: New → Confirmed
Bryce Harrington (bryce) on 2009-01-23
description: updated
Bryce Harrington (bryce) wrote :

Hi Max,

Could you try again with current Jaunty with all updates? We've recently upgraded to the 2.6.1 -intel driver, along with new libdrm, mesa, and xserver, any of which may have addressed this issue.

Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
Max (maxter) wrote :

Hi Bryce,

sorry, it seems that the recent upgrades doesn't solved the problem.
let me know if i must post my xorg logs for new versions of the involved software.

Max (maxter) on 2009-01-29
Changed in xserver-xorg-video-intel:
status: Incomplete → Confirmed
Bryce Harrington (bryce) wrote :

Ideally, I'd like a solution better than disabling DRI, since that means there will be no 3D acceleration for 865 chips. However, no 3D is better than freezing.

Here's a patch that forces DRI off for 865 (and 845).

Bryce Harrington (bryce) wrote :

Until a better fix is found, we'll be disabling DRI on this chipset.

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → bryceharrington
importance: Undecided → High
milestone: none → ubuntu-9.04
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.6.3-0ubuntu3

---------------
xserver-xorg-video-intel (2:2.6.3-0ubuntu3) jaunty; urgency=low

  * Add 116_865g_disable_dri.patch:
    - On 865G chipset, X freezes during boot with DRI enabled. Disabling it
      as a workaround until a better fix is found.
      (LP: #317457)
  * Drop explicit dependency on libdrm-intel1, as libdrm now provides
    this properly (libdrm2 commit a87c1a081b77a29fe3430d).

 -- Bryce Harrington <email address hidden> Tue, 31 Mar 2009 18:36:00 -0700

Changed in xserver-xorg-video-intel:
status: Fix Committed → Fix Released
Max (maxter) wrote :

many thanks Bryce...

Matthew Holtz (matthew-holtz) wrote :

Is there anything I can do to help get to a better solution here? I have a i865 and suffer from this problem. While I agree 2D is better than no accelerated 3D, it should work. How can I help?

Well, the problem is that the developers at Intel are no longer giving
much priority attention to 8xx chips, for various reasons. Thankfully,
the code is open, so users aren't completely screwed, but that means
that it's needed for community members to step up and investigate bugs
with these chips.

What that means in practice is that help is needed from owners of these
chips to dig into the source code of the -intel driver and work on
identifying the source of the problem, and to suggest code changes that
you find resolves the issue on your hardware.

On Thu, May 14, 2009 at 03:05:58AM -0000, Matthew Holtz wrote:
> Is there anything I can do to help get to a better solution here? I
> have a i865 and suffer from this problem. While I agree 2D is better
> than no accelerated 3D, it should work. How can I help?
>
> --
> [i865G] 82865G freeze, works only with dri false
> https://bugs.launchpad.net/bugs/317457
> You received this bug notification because you are a bug assignee.
>
> Status in “xserver-xorg-video-intel” source package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: xserver-xorg-video-intel
>
> this is a critic bug because don't let install jaunty.
> to install i have had to switch to a consolle before gnome is fully loaded.
> with
> Option "DRI" "False"
> X works, but with poor performances (the vesa driver performs better).
> in attachment the Xorg.0.log.intel file of a freezed session with DRI enabled
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> Package: xserver-xorg-video-intel 2:2.5.1-1ubuntu7
> ProcEnviron:
> LANG=it_IT.UTF-8
> SHELL=/bin/bash
> ProcVersion: Linux version 2.6.28-4-generic (buildd@vernadsky) (gcc version 4.3.3 20090111 (prerelease) (Ubuntu 4.3.2-2ubuntu11) ) #10-Ubuntu SMP Mon Jan 12 19:35:29 UTC 2009
>
> SourcePackage: xserver-xorg-video-intel
> Uname: Linux 2.6.28-4-generic i686
>
> [lspci]
> 00:00.0 Host bridge [0600]: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface [8086:2570] (rev 02)
> Subsystem: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface [8086:2570]
> 00:02.0 VGA compatible controller [0300]: Intel Corporation 82865G Integrated Graphics Controller [8086:2572] (rev 02)
> Subsystem: IBM Device [1014:0285]

Götz Christ (g-christ) wrote :

I have a 865G chip but I don't suffer this bug. I'm using xserver-xorg-video-intel 2.7 from the xorg-edgers PPA, the rest are the default packages from Jaunty.

00:02.0 VGA compatible controller [0300]: Intel Corporation 82865G Integrated Graphics Controller [8086:2572] (rev 02)
        Subsystem: ASRock Incorporation Device [1849:2572]

Dfg11333 (dfg11333) wrote :

I have also a 865G and upgrading with packages from http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu didn't work. Is that the package you used ? (xorg edgers have lots of repository but this one seemed to be the most advanced one)

I now have a 2.7 intel driver instead of the original Jaunty driver (2.6.?) :
(II) Module intel: vendor="X.Org Foundation"
        compiled for 1.6.0, module version = 2.7.1
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 5.0

but I still have the message :
(**) intel(0): DRI is disabled because it fails to run without freezing on i810 and i865G chips. (See LP 304871)

Here is an extract from my dpkg -l :
xserver-xorg 1:7.4~5ubuntu18
xserver-xorg-video-intel 2:2.7.1-0ubuntu1~xup~1

And like you, I have :
00:02.0 VGA compatible controller [0300]: Intel Corporation 82865G Integrated Graphics Controller [8086:2572] (rev 02)
             Subsystem: Packard Bell B.V. Device [1631:e008]

Dfg11333 (dfg11333) wrote :

Getting the source package, the patch 116_8xx_disable_dri.patch is still present in debian/patches/series.

I removed/rebuilt/installed it and I now have DRI back. It seems to work fine (perhaps because the 2.7 release fixed the bug).

Götz Christ (g-christ) wrote :

@Dfg11333: I was using an old version from xorg-edgers, xserver-xorg-video-intel 2.6.99.x from 4. April, this didn't have this patch.

As you said, removing the patch and rebuilding brings DRI back.

I have uploaded a .deb package based on -intel 2:2.7.1-0ubuntu1~xup~1 from ubuntu-x-swat without this patch to my PPA, so people interested can test this to see if this works for them.

https://launchpad.net/~g-christ/+archive/ppa

fowie (fowdawgg) wrote :

I've had the same issues on four Dell Optiplex SX270 computers. These all use the Intel 865 chipset and ended up using software-only rasterizer for 3D acceleration. I used G. Christ's intel driver provided above and the cards started working. I still get occasional freezing when trying to run XBMC under linux though (haven't really tested a lot of other linux programs since these computers were built as HTPCs)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers