[Kubuntu 9.04 Alpha 2] Slow performance with Kwin desktop effects enabled, xorg or kwin bug?

Bug #314914 reported by Wesley Velroij on 2009-01-08
38
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Acording to the information that Intel provides on their website about the intel D945GCLF2 with atom 330, it should have a Intel® 945GC Express Chipset, and it uses for video the Intel® Graphics Media Accelerator 950, so i dont which driver ubuntu uses for this device, because there no grapical user interface to point the vga driver, KDE4.2 only handles screen resolution, no chaning of drivers for vga.

http://www.intel.com/products/desktop/motherboards/D945gclf2/D945gclf2-overview.htm

But when i look into hardware plasmoid i see this:

CPU: Intel(R) Atom(TM) CPU 330 @ 1.60GHz
GPU: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
Audio: HDA Intel (ALC662 Analog)
Audio: HDA Intel (ALC662 Digital)
Audio: HDA Intel ()
Netwerk: Loopback device Interface
Netwerk: Bridge Interface
Netwerk: Networking Interface

So it seems that Ubuntu sees it as a different device? or am i wrong here? I just hope the performance overall of intel gma would improve, because it seems xorg has serieus performance issius with intel gma''s.

This is the result i get when running glxgears

wesley@Dexter:~$ glxgears
102 frames in 5.0 seconds = 20.380 FPS
138 frames in 5.0 seconds = 27.444 FPS
140 frames in 5.0 seconds = 27.939 FPS
146 frames in 5.0 seconds = 28.985 FPS
154 frames in 5.0 seconds = 30.782 FPS
43 frames in 5.1 seconds = 8.406 FPS
34 frames in 5.0 seconds = 6.782 FPS
35 frames in 5.1 seconds = 6.921 FPS
33 frames in 5.0 seconds = 6.545 FPS
35 frames in 5.1 seconds = 6.834 FPS
35 frames in 5.1 seconds = 6.874 FPS
34 frames in 5.0 seconds = 6.743 FPS
77 frames in 5.0 seconds = 15.251 FPS
138 frames in 5.0 seconds = 27.570 FPS
87 frames in 5.1 seconds = 17.033 FPS
47 frames in 5.0 seconds = 9.387 FPS
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 7977 requests (7766 known processed) with 0 events remaining.
wesley@Dexter:~$

I have enabled kwin desktop effects, and seems overall okay, but i believe that the performance could be better, i think i just dont ask much, but there is probably a serieus bug, and i ask you please go investigate this, there are more bugs like this on, and none is important enough acording to ubuntu to be fixed as fast as possible, i know that 9.04 is unstable but thats just why we should get things have stable in less then 4 month, he intel issues is already there since 8.10, it was reported about slow performance on gma 965, it seems this is on more gma''s from intel and could be a bug in xorg itself. 3d

Wesley Velroij (velroy1) on 2009-01-08
description: updated

Maby intresseting, but i have installed osx 10.5.2 on my intel atom 330 machine and i did get better results then in kubuntu 9.04 alpha 2, so are we using the good drivers? Is the performance stable?

this are the system bechmarks result, seeing that opengl performs pretty well.

Results 55.84
 System Info
  Xbench Version 1.3
  System Version 10.5.2 (9C7010)
  Physical RAM 2048 MB
  Model MacPro3,1
  Drive Type Hitachi HDT721010SLA360 Hitachi HDT721010SLA360
 CPU Test 28.77
  GCD Loop 61.89 3.26 Mops/sec
  Floating Point Basic 18.70 444.34 Mflop/sec
  vecLib FFT 24.25 799.94 Mflop/sec
  Floating Point Library 35.52 6.19 Mops/sec
 Thread Test 102.93
  Computation 87.98 1.78 Mops/sec, 4 threads
  Lock Contention 123.99 5.33 Mlocks/sec, 4 threads
 Memory Test 74.12
  System 66.85
   Allocate 92.44 339.47 Kalloc/sec
   Fill 85.74 4168.88 MB/sec
   Copy 44.65 922.19 MB/sec
  Stream 83.18
   Copy 80.78 1668.50 MB/sec
   Scale 80.21 1657.09 MB/sec
   Add 90.54 1928.71 MB/sec
   Triad 81.99 1753.87 MB/sec
 Quartz Graphics Test 66.59
  Line 60.99 4.06 Klines/sec [50% alpha]
  Rectangle 60.43 18.04 Krects/sec [50% alpha]
  Circle 52.83 4.31 Kcircles/sec [50% alpha]
  Bezier 60.49 1.53 Kbeziers/sec [50% alpha]
  Text 149.78 9.37 Kchars/sec
 OpenGL Graphics Test 89.26
  Spinning Squares 89.26 113.23 frames/sec
 User Interface Test 36.04
  Elements 36.04 165.43 refresh/sec
 Disk Test 74.45
  Sequential 146.75
   Uncached Write 165.58 101.66 MB/sec [4K blocks]
   Uncached Write 190.81 107.96 MB/sec [256K blocks]
   Uncached Read 88.49 25.90 MB/sec [4K blocks]
   Uncached Read 213.83 107.47 MB/sec [256K blocks]
  Random 49.88
   Uncached Write 17.72 1.88 MB/sec [4K blocks]
   Uncached Write 142.38 45.58 MB/sec [256K blocks]
   Uncached Read 91.99 0.65 MB/sec [4K blocks]
   Uncached Read 170.54 31.65 MB/sec [256K blocks]

Wesley Velroij (velroy1) on 2009-01-09
Changed in xserver-xorg-video-intel:
status: Incomplete → New
Bryce Harrington (bryce) wrote :

Hi velroy1,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

Please attach the output of `lspci -vvnn` too.

[This is an automated message. If this script has reached you erroneously, please accept our apologies; any reply to this message will be sufficient to prevent it from doing further automated processing.]

Changed in xserver-xorg-video-intel:
status: New → Incomplete
Geir Ove Myhr (gomyhr) on 2009-01-18
description: updated
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-intel:
status: Incomplete → Invalid
nowardev (nowardev) wrote :

Hey i am on

-kubuntu 9.04 alpha 5
PROBLEM
 and i can't run compiz or kwin effects , they work but VERY VERY VERY SLOW
GRAPHIC CARD
intel 945gm
1 gig of ram
dual core.

it seems on live cd is better lol

nowardev (nowardev) wrote :

/var/log/Xorg.0.log

I am also having very slow video/graphics performance using Alpha5 in my HP nc6400 laptop with Intel 945 GM !!

All the times, xorg is running with more than 50% of cpu and I can clearly hear my laptop fan sound !!!

The sluggishness can be clearly seen even when typing in a konsole and it is very slow.

This was not the case with Kubuntu Intrepid with KDE 4.2.

Could you please help me in resolving this before the final release ??

Thanks a lot...

Daniel Wehner (dereine) wrote :

i have the same Problems.

for example if i edit a file with vim the scrolling throught the file is very slow, it updates the screen only every lets say 0.3 secons

what other logfiles do you need.

tandem (baumhaus691) wrote :

I have this problem too (jaunty beta). Worked well with intrepid. I've got an intel Graphic. I will attach my lspci (hope it helps some how).

I have the same problems with intel GM965/GL960 and it seemed to work well in Intrepid. Attached in my lscpci. I have an Lenovo Thinkpad T60.

Gnurou (gnurou) wrote :

After upgrading today (945GM), I noticed desktop effects were working properly, with the expected performance. Has this bug been fixed?

I'm on a 945GM, and after waiting some time- in case my mirror needed to catch up- and running $ sudo dpkg-reconfigure -phigh xserver-xorg, for good measure (which changed nothing), I can happily say I've still got terrible performance with EXA. This along with that UXA/Compiz memory leak is making a pretty desktop an absolute "no" on Jaunty.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers