[i915] [i965] [Jaunty] Text consoles corrupted on GM965

Bug #312677 reported by Matt Zimmerman on 2008-12-31
42
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

Since upgrading from 8.10 to Jaunty, my text consoles now display a corrupted version of the usplash screen state (with green and blue lines near the top, consistently), rather than the expected text login.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-video-intel 2:2.5.1-1ubuntu7
ProcEnviron:
 LC_COLLATE=C
 PATH: custom, user
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
ProcVersion: Linux version 2.6.28-4-generic (buildd@crested) (gcc version 4.3.3 20081217 (prerelease) (Ubuntu 4.3.2-2ubuntu9) ) #5-Ubuntu SMP Fri Dec 26 22:48:55 UTC 2008

SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.28-4-generic x86_64
xkbcomp:

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
     Subsystem: Lenovo Device [17aa:20b3]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c)
     Subsystem: Lenovo Device [17aa:20b5]

Matt Zimmerman (mdz) wrote :

usually a bug in the kernel drm driver..

Timo Aaltonen (tjaalton) wrote :

or rather the cooperation of kernel and userland. Wonder if just updating the X driver would solve it.

unggnu (unggnu) wrote :

Happens with i915 too.

Jouni Mettala (jouni-mettala) wrote :

Similar looking bug 304136 is just fixed. Could you reproduce this with current Jaunty?

Changed in linux:
status: New → Incomplete
Bryce Harrington (bryce) on 2009-01-06
Changed in xserver-xorg-video-intel:
status: New → Confirmed
Jeffrey Baker (jwbaker) wrote :

The previous user set this to confirmed, but as far as I can tell this is fixed in Jaunty. Should this be set to fixed, or can someone still reproduce it?

unggnu (unggnu) wrote :

Still a problem at least with yesterdays repository status.

unggnu (unggnu) wrote :

Changed to main repository and installed all available updates. After a restart the problem still appears with intel driver.

Changed in linux:
status: Incomplete → Confirmed
Sebastian Keller (skeller) wrote :

When trying to fix some MTRR issue (or at least what I think could be an issue) I managed to get the ttys working again, the details can be found in bug 314928.

unggnu (unggnu) wrote :

Isn't there already an upstream bug report? I haven't found one but if so then it is time to move it upstream.

Sebastian Keller (skeller) wrote :

Using the packages from https://launchpad.net/~xorg-edgers/+archive also fixes that issue for me, so probably it has already been fixed upstream.

unggnu (unggnu) wrote :

Maybe it was random but the patch from report Bug #312849 seems to fix this problem too.

Bryce Harrington (bryce) on 2009-01-23
description: updated
Bryce Harrington (bryce) wrote :

Sounds like the issue is fixed for everyone. Matt, is it fixed for you as well? If not, please reopen.

Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released

On Fri, Jan 30, 2009 at 02:14:41AM -0000, Bryce Harrington wrote:
> Sounds like the issue is fixed for everyone. Matt, is it fixed for you
> as well? If not, please reopen.

Yes, it is.

--
 - mdz

Martin Pitt (pitti) on 2009-01-30
Changed in linux:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers