[i830] Closing lid freezes system on Thinkpad X30

Bug #304614 reported by Linuxonlinehelp_de on 2008-12-03
2
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Bryce Harrington

Bug Description

Binary package hint: xserver-xorg-video-intel

Steps to reproduce:
1. Close Lid freezes System
2. Open Firefox makes Graphic Errors on Buttons (grey on grey)
3.

Stack trace:
Binary package hint: xserver-xorg-driver intel+i810+gnome-power-manager

System: Thinkpad X30 intel Graphics 82830 shared videoram

Affected OS: Ubuntu 8.04, 8.10 + Debian-Testing-Lenny

Error: Close Lid freezes System, after some time the Firefox-Browser and
Systray buttons are shown as bad Graphic (Grey on grey) unreadable.

Tested:
xserver-xorg-driver-intel + xserver-xorg-driver-i810 at xorg.conf = no help
Videoram to 32768 setting at xorg.conf = no help

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82830 830 Chipset Host Bridge [8086:3575] (rev 04)
     Subsystem: IBM ThinkPad A/T/X Series [1014:021d]
00:02.0 VGA compatible controller [0300]: Intel Corporation 82830 CGC [Chipset Graphics Controller] [8086:3577] (rev 04) (prog-if 00 [VGA controller])
     Subsystem: IBM ThinkPad A/T/X Series [1014:0513]

Thank you for reporting this bug. Could you also include attach the following:
- /var/log/Xorg.0.log
- /var/log/Xorg.0.log.old
- /etc/X11/xorg.conf
- output of `lspci -vvnn`

Changed in xserver-xorg-video-intel:
status: New → Incomplete
Linuxonlinehelp_de (linuxhelp) wrote :
Linuxonlinehelp_de (linuxhelp) wrote :
Linuxonlinehelp_de (linuxhelp) wrote :
Linuxonlinehelp_de (linuxhelp) wrote :

i test a modified xorg.conf

with parameters i found on a other forum
it seems to help against the graphic errors "grey buttons"
i don't know what the switches force to the driver.

It was posted as solution against "poor graphics"

Section "Device"
Identifier "Intel Corporation 82830 CGC [Chipset Graphics Controller]"
Driver "i810"
BusID "PCI:0:2:0"
Option "AccelMethod" "EXA"
Option "MigrationHeuristic" "greedy"
Videoram 32768
EndSection

Geir Ove Myhr (gomyhr) on 2008-12-04
Changed in xserver-xorg-video-intel:
status: Incomplete → New
Bryce Harrington (bryce) on 2008-12-05
Changed in xserver-xorg-video-intel:
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Please see if forcing pipe-a makes the lid close issue go away. See https://wiki.ubuntu.com/X/Quirks for directions on what to do.

Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
Linuxonlinehelp_de (linuxhelp) wrote :

Seems Solved, running this setting now

Section "Device"
Identifier "Intel Corporation 82830 CGC [Chipset Graphics Controller]"
Driver "i810"
BusID "PCI:0:2:0"
Option "ForceEnablePipeA" "true"
Option "AccelMethod" "EXA"
Option "MigrationHeuristic" "greedy"
Videoram 32768
EndSection

is that right? (i am not a kernel specialist)

Geir Ove Myhr (gomyhr) wrote :

That seems right. Most of your xorg.conf settings are not necessary, though, as they are autodetected or the default choice anyway. Your Xorg.0.log seems to be from Debian and not Ubuntu, though, and I don't know the details there. On Ubuntu,
Section "Device"
Identifier "Intel Corporation 82830 CGC [Chipset Graphics Controller]"
Option "ForceEnablePipeA" "true"
EndSection
should be enough.

The information from your lspci.txt should be sufficient to fix this (but to be sure, you can upload Xorg.0.log Xorg.0.log.old and output of `lspci -vvnn` from after a crash on your Ubuntu system.

Changed in xserver-xorg-video-intel:
status: Incomplete → Confirmed
Linuxonlinehelp_de (linuxhelp) wrote :

Hello@ALL

thanks for help

the xorg.conf was at first of debian lenny and later copied to Ubuntu too.

Cause i got bad graphics (grey Firefox or PCMAN-buttons at LXDE-Openbox use)
without the use of:
Option "AccelMethod" "EXA"
Option "MigrationHeuristic" "greedy"
Videoram 32768

could i be that the system shared ram is not allocated correctly by default?
at boot the allocation is shown like ~ 8081kb
(can't give you the exactly kb-value cause i have not the screenshot)
the pipe was helping againts freeze state with the
gnome-power-manager and Screensaver-Action-Lid-Close

now i am very happy..

Bryce Harrington (bryce) on 2009-01-14
description: updated
Bryce Harrington (bryce) wrote :

Thanks, queued up patch for upload.

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → bryceharrington
importance: Undecided → High
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.6.3-0ubuntu4

---------------
xserver-xorg-video-intel (2:2.6.3-0ubuntu4) jaunty; urgency=low

  * Add 117_quirk_thinkpad_x30.patch:
    - Pipe-A quirk to fix lid close freeze on Thinkpad X30
      (LP: #304614)
  * Add 118_drop_legacy3d.patch:
    - Remove Legacy3D as a user-configurable option and force fallback to
      legacy fixed textures when GEM is not being used. Fixes "couldn't
      bind memory for BO backbuffer" issue on at least i855 chipsets.
      (LP: #322646)

 -- Bryce Harrington <email address hidden> Wed, 01 Apr 2009 00:25:55 -0700

Changed in xserver-xorg-video-intel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers