Ubuntu

[i915] No 3D graphics support with Intel 915GM/GMS/910GML

Reported by Phil Bull on 2008-11-25
2
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

I can't run applications requiring 3D graphics on Ubuntu Intrepid. These applications (such as compiz, AssaultCube) worked fine on previous versions of Ubuntu. For example, when I try to enable Compiz I get the error message "Desktop effects could not be enabled".

GLX does not seem to be enabled for my graphics card:

$ glxinfo | grep display
Xlib: extension "GLX" missing on display ":0.0".

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)

Phil Bull (philbull) wrote :
Bryce Harrington (bryce) wrote :

[This is an automated message]

Hi philbull,

Please attach the output of `lspci -vvnn` too.

Changed in xserver-xorg-video-intel:
status: New → Incomplete
Bryce Harrington (bryce) wrote :

[This is an automatic notice.]

We'd like to forward your bug upstream, however upstream requires
that you first test it against their newer driver code.

To save you the effort of building the driver from source, we've built
packages for the driver and its new dependencies.

So you have a couple options:

 1. Download and test .debs for intrepid, from:
     https://edge.launchpad.net/~intel-gfx-testing/+archive

 -or-

 2. Download and test the Jaunty alpha-2 (or newer) Live CD,
     (which includes a beta of the new xserver 1.6 as well).
     See http://cdimage.ubuntu.com/releases/9.04/ for ISOs

Thanks ahead of time! You can simply reply to this email to report your
findings.

P.S., if you wish to forward your bug upstream yourself, please follow
these directions to do so:
  http://intellinuxgraphics.org/how_to_report_bug.html

Bryce Harrington (bryce) on 2008-12-20
Changed in xserver-xorg-video-intel:
status: Incomplete → New
status: New → Incomplete
Phil Bull (philbull) wrote :
Phil Bull (philbull) wrote :

Hi Bryce,

I've downloaded and installed the test .debs. However, they don't seem to have made any difference, I still can't enable desktop effects. I still get these GLX error messages:

$ glxinfo | grep display
Error: couldn't find RGB GLX visual or fbconfig
Xlib: extension "GLX" missing on display ":0.0".

Bryce Harrington (bryce) wrote :

Thanks for testing; this should go upstream. Setting to Triaged for now.

Oh, it might also be worthwhile to test against the Jaunty Alpha-2 cd, just in case there was a fix for this in mesa or the xserver. Would you mind burning a cd and testing it in a LiveCD environment?

Changed in xserver-xorg-video-intel:
status: Incomplete → Triaged
Timo Aaltonen (tjaalton) wrote :

"(EE) intel(0): [dri] I830CheckDRIAvailable failed: glx not loaded"

do you have libgl1-mesa-dri installed? Or some nvidia crap?

"(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)"

Changed in xserver-xorg-video-intel:
status: Triaged → Incomplete
Phil Bull (philbull) wrote :

Hi Timo,

Yes, I have libgl1-mesa-dri installed, along with about 8 nvidia-* packages. Could they be interfering with the Intel driver?

Timo Aaltonen (tjaalton) wrote :

Yes, since they divert the GL libraries, for instance. Purge them, they probably were pulled in when there was a bug in one nvidia package dependancies (or similar, can't remember).

Changed in xserver-xorg-video-intel:
status: Incomplete → Invalid
Phil Bull (philbull) wrote :

Yep, that worked. I can now start GL programs, compiz etc. Thanks Timo!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers