Need Pipe-A quirk for 855 and earlier chipsets (like 1014:0513)

Bug #288859 reported by Iain B on 2008-10-24
6
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Medium
Bryce Harrington
Hardy
High
Unassigned
Intrepid
Medium
Bryce Harrington

Bug Description

[Impact]
Laptops with 855 and earlier chipsets hang when the lid is closed.

[Addressed]
In Hardy we have been fixing these bugs on a case-by-case basis.
Upstream analyzed the situation and found all 855 and earlier chipsets need the Pipe-A quirk,
so they introduced a quirk upstream to solve it for all 855 and earlier cards.
We have been carrying this fix in Intrepid since Intrepid opened.

[Patch]
2-line change (attached below)

[Reproduction]
1. On any 855 or earlier laptop that has not already been patched,
2. Close lid
3. Hangs Xorg
See bug #138256 for a detailed discussion about the issue.

[Regression Potential]
In general we've found quirks to be highly stable and safe for backport.
This one is somewhat more aggressive than usual since it covers a large class of hardware.
The hardware it covers is quite old (and in fact no longer supported upstream anyway, really), so worst case is it may cause some regression in hardware we don't really support that well anyway.
However, due to the extensive analysis upstream and testing over the last 6 months, the chance of regressions are acceptably low.

This patch was first made available in July, around the time of Hardy's release. I've held off backporting it in order to accumulate a sufficient amount of testing. With Intrepid now released and no serious issues discovered due to this change so far, I feel comfortable backporting it for hardy.

[Original Report]
Binary package hint: xserver-xorg-video-intel

laptop model: IBM X30
adding "ForceEnablePipeA" to Xorg.conf solved the problem

problem related to bug# 138256

lspci -vvnn | grep -A1 "VGA compat"
00:02.0 VGA compatible controller [0300]: Intel Corporation 82830 CGC [Chipset Graphics Controller] [8086:3577] (rev 04)
 Subsystem: IBM Device [1014:0513]

Iain B (iain-bullard) on 2008-10-24
description: updated
Bryce Harrington (bryce) on 2008-10-24
Changed in xserver-xorg-video-intel:
assignee: nobody → bryceharrington
importance: Undecided → Medium
status: New → Triaged
Bryce Harrington (bryce) wrote :

For Intrepid, we're carrying the pipea quirk for all 855 and before chipsets, so this *should* be fixed for Intrepid. If not, please comment here, since that'd be highly unusual.

For Hardy, we can still backport the quirk fix.

Changed in xserver-xorg-video-intel:
status: Triaged → Fix Released
Bryce Harrington (bryce) on 2008-11-04
description: updated
Bryce Harrington (bryce) wrote :
Changed in xserver-xorg-video-intel:
importance: Undecided → High
status: New → Fix Committed
Bryce Harrington (bryce) wrote :

[Fix is already present in Intrepid/Jaunty]

Changed in xserver-xorg-video-intel:
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Seva Gluschenko (gvs-ya) wrote :

well, one fact which seems to be completely disappointing is that the issue discussed long ago here

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/32963

wasn't fixed yet, so I'm forced to sit back on xserver-xorg-video-intel_2.2.1-1ubun.deb package taken from there. (Attached.)

Is it really that impossible to merge that patch into the package? The XV_CONTRAST/XV_SATURATION warp is pretty annoying thing.

Philip Wyett (philwyett) wrote :

Any updates available from those affected regards the package with patch in hardy-proposed as it it 49 days in proposed and really should be now pushed to updates if there are no objections.

Regards

Phil

Iain B (iain-bullard) wrote :

Unfortunately I am no-longer running hardy. However, I can confirm that this issue is fixed in Intrepid.

Thanks for all your help.

Iain.

Thomas Fritzsche (tf-noto) wrote :

I wonder my XV Saturation / Contrast could be integrated into the next version of the Ubuntu Intel driver package.
Got several reports this helps. So far I have provided pre-compiled packages beside the source patch (on http://linux.pengin.de/#xvattr ), but I'm now running on Intrepid and I get asked for Hardy packages.

See this discussion:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/32963

Thanks,
Thomas

Colin Watson (cjwatson) wrote :

Phil: the thing we need here is confirmation that the package still works on hardy, and actually fixes the problem. The reason we put changes into -proposed is so that they can be tested; without comments from people who've tried them, whether with good or bad results, we can't assume that they're OK. (Bug 267570 has the same issue, and Martin asked roughly the same thing on 27th December, with no response so far.)

Marc Tardif (cr3) wrote :

This is my graphics device on a ThinkPad X40:

lspci -vvnn | grep -A1 "VGA compat"
00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02) (prog-if 00 [VGA controller])
        Subsystem: IBM Unknown device [1014:0557]

After updating hardy from proposed, closing my lid does not seem to blank the screen and opening my lid does not result in a hung system.

Steve Langasek (vorlon) wrote :

Thanks, marking this bug as verified.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.2.1-1ubuntu13.8

---------------
xserver-xorg-video-intel (2:2.2.1-1ubuntu13.8) hardy-proposed; urgency=low

  * 25_8xx_pipea_quirk.patch: Use Pipe-A quirk for all 855 and earlier
    chips. In Hardy we've been patching 8xx chipsets individually up
    until now, but upstream investigated and found this issue affects all
    of the early 8xx chips. This patch was introduced upstream about 6
    months ago and has been shipping in Intrepid. It safely solves a wide
    range of xorg-hang-on-lid-close issues.
    (LP: #288859, #267570)

 -- Bryce Harrington <email address hidden> Mon, 03 Nov 2008 17:14:46 -0800

Changed in xserver-xorg-video-intel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers