intel gfx: Error in I830WaitLpRing(), timeout for 2 seconds

Bug #285298 reported by LimCore on 2008-10-18
84
This bug affects 8 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
New
Undecided
Unassigned
xserver-xorg-video-intel (Debian)
Fix Released
Unknown
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

Ubuntu 8.10 beta (up to date on 2008-10-16)
Acer extensa5220 (but 1.5 GB ram) single core intell, GM965/GL960 gfx (also called X3100 ?)

1. run serveral windowed OpenGL applications like amoeba (opengl demo) i.e. 5-7 instances with
amoeba -windowed -nosound &

2. with 2nd or 3rd there will be small quircks in some textures
3. around 4-5 there will be large quircks all over
4. soon computer can froze up, i.e. showing random trash all over the screen - attachment photo

Same thing after upgrade to xserver-xorg-video-intel 2:2.4.1-1ubuntu8 (up to date system on 2008-10-18 3:00 GTM+2)

I couldn't find any info in Xorg.log while the problems started (some quircks showing on screen).

/var/log/Xorg.0.log.old that I found after rebooting system, was 151 MB long (and btw caused Apport problems - bug#92653), 24 MB compressed;
Begining of it is attached. I have entire dump if needed (probably not)

There are 2 problems

1) For even 2 instances running in windows, there are small glitches (10x10 pixel random blocks)
p.s. do not confus that with the nice white VERTICAL lines "static" - this is the DESIRED ARTISTIC EFFECT in the demo, not a bug!
See new screenshot for that.

2) For 6+ instances, after ~30 s, there is all-screen static outside of windows of applications affected, and X resets or freezes.

*** INFO ***
Looks a bit like - bug##56501

LimCore (limcore) wrote :
LimCore (limcore) on 2008-10-18
description: updated

This occurs even with just 2 instances of amoeba 3d demo running, but then the distortion is small, (around 20x20 pixel random blocks pop up) and only INSIDE the window of application.

---------

the small distortion (in-window, for 2 instances) is confirmed on debian i386 kernel 2.6.26 by jelly-home @ #debian (thanks)

the big distortion seems to **NOT** occur on debian i386 2.6.26 xserver-xorg-video-intel 2:2.4.2-1 + xserver-xorg 1:7.4~4 + libgl1-mesa-dri 7.1-1

LimCore (limcore) wrote :
description: updated
LimCore (limcore) wrote :

This are the small bugs.

full random pixels in blocks inside
also often green glitches appear on top of the window

I have also seen the same error today.

I wonder if it is related?

Intrepid 8.10
Full updates as of 19th Oct 2008 (yesterday).
xserver-xorg-video-intel 2.4.1-1ubuntu9
Intel Corporation 82G33/G31 Express Integrated Graphics Controller

Machine hanging after X/GDM filled / with log files. Machine doing nothing - left during the day running.

Got back from work, discovered my desktop PC was "frozen" - at least the graphics were dead (garbage on screen). Constant disk I/O. Logged in remotely via SSH - disk activity was kjournald ..turned out my disk was 100% full. Looking - it was all in /var/log and /var/log/gdm/ - 2x 1 GB log files :

/var/log/Xorg.0.log
/var/log/gdm/:0.log

X/GDM dead. I have saved these files and attach the top 500 lines of each.

Stand out :

(WW) intel(0): ESR is 0x00000001, instruction error
(WW) intel(0): PRB0_CTL (0x0001f001) indicates ring buffer enabled
(WW) intel(0): PRB0_HEAD (0x8620bce0) and PRB0_TAIL (0x0000bd20) indicate ring buffer not flushed
(WW) intel(0): Existing errors found in hardware state.
Error in I830WaitLpRing(), timeout for 2 seconds
pgetbl_ctl: 0x00000001 getbl_err: 0x00000000
ipeir: 0x00000000 iphdr: 0x18800080
LP ring tail: 0x0000bd28 head: 0x0000bce0 len: 0x0001f001 start 0x00000000

I also attach the Xorg.0.log.old - it seems fine.

Looking at /var/log/syslog, I see an error at :

Oct 20 15:19:22 persephone gdm[6209]: WARNING: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
Oct 20 15:19:22 persephone kernel: [73886.831809] __ratelimit: 15 callbacks suppressed
Oct 20 15:19:22 persephone kernel: [73886.831816] console-kit-dae[5339]: segfault at 0 ip b7fc0d07 sp bfbec234 error 4 in libglib-2.0.so.0.1800.2[b7f64000+b5000]
Oct 20 15:19:24 persephone kernel: [73888.982131] mtrr: no more MTRRs available
Oct 20 15:19:25 persephone kernel: [73889.704906] [drm:i915_wait_irq] *ERROR* EBUSY -- rec: 17256485 emitted: 17256488

CRON (update-motd) runs for a bit, until it sticks at 16:10:02. Nothing in syslog after.

I attach the syslog as well.

I also attach lspci -vvvnn

LimCore (limcore) on 2008-10-20
Changed in xserver-xorg-video-intel:
status: New → Confirmed
LimCore (limcore) on 2008-10-20
description: updated
Changed in xserver-xorg-video-intel:
status: Unknown → Fix Released
Changed in xserver-xorg-video-intel:
status: Unknown → Fix Released
Changed in xserver-xorg-video-intel:
assignee: nobody → ubuntu-x-swat
importance: Undecided → Medium
status: Confirmed → Triaged
Bryce Harrington (bryce) on 2008-11-29
Changed in xserver-xorg-video-intel:
assignee: ubuntu-x-swat → nobody
David Young (youngde) wrote :

For what it's worth, I'm running Ubuntu 8.10 (fully updated) on a Sony Vaio with this chipset and am having the same server lockups. Let me know if I can provide any information that will help.

For my system, failure seems to occur when I visit certain web pages, but returning to them after restart does not reproduce the problem.

-- david

Just encountered a similar error, running Kubuntu 8.10 on DQ45CB (Intel Q45, X4300 video). I had started a glxgears instance and was tailing the output of Xorg.0.log to try to see if there were any errors when running 3D applications (trying to troubleshoot bad video performance). X locked up hard; I tried rebooting the system with ctrl+alt+del, and it seemed to worked, but after rebooting my monitors received no signal and went into standby and the whole works locked up. In order to get things working again, I had to actually power off and back on. Scary!

Linux zaphod 2.6.27-9-generic #1 SMP Thu Nov 20 22:15:32 UTC 2008 x86_64 GNU/Linux
ii xserver-xorg-video-intel 2:2.4.1-1ubuntu10 X.Org X server -- Intel i8xx, i9xx display d

Xorg.0.log:

Error in I830WaitLpRing(), timeout for 2 seconds
pgetbl_ctl: 0x00000001 pgetbl_err: 0x00100000
ipeir: 0x00000000 iphdr: 0x60020100
LP ring tail: 0x00002158 head: 0 len: 0x0001f001 start 0x00000000
Err ID (eir): 0x00000000
Err Status (esr): 0x00000011
Err Mask (emr): 0xffffff3f
instdone: 0x808fffff instdone_1: 0x9fbd1922
instpm: 0x00000000
memmode: 0x00000000 instps: 0x0001f02e
HW Status mask (hwstam): 0xfffffffe
IRQ enable (ier): 0x00000002 imr: 0xfffe0000 iir: 0x000000f0
acthd: 0x04d9ff98 dma_fadd_p: 0x04da0180
ecoskpd: 0x00000307 excc: 0x00000900
cache_mode: 0x00006820/0x00000180
mi_arb_state: 0x00000040
IA_VERTICES_COUNT_QW 0x00000000/0x00000000
IA_PRIMITIVES_COUNT_QW 0x00000000/0x00000000
VS_INVOCATION_COUNT_QW 0x00000000/0x00000000
GS_INVOCATION_COUNT_QW 0x00000000/0x00000000
GS_PRIMITIVES_COUNT_QW 0x00000000/0x00000000
CL_INVOCATION_COUNT_QW 0x00000000/0x00000000
CL_PRIMITIVES_COUNT_QW 0x00011ae5/0x00000000
PS_INVOCATION_COUNT_QW 0x000000f4/0x00000000
PS_DEPTH_COUNT_QW 0x01b5e6aa/0x00000000
WIZ_CTL 0x00000000
TS_CTL 0x00000000 TS_DEBUG_DATA 0x00000000
TD_CTL 0x00000000 / 0x00000000
Ring at virtual 0x7f1235e3c000 head 0x0 tail 0x2158 count 2134
Ring at virtual 0x7f1235e3c000 head 0x0 tail 0x2158 count 2134
        0001ff00: 00000000 MI_NOOP 1
        0001ff04: 01000000 MI_USER_INTERRUPT 1
        0001ff08: 10800001 MI_STORE_DATA_INDEX 3
        0001ff0c: 00000014
        0001ff10: 00878707
        0001ff14: 00000000 MI_NOOP 1
        0001ff18: 00000000 MI_NOOP 1
        0001ff1c: 01000000 MI_USER_INTERRUPT 1
        0001ff20: 18800180 MI_BATCH_BUFFER_START 2
        0001ff24: 04b8d000
Batch buffer at 0x04b8d000 {
        04b8d000: 00000000 MI_NOOP 1
        04b8d004: 00000000 MI_NOOP 1
        04b8d008: ffffffff Reserved
[... apparently Xorg tried to dump all of the video memory here, the log is hundreds of megabytes; truncated for obvious reasons]

Bryce Harrington (bryce) wrote :

[This is an automatic notice.]

We'd like to forward your bug upstream, however upstream requires
that you first test it against their newer driver code.

To save you the effort of building the driver from source, we've built
packages for the driver and its new dependencies.

So you have a couple options:

 1. Download and test .debs for intrepid, from:
     https://edge.launchpad.net/~intel-gfx-testing/+archive

 -or-

 2. Download and test the Jaunty alpha-2 (or newer) Live CD,
     (which includes a beta of the new xserver 1.6 as well).
     See http://cdimage.ubuntu.com/releases/9.04/ for ISOs

Thanks ahead of time! You can simply reply to this email to report your
findings.

P.S., if you wish to forward your bug upstream yourself, please follow
these directions to do so:
  http://intellinuxgraphics.org/how_to_report_bug.html

Changed in xserver-xorg-video-intel:
status: Triaged → Incomplete

I have done number 1 (installed and tested the debs from the link you have provided). The output is attached. I've had the same messages in Xorg log file and syslog file before. Now I do not get the
[drm:i915_wait_irq] *ERROR* EBUSY

lines in syslog, only the Xorg log file says:
[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Is that enough, or should I try or attach something else here?

Bryce Harrington (bryce) on 2009-01-28
Changed in xserver-xorg-video-intel:
status: Incomplete → Confirmed
importance: Unknown → Undecided
status: Fix Released → New
Bryce Harrington (bryce) wrote :

It may be enough. It would be helpful if you could test jaunty (with all current updates) just in case there was a fix in the newer xserver. But I think we can upstream it at this point.

Changed in xserver-xorg-video-intel:
status: Confirmed → Triaged

I can't test it on jaunty, at least not at the moment. But the xserver is in the same version as in jaunty so that should not matter.

ls (schildm) wrote :

My IBM x60 is affected too. Have this Notebook for a few weeks now, but today ist was the first time this happend.

My laptop froze thrice in the last month because of this issue, but I am unable to reproduce it.
It is HP/Compaq nc6400 with Intel 945G.

Linux knownwest-lx 2.6.27-13-generic #1 SMP Thu Feb 26 07:26:43 UTC 2009 i686 GNU/Linux

Bryce Harrington (bryce) wrote :

I'm closing this bug because we've still not heard back from the original reporter on the information request.

For everyone else, "I830WaitLpRing(), timeout" is a generic error message that's printed out for a variety of different cases. So without knowing more from the original reporter, it's impossible to determine for certain if you all have the same bug or different ones. In any case, upstream has a "one person per bug report" policy so we'll need to have you report NEW bugs for your issues. See http://wiki.ubuntu.com/X/Reporting for directions on reporting X bugs.

Changed in xserver-xorg-video-intel:
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.