[i915] [intrepid ] screen flickers while loading X, running xrandr or playing a video (i915)

Bug #278146 reported by unggnu on 2008-10-04
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Medium
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

After gdm login, running xrandr or opening a video screen flickers heavily. Mostly black lines are shown in the center on boot or after running xrandr and mirrored artifacts of the screen if a video is loaded. After resolution change the whole screen flickers for several seconds.
Opengl apps like glxgears doesn't seem to be affected.
It happens for all Intrepid versions I have tested so far and of course the current one. Hardy and older revisions doesn't have this problem.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
Package: xorg 1:7.4~2ubuntu5
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.27-4-generic (buildd@rothera) (gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu7) ) #1 SMP Wed Sep 24 01:30:51 UTC 2008

SourcePackage: xorg
Uname: Linux 2.6.27-4-generic i686
xkbcomp:

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller [8086:2590] (rev 03)
     Subsystem: Sony Corporation Device [104d:81e2]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 03)
     Subsystem: Sony Corporation Device [104d:81e2]

unggnu (unggnu) wrote :
unggnu (unggnu) wrote :
unggnu (unggnu) on 2008-10-04
description: updated
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
unggnu (unggnu) on 2008-10-08
Changed in xserver-xorg-video-intel:
status: Confirmed → Unknown
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed

I have the same issue with the same hardware. I get horizontal black lines flashing on the screen at login, and the screen appears to "twitch" (portions of the screen seem to be randomly flashed, appearing in different locations) whenever I run xrandr or start any programs, like games, that change the resolution.

This never happened with any versions of Ubuntu before Intrepid.

Bryce Harrington (bryce) on 2008-11-14
Changed in xserver-xorg-video-intel:
status: New → Confirmed
daspooky (daspooky) wrote :

I confirm this. I have the same problem on Intrepid, with the same hardware. Hardy doens't have the problem.

Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
Bryce Harrington (bryce) wrote :

[This is an automatic notice.]

We'd like to forward your bug upstream, however upstream requires
that you first test it against their newer driver code.

To save you the effort of building the driver from source, we've built
packages for the driver and its new dependencies.

So you have a couple options:

 1. Download and test .debs for intrepid, from:
     https://edge.launchpad.net/~intel-gfx-testing/+archive

 -or-

 2. Download and test the Jaunty alpha-2 (or newer) Live CD,
     (which includes a beta of the new xserver 1.6 as well).
     See http://cdimage.ubuntu.com/releases/9.04/ for ISOs

Thanks ahead of time! You can simply reply to this email to report your
findings.

P.S., if you wish to forward your bug upstream yourself, please follow
these directions to do so:
  http://intellinuxgraphics.org/how_to_report_bug.html

Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
unggnu (unggnu) wrote :

This problem still exists in Jaunty after login but then the whole X server dies and GDM restarts so I can't test it with XV but this i s a different problem.

Changed in xserver-xorg-video-intel:
status: Incomplete → Confirmed
Bryce Harrington (bryce) wrote :

Is it exactly the same symptoms, or has it changed? The upstream bug says that if it occurs only with Xv, we should report a new bug; otherwise we should reopen the upstream bug with additional details. Can you do some additional testing as best you can, to determine what route we should take?

Also, have you reported the xserver dying issue? Which bug#?

Changed in xserver-xorg-video-intel:
importance: Undecided → Medium
status: Confirmed → Triaged
unggnu (unggnu) wrote :

Same symptoms at least on gdm login. I couldn't test it further because shortly after the flickering X dies and GDM restarts. Even if I try to change to console with ctrl + alt + f1 I only see vertical colored and black bars and can't do anything except of changing back to the X slot. I have tested it with todays daily live cd.
That's why I haven't posted more information. The intel driver was one of the best X drivers but it gets worse and worse with every release. First problem was the textured video which doesn't work really because of tearing, then the flickering and now the dying. Last ones seem to be an i915 problem but video watching is annoying in Intrepid even with other Intel graphic cards and according to manpage it isn't possible to activate Overlay without changing the source. Not to mention the great performance loss.
And btw. the greatest part is to just closing the upstream bug report without fixing anything.
I will post more debug information soon but it is really annoying and time consuming. It is fine if it leads to a better driver but atm. it doesn't seem so.

unggnu (unggnu) wrote :

Ok, I have reported the (maybe on of the) crash(es) at Bug #312849 . There was one with and one without compiz so maybe another one will follow.

unggnu (unggnu) wrote :

The garbage after changing to console with ctrl + alt + f* seems to be general Jaunty Intel driver problem and is reported under Bug #312851.

Bryce Harrington (bryce) wrote :

Thanks, I've reopened the bug. Please add your findings upstream.
https://bugs.freedesktop.org/show_bug.cgi?id=17405

Bryce Harrington (bryce) on 2009-01-14
description: updated
Changed in xserver-xorg-video-intel:
status: Fix Released → Confirmed
unggnu (unggnu) wrote :

Can anyone confirm this workaround?

1. add this line to your xorg.conf device section.
Option "Monitor-TV" "TV"
2. add a monitor section
Section "Monitor"
        Identifier "TV"
        option "ignore" "true"
EndSection

Aurimas (aurimas-racas) wrote :

unggnu, yes I can confirm that the workaround works for me (Intrepid, 915i series Intel video card). Not only it removes the flickering while using xrandr/videos, but also the constant flickering on KDE (a related bug, afaik).

unggnu (unggnu) wrote :

Yes, the "KDE bug" is related. A KDE service polls xrandr every x seconds which results in the flickering on effected machines.

Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
Jeffrey Knockel (jeff250) wrote :

unggnu, I can also confirm your workaround. With intrepid, I had been using the outdated version 2.3.2 of the intel xorg drivers to get around this issue. However, now that I've upgraded to jaunty and am now using the latest jaunty version, I can confirm that your workaround works with the latest intel drivers.

Bryce Harrington (bryce) on 2009-05-06
tags: added: flicker
Bryce Harrington (bryce) wrote :

From the upstream bug report, this was fixed upstream Mar 16, and the fix is available as of 2.6.99.903.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Released
unggnu (unggnu) wrote :

This isn't fixed until kms is enabled. But since it is planned for Karmic this could be still marked as fixed release.

Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
Changed in xserver-xorg-video-intel:
importance: Medium → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.