[GM45] 3D much slower in Intrepid than in Hardy

Bug #277827 reported by ThyMythos on 2008-10-03
56
This bug affects 9 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

glxgears shows about 1300 fps in Hardy but only about 300 in Intrepid.
Also window effects are smoother in Hardy. Texture compression makes no difference. Same effect also with x64 versions.

Kernel for Intrepid is 2.6.27-4-generic.

Attached are the Xorg logs for Hardy and Intrepid.

ThyMythos (thymythos) wrote :
ThyMythos (thymythos) wrote :
Jonas Pedersen (jonasped) wrote :

I can confirm the exact same behavior on my new Lenovo T500 laptop (GM45 Express with Intel GMA 4500MHD). Normally I have the latest updates Intrepid beta installed and I get this very low performance in glxgears. Tried to install Hardy on another partition and I get the higher FPS.

Further to above I can not get KDE4 desktop effects to work in Intrepid. I installed KDE 4.1.2 on Hardy and desktop effects worked as expected. I am not sure, but I suspect that these two issues are related.

I have attached xorg.conf and x.org log file from both Intrepid and hardy.

Jonas Pedersen (jonasped) wrote :
Jonas Pedersen (jonasped) wrote :
Jonas Pedersen (jonasped) wrote :

I can confirm problems with Intrepid here (Dell Latitude D830 with GMA 965). Frame rates in glxgears are rather low (around 600 fps) and video overlay doesn't seem to work:

* googleearth isn't displaying anything correctly (worked in Hardy),
* celestia paints over its own menus
* As soon as I move a window over a running glxgears, I get display errors.

Marc

Irios (irios) wrote :

Same in an eee PC 901, with an Intel 945 chipset.

glxgears gives only around 50 fps in the tiny window and around 10 fps maximized. No wonder, because it reports that it is doing software rendering:

GL_RENDERER = Software Rasterizer
GL_VERSION = 2.1 Mesa 7.2

Compiz does not work, and the UME launcher takes several seconds to switch between its tabs.

I would say there is no 2D acceleration either, because windows move around with a bit of tearing, and scrolling is pretty rough.

I have checked the Xorg.log to see if there had been some problem loading the intel driver and I was in fact running VESA, but it is indeed the intel driver that has loaded, and there were no alarming messages.

This is not the place to bicker, but it seems to me that Intrepid has been released a bit prematurely.

Irios (irios) wrote :

Oh, and the OpenGL gnome screensavers do work, but update at around 1 fps

tapczan (tapczan) wrote :

In Hardy:
$ glxgears
5530 frames in 5.0 seconds = 1105.941 FPS
5740 frames in 5.0 seconds = 1147.867 FPS
5671 frames in 5.0 seconds = 1134.048 FPS

Intrepid:
$ glxgears
2842 frames in 5.0 seconds = 568.360 FPS
2796 frames in 5.0 seconds = 559.099 FPS
2874 frames in 5.0 seconds = 574.798 FPS

# lspci -vv
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
 Subsystem: Acer Incorporated [ALI] Device 011f
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 16
 Region 0: Memory at fc000000 (64-bit, non-prefetchable) [size=1M]
 Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256M]
 Region 4: I/O ports at 1800 [size=8]
 Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
  Address: 00000000 Data: 0000
 Capabilities: [d0] Power Management version 3
  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
  Bridge: PM- B3+
 Kernel modules: intelfb

# dpkg -l xserver-xorg-video-intel|grep ^ii|awk {'print $2" "$3'}
xserver-xorg-video-intel 2:2.4.1-1ubuntu10

archdrone (archdrone) wrote :

I had the same problem in Intrepid, then upgraded to Jaunty a things got even worse for a while but now the 3D performance is on the level as in Hardy (after I decided to use 2.6.28 which has GEM support instead of 2.6.27 kernel and chmod 666 /dev/dri/card0)

Greya (grreya) wrote :

I can also confirm problems with 3D at Intel GM45 (kernel 2.6.27-9, sony vaio cs190, intrepid) - it's not working at playing some simple 3D games, for example, or the majority of 3D screensavers
~$ glxgears:
2994 frames in 5.0 seconds = 598.697 FPS
3428 frames in 5.0 seconds = 685.464 FPS
3402 frames in 5.0 seconds = 680.383 FPS...
Hope it can get fixed in future upgrades and Jaunty!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers