[i945G] wrong LCD resolution detected - 1400x1050 fuzzy match

Bug #260341 reported by Oibaf on 2008-08-22
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

I have tried the intrepid alpha 4 live CD on a system with an "Intel 945G chipset" and an "I-See S 171" 17 inch LCD monitor. The system fails at detecting the right resolution (1280x1024), and use a higher resolution:
(II) intel(0): Output VGA using initial mode 1400x1050
The intel driver in intrepid alpha 4 is xserver-xorg-video-intel 2:2.4.0-1ubuntu1 .

I have also tried the Ubuntu 8.04.1 LiveCD, in this case the resolution detected is fine:
(II) intel(0): Output VGA using initial mode 1280x1024

I'll attach the Xorg log obtained with the intrepid alpha 4 and 8.04.1 LiveCDs.

Oibaf (oibaf) wrote :

This is the diff of the two log on what I thik is the problematic part:
@@ -395,74 +212,57 @@ Markers: (--) probed, (**) from config f
 (II) intel(0): Modeline "1024x768"x0.0 65.00 1024 1048 1184 1344 768 771 777 806 -hsync -vsync (48.4 kHz)
 (II) intel(0): Modeline "800x600"x0.0 49.50 800 816 896 1056 600 601 604 625 +hsync +vsync (46.9 kHz)
 (II) intel(0): Modeline "800x600"x0.0 50.00 800 856 976 1040 600 637 643 666 +hsync +vsync (48.1 kHz)
-(II) intel(0): Modeline "1280x1024"x59.9 109.00 1280 1368 1496 1712 1024 1027 1034 1063 -hsync +vsync (63.7 kHz)
-(II) intel(0): Modeline "1280x1024"x74.9 138.75 1280 1368 1504 1728 1024 1027 1034 1072 -hsync +vsync (80.3 kHz)
+(II) intel(0): Modeline "1280x1024"x60.0 108.88 1280 1360 1496 1712 1024 1025 1028 1060 -hsync +vsync (63.6 kHz)
+(II) intel(0): Modeline "1280x1024"x75.0 138.54 1280 1368 1504 1728 1024 1025 1028 1069 -hsync +vsync (80.2 kHz)
 (II) intel(0): EDID vendor "KTC", prod id 6000
 (II) intel(0): Output VGA connected
-(II) intel(0): Output VGA using initial mode 1280x1024
+(II) intel(0): Using fuzzy aspect match for initial modes
+(II) intel(0): Output VGA using initial mode 1400x1050
 (II) intel(0): detected 256 kB GTT.
 (II) intel(0): detected 7932 kB stolen memory.
 (==) intel(0): video overlay key set to 0x101fe

Andreas Moog (ampelbein) on 2008-08-26
Changed in xserver-xorg-video-intel:
status: New → Confirmed

Same problem with the new version 2.4.1-1ubuntu1 .

Adding

Modeline "1440x900" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync

To the monitor section of /etc/X11/xorg.conf

fixed it for me!

(This was after finding the binary drivers here: http://ncc-1701a.homelinux.net/WikiBerd/index.php?page=LinuxSis67x)

Thats for my LCD; Turns out the SIS driver doesnt use the GTF timing formula to calculate it's timings. (Theres a "hacked" intel driver which is basically the same SIS driver, apparently)

gtf 1440 900 60

gave my modeline, you could try

gtf 1280 1024 60

or something similar to find a suitable modeline for your monitor... or maybe even a different timing formula.

This bug was reported in the Intrepid development cycle; removing regression-potential and marking as regression-release.

Bryce Harrington (bryce) wrote :

[This is an automatic notice.]

We'd like to forward your bug upstream, however upstream requires
that you first test it against their newer driver code.

To save you the effort of building the driver from source, we've built
packages for the driver and its new dependencies.

So you have a couple options:

 1. Download and test .debs for intrepid, from:
     https://edge.launchpad.net/~intel-gfx-testing/+archive

 -or-

 2. Download and test the Jaunty alpha-2 (or newer) Live CD,
     (which includes a beta of the new xserver 1.6 as well).
     See http://cdimage.ubuntu.com/releases/9.04/ for ISOs

Thanks ahead of time! You can simply reply to this email to report your
findings.

P.S., if you wish to forward your bug upstream yourself, please follow
these directions to do so:
  http://intellinuxgraphics.org/how_to_report_bug.html

Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
slush (slush) wrote :

> 1. Download and test .debs for intrepid, from:
> https://edge.launchpad.net/~intel-gfx-testing/+archive

I tried this option, made dist-upgrade and restart X server, but unfortunately no change. I have still bad resolution on my external LCD monitor.

Bryce Harrington (bryce) wrote :

Thanks for testing

Changed in xserver-xorg-video-intel:
importance: Undecided → Medium
status: Incomplete → Triaged
Oibaf (oibaf) wrote :

Works fine with current jaunty LiveCD. Note that maybe the fix was in xserver 1.6 and not in the intel driver, since I had the same problem with the same monitor also with a radeon card.

Changed in xserver-xorg-video-intel:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers