Comment 27 for bug 252094

I have an Inspiron 1525 notebook with GM965/GL960 Integrated Graphics Controller. In Hardy it worked flawlessly. I upgraded to Intrepid after it was released and I have my Ubuntu fully updated. Still, I have this problem. If I run glxgears and move the window it leaves garbage on the screen (seems like glxgears renders on top of compiz, which I have enabled). Also OpenGL screensavers doesn't seem to work either, sometimes they start, but something is wrong with them. I did not experienced a total X lock-up until now. Also OpenArena's screen is corrupted and the menu is invisible. Besides this normal desktop operations work OK, and all compiz effects are also OK. I have experienced a total system lock-up during a fullscreen video playback after about one hour of watching, only a hard switch-off/switch-on worked. I emphasize that this does not happened on Hardy. Maybe something in the new intel driver features causes the problem, like the acceleration architecture, not sure, though. In glxgears I get only around 500 fps. I used to get above 1000 fps.

@Marc Nieper-Wißkirchen: Google Earth is unusable, the screen gets all messed up, and the textures on the globe's surface doesn't show up, either.

If you need any other info, please let me know.