Ubuntu

[i965] Java plugin causes massive Xorg CPU usage, fixed with XAA (UXA/EXA)

Reported by Tom Chiverton on 2008-06-09
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: firefox-3.0

See #38131 - Java plugins (stable and the .10 beta) cause massive CPU spike and hang of FireFox UI.
This goes away when changing from the default 'EXA' to 'XAA' 'AccelMethod' in Xorg.conf

ProblemType: Bug
Architecture: i386
Date: Mon Jun 9 18:56:50 2008
DistroRelease: Ubuntu 8.04
Package: firefox-3.0 3.0~rc1+nobinonly-0ubuntu1~fta2~hardy
PackageArchitecture: i386
ProcEnviron:
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.24-17-generic i686
UnreportableReason: This is not a genuine Ubuntu package

Michael Rooney (mrooney) wrote :

Hi Tom, thanks for using and Ubuntu and for contributing by filing this bug report. However, it looks like you may be using an unsupported package. I see you are using Firefox 3 RC1 but it doesn't appear to be from the -updates or -proposed sections. If this is the case the bug is Invalid, and must be duplicated on an official Firefox package within Ubuntu. RC1 has been in -proposed for awhile and was just pushed to -updates a few hours ago, so if you install the official package and duplicate this you or I can re-open the bug. Thanks!

Changed in firefox-3.0:
status: New → Invalid

On Mon, Jun 09, 2008 at 05:59:45PM -0000, Tom Chiverton wrote:
> Public bug reported:
>
> Binary package hint: firefox-3.0
>
> See #38131 - Java plugins (stable and the .10 beta) cause massive CPU spike and hang of FireFox UI.
> This goes away when changing from the default 'EXA' to 'XAA' 'AccelMethod' in Xorg.conf

Which xorg driver are you using?

 status incomplete
 tag likely-dup

 - Alexander

Changed in firefox-3.0:
status: Invalid → Incomplete

@Mike: Still happens in the offical RC1 from -updates, sorry for confusion. If you let me know how to find the files the menu item auto-uploaded, I can attach them again if req.

@Alexander:
/var/log/Xorg.0.log
(II) LoadModule: "intel"
(II) Loading /usr/lib/xorg/modules/drivers//intel_drv.so
(II) Module intel: vendor="X.Org Foundation"
        compiled for 1.4.0.90, module version = 2.2.1
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 2.0

falken@wopr:~$ dpkg-query -l '*video*intel*'
...
ii xserver-xorg-video-intel 2:2.2.1-1ubuntu13 X.Org X server -- Intel i8xx, i9xx display driver
un xserver-xorg-video-intel-modes <none> (no description available)

Alexander Sack (asac) wrote :

EXA has issue, XAA not: most likely a driver issue. Reassigning.

Changed in firefox-3.0:
status: Incomplete → New

Not fixed by todays new kernel/modules and Firefox 3.0 release.

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
20125 falken 20 0 185m 67m 20m R 99 3.4 1:54.50 firefox
 5275 root 20 0 431m 93m 4880 R 55 4.6 12:04.41 Xorg
20187 falken 20 0 221m 33m 13m S 43 1.6 1:04.21 java_vm

unggnu (unggnu) wrote :

Could you please attach the file /var/log/Xorg.0.log with a standard xorg.conf and Exa activated? Maybe another one with your Xaa configuration too.
Are there any sites on which this always happen so we can reproduce it?

Changed in xserver-xorg-video-intel:
status: New → Incomplete

http://www.formula1.com/services/live_timing/live_timing_popup.html always triggers it - you'll need BugMeNot or enter a fake address to register.

Attaching xaa startup log first, will then reboot, attach the other (default, as shipped) config that exhibits the problem.

Nope, confirmed not fixed. Still takes ages to start (if at all) without
  Option "AccelMethod" "xaa"
  Option "RenderAccel" "true"
Even using the new "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3" released this week

yesterday i also recognized big performance differences with java programms when using "EXA" with an older celeron and ati RV280 [Radeon 9200 PRO]. Gtkperf performance is practically identical with EXA/XAA but java programs make a big difference (tvbrowser, netbeans). I use intrepid xserver and ati drivers.

Reverting to XAA made java programs useable again:

Architecture: i386
Source: sun-java6
Version: 6-10-0ubuntu2

Package: xserver-xorg-video-ati
Version: 1:6.9.0+git20081003.f9826a56-0ubuntu2

Architecture: i386
Source: xorg-server
Version: 2:1.5.2-2ubuntu1

[This is an automatic notice.]

We'd like to forward your bug upstream, however upstream requires
that you first test it against their newer driver code.

To save you the effort of building the driver from source, we've built
packages for the driver and its new dependencies.

So you have a couple options:

 1. Download and test .debs for intrepid, from:
     https://edge.launchpad.net/~intel-gfx-testing/+archive

 -or-

 2. Download and test the Jaunty alpha-2 (or newer) Live CD,
     (which includes a beta of the new xserver 1.6 as well).
     See http://cdimage.ubuntu.com/releases/9.04/ for ISOs

Thanks ahead of time! You can simply reply to this email to report your
findings.

P.S., if you wish to forward your bug upstream yourself, please follow
these directions to do so:
  http://intellinuxgraphics.org/how_to_report_bug.html

Bryce Harrington (bryce) on 2008-12-20
Changed in xserver-xorg-video-intel:
status: Incomplete → New
status: New → Incomplete

Installed the updated files.
Xorg still lists
(==) intel(0): Using EXA for acceleration
at start up.
My Xorg.conf file is currently empty.

http://www.formula1.com/services/live_timing/live_timing_popup.html still takes forever to load, max'ing out Xorg on CPU

Bryce Harrington (bryce) wrote :

Thanks for testing and confirming it's still an issue.

Changed in xserver-xorg-video-intel:
importance: Undecided → Medium
status: Incomplete → Confirmed
Arc Royal (kevku) wrote :

The performance has gone better in jre1.6.0_12 build b03 and i read from the release notes http://download.java.net/jdk6/6u12/promoted/b03/changes/jdk6uN-b03.html fixed bug http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6708580

java.sun.com has never head of that version, but I located it on http://download.java.net/jdk6/binaries/

I double checked the formula1.com URL still hung.

I uninstalled the sun-java6-plugin package and removed a spare /usr/lib/xulrunner-addons/plugins/libjavaplugin.so that survived. Firefox reported no java plugin installed.

I then ran the 1.6.0_12 installer and added a sym. link to the plugin to ~/.mozilla/plugins/

Revisited the formula1.com URL and it loads in a fraction of a second !

Nice find Arc Royal !

John Vivirito (gnomefreak) wrote :

I dont see how this is a Firefox issue since it seems to be Xorg as per most comments above.
Closing Firefox task.

Changed in firefox:
status: New → Invalid

John:
Only FireFox appears to have an issue with the older SDK...

Bryce Harrington (bryce) wrote :

Could you test it again with current Jaunty with all updates? We've recently upgraded to the 2.6.1 -intel driver, along with new libdrm, mesa, and xserver, any of which may have addressed this issue.

Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
UncleGeorge (netbeans) wrote :

/etc/X11/xorg.conf:
Section "Device"
        Identifier "Videocard0"
        Driver "intel"
        Option "AccelMethod" "xaa"
        Option "RenderAccel" "true"
EndSection

I added, as per the faq, the two Option parameters. This appears to have fixed my garbled characters on scrolling.
BTW: my xterm scroll was not affected by these missing X11 Options

[Still waiting for testing on jaunty]

Fwiw, most high Xorg CPU usage bugs are not really X but a client application. See:
https://wiki.ubuntu.com/X/Troubleshooting/HighCPU

Changed in xserver-xorg-video-intel:
status: Incomplete → New
status: New → Incomplete
Dmitriy Geels (dmig) wrote :

Problem also noticeable, when running eclipse pdt debugger. Xorg eats 60-70% cpu and for each debugger step eclipse redraws its variables view 3-15 seconds (depending on defined variables count).
Switching to XAA decreases cpu load to ~20%, making system usable.

I'll test debugging procedure in latest jaunty later and post results here.

@Dmitriy Did you try my steps from https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/238629/comments/17 to try with an updated Java (i.e. 1.6.0_12) and the non-XAA config ?

Dmitriy Geels (dmig) wrote :

I tried to work for two month with this java version and default xorg setting. That was awful!
Yesterday I found this bug and workaround.
Now there is JRE b14 available, but I'm not sure, that something is changed.

dmig@dmig-desktop:~$ apt-cache policy sun-java6-jre
sun-java6-jre:
  Установлен: 6-12-intrepid~ppa1
  Кандидат: 6-12-intrepid~ppa1
  Таблица версий:
 *** 6-12-intrepid~ppa1 0
        500 http://philip.magicalforest.se intrepid/extra Packages
        100 /var/lib/dpkg/status
     6-10-0ubuntu2 0
        500 http://ru.archive.ubuntu.com intrepid/multiverse Packages

Dmitriy Geels (dmig) wrote :

Just tried to open http://www.formula1.com/services/live_timing/live_timing_popup.html with default video settings in Jaunty amd64. One cpu core is 100% loaded, cpu became hot.

dmig@dmig-laptop:~$ apt-cache policy sun-java6-jre
sun-java6-jre:
  Установлен: 6-12-0ubuntu1
  Кандидат: 6-12-0ubuntu1
  Таблица версий:
 *** 6-12-0ubuntu1 0
        500 http://ru.archive.ubuntu.com jaunty/multiverse Packages
        100 /var/lib/dpkg/status

32 or 64 bit FireFox ?

Dmitriy Geels (dmig) wrote :

64 bit

Ahh, all my testing has been with a 32bit one.

Dmitriy Geels (dmig) wrote :

Repeated both testcases on jaunty x32 with UXA acceleration enabled -- no problems.

dmig@dmig-desktop:~$ apt-cache policy sun-java6-jre
sun-java6-jre:
  Установлен: 6-13-1
  Кандидат: 6-13-1
  Таблица версий:
 *** 6-13-1 0
        500 http://ru.archive.ubuntu.com jaunty/multiverse Packages
        100 /var/lib/dpkg/status

UXA acceleration was unusable on my laptop, I'll try to enable it again, since intel driver was updated not so long ago.

Dmitriy Geels (dmig) wrote :

But problem with java hang is still there for Jaunty x64 with UXA enabled.

dmig@dmig-laptop:~$ apt-cache policy sun-java6-jre
sun-java6-jre:
  Установлен: 6-13-1
  Кандидат: 6-13-1
  Таблица версий:
 *** 6-13-1 0
        500 http://ru.archive.ubuntu.com jaunty/multiverse Packages
        100 /var/lib/dpkg/status

Could you locate the libjavaplugin_oji.so file ? It should be a symbolic link into the jre i.e.:
$ ls -lah .mozilla/plugins/libjavaplugin_oji.so
lrwxrwxrwx 1 root root 64 2009-03-30 20:27 libjavaplugin_oji.so -> /usr/lib/jvm/java-6-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so

Bryce Harrington (bryce) on 2009-04-07
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Dmitriy Geels (dmig) wrote :

Tom:
dmig@dmig-desktop:~$ ll /usr/lib/firefox/plugins/
lrwxrwxrwx 1 root root 37 2009-04-07 12:34 flashplugin-alternative.so -> /etc/alternatives/firefox-flashplugin
lrwxrwxrwx 1 root root 39 2009-02-17 17:05 libjavaplugin.so -> /etc/alternatives/firefox-javaplugin.so

dmig@dmig-desktop:~$ ll /etc/alternatives/firefox-javaplugin.so
lrwxrwxrwx 1 root root 64 2009-04-07 10:13 /etc/alternatives/firefox-javaplugin.so -> /usr/lib/jvm/java-6-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so

dmig@dmig-desktop:~$ ll /usr/lib/jvm/java-6-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so
-rw-r--r-- 1 root root 137021 2009-03-09 12:55 /usr/lib/jvm/java-6-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so

This is for Jaunty x32.

Cool, just checking the plugin was set to use the same Java apt had installed :-)

Bryce Harrington (bryce) on 2009-05-02
summary: - [i965] [EXA] Java plugin causes massive Xorg CPU usage, fixed by
- changing Xorg acceleration mode [i965GM]
+ [i965] Java plugin causes massive Xorg CPU usage, fixed with XAA
+ (UXA/EXA)
Andrew Ash (ash211) on 2009-05-08
tags: added: high-cpu
Bryce Harrington (bryce) wrote :

This may be fixed now with more recent updates to the intel driver stack. Please re-test this against Karmic with the xorg-edgers PPA enabled to verify it is indeed fixed, and let us know either way.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Ramon Casha (rcasha) wrote :

Any way to apply the latest solutions to Jaunty?

Bryce Harrington (bryce) wrote :

It'd be nice to get some testing feedback that this is indeed solved on Karmic, but given how much has changed it would surprise me if it is the case. Tom, you can reopen the bug if you find it is still an issue when you test Karmic.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released
David Matějček (dmatej) wrote :

It seems that this bug is also cause of the Eclipse 4.x crashes (and high CPU load and hanging)
https://bugs.eclipse.org/bugs/show_bug.cgi?id=397291

I have maybe 10 dumps beginning with the following:
# SIGSEGV (0xb) at pc=0x00007fe9bb3dd92a, pid=7396, tid=140643637405440
#
# JRE version: OpenJDK Runtime Environment (7.0_51) (build 1.7.0_51-b00)
# Java VM: OpenJDK 64-Bit Server VM (24.45-b08 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [libgtk-x11-2.0.so.0+0x24492a] gtk_widget_queue_draw+0x1a
#

The XAA Option evidently helped.
Firefox did not crash before this change and does not crash even after that.
Eclipse did not crash after this change and is much faster (does not slow down after hours of work on the big workspace).

Kubuntu 13.10 64bit, Dell Latitude E6520 with i5 CPU.

Chris Wilson (ickle) wrote :

Not this bug since you have an issue with a different GPU. Note that this is accelerated in current -intel drivers.

David Matějček (dmatej) wrote :

I don't think that the problem is driver or hardware. It seems the problem is X server/GTK implementation.
After the simple change in /etc/X11/xorg.conf I have found here in comments the Eclipse had 17 hours uptime with heavy refactoring and then I only turned off the computer. Eclipse never before lasted so long and GUI was not so fast.

Option "AccelMethod" "xaa"

I can't say that the cause is exactly same, but surely helped the same thing.
I don't know who and why thinks that the problem is only with Intel ...?

Chris Wilson (ickle) wrote :

This bug is filed against -intel, where it has been fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.