Ubuntu

[i830] Xorg does not detect proper video driver for Fujitsu Lifebook S6010

Reported by Chris Muller on 2008-06-07
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Confirmed
Unknown
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: xorg

Since Ubuntu Gutsy Gibbon, xorg does not properly autodetect the video card of my Fujitsu Lifebook S6010. It chooses the "intel" driver, which gives a black screen, rather than the i810 driver, which works properly.

This is still the case with Ubuntu Hardy Heron.

This should be fixed in xorg's autodetection code of video hardware.

Dereck Wonnacott (dereck) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Could you include the following information please? Then set the bug status to 'new' to signify that it is ready for triage / review.

Resolution, rate, or other parameter expected
Resolutions, rates, or other parameters actually obtained

/etc/X11/xorg.conf
/var/log/Xorg.0.log
output of sudo ddcprobe
output of xrandr

Changed in xorg:
status: New → Incomplete
Timo Aaltonen (tjaalton) wrote :

-i810 driver is gone from Intrepid, btw.

mjatti (matson) wrote :

It seems to be impossible(?) to install Xubuntu 8.04.1 on the S6010 (from a CD) due to the video driver issues. The normal graphics mode exits the installation process to text mode and the safe graphics mode gives a vertically striped screen.

On Wed, Oct 01, 2008 at 09:00:39AM -0000, mjatti wrote:
> It seems to be impossible(?) to install Xubuntu 8.04.1 on the S6010
> (from a CD) due to the video driver issues. The normal graphics mode
> exits the installation process to text mode and the safe graphics mode
> gives a vertically striped screen.

Can you install using the alternate CD?

This is a confirmed issue with Xubuntu 8.10.

/etc/X11/xorg.conf appears to be empty (!)
/var/log/Xorg.0.log is 290 lines - how do I post to launchpad from a laptop which is online, but without GUI?
sudo ddcprobe = command not found + couldn't find package when running sudo apt-get install ddcprobe
xrandr = can't open display

Bryce Harrington (bryce) wrote :

Closing as invalid due to lack of needed information. Please feel free to reopen with the requested information if the problem still exists in Jaunty.

Changed in xserver-xorg-video-intel:
status: Incomplete → Invalid
chungyan5 (yan-amonics) wrote :
Download full text (3.6 KiB)

hi i just upgrade to ubuntu 8.10 for fujitsu s6010, and face the same problem above. It is worked in Ubuntu 7.10 & ubuntu 8.04 which i used i810 driver, however 8.10 is no luck for this, it is gone. Here is the information:

==sudo ddcprobe==
vbe: VESA 3.0 detected.
oem: Almador Graphics Chip Accelerated VGA BIOS
vendor: Intel Corporation
product: Almador Graphics Controller Hardware Version 0.0
memory: 8000kb
mode: 1280x1024x256
mode: 640x480x16m
mode: 800x600x16m
mode: 1024x768x32k
mode: 1024x768x64k
mode: 1024x768x16m
mode: 1280x1024x64k
mode: 1280x1024x16m
mode: 640x480x256
mode: 800x600x256
mode: 1024x768x256
mode: 640x480x64k
mode: 800x600x64k
edid:
edidfail

==xrandr==
===inside Ctrl-Alt-F1===
Can't open display
===inside ssh client terminal===
Screen 0: minimum 640 x 480, current 1368 x 768, maximum 1368 x 768
default connected 1368x768+0+0 (normal left inverted right) 0mm x 0mm
   1366x768 60.0
   1024x768 60.0
   800x600 60.0
   640x480 60.0
   1368x768 60.0*

==xorg.conf==
Section "ServerLayout"
 Identifier "X.org Configured"
 Screen 0 "Screen0" 0 0
 InputDevice "Mouse0" "CorePointer"
 InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
 ModulePath "/usr/lib/xorg/modules"
 FontPath "/usr/share/fonts/X11/misc"
 FontPath "/usr/share/fonts/X11/cyrillic"
 FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
 FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
 FontPath "/usr/share/fonts/X11/Type1"
 FontPath "/usr/share/fonts/X11/100dpi"
 FontPath "/usr/share/fonts/X11/75dpi"
 FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
 Load "extmod"
 Load "dbe"
 Load "xtrap"
 Load "record"
 Load "glx"
 Load "dri"
EndSection

Section "InputDevice"
 Identifier "Keyboard0"
 Driver "kbd"
EndSection

Section "InputDevice"
 Identifier "Mouse0"
 Driver "mouse"
 Option "Protocol" "auto"
 Option "Device" "/dev/input/mice"
 Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
 Identifier "Monitor0"
 Option "DPMS"
 VendorName "Monitor Vendor"
 ModelName "Monitor Model"
 HorizSync 28-49
        VertRefresh 43-72
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option "NoAccel" # [<bool>]
        #Option "SWcursor" # [<bool>]
        #Option "ColorKey" # <i>
        #Option "CacheLines" # <i>
        #Option "Dac6Bit" # [<bool>]
        #Option "DRI" # [<bool>]
        #Option "NoDDC" # [<bool>]
        #Option "ShowCache" # [<bool>]
        #Option "XvMCSurfaces" # <i>
        #Option "PageFlip" # [<bool>]
 Identifier "Card0"
 Driver "intel"
 VendorName "Intel Corporation"
 BoardName "82830 CGC [Chipset Graphics Controller]"
 BusID "PCI:0:2:0"
EndSection

Section "Screen"
 Identifier "Screen0"
 Device ...

Read more...

chungyan5 (yan-amonics) wrote :

facing this problem in new released of ubuntu 8.10

Changed in xserver-xorg-video-intel:
status: Invalid → Incomplete
chungyan5 (yan-amonics) wrote :

i let the fujitsu S6010 to work again.
I downgrade to Ubuntu 8.04(which using Xserver 7.3), then i also downgrade the driver to xserver-xorg-video-i810_1.7.4-0ubuntu7_i386.deb, then it works.

The display is not working with Jaunty alpha 3.

Tekno (tekno) wrote :

Ubuntu 7.04 Feisty Fawn seems to be latest Ubuntu version where this problem does NOT exist.

Bryce Harrington (bryce) on 2009-04-07
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-04-24
summary: - Xorg does not detect proper video driver for Fujitsu Lifebook S6010
+ [i830] Xorg does not detect proper video driver for Fujitsu Lifebook
+ S6010
Andrew Ash (ash211) on 2009-05-08
tags: added: i830 intel
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

A new major version of the -intel driver is now available in Karmic.

This version includes a major reworking of the acceleration
architecture, which resolves a huge number of issues. We do not know
whether it resolves the issue you reported.

Would you mind testing Karmic Alpha-2 and seeing if it is still a
problem? CD ISO images are available here:

  http://cdimages.ubuntu.com/releases/karmic/

If the issue can still be reproduced on karmic, please report here with
your findings, and attach a fresh Xorg.0.log from your test, and we will
be able to forward the bug upstream.

Otherwise, if the bug no longer exists in Karmic, let us know that as
well.

In the off chance you encounter different bugs while attempting to test
Karmic, please report those as new bug reports.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → New
status: New → Incomplete
dentra (trachuk) wrote :

With Karmic Alpha-2 the problem is still exists.

Bryce Harrington (bryce) wrote :

[Resetting to Incomplete since we need confirmation from the original reporter.]

dentra, it does not help to report that the issue still exists unless you can provide proof (logs etc) that you have identical hardware to the original reporter... as far as we know you may have some unrelated problem that just seems to have similar symptoms (this is very common with X bugs.)

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Tekno (tekno) wrote :

Problem still exists in Karmic Alpha-2

Normal graphics mode: Vertical stripes appear in screen
Safe graphics mode: Xorg seems to restart itself few times and message appears with:
"sil164 not detected
tfp410 not detected
(EE) intel 0: No valid modes"
and to the screen comes vertical and horizontal stripes

ttys are accessible with ctrl+alt+fX.

Bryce Harrington (bryce) wrote :

Thanks for testing

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
dentra (trachuk) wrote :

I have the same laptop as original reporter - FS Lifebook S6010 and I have the same video effects (vertical and horizontal stripes) on my screen.
What logs should I post here?

danioj (dan-danioj) wrote :

Hi All.

I have the same problem, I tried everything for hours last night. Nothing.

I am at the disposal of whoever beleive's they can fix this problem. Nothing else is going on this laptop until this is fixed or we figure it can't be! LOL! =:-)

Ta,

Dan

Bryce Harrington (bryce) wrote :

[Closing the bug since the original reporter has not replied, and commenters symptoms (vertical stripes) don't match to the original report (black screen).]

@dentra and techno, see https://wiki.ubuntu.com/X/Reporting for directions on how to report your own bugs.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Invalid

This problem is due to unsupported i830 variant since the rewrite of the v2 of the intel driver. I am myself having such laptop (fujitsu-siemens stylistic ST4000 series) and using gentoo. I have been trying to get the attention and help of intel developers but since they couldn't get their hands on such hardware themselves we are pretty much left on the road until someone can figure it out.

hum forgot to say that the bug either results in a black screen or white stripes getting brighter and brigther and kernel mode setting obviously won't work for this hardware as well with the same symptoms. The only way to get a working X on this hardware for me is to plug a screen on the VGA connector.

chungyan5 (yan-amonics) wrote :

hi all

i am sorry to reply late.

I cannot easy to test my Fujitsu Lifebook S6010 by CD ISO images, since my S6010 does not contains CD driver.

Is it possible to release .deb file(s) to me. I can remove my original xserver-xorg-video-i810_1.7.4-0ubuntu7_i386.deb, then install your new release to test. After test, i can re-install my worked xserver-xorg-video-i810_1.7.4-0ubuntu7_i386.deb

Sorry a late message, hope this does not affect your development.

Tekno (tekno) wrote :

I assume you are using hardy now. Is that correct?

It's not good idea to install karmic packages to hardy.

If you still want to try it and solve possible dependencies, here is intel driver from karmic:
http://mirrors.kernel.org/ubuntu/pool/main/x/xserver-xorg-video-intel/xserver-xorg-video-intel_2.6.3-0ubuntu9_i386.deb

You may not need to remove xserver-xorg-video-i810 as driver "intel" is separated (rewrite) from "i810".

Just remember to change 'Driver' to "intel" in xorg.conf Device section!

chungyan5 (yan-amonics) wrote :

hi Tekno

you are right that i cannot install this deb into my hardy, it has dependency error.

Is it no any testing method in hardy for this new driver? Or i need to upgrade to karmic. However, if it does not work proper, i need to re-install Hardy again, Like i upgrade to 8.10, then downgrade to Hardy again last time.

Any suggestion is wellcome.

Tekno (tekno) wrote :

You can upgrade to intrepid and then to karmic and test new driver.

If the new intel driver doesn't work properly and you want to get old intel (i810) driver back, you don't need to downgrade to hardy, just use driver from hardy:

I expect you have Karmic installed in this point.
Install wajig (sudo apt-get install wajig)
Remove karmic's xserver-xorg with aptitude (aptitude remove xserver-xorg) press Y!
Change repositories temporarily to hardy (sudo sed -i s/karmic/hardy/g /etc/apt/sources.list)
Update package list (sudo apt-get update)
Install xserver-xorg with aptitude (sudo aptitude install xserver-xorg)
Download old driver from hardy and put it to 'hold' with wajig (sudo wajig hold xserver-xorg-video-i810)
Change repos back to karmic (sudo sed -i s/hardy/karmic/g /etc/apt/sources.list)
Now, let's make sure every package is upgraded:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
And finally sudo nano /etc/X11/xorg.conf and add/change to Device -section: Driver "i810")

Result should be Ubuntu 9.10 but with old i810 driver running properly.

Please report if that works or doesn't work. I'm using Karmic+i810 with that method.
Thanks goes to: http://forum.ubuntu-fi.org/index.php?topic=24701.msg208685#msg208685

chungyan5 (yan-amonics) wrote :

hi Tekno

i just do the upgrade from 8.04 to 8.10 to 9.04 to Karmic. After i leave 8.04, i totally lose the GUI, and always command console only.

After boot-up Karmic, the default kernel 2.6.31 cannot let my Fujitsu Lifebook S6010 to boot-up, the LCD change white color and seems lose control of LCD. I use another kernel 2.6.27, i can boot. However, i want to test that x-windows cannot start-up still. I am still in console.

What log file(s) do you want to post on here?

Otherwise, i will use your method provided on above to downgrade the driver and test again.

chungyan5 (yan-amonics) wrote :

hi Tekno

i follow your method, and let the xserver to run again by using i810 driver, thanks your suggestion and i can upgrade my Fujitsu to Karmic.

However, i cannot use gnome, and it is XFCS(i setup as xubuntu before). When i want to install gnome again, it said, it will remove the i810 driver, and upgrade the xserver-xorg, i am afraid it will destroy for what did(downgrade the xserver-xorg). Do you have any suggestion for using gnome again?

Samuli Lager (samuli-lager) wrote :

"After boot-up Karmic, the default kernel 2.6.31 cannot let my Fujitsu Lifebook S6010 to boot-up, the LCD change white color and seems lose control of LCD."

To get rid of this problem use acpi=off option for grub.

Samuli Lager (samuli-lager) wrote :

How i get this thing to boot with acpi on?

Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.