Ubuntu

Hard lock booting/logging out/restarting [Q965]

Reported by Axel on 2008-04-21
18
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Critical
xserver-xorg-video-intel (Debian)
Fix Released
Unknown
xserver-xorg-video-intel (Ubuntu)
High
Bryce Harrington

Bug Description

Binary package hint: xorg

This is a fresh install of Hardy release candidate on a Dell Optiplex 745 desktop. No problem during the installation, even though at the end the system didn't reboot. It got stuck at the eject CD and press Enter screen. However, first boot failed. The system froze with a blank screen when the gdm login should appear. Booting in rescue mode and choosing resume normal booting worked. However, the system freezes when the gdm login should appear after logging out, and when restarting the computer (I get some network manager stuff, the splash screen reappears, and nothing happens). Suspend to ram and resume works. I tried booting normally several times, and sometimes it works, sometimes it freezes.

The only unusual message I found in the logs is this:
gdm[5561]: segfault at 08000000 eip b77254c7 esp bfe65568 error 4

The graphic card is Intel 82Q963/Q965 Integrated Graphics Controller (rev 02).

I had no problems with Gutsy in this computer.

ProblemType: Bug
Architecture: i386
Date: Mon Apr 21 08:36:23 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/yelp
Package: yelp 2.22.1-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: yelp
Uname: Linux 2.6.24-16-generic i686

Axel (axelgrau) wrote :
Axel (axelgrau) wrote :

Sorry for the useless stuff about Yelp.
I attached the last part of the syslog for of a successful boot and for a hard lock.

Axel (axelgrau) wrote :

This is the hard lock.

Axel (axelgrau) wrote :

Some more info from Syslog. This seems to be the problem.

Apr 21 09:01:00 plasma init: tty4 main process (4521) killed by TERM signal
Apr 21 09:01:00 plasma init: tty5 main process (4522) killed by TERM signal
Apr 21 09:01:00 plasma init: tty2 main process (4524) killed by TERM signal
Apr 21 09:01:00 plasma init: tty3 main process (4527) killed by TERM signal
Apr 21 09:01:00 plasma init: tty6 main process (4528) killed by TERM signal
Apr 21 09:01:00 plasma init: tty1 main process (5466) killed by TERM signal
Apr 21 09:01:00 plasma gdm[5300]: WARNING: main daemon: Got SIGABRT. Something went very wrong. Going down!
Apr 21 09:01:00 plasma kernel: [ 81.550899] gdm[5300]: segfault at 08000000 eip b76a04c7 esp bfe185b8 error 4

Axel (axelgrau) wrote :

The final release of Ubuntu Hardy still has problems. Unlike the release candidate, the live CD froze when starting ubiquity. However I could install in safe graphics mode.
Ubuntu works if the vesa or i810 drivers are selected in xorg.conf, but freezes with intel.

Bryce Harrington (bryce) wrote :

Please attach your /var/log/Xorg.0.log from after the failure.

Changed in xserver-xorg-video-intel:
status: New → Incomplete
Axel (axelgrau) wrote :

This is after the failure (with the release candidate).

Axel (axelgrau) wrote :

Success (release candidate)

Axel (axelgrau) wrote :

This looks a lot like Debian bug #471413, which has been forwarded upstream (https://bugs.freedesktop.org/show_bug.cgi?id=14867) and apparently fixed. Have you got any plan to add the 2.3 version of the drivers to your bisect page? Thank you.

Bryce Harrington (bryce) wrote :

Thanks for identifying the upstream bug. I've marked it so we can examine them for a patch for backporting.

I do plan to update the bisect page, however my build machine is in process of being rebuilt, so may be a bit before I have new packages uploaded. Thanks for asking.

Changed in xserver-xorg-video-intel:
importance: Undecided → High
status: Incomplete → In Progress
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Changed in xserver-xorg-video-intel:
status: Unknown → Fix Released
Miika Laaksonen (miika) wrote :

Confirmed with my optiplex 745. I filled my probes to other bug. You can find them there:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/221179

Miika Laaksonen (miika) wrote :

2.3 is now in debian experimental. Could someone try compile that one for hardy so that we test and confirm that this but is really fixed in newer drivers?
http://packages.qa.debian.org/x/xserver-xorg-video-intel/news/20080423T163205Z.html

Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
papo (weyland) wrote :

Hi

I tried 2.3.1 by rebuilding debian's xserver-xorg-video-intel 2:2.3.1-1. I can't confirm that the new version is fixing this bug; I'm still getting the same black screen in 80% of all cases on a dell optiplex 745 with precisely the graphics card listed in the initial posting. Furthermore, the upstream ticket attached to this bugreport does't look active to me.

Axel (axelgrau) wrote :

I tried the 2.3.1 drivers as well, and I agree that they don't fix this bug. The system worked fine a couple of times, but it froze about 5 times.
I also tried Fedora 9 live cd, which uses intel 2.2.1 drivers, and it works fine, with desktop effects both on and off. It seems there may be some software combination specific to Ubuntu that triggers this bug.

Miika Laaksonen (miika) wrote :

Strange. I installed Debian experimental binary packet 2.3.0-1 directly and that seems to works without any freeze. VT switching still cause black screen but that probably other unresolved bug.

Axel (axelgrau) wrote :

That's right. The 2.3.0 package works, whereas the 2.3.1 hangs the system.

papo (weyland) wrote :

Thank you. I just tried debian's (binary) package version 2.3.0 and was able to reboot three times, always getting a nice gdm login screen. For those who need a hotfix: This debian package is available at snapshot.debian.net

Axel (axelgrau) wrote :

The upstream bug for the 2.3.0 - 2.3.1 regression is https://bugs.freedesktop.org/show_bug.cgi?id=15933

papo (weyland) wrote :

Does anyone know why ubuntu's 2.2.0 driver shows the same bug as 2.3.1? Has some buggy stuff been backported? What about upstream's 2.2.0, does that version show the same bug? I'm a bit puzzeled that gutsy's driver was working while hardy's driver isn't, even though it looks like they both are based on the same upstream release (2.2.0).

Bryce Harrington (bryce) on 2008-05-24
Changed in xserver-xorg-video-intel:
assignee: nobody → bryceharrington
Changed in xserver-xorg-video-intel:
status: Fix Released → Confirmed
Uwe (gandalf.the.grey) wrote :

Problem seems to be solved with Dell Optiplex 745 after latest upgrade to driver version 2:2.2.1-1ubuntu13.3.

Uwe (gandalf.the.grey) wrote :

I have to correct myself: The system still hangs after suspend to RAM. BTW: Hibernation does not work at all.

Bryce Harrington (bryce) wrote :

Does it make any difference if ForceEnablePipeA is turned on? I.e.:

  Section "Device"
    ...
    Option "ForceEnablePipeA" "true"
  EndSection

If that makes it work, then please paste in the output of `lspci -vvnn | grep -A1 "VGA compat"`, and give the laptop model name and number

Axel (axelgrau) wrote :

The system still locks with ForceEnablePipeA on. By the way, Optiplex 745 are desktop computers.
The problem with suspend to Ram is probably the same of bug #226279.

Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
TundraMan (asselsm) wrote :

Wooohooo. The latest .24-19 kernel along with whatever xorg-intel updates that have gone out lately have solved this problem for me on my Dell Optiplex 745. I no longer have troubles with hard lockup just as kdm starts and also the suspend/resume is working like a champ.

On my home computer which had problems on return from suspend with the -18 kernel the -19 now fixes this. I am now much happier.

Axel (axelgrau) wrote :

I can't confirm that new kernel and new driver fix this problem. I tried 4 times and it locked twice.

David Norton (norty) wrote :

I concur -- 2.6.24-19-generic on an HP Compaq nx9030 business laptop occasionally hard locks either on shutdown or restart.

Confirming on another Optiplex 745 under Hardy, latest kernel 2.6.24.19 and intel driver package 2:2.2.1-1ubuntu13.4.

Note that, for Dells at least, the specific motherboard version seems to make a difference (as for the reboot problem in bug 115011 - see my comments there). With my m/board code 0KW628, it hard locks. A colleague also has an Optiplex 745, but with m/board code 0WK833 and he has no problems (still same chipset and onboard graphics as far as I can see).

Don't know if that might help with diagnosis.

Also can confirm workaround using i810 driver (logon screen is wrong resolution - only see top left quarter - but then fine once logged in). I assume only potential issues are reduced graphics performance.

P.S. I haven't tried the older Hardy intel driver version 2:2.2.1-ubuntu12; don't know if that might be a (better?) workaround but presume may break other stuff.

P.P.S. Off topic but, AFAIK, the intel driver is just a more modern version of the i810 one (is it a fork?)? What are the differences / release strategies? Are they managed by separate development teams? Web links?

David Norton (norty) wrote :

I just had it lock directly after logging in, too. Also using kernel 2.6.24.19 and intel driver package 2:2.2.1-1ubuntu13.4.

The lock-on-login occurred after I did a hard shutdown because it locked (same lock) after idling.

Sorry, I don't know any way to reproduce it (though I know it's happened at least once before), and the logs have probably been overwritten by now.

Bryce Harrington (bryce) on 2008-07-29
Changed in xserver-xorg-video-intel:
status: In Progress → Triaged
Bryce Harrington (bryce) wrote :

Is anyone still seeing this? I noticed the problem go away when I updated to the latest kernel and -intel.

Changed in xserver-xorg-video-intel:
status: Triaged → Incomplete

I had it happen just yesterday, and I have the latest stable Hardy patches
(hardy-security and hardy-updates). I'm using Kubuntu 8.04.

David

On Sat, Sep 20, 2008 at 3:15 PM, Bryce Harrington <<email address hidden>
> wrote:

> Is anyone still seeing this? I noticed the problem go away when I
> updated to the latest kernel and -intel.
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: Triaged => Incomplete
>
> --
> Hard lock booting/logging out/restarting [Q965]
> https://bugs.launchpad.net/bugs/220135
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in X.org xf86-video-intel: Fix Released
> Status in "xserver-xorg-video-intel" source package in Ubuntu: Incomplete
> Status in "xserver-xorg-video-intel" source package in Debian: Fix Released
>
> Bug description:
> Binary package hint: xorg
>
> This is a fresh install of Hardy release candidate on a Dell Optiplex 745
> desktop. No problem during the installation, even though at the end the
> system didn't reboot. It got stuck at the eject CD and press Enter screen.
> However, first boot failed. The system froze with a blank screen when the
> gdm login should appear. Booting in rescue mode and choosing resume normal
> booting worked. However, the system freezes when the gdm login should appear
> after logging out, and when restarting the computer (I get some network
> manager stuff, the splash screen reappears, and nothing happens). Suspend to
> ram and resume works. I tried booting normally several times, and sometimes
> it works, sometimes it freezes.
>
> The only unusual message I found in the logs is this:
> gdm[5561]: segfault at 08000000 eip b77254c7 esp bfe65568 error 4
>
> The graphic card is Intel 82Q963/Q965 Integrated Graphics Controller (rev
> 02).
>
> I had no problems with Gutsy in this computer.
>
> ProblemType: Bug
> Architecture: i386
> Date: Mon Apr 21 08:36:23 2008
> DistroRelease: Ubuntu 8.04
> ExecutablePath: /usr/bin/yelp
> Package: yelp 2.22.1-0ubuntu2
> PackageArchitecture: i386
> ProcEnviron:
>
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> SourcePackage: yelp
> Uname: Linux 2.6.24-16-generic i686
>

--
Alpha Epsilon Pi Exchequer

muzincs (ureta-manuelita) wrote :
Download full text (3.2 KiB)

Hello there. I am still following this thread because I have the exact same
problem. My equipment is a Dell Optiplex 745 coupled with a 2407WFP
monitor. I used to enjoy native resolution (1920x1200) with gutsy, but I
have had nothing but problems since hardy. All the problems that have been
described in this thread, I've had, re the system freezing at boot, after
locking the screen, etc etc. From all I have tried I discovered I could get
the display to be 1600xsomething or other (everything a little chubby
looking) and no system freezes if in xorg.conf I set the driver to "i810".
Today, after reading all over the web, I set the driver to "intel". Voila,
for the first time in months I had native resolution and all was well until
I rebooted. System freeze, same at start up. Put the old xorg.conf to
work. But something seems very broken. The system won't start at all
(except in recovery mode, of course). I have given up on Ubuntu for this
machine for now and I am typing this in Windows XP. It has been a very
frustrating 4 months or longer.

But I will keep checking this thread, hoping for a solution.

Manuelita

On Sat, Sep 20, 2008 at 3:15 PM, Bryce Harrington <<email address hidden>
> wrote:

> Is anyone still seeing this? I noticed the problem go away when I
> updated to the latest kernel and -intel.
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: Triaged => Incomplete
>
> --
> Hard lock booting/logging out/restarting [Q965]
> https://bugs.launchpad.net/bugs/220135
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in X.org xf86-video-intel: Fix Released
> Status in "xserver-xorg-video-intel" source package in Ubuntu: Incomplete
> Status in "xserver-xorg-video-intel" source package in Debian: Fix Released
>
> Bug description:
> Binary package hint: xorg
>
> This is a fresh install of Hardy release candidate on a Dell Optiplex 745
> desktop. No problem during the installation, even though at the end the
> system didn't reboot. It got stuck at the eject CD and press Enter screen.
> However, first boot failed. The system froze with a blank screen when the
> gdm login should appear. Booting in rescue mode and choosing resume normal
> booting worked. However, the system freezes when the gdm login should appear
> after logging out, and when restarting the computer (I get some network
> manager stuff, the splash screen reappears, and nothing happens). Suspend to
> ram and resume works. I tried booting normally several times, and sometimes
> it works, sometimes it freezes.
>
> The only unusual message I found in the logs is this:
> gdm[5561]: segfault at 08000000 eip b77254c7 esp bfe65568 error 4
>
> The graphic card is Intel 82Q963/Q965 Integrated Graphics Controller (rev
> 02).
>
> I had no problems with Gutsy in this computer.
>
> ProblemType: Bug
> Architecture: i386
> Date: Mon Apr 21 08:36:23 2008
> DistroRelease: Ubuntu 8.04
> ExecutablePath: /usr/bin/yelp
> Package: yelp 2.22.1-0ubuntu2
> PackageArchitecture: i386
> ProcEnviron:
>
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> SourcePac...

Read more...

On Thu, Sep 25, 2008 at 08:43:49PM -0000, muzincs wrote:

Hello Manuelita

> But I will keep checking this thread, hoping for a solution.

Just for the record: I posted a workaround in this thread some time ago.
I had no single freeze since then, however, this was not confirmed by
anyone yet.

Best regards

Matt

Hello everyone. I want to report that I installed Intrepid Alpha-6 on my
optiplex 745 (out of frustration) and all the problems went away! The wide
screen monitor now has the correct resolution, and all the system freezes,
etc., are gone.

Here is a tip in case you give Intrepid a try: most likely your internet
connection will fail, if you have a static IP address. This is a known
bug. The current workaround is to, in synaptic, remove all four packages
that appear as installed if you search for "network manager". Upon
restarting, the system will use the previous settings and the connection
will be reestablished. Apparently one has to do this with every upgrade
that reinstalls network manager.

--
Manuelita Ureta

Bryce Harrington (bryce) wrote :

Alright, most people are reporting it's fixed in Intrepid. It may still exist for hardy but since we don't know what patch fixed it specifically, I hesistate to nominate it for hardy; quite likely it is the kernel that was fixed. If anyone knows better, feel free to open a Hardy task for this.

Changed in xserver-xorg-video-intel:
status: Incomplete → Fix Released
Cousin Marc (cousinmarc) wrote :

Debian 2.3.0 package corrects the problem here too.
Intrepid works too, but at least for some kubuntu users like me, it will be a while before I will consider using it for work (KDE 4.1 is still far from KDE 3 on functionality)

Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
Changed in xserver-xorg-video-intel:
importance: Critical → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.