[Hardy] No DRI with Intel GMA 950 (aka 945GM)

Bug #204762 reported by Alvaro Kuolas
30
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
kernel-package (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
linux (Ubuntu)
Medium
Stefan Bader
Hardy
Medium
Unassigned
Intrepid
Medium
Stefan Bader
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

The intel video driver is unable to open the DRM Device, that's what is said on the Xorg.log. i915 kernel module is loaded, don't know if it's a incompatible module for this driver.

(II) intel(0): I830CheckAvailableMemory: 441340 kB available
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: Open failed
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card1
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card2
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card3
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card4
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card5
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card6
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card7
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card8
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card9
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card10
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card11
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card12
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card13
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card14
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card1
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card2
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card3
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card4
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card5
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card6
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card7
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card8
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card9
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card10
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card11
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card12
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card13
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card14
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
(EE) [drm] drmOpen failed.
(EE) intel(0): [dri] DRIScreenInit failed. Disabling DRI.

Revision history for this message
Alvaro Kuolas (kuolas) wrote :
Revision history for this message
Alvaro Kuolas (kuolas) wrote :

This is Hardy Alpha6 with all the updates.

Revision history for this message
Alvaro Kuolas (kuolas) wrote :

The Machine

bios-version:68MVU Ver. F.06
system-manufacturer:Hewlett-Packard
system-product-name:HP 530 Notebook PC(KD089AA#ABM)
system-version:F.06

Revision history for this message
Alvaro Kuolas (kuolas) wrote :

I suggest using Intel video driver 2.3 for this LTS version of Ubuntu. (2.4 comes with XvMC for Intel i8xx and GMA 900 and GMA 950. That's helpful for Mythubuntu and Multimedia Apps. on Intel Platform.)

Revision history for this message
Alvaro Kuolas (kuolas) wrote :

"2.4 comes with" that's a typo, sorry... it should say 2.3

Revision history for this message
Alvaro Kuolas (kuolas) wrote :

http://intellinuxgraphics.org/community_testing.html

It's says:

Known driver issues
Work in progress:
- EXA (default acceleration method starting from 2.2.0 release) has performance issue, to be resolved in the next release with batchbuffer branch merged: bug#13389
- XvMC support in xvmc branch: mostly working but with performance issue due to ttm on i915, developed in progress on i965. Expected to be in the next release.

This is as version 2.2, that's the shiping version in Ubuntu 8.04 LTS

Revision history for this message
Alvaro Kuolas (kuolas) wrote :

I update the video driver with the latest Git (DDX, DRI and DRM, no MESA) and I got this on dmesg:

[ 134.919788] [drm] Initialized drm 1.1.0 20060810
[ 134.925273] ACPI: PCI Interrupt 0000:00:02.0[A] -> GSI 16 (level, low) -> IRQ 16
[ 134.925283] PCI: Setting latency timer of device 0000:00:02.0 to 64
[ 134.926810] ACPI: PCI interrupt for device 0000:00:02.0 disabled
[ 134.926823] DRM: drm_get_dev failed.
[ 134.927440] i915: probe of 0000:00:02.0 failed with error -22

Revision history for this message
Alvaro Kuolas (kuolas) wrote :

With kernel option: acpi=off

[ 47.833396] [drm] Initialized drm 1.1.0 20060810
[ 47.852853] PCI: Found IRQ 10 for device 0000:00:02.0
[ 47.852873] PCI: Sharing IRQ 10 with 0000:00:1f.1
[ 47.852887] PCI: Setting latency timer of device 0000:00:02.0 to 64
[ 47.853306] DRM: drm_get_dev failed.
[ 47.853315] i915: probe of 0000:00:02.0 failed with error -22

Revision history for this message
McLin (mclin23) wrote :

I have the same Notebook and the same problem, i have formated my hdd and install the Hardy bete and now i didnt have 3d anymore...

I dont know where the problem is, because in 7.10 it was allright.

Revision history for this message
McLin (mclin23) wrote :

Ok the bug resolved when you installed the Kernel from Debain sid 2.6.24

Revision history for this message
Bryce Harrington (bryce) wrote :

The 2.3 driver has not been released yet, so obviously it's impossible for us to include it. ;-)

However, I've built a series of snapshots from newer versions of the driver for you to test. If you can identify the version closest to the Current Hardy version that enables your system to work, it would help in identifying which patch is needed. If 2.3 is not released in time for Hardy, we can consider backporting specific patches. We would just need your help in identifying which solves the problem you're having.

  http://people.ubuntu.com/~bryce/bisect/

If you find that your issue still occurs even with the newest git version, then the problem may lay with the kernel rather than with -intel.

Changed in xserver-xorg-video-intel:
status: New → Incomplete
Revision history for this message
McLin (mclin23) wrote :

But its an Kernel Bug not from the Driver...

Revision history for this message
Alexander Oltu (sazs) wrote :

I have the same problem and I think the problem is in i915 drm module, which is located in linux-image-2.6.24-12-generic package.

I think so because when you load i915 modules you get
DRM: drm_get_dev failed.
and nothing is in /dev/dri/

Unfortunately there is not much information when drm module is loaded with debug=1.

Revision history for this message
Bryce Harrington (bryce) wrote :

thanks - dropping xorg driver component due to comment #14. Sounds like it's considered to be a kernel issue.

Changed in xserver-xorg-video-intel:
status: Incomplete → Invalid
Revision history for this message
Alexander Oltu (sazs) wrote :

I compiled DRM module from git (http://www.intellinuxgraphics.org/download.html), same problem (drm debug=1):

[ 821.578712] [drm] Initialized drm 1.1.0 20060810
[ 824.555011] [drm:drm_init]
[ 824.555066] [drm:drm_get_dev]
[ 824.555081] ACPI: PCI Interrupt 0000:00:02.0[A] -> GSI 16 (level, low) -> IRQ 16
[ 824.555090] PCI: Setting latency timer of device 0000:00:02.0 to 64
[ 824.555130] [drm:drm_get_minor]
[ 824.555168] [drm:drm_get_minor] new minor assigned 0
[ 824.555174] [drm:drm_addmap_core] offset = 0x00003000, size = 0x00000008, type = 1
[ 824.555723] [drm:drm_put_minor] release secondary minor 0
[ 824.555779] ACPI: PCI interrupt for device 0000:00:02.0 disabled
[ 824.555786] DRM: drm_get_dev failed.
[ 824.555795] i915: probe of 0000:00:02.0 failed with error -22

Maybe we have to open bug upstream?

Revision history for this message
Alvaro Kuolas (kuolas) wrote :

On comment #7 and #8 I tested the latest Git of Intel 2.2.99 (aka 2.3RC1) and the latest DRM. There's something on the kernel not the modules.

Revision history for this message
Alexander Oltu (sazs) wrote :

I compiled vanilla 2.6.24.4 kernel and applied git drm modules, same problem. Please note that debian kernel use stock intel drm which is version 1.6 or something, which works fine.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

H Guys,

It would seems you are comfortable compiling and testing the upstream kernel. That's great and very helpful. Care to test the latest 2.6.25-rc8 upstream kernel and verify if the issue still exists upstream? If it does exist upstream we'll want to open an upstream bug report at bugzilla.kernel.org. You can refer to the "Reporting Bugs Upstream" section of https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. It is often the case that once bugs are escalated upstream they are quickly resolved through the help of the upstream kernel community. Thanks for testing and your help.

Changed in linux:
status: New → Incomplete
Revision history for this message
Alexander Oltu (sazs) wrote :

Same problem with 2.6.25-rc8. I opened upstream bug.

Changed in linux:
status: Unknown → Confirmed
Revision history for this message
Alexander Oltu (sazs) wrote :

Maybe I have to mention this bug too https://bugs.freedesktop.org/show_bug.cgi?id=15330 , which I opened some time ago?
And this patch fixed my problem http://bugzilla.kernel.org/show_bug.cgi?id=10395#c4

Changed in linux:
status: Confirmed → Fix Released
Revision history for this message
Chris Quach (quach-c) wrote :

I still have the same problems with the official release of Hardy... I'm not sure how to apply the suggested patch or what to do otherwise, maybe someone could point me in the correct direction...

Revision history for this message
Alexander Oltu (sazs) wrote :

Hi Chris,

It looks like latest intel's git has this patch applied, so you may follow instructions from here:http://www.intellinuxgraphics.org/download.html, regarding DRM kernel module.

Revision history for this message
Chris Quach (quach-c) wrote :

installed the latest git and still no go... compiled the git without errors, copied the .ko files to the correct directory and still no compiz with the same errors in the xorg.log

Revision history for this message
Alexander Oltu (sazs) wrote :

Could you attach you lspci -nnv ?

Also you can check that i915_drv.h has your device inside it, something like:
 grep -m 1 -A 5 "IS_I945GM(dev)" <path_to_local_git_files>/drm/linux-core/i915_drv.h

I am using latest git with 8086:27ae without patching and have running compiz.

Revision history for this message
Chris Quach (quach-c) wrote :

One of the last updates fixed it!! :D:D:D

Thanks for the help and really appreciate all the work you guys do..

Revision history for this message
John Dong (jdong) wrote :
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Reassigning to the kernel team and milestoning this for Hardy's 8.04.1 point release. Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
milestone: none → ubuntu-8.04.1
status: Incomplete → Triaged
Revision history for this message
rod22 (rodrigo-aros-m) wrote :

I had same issue whit this GMA 950 in an HP530 laptop, no visual effects working for me on final hardy 8.04,
my friend Maackenzie Morgan offered herself to recompile my kernel adding my video card to the code, GMA950 and now i have visual effects going smooth. hope this helps at all.

Revision history for this message
Mackenzie Morgan (maco.m) wrote :

To clarify what rod22 said, I applied the patch John Dong linked and recompiled it for him.

Revision history for this message
Alexander Oltu (sazs) wrote :

As I mentioned before there is no need to apply this patch, as it is already in kernel and intel git sources, just take the latest version from desired source and compile it for yourself.

Alex.

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

Just posting a note here for anyone interested (and also maybe for those not as comfortable with building their own kernel). The Intrepid Ibex 8.10 kernel is available for testing and contains the patch John had referenced. It is currently available in the following PPA:

https://edge.launchpad.net/~kernel-ppa/+archive

If you are not familiar with how to install packages from a PPA basically do the following:

Create the file /etc/apt/sources.list.d/kernel-ppa.list to include the following two lines:

deb http://ppa.launchpad.net/kernel-ppa/ubuntu hardy main
deb-src http://ppa.launchpad.net/kernel-ppa/ubuntu hardy main

Then run the command:

sudo apt-get update

You should then be able to install the linux-image-2.6.25 kernel package. Thanks.

Stefan Bader (smb)
Changed in linux:
status: Triaged → In Progress
Revision history for this message
Stefan Bader (smb) wrote :

SRU Justification

Impact: Regression for DRI and Intel 945GM

Fix description: Simple patch that adds an ID to a macro. (See https://bugs.launchpad.net/ubuntu/+source/linux/+bug/204762/comments/26) Cherry-picked from upstream.

Testcase: Starting X with Intel 945GM card yields DRI error messages.

Changed in linux:
assignee: ubuntu-kernel-team → stefan-bader-canonical
status: In Progress → Fix Committed
Revision history for this message
Torsten Spindler (tspindler) wrote :

The 2.6.24-17.32ubuntu7 kernel from https://edge.launchpad.net/~timg-tpi/+archive fixes this problem for me on Hardy.

Steve Langasek (vorlon)
Changed in xserver-xorg-video-intel:
status: New → Invalid
Changed in linux:
status: New → Triaged
Steve Langasek (vorlon)
Changed in linux:
milestone: ubuntu-8.04.1 → none
importance: Undecided → Medium
milestone: none → ubuntu-8.04.1
Martin Pitt (pitti)
Changed in kernel-package:
status: New → Invalid
status: New → Invalid
Revision history for this message
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in linux:
milestone: ubuntu-8.04.1 → none
status: Triaged → Fix Committed
Steve Langasek (vorlon)
Changed in linux:
milestone: none → ubuntu-8.04.1
Revision history for this message
Alexander Oltu (sazs) wrote :

Upgraded to
>uname -a
Linux dynamo 2.6.24-18-generic #1 SMP Wed May 28 20:27:26 UTC 2008 i686 GNU/Linux

Problem still persist:
[ 98.413710] DRM: Fill_in_dev failed. and DRI is not working

Revision history for this message
Alvaro Kuolas (kuolas) wrote :

I think it's still not in the repos, I'm with the proposed repo but I don't see any kernel update

Revision history for this message
Alvaro Kuolas (kuolas) wrote :

Got it from the repos yesterday and it's been 24 hours testing it and it works well. Now I'm investigating some lockups/freeze on Hardy (No need to reboot but it's annoying). That, the wifi LED and Hardy it's "stable" for me.

Revision history for this message
Alexander Oltu (sazs) wrote :

Updated today, now it works for me too.

Revision history for this message
Steve Langasek (vorlon) wrote :

thanks for the feedback, marking as verified for the SRU.

Revision history for this message
Simos Xenitellis  (simosx) wrote :

By adding Tim's repository, APT shows that there are new kernel packages to install,
however it does show the linux-kernel-2.6.24 package.
Would that be related to the recent main kernel update (4th June 08) that may override this PPA kernel?

What instructions would I give to an end-user to get this kernel installed?

Revision history for this message
Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in linux:
status: Fix Committed → Fix Released
Revision history for this message
Jouston Huang (jouston-huang) wrote :

After upgrading to 2.6.24-19 kernel in main, it works fine out of box without any patches needed.

Revision history for this message
Stefan Bader (smb) wrote :

The change went into upstream before 2.6.26, so it should be in the alpha by now.

Changed in linux:
status: Fix Committed → Fix Released
Revision history for this message
Liox (liox) wrote :

Hello everybody,

I've the same problem with my Lenovo Thinkpad R61 which has a Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller. I know, it was working before, but after an upgrade of the kernel it doesn't anymore.
The drm kernel modul is loaded, but I don't have a /dev/dri/card0 device.
dmesg gives me no information about an error. It just says:
[ 35.314895] [drm] Initialized drm 1.1.0 20060810
[ 35.319054] [drm] Initialized i915 1.6.0 20060119 on minor 0
But glxinfo tells me:
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa GLX Indirect
If I set LIBGL_DEBUG=verbose, I get no more information.
My xorg.conf is not changed, it is the original one which was generated by the system.
The error message in the xorg log is the one which you can read in the first contribution.
Last but not least, my kernel version is: 2.6.24-24-generic
Now my questions. Is the bug still not fixed for some intel graphic cards? Is there a chance to get 3D acceleration to work on my system? If yes, may you know a repository to download the right version.

Revision history for this message
Stefan Bader (smb) wrote : Re: [Bug 204762] Re: [Hardy] No DRI with Intel GMA 950 (aka 945GM)

Likely not the same but maybe a similar problem. This bug was opened for a
945GM and you say, you got a 965. Also you say this worked before, but what was
before? Could you please add 'sudo lspci -vvvnn', dmesg and the version number
of the kernel, which worked?

Revision history for this message
Liox (liox) wrote :

sorry Stefan, I recognized your post this day. Because I do not know which was the last kernel version where 3D was working, I just booted the LiveCD. There it is working. See the working3D.txt for more information.
Meanwhile I have kernel 2.6.24-25-generic but 3D is still not working again. I guess the problem is, that I do not have a /dev/dri/card0 device. There is no dri directory at all but the i915 modul is loaded without an error.

Revision history for this message
Liox (liox) wrote :
Revision history for this message
Liox (liox) wrote :
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.