[i915] [HARDY] X crashes with 915GM/GMS/910GML (104d:81b8)

Bug #201352 reported by wuddiwupp on 2008-03-12
18
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Bryce Harrington

Bug Description

Hi,

sometimes X crashs it looks like a memory problem, there is no specified action before.

wuddiwupp (stefan-wuttke) wrote :
unggnu (unggnu) wrote :

This looks like a hardware issue. Could you please choose at boot memory test and let it run. If you got errors there is a serious hardware problem like corrupted mem or something like that.
Do you have another operating system to recheck if this problem happens too?
Which Ubuntu version do you use and could you please attach the output of 'lspci -vvnn' in a file?

Changed in xserver-xorg-video-intel:
status: New → Incomplete

at the moment I use Hardy for testing, here is output of lspci.
I check the mem now and report the result ;)

wuddiwupp (stefan-wuttke) wrote :

So memory is checked with *no* errors :)

Does this crash only happen with Hardy and not Gutsy or similar?
Could you please attacht the following information?

Detailed list of steps to reproduce

How complete is the X failure?
+ Does ctrl+alt+f1 take you to a console?
+ Does ctrl+alt+backspace restart X?
+ Does mouse pointer still move?
+ Does the keyboard LED come on when hitting the CAPSLOCK key?

/etc/X11/xorg.conf
/var/log/Xorg.0.log
~/.xsession-errors
output of cat /proc/acpi/video/*/DOS
output of sudo cat /proc/acpi/dsdt

wuddiwupp (stefan-wuttke) wrote :

With Gusty there is still no Problem.
Okay the problem is, i can't reproduce this failure, sometimes it happens between switching applications
in the taskbar, or only touch to the touchpad :/

1. ctrl+alt+f1 works for 10 seconds, then the console is blank too!
2. ctrl+alt+backspace doesn't work
3. Blank screen, no mouse
4. yes, the keyboard is working

there is only one way, switch to console and press ctrl+alt+del to reboot the system.

Augusto (augusto.rendon) wrote :

I have the same issue with very similar Xorg.0.log.old output.

unggnu (unggnu) wrote :

I guess it is the best to get a backtrace https://wiki.ubuntu.com/DebuggingXorg of the crash. The hardware state message isn't so rare according to some searches. Btw. please make sure that you have all updates installed.

@ar
Could you please attach your data too and create a backtrace?

I don't seem to find a core dump in either /etc/X11/core or in /var/crash/ so not sure how to get the backtrace. I followed the changes in https://wiki.ubuntu.com/DebuggingXorg, i.e.:
changed the file /etc/default/apport to enabled=0

and added

Section "ServerFlags"
        Option "NoTrapSignals" "true"
EndSection

to my xorg.conf

I attach the Xorg.0.log.old

The description of the problem is identical to wuddiwupp's

thanks

Augusto (augusto.rendon) wrote :

I add also the Xorg.9.log.old

Augusto (augusto.rendon) wrote :

ignore the last file, wrong date.

unggnu (unggnu) wrote :

You have to use gdb to get a backtrace from Xorg like described in https://wiki.ubuntu.com/DebuggingXorg and you need another machine to log in remotely.

NuZeb (nudelzebra) wrote :

same error here on my thinkpad x41 (intel 900).

Bryce Harrington (bryce) wrote :

We will not be able to begin troubleshooting this issue without a backtrace. The directions on https://wiki.ubuntu.com/DebuggingXorg explain how to do this; you may need to ssh into the box after it has crashed in order to connect gdb to the Xorg process.

I have connected remotely to the broken machine.
After starting gdb, the command attach <pid> never completed
Tried Ctrl-C, with no effect
Xorg was meanwhile eating up 100% cpu.

thanks.

On Tue, 2008-03-25 at 23:29 +0000, Bryce Harrington wrote:

> We will not be able to begin troubleshooting this issue without a
> backtrace. The directions on https://wiki.ubuntu.com/DebuggingXorg
> explain how to do this; you may need to ssh into the box after it has
> crashed in order to connect gdb to the Xorg process.
>
> ** Summary changed:
>
> - [HARDY] X crashes randomly (i915)
> + [HARDY] X crashes with 915GM/GMS/910GML (104d:81b8)
>

I have the same problem in Macbook with Intel 945GM. The crashes seems to be random :(

Kieran Hogg (xerosis) wrote :

Am confirming this, I've been seeing frequent, similar X crashes with my 945GM/GMS/GME. It seems to triggered for me with things like opening a video or alt+tabbing but I've seen it crash, like the original reporter said, when doing nothing. I'll try and get a backtrace next crash.

Changed in xserver-xorg-video-intel:
status: Incomplete → Confirmed
jon1012 (jonathan-schemoul) wrote :

Same bug here but with an nvidia card... So not related to Intel card.

jon1012 (jonathan-schemoul) wrote :

Oh by the way, I've found a temporary workaround...
ctrl+alt+backspace doesn't work, but alt+super+k can kill the x server and from there I can start a session again.

I've seen that receiving files in gaim triggers that bug too.

jon1012 (jonathan-schemoul) wrote :

I'm experiencing this same bug on NVIDIA cards, so not related to Intel cards only.

Kieran Hogg (xerosis) wrote :

I'm sure if it's the same bug, but opening a video in totem seems to 'freeze' X about 50% of the time currently.

Timo Aaltonen (tjaalton) wrote :

jon1012: even if you have problems with nvidia doesn't mean that it's the same bug. This is clearly intel-specific.

unggnu (unggnu) on 2008-05-04
Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
Antono Vasiljev (antono) wrote :

I have the same problems especially when i want to watch flv videos in totem. But sometimes X crashes without visible reason (macbook, intel).

Bryce Harrington (bryce) wrote :

Antono or Kieran, can you collect a backtrace for us?

Antono Vasiljev (antono) wrote :

Any suggestion how to collect the backtrace for totem embedded into firefox?

+ Somtimes i have the same freezes with Cheese and iSight. Will try to catch something.

Antono, I also have random freezes with the iSight and some flash videos :(

Kilua84 (kilua84) wrote :

Same problem here, on Dell Inspiron 640m, Ubuntu Hardy.
Random crash when I start a video.

Antono Vasiljev (antono) wrote :

i figured out that problem occurs in most cases when laptop is on battery power.

Antono Vasiljev (antono) wrote :

finally i catch the moment when my computer hangs and tried to follow instructions at

https://wiki.ubuntu.com/X/Backtracing

See log in attachement.

Symptoms: i can move mouse, music plays but screen is unresponsive at all. Even system monitor freezed.

Bryce Harrington (bryce) wrote :

[Please don't archive files when attaching them, as it makes it harder to review them.]

Thanks for collecting the backtrace. Unfortunately, it doesn't show any calls except this one, so isn't of much use:

0xb7f71410 in __kernel_vsyscall ()

Maybe we'll upstream it and hope they can offer better advice for how to troubleshoot this one.

Bryce Harrington (bryce) wrote :

In looking at this bug report further, this isn't upstreamable; there's no error messages and no steps identified to reliably reproduce the issue. So without a valid backtrace there is nothing that can be investigated.

Leaving at Incomplete until someone can provide a better backtrace.

Note that to get a backtrace you need to run 'bt full' at the (gdb) prompt. It looks like in the above backtrace this was not done, which is why the backtrace is so incomplete.

Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-intel:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers